Subject: [openpgp] I-D Action: draft-ietf-openpgp-crypto-refresh-03.txt

From: [email-masked]
Date: Sun, 02 May 2021 19:28:23 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Open Specification for Pretty Good Privacy WG of the IETF.

        Title           : OpenPGP Message Format
        Authors         : Werner Koch
                          Paul Wouters
	Filename        : draft-ietf-openpgp-crypto-refresh-03.txt
	Pages           : 117
	Date            : 2021-05-02

Abstract:
   { Work in progress to update the OpenPGP specification from RFC4880 }

   This document specifies the message formats used in OpenPGP.  OpenPGP
   provides encryption with public-key or symmetric cryptographic
   algorithms, digital signatures, compression and key management.

   This document is maintained in order to publish all necessary
   information needed to develop interoperable applications based on the
   OpenPGP format.  It is not a step-by-step cookbook for writing an
   application.  It describes only the format and methods needed to
   read, check, generate, and write conforming packets crossing any
   network.  It does not deal with storage and implementation questions.
   It does, however, discuss implementation issues necessary to avoid
   security flaws.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-openpgp-crypto-refresh/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-openpgp-crypto-refresh-03.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-openpgp-crypto-refresh-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Paul Wouters <[email-masked]>
Date: Sun, 2 May 2021 22:33:08 -0400 (EDT)

On Sun, 2 May 2021, [email-masked] wrote:

> Subject: [openpgp] I-D Action: draft-ietf-openpgp-crypto-refresh-03.txt

> https://www.ietf.org/rfcdiff?url2=draft-ietf-openpgp-crypto-refresh-03

This release fixes the items discussed on the list in response to the
-02 version. If further merges in somre more items, most notably v5 key
format, removal of old ciphers, addeding some new ciphers.

* 74b1148 - (HEAD -> main, origin/main, origin/HEAD) update my affiliation (79 seconds ago) <Paul Wouters>
* 9428808 - (tag: draft-ietf-openpgp-crypto-refresh-03) Clarify CRC is optional. Use MUST instead of SHALL (11 minutes ago) <Paul Wouters>
* ca55965 - s/both keys and messages/either keys and messages (20 minutes ago) <Paul Wouters>
* 27e70ca - use s0 s1 to denote the checksum octets instead of c0 c1 (4 days ago) <Paul Wouters>
* b705758 - Clarify CRC24_GENERATOR code with Hal Finney's second suggestion. (4 days ago) <Paul Wouters>
* 1edfd5d - update text on "Simple S2K and Salted S2K specifiers" as per WG discussion (4 days ago) <Paul Wouters>
* f310cd3 - Reference Notation flag registry (4 days ago) <Daniel Kahn Gillmor>
* f35e852 - Avoid mentioning IDEA, CAST5, Blowfish, and TripleDES in examples (4 days ago) <Daniel Kahn Gillmor>
* 71d14ac - minor textual clarifications (4 days ago) <Daniel Kahn Gillmor>
* df7dc92 - forbid S2K 255 for v5 secret keys (4 days ago) <Daniel Kahn Gillmor>
* af71082 - v5 signature format (4 days ago) <Daniel Kahn Gillmor>
* d230c7d - Issuer Fingerprint subpacket (4 days ago) <Daniel Kahn Gillmor>
* 3d3b18b - forbid the use of "Issuer" (keyid) subpacket with v5 keys (4 days ago) <Daniel Kahn Gillmor>
* 60e7a86 - introduce v5 fingerprint (4 days ago) <Daniel Kahn Gillmor>
* 0ffeeaa - Introduce the v5 key format (4 days ago) <Daniel Kahn Gillmor>
* bbcdd63 - Include EdDSA (4 days ago) <Daniel Kahn Gillmor>
* df39837 - Merge branch 'clean-up-crc24' into 'main' (4 days ago) <Paul Wouters ☕️>
* 998f554 - Clarify CRC-24 C example implementation (7 weeks ago) <Daniel Kahn Gillmor>
* 0c23c76 - Drop "Compatibility Profiles" section. (6 weeks ago) <Daniel Kahn Gillmor>
* ded0b29 - ignore more generated files (7 weeks ago) <Daniel Kahn Gillmor>
* 8c4824f - More README.md cleanup (7 weeks ago) <Daniel Kahn Gillmor>
* c9c0222 - bump version to -03 in preparation of upcoming work (7 weeks ago) <Daniel Kahn Gillmor>
* d804d4e - update README to include suggestions for release process (7 weeks ago) <Daniel Kahn Gillmor>
* edab546 - Move older drafts out of the way (7 weeks ago) <Daniel Kahn Gillmor>
* e02a925 - drop no-longer-relevant build accessories (7 weeks ago) <Daniel Kahn Gillmor>
* e6c95c0 - Document repository better in README (7 weeks ago) <Daniel Kahn Gillmor>

As always, please review and let us know on the list if there are any
issues. Meanwhile, we will prepare the -04 version for next week,
folding in the next set of changes.

full commit history available at: https://gitlab.com/openpgp-wg/rfc4880bis/

Paul