Subject: Re: Keep SMTP Client Alive [: Re: Activation points and callout modes]

From: Tony Hansen <[email-masked]>
Date: Tue, 08 Mar 2005 16:02:49 -0500

Hector Santos wrote:
> The "150-" was required, so test #2 was successful:
> 
>     C: DATA
>     S: 354 Start mail input; end with <CRLF>.<CRLF>
>     S: 150-Please Wait
>     S: 250 Message accepted for delivery. (bytes: 2573)
>     C: QUIT
> 
> Outlook accepted the "150-" without any error and waited for the 250
> response.

A 250- should have worked as well.

	Tony Hansen
	[email-masked]

---

From: "Hector Santos" <[email-masked]>
Date: Wed, 9 Mar 2005 11:38:12 -0500

----- Original Message -----
From: [email-masked]
To: <[email-masked]>
Sent: Tuesday, March 08, 2005 4:36 PM

> A 250- should have worked as well.

That was my first natural thought and trial.  Just like in FTP.

The client in this case, didn't like that.

Personally, I think this is better this way because you don't know what the
eventual response code might be.

This is the problem with the FTP continuation codes.   If I recall, the
first
continuation code provided must be the same across all remaining responses
and the
final response code.  It doesn't have a "150" like concept.

Sincerely,

Hector Santos, CTO
Santronics Software, Inc.
http://www.santronics.com
305-431-2846 Cell
305-248-3204 Office