Subject: Re: [OPS-AREA] [PEPPERMINT] potenntial charter for PEPPERMINT

From: Mehmet Ersue <[email-masked]>
Date: Wed, 6 Feb 2008 16:14:57 +0000 (GMT)

Hi All,

I fully agree with Margaret that the choice of the technology needs 
to be a group consensus.

Since IETF and IESG are always interested to use already existing 
protocols if they are suitable to do the job I'm pretty much interested to 
hear the concrete arguments why the gateway configuration cannot be 
done with NETCONF over SOAP.

NETCONF is a suitable protocol for network element configuration and 
configuration data exchange. NETCONF is also reliable and supports 
notification and transaction mechanisms. BTW: NETCONF over SOAP 
is not heavy-weight.

NETCONF is already available as a standard and has been implemented 
many times. Already different companies are using it in their products.

You don't get all these functionalities for free. It takes usually many years 
of hard work to develop the standard documents and get them stable based 
on implementations.

This is the reason why IESG is usually keen of using already existing IETF 
technologies instead of starting another overlapping work which takes years
to finalize.

So, please tell me, what are the hard-reasons for not using an existing 
technology?

Cheers, 
Mehmet Ersue

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Margaret 
> Wasserman
> Sent: Wednesday, February 06, 2008 4:29 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [PEPPERMINT] potenntial charter for PEPPERMINT
> 
> 
> By "NETCFG", does Richard mean NETCONF?
> 
> I would prefer to see the line removed that states that "bias 
> will be  
> given" to particular solutions.  I think it is okay to charter a  
> group with restrictions on the solution space, such as "will 
> be based  
> on XML" if there is consensus to do so, but I'm not sure what it  
> would mean to charter a group and require that they be "biased"  
> towards certain solutions.  If there isn't consensus that the  
> solution must be based on one of the technologies listed, I think  
> that line should be removed and the choice of technology should be a  
> group consensus decision.
> 
> Margaret
> 
> 
> 
> On Feb 6, 2008, at 5:30 AM, Romascanu, Dan (Dan) wrote:
> 
> >
> > Comments are welcome.
> >
> > Dan
> >
> >
> >
> >
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]
> > On Behalf Of Richard Shockey
> > Sent: Wednesday, February 06, 2008 2:06 AM
> > To: [email-masked]
> > Subject: [PEPPERMINT] potenntial charter for PEPPERMINT
> >
> >
> > Folks ..we had a successful BOF in Vancouver in order to 
> progress the
> > work towards a full charter by the IETF it is necessary to reach
> > consensus on a charter.
> >
> > I have a proposal for a charter here below. I welcome 
> comments public
> > private etc.
> >
> >
> > PROPOSED CHARTER FOR PEPPERMINT
> >
> > The IETF has been working on various aspects of Multi-Media
> > Interconnection among administrative domains.
> >
> > ENUM is specifically chartered to develop protocols that involve the
> > translation of E.164 numbers to URI's.
> >
> > SPEERMINT has been chartered to develop best current practices among
> > real-time application service providers and how such services
> > interconnect across administrative boundaries.
> >
> > These forms of interconnection will require various forms of data  
> > to be
> > exchanged among administrative domains outside the normal scope of
> > establishing various SIP sessions.
> >
> > The IETF has, in the past done, significant work on data exchanges  
> > among
> > various network elements. PROVREG and NETCFG being the most 
> prominent
> > recent examples.
> >
> > Data exchanges to facilitate Multi-Media Interconnection 
> are typically
> > between various Client User Agents and Registries containing  
> > mappings of
> > phone numbers to URI's, policies surrounding admission to points of
> > network interconnection and various types of trunking data.  In  
> > addition
> > there is a specific need for redistribution of Registry data to  
> > various
> > types of network databases.
> >
> > The proposed PEPPERMINT working group will build upon the 
> knowledge  
> > and
> > expertise of the PROVREG, ENUM and SPEERMINT working groups. The  
> > goal of
> > the WG is to find a provisioning solution for interconnection to be
> > ultimately used by SPEERMINT. The working group may also reuse  
> > elements
> > of RFC 4114 if possible.
> >
> > The final work product(s) from this working group will be based upon
> > XML.
> >
> > Additionally, bias will be given to using, HTTP/REST, 
> HTTP/XML-RPC, or
> > HTTP/SOAP.
> >
> > The working group will draw upon expert advice and ongoing  
> > consultation
> > from the ENUM, SPEERMINT and PROVREG working groups.
> >
> >
> > PROPOSED GOALS AND MILESTONES
> >
> >
> > Requirements for Interconnection data exchanges.       July 08
> >
> > Provisioning of Interconnection data registries.       Sep 08
> >
> > Provisioning of Interconnection data caches.           Dec 08
> >
> >
> > Richard Shockey
> > Director, Member of the Technical Staff
> > NeuStar
> > 46000 Center Oak Plaza - Sterling, VA 20166 PSTN Office +1  
> > 571.434.5651
> > PSTN Mobile: +1 703.593.2683 <mailto:richard(at)shockey.us>
> > <mailto:richard.shockey(at)neustar.biz>
> >
> >
> >
> >
> > _______________________________________________
> > PEPPERMINT mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/peppermint
> >
> > --
> > to unsubscribe send a message to [email-masked] with
> > the word 'unsubscribe' in a single line as the message text body.
> > archive: <http://ops.ietf.org/lists/netconf/>
> 
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>
> 

      Lesen Sie Ihre E-Mails jetzt einfach von unterwegs.
www.yahoo.de/go

_______________________________________________
OPS-AREA mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ops-area

---

From: "GOGWIM, JOEL GODWIN" <[email-masked]>
Date: Thu, 7 Feb 2008 07:41:19 +0100 (WAT)

I share your view too.

On Wed, February 6, 2008 5:14 pm, Mehmet Ersue said:
> www.yahoo.de/go_______________________________________________
> OPS-AREA mailing list
> [email-masked]