Subject: [OPS-AREA] UUID required for all energy objects -> ENTITY-MIB v4?

From: Benoit Claise <[email-masked]>
Date: Fri, 28 Oct 2011 15:49:48 +0200

Dear all,

At the last IETF meeting, we concluded that we would need an UUID for 
every energy objects.
See http://www.ietf.org/proceedings/81/minutes/eman.txt

We also concluded there were two ways to add this UUID
1. within the ENERGY-AWARE MIB to be fast
2. within the ENTITY-MIB v4 (because the UUID is not energy specific) 
with a compliance statement in the ENERGY-AWARE-MIB to implement a 
couple of MIB objects from the ENTITY-MIB v4. One of them being the UUID.

I haven't seen any work in the direction of option 2. So, right now, 
we're stuck with 1.
Does anybody have been working on this? Does any of you have in interest 
in participating in such work?

Regards, Benoit.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 28 Oct 2011 16:05:07 +0200

On Fri, Oct 28, 2011 at 03:49:48PM +0200, Benoit Claise wrote:
> Dear all,
> 
> At the last IETF meeting, we concluded that we would need an UUID
> for every energy objects.
> 2. within the ENTITY-MIB v4 (because the UUID is not energy
> specific) with a compliance statement in the ENERGY-AWARE-MIB to
> implement a couple of MIB objects from the ENTITY-MIB v4. One of
> them being the UUID.
> 
> Does anybody have been working on this? Does any of you have in
> interest in participating in such work?

The ENTITY-MIB version 3 has the entPhysicalUris object and it
can hold an RFC 4122 UUID in URN format. There is no need for an
ENTITY-MIB v4 to carry a UUID.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 28 Oct 2011 16:47:04 +0200

Thanks Juergen for the pointer.
So it means that , whatever the entPhysicalUris MIB object contains, we 
could add a UUID (as specified to in RFC4122) to it, separated by a 
space, right?

Regards, Benoit.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 28 Oct 2011 18:25:49 +0200

On Fri, Oct 28, 2011 at 04:47:04PM +0200, Benoit Claise wrote:

> So it means that , whatever the entPhysicalUris MIB object contains,
> we could add a UUID (as specified to in RFC4122) to it, separated by
> a space, right?

entPhysicalUris can contain a white space separated list of URIs:

            Multiple URIs may be present and are separated by white
            space characters.  Leading and trailing white space
            characters are ignored.

There was debate around CLEI codes (the pros and cons) and the final
resolution was to support anything that can be represented as a URI.
Today we seem to like UUIDs. This can all happily co-exist (note that
entPhysicalUris does not even have the typical 255 octets size limit).

/js

---

From: Michael MacFaden <[email-masked]>
Date: Fri, 28 Oct 2011 09:40:02 -0700 (PDT)

> ENTITY-MIB v4 to carry a UUID.

Hi Juergen,

What would be the encoding?
Text
 38a52be4-9352-453e-af97-5c3b448652f0
Text with brackets
 {38a52be4-9352-453e-af97-5c3b448652f0}.
URL:
  uuid://38a52be4-9352-453e-af97-5c3b448652f0

??

Thanks,
Mike MacFaden

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 28 Oct 2011 19:41:45 +0200

>   uuid://38a52be4-9352-453e-af97-5c3b448652f0

entPhysicalUris contains URIs, see the description clause. Copying an
example from RFC 4122, it should be

   urn:uuid:f81d4fae-7dec-11d0-a765-00a0c91e6bf6

/js