Subject: Re: [OPSAWG] Proposed update to syslog Alarm

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 3 Apr 2009 08:59:50 -0400

Hi

It is acknowledged that resourceOID does not work in all circumstances
but the idea of leaving it in is that it is understood by the majority
of SNMP users. The URI approach was introduced to cover the cases that
OID could not. So, we are using the SNMP URI approach either way, the
question is whether to also keep the resourceOID. In my view, using
OIDS, which are universally understood, is something a lot of
implementations will want to do so it would be nice to have a standard
way to do that, but I'll go with working group consensus. 

So far I have heard

Dave H - remove it
Sharon - keep it
Juergen - remove it or align it to other work

So, if there are no other views I would suggest that we remove it.

Sharon 

-----Original Message-----
From: Juergen Schoenwaelder
[mailto:[email-masked]] 
Sent: Monday, March 23, 2009 12:54 PM
To: Chisholm, Sharon (CAR:ZZ00)
Cc: [email-masked]
Subject: Re: [OPSAWG] Proposed update to syslog Alarm

On Mon, Mar 23, 2009 at 05:04:41PM +0100, Sharon Chisholm wrote:
 
> So, are you OK with leaving all three in the document?

Once again, resourceOID is broken. If you leave it, you have to fix it.
My preference would be to either (a) use the SNMP URI scheme or
(b) use the the SNMP to SYSLOG mappings also defined as part of the
OPSAWG working group. If you plan to invent a third solution, make sure
you have strong arguments; I prefer to reuse existing solutions.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 3 Apr 2009 12:45:19 -0700

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Juergen Schoenwaelder" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, April 03, 2009 5:59 AM
...
> So, if there are no other views I would suggest that we remove it.

I'd prefer removal, but would find it acceptable to leave it in if it
were made clear that resourceOID could only be used for the context "",
and MUST NOT be used for any other context, and that in all other
cases SNMP URI MUST be used instead.

Randy

---

From: "David Harrington" <[email-masked]>
Date: Thu, 9 Apr 2009 12:37:55 -0400

Hi,

I think my perspective is to either fix it or remove it. As Juergen
and I have pointed out, the OID is incomplete without a context. 

dbh

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Sharon Chisholm
> Sent: Friday, April 03, 2009 9:00 AM
> To: Juergen Schoenwaelder
> Cc: [email-masked]
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>