Subject: Re: [OPSAWG] opsawg CC @1 - Generic Management Data Model

From: Mehmet Ersue <[email-masked]>
Date: Fri, 7 Aug 2009 21:13:26 +0000 (GMT)

Hi Dave,

can you please elaborate a bit how the template will look like?
Is it rather a "Generic Template for Management Data Models"?
Is it for both, MIBs and YAMs?

Thank you.

Cheers,
Mehmet

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext David Harrington
> Sent: Friday, August 07, 2009 9:50 PM
> To: 'Scott O. Bradner'; [email-masked]
> Subject: Re: [OPSAWG] opsawg CC @1 - Generic Management Data Model
> 
> Hi,
> 
> This is not about developing a generic data model; it is only about
> developing a template. 
> The subject line is rather misleading.
> 
> I believe the template belongs on the tools page, and could be
> different templates for different management protocols.
> 
> dbh
> 
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]] On Behalf Of Scott O. Bradner
> > Sent: Friday, August 07, 2009 12:52 PM
> > To: [email-masked]
> > Subject: [OPSAWG] opsawg CC @1 - Generic Management Data Model
> > 
> > 
> > THe opsawg charter includes milestones for a 'Template for Generic 
> > Management Data Models'
> > 
> > There has been no work to date on such a document (as far as I know)
> > 
> > Dan asked the room in Stockholm if this item should stay in the
> opsawg
> > charter.
> > 
> > The view in the room was none in favor of keeping the document 
> > as a chartered item, 6 against.
> > 
> > please let the list know if you feel that the milestones 
> > should be removed
> > from the charter or if you feel that the working group should still
> > develop such a document. (if you feel that the task should be
> > maintaind please suggest someone to be the editor of the document if
> > you have any suggestions)
> > 
> > thanks
> > 
> > Scott
> > _______________________________________________
> > OPSAWG mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/opsawg
> > 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: "David Harrington" <[email-masked]>
Date: Fri, 7 Aug 2009 23:55:58 +0200

There are templates for developing documents that contain MIB modules.
The purpose is to make the layout and content surrounding a MIB fairly
consistent, so it makes it easier to review the documents. The
template follows the guidelines in RFC4181.
 
If the WG did a generic template, it would look something like
http://tools.ietf.org/tools/templates/mib-doc-template-xml.txt,
modified to make it less SNMP, SMI, and MIB-specific.
 
A generic template would presumably have the advantage of similarity
across interfaces, which could make it easier to review proposed data
models, regardless of interface, but we would need to focus on the
least common denominator. It could have limited utility because it
could only address the least common denominator (or end up having a
bunch of conditional clauses that would make it more complex).
 
An alternative would be to define a template for each NM interface. If
these are substantially different then it becomes harder to review
proposed data models.
 
six of one, half dozen of the other.
 
Juergen has argued this is just a tools issue. In some ways I agree.
In some ways I disagree. That is why I developed a template for use
with xml2rfc. But xml2rfc does not generate such information in MIB
documents by itself; the MIB template helps editors know what sections
are recommended and what should go into them following RFC4181
guidelines. Most of the useful content cannot be generated
algorithmically by a tool; it must be generated by humans explaining
the purpose, layout, dependencies, and security vulnerabilities of the
particular MIB module. The template helps provide (inline) advice to
editors of MIB documents.
 
dbh

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mehmet Ersue
Sent: Friday, August 07, 2009 11:13 PM
To: [email-masked]
Subject: Re: [OPSAWG] opsawg CC @1 - Generic Management Data Model

Hi Dave,

Thank you.

Cheers,
Mehmet