Subject: Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on Monday-28-March2011 in Barcelona/Berlin

From: "So, Ning" <[email-masked]>
Date: Tue, 29 Mar 2011 07:31:43 +0000

All,

Given the clear direction from APS AD during the OPSAWG meeting and the
in room discussion, all DCOPS related work will be done in OPSAWG for
now.  I do not see the needs to have another separate meeting today.  It
is rather unfortunate that many Cloud related presentation could not be
presented at this IETF meeting.  I will make sure to remind everyone to
follow the IETF procedure and upload the drafts before deadline, and
request the presentation slots properly.  

OPS AD and OPSAWG chair indicated during the meeting that they are
looking for signs of significant activity for Cloud/Data center related
work, both from drafts (not presentations), and e-mail list discussion,
to determine the needs for a separate WG.  Personally I think that's a
good and fair instruction.  Now the work has an official IETF home, so I
strongly encourage everyone to sign up onto the OPSAWG mail list if you
have not already done so, and freely open up any dialog you may have in
Cloud Data Center related issues.   We should try to move all future
Cloud related IETF discussions to OPSAWG and close down all other
channels of unofficial communication.

I am aware some of the people contributing to the Cloud IETF effort may
not be totally clear on the IETF procedure.  Please feel free to contact
me directly if you have any questions.  I will try my best to help.   

Best regards,
 
Ning So
Network Evolution Planning
Verizon, Inc.
(office) 972-729-7905
(Cell) 972-955-0914

-----Original Message-----
From: Keiichi SHIMA [mailto:[email-masked]] 
Sent: Tuesday, March 29, 2011 1:54 AM
To: Bhumip Khasnabish
Cc: Keiichi SHIMA; So, Ning; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; Subir Das; Steiner,
Moritz; Zeltsan, Zachary
Subject: Re: PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on
Monday-28-March2011 in Barcelona/Berlin

Hi all,

On Mar 27, 2011, at 11:15 PM, Bhumip Khasnabish wrote:

> We plan to continue discussion on Tuesday (29-March2011) during lunch
break, if possible/needed, will let you know the room number later.

I wonder if the above meeting is still planned or not.  If planned, is
there any information of the room?

---
Keiichi SHIMA
Research Laboratory, IIJ Innovation Institute  <[email-masked]> WIDE
Project <[email-masked]>

On Mar 27, 2011, at 11:15 PM, Bhumip Khasnabish wrote:

> We'll have VPN oriented Cloud Services, DataCenter, and VNM related
presentations during this mtg.; the detailed agenda can be found at the
following URL..
> 
>   http://www.ietf.org/proceedings/80/agenda/opsawg.txt
>  
>  
> I requested Scott and Chris to move item-8 up so that we can have {3,
4, and 8} presentations in one cluster.
>  
> We plan to continue discussion on Tuesday (29-March2011) during lunch
break, if possible/needed, will let you know the room number later.
> Thanks.
> Best.
> Bhumip

---

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Tue, 29 Mar 2011 22:38:20 +1100

Greetings Ning et al,

	Please do start the activity on the mailing list sooner rather later (so we can gauge the level of activity here).  Also, as this is the operations wg, we would really like to see input from operators who are using (or attempting) to use this technology in anger, and what the issues are, for example.  Theory is great, practice is better :)

	Thank's,
	Chris

On 29Mar2011, at 18.31, So, Ning wrote:

> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---
李柯睿
Check my PGP key here:
https://www.asgaard.org/~cdl/cdl.asc

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 29 Mar 2011 13:55:06 +0200

Hi, 

Thanks, Ning for the clarification. 

One point of clarification is needed though. The OPSAWG is discussing
area-wide work for the OPS area as well as smaller incremental
specifications related to existing work in the area. I think it is fine
to bring here all clouds and data center operational and management
issues, but things that are not related to the OPS area scope should be
brought some other place. 

If you have any questions on this please approach me, Ron, Scott or
Chris. 

Regards,

Dan 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of So, Ning
> Sent: Tuesday, March 29, 2011 9:32 AM
> To: Keiichi SHIMA; Bhumip Khasnabish
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; Zeltsan,Zachary; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; Steiner, Moritz; Subir Das; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 
> 10:15 AM on Monday-28-March2011 in Barcelona/Berlin
> 
> All,
> 
> Given the clear direction from APS AD during the OPSAWG 
> meeting and the in room discussion, all DCOPS related work 
> will be done in OPSAWG for now.  I do not see the needs to 
> have another separate meeting today.  It is rather 
> unfortunate that many Cloud related presentation could not be 
> presented at this IETF meeting.  I will make sure to remind 
> everyone to follow the IETF procedure and upload the drafts 
> before deadline, and request the presentation slots properly.  
> 
> OPS AD and OPSAWG chair indicated during the meeting that 
> they are looking for signs of significant activity for 
> Cloud/Data center related work, both from drafts (not 
> presentations), and e-mail list discussion, to determine the 
> needs for a separate WG.  Personally I think that's a good 
> and fair instruction.  Now the work has an official IETF 
> home, so I strongly encourage everyone to sign up onto the 
> OPSAWG mail list if you have not already done so, and freely 
> open up any dialog you may have in
> Cloud related IETF discussions to OPSAWG and close down all 
> other channels of unofficial communication.
> 
> I am aware some of the people contributing to the Cloud IETF 
> effort may not be totally clear on the IETF procedure.  
> Please feel free to contact
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; Subir Das; 
> Steiner, Moritz; Zeltsan, Zachary
> I wonder if the above meeting is still planned or not.  If 
> planned, is there any information of the room?
> 
> ---
> Keiichi SHIMA
> Research Laboratory, IIJ Innovation Institute  
> <[email-masked]> WIDE Project <[email-masked]>
> 
> 
> 
> 
> 
> presentations during this mtg.; the detailed agenda can be 
> found at the following URL..
> >

---

From: "So, Ning" <[email-masked]>
Date: Tue, 29 Mar 2011 13:54:27 +0000

Yes, let’s get the discussion beginning.  I actually have a short presentation on the addressing resolution issues/problems induced by VPN-o-CS in ARMD WG tomorrow.  There is large opportunity, but also large challenges.   

Best regards,

Ning So

Verizon, Inc.

(office) 972-729-7905

(Cell) 972-955-0914

From: Christopher LILJENSTOLPE [mailto:[email-masked]] 
Sent: Tuesday, March 29, 2011 6:38 AM
To: So, Ning
Cc: Keiichi SHIMA; Bhumip Khasnabish; [email-masked]; [email-masked]; Jeff Young; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Sumit Naiksatam (snaiksat); [email-masked]; Clive E Webber; [email-masked]; [email-masked]; [email-masked]; Masum Hasan (masum); Sundar K Iyer; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Zeltsan, Zachary; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Steiner, Moritz; Subir Das; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Daryl A Bourke; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on Monday-28-March2011 in Barcelona/Berlin

Greetings Ning et al,

            Thank's,

            Chris

All,

Best regards,

Ning So

-----Original Message-----
From: Keiichi SHIMA [mailto:[email-masked]] 
Sent: Tuesday, March 29, 2011 1:54 AM
To: Bhumip Khasnabish
Cc: Keiichi SHIMA; So, Ning; [email-masked];

Hi all,

---
Keiichi SHIMA

 

	 

 

 

	Thanks.

	Best.

	Bhumip

---

李柯睿
Check my PGP key here:

---

From: "So, Ning" <[email-masked]>
Date: Tue, 29 Mar 2011 14:07:10 +0000

Dan,

As my understanding, if a draft has OPS area implication (regardless
large or small implication), shouldn't we first discuss and present the
drafts and issues in OPSAWG first, and then OPSAWG send the accepted
requirements to other appropriate WGs for protocol development?  That is
my understanding, as well as the public feedback I got from L2VPN WG
chair when I presented the VPN-o-CS draft there this morning.

If that is correct, then the discussions and presentations in OPSAWG may
very well include un-OPS area related issues.  Otherwise we fall back to
where we were before there was a home for the cloud drafts.  Please
advise. 
 
Best regards,
 
Ning So

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Tuesday, March 29, 2011 6:55 AM
To: So, Ning; Keiichi SHIMA; Bhumip Khasnabish
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]; Zeltsan,Zachary;
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked];
Steiner, Moritz; Subir Das; [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; Ron Bonica; Scott Bradner; Chris Liljenstolpe
Subject: RE: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM
on Monday-28-March2011 in Barcelona/Berlin

Hi, 

Regards,

Dan 

> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> Given the clear direction from APS AD during the OPSAWG meeting and 
> the in room discussion, all DCOPS related work will be done in OPSAWG 
> for now.  I do not see the needs to have another separate meeting 
> today.  It is rather unfortunate that many Cloud related presentation 
> could not be presented at this IETF meeting.  I will make sure to 
> remind everyone to follow the IETF procedure and upload the drafts 
> looking for signs of significant activity for Cloud/Data center 
> related work, both from drafts (not presentations), and e-mail list 
> discussion, to determine the needs for a separate WG.  Personally I 
> think that's a good and fair instruction.  Now the work has an 
> official IETF home, so I strongly encourage everyone to sign up onto 
> the OPSAWG mail list if you have not already done so, and freely open 
> up any dialog you may have in
> I am aware some of the people contributing to the Cloud IETF effort 
> may not be totally clear on the IETF procedure.

> Research Laboratory, IIJ Innovation Institute <[email-masked]> 
> WIDE Project <[email-masked]>
> 
> 
> 
> 
> 
> presentations during this mtg.; the detailed agenda can be found at 
> the following URL..
> >

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 29 Mar 2011 17:39:16 +0200

Hi Ning, 

Yes - IF the draft has OPS area implications. Not all current and future
Cloud related IETF drafts and discussions have OPS area implications. 

Thanks and Regards,

Dan 

> From: So, Ning [mailto:[email-masked]] 
> Sent: Tuesday, March 29, 2011 4:07 PM
> To: Romascanu, Dan (Dan); Keiichi SHIMA; Bhumip Khasnabish
> [email-masked]; [email-masked]; Ron Bonica; Scott 
> Bradner; Chris Liljenstolpe
> Subject: RE: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 
> As my understanding, if a draft has OPS area implication 
> (regardless large or small implication), shouldn't we first 
> discuss and present the drafts and issues in OPSAWG first, 
> and then OPSAWG send the accepted requirements to other 
> appropriate WGs for protocol development?  That is my 
> understanding, as well as the public feedback I got from 
> L2VPN WG chair when I presented the VPN-o-CS draft there this morning.
> 
> If that is correct, then the discussions and presentations in 
> OPSAWG may very well include un-OPS area related issues.  
> Otherwise we fall back to where we were before there was a 
> home for the cloud drafts.  Please advise. 
>  
> Best regards,
>  
> Ning So
> [email-masked]; [email-masked]; Ron Bonica; Scott 
> Bradner; Chris Liljenstolpe
> Subject: RE: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 
> One point of clarification is needed though. The OPSAWG is 
> discussing area-wide work for the OPS area as well as smaller 
> incremental specifications related to existing work in the 
> area. I think it is fine to bring here all clouds and data 
> center operational and management issues, but things that are 
> not related to the OPS area scope should be brought some other place. 
> 
> If you have any questions on this please approach me, Ron, 
> Scott or Chris. 
> 
> Regards,
> 
> Dan 
>  
> 
> [email-masked];

---

From: Bhumip Khasnabish <[email-masked]>
Date: Tue, 29 Mar 2011 18:58:57 -0400

Thanks Chris. Yes agreed, and have requested all of the data center
operations and management related ID owners (and developers) to do so
immediately.

We'll also announce the conf call invitation to the operations wg mailing
list.

Thanks again.

Best.

Bhumip

On Tue, Mar 29, 2011 at 7:38 AM, Christopher LILJENSTOLPE
<[email-masked]>wrote:

> Greetings Ning et al,
>
> Please do start the activity on the mailing list sooner rather later (so we
> can gauge the level of activity here).  Also, as this is the operations wg,
> we would really like to see input from operators who are using (or
> attempting) to use this technology in anger, and what the issues are, for
> example.  Theory is great, practice is better :)
>
> Thank's,
> Chris
>
>
>

---

From: "So, Ning" <[email-masked]>
Date: Wed, 30 Mar 2011 07:36:30 +0000

Dan,

Certainly.  Thanks for the clarification.

Best regards,
 
Ning So
 
-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Tuesday, March 29, 2011 10:39 AM
To: So, Ning; Keiichi SHIMA; Bhumip Khasnabish
Cc: [email-masked]; [email-masked];

Hi Ning, 

Thanks and Regards,

Dan 

> [email-masked]; [email-masked]; [email-masked]; Ron 
> Bonica; Scott Bradner; Chris Liljenstolpe
> large or small implication), shouldn't we first discuss and present 
> the drafts and issues in OPSAWG first, and then OPSAWG send the 
> accepted requirements to other appropriate WGs for protocol 
> development?  That is my understanding, as well as the public feedback

> I got from L2VPN WG chair when I presented the VPN-o-CS draft there 
> this morning.
> 
> If that is correct, then the discussions and presentations in OPSAWG 
> may very well include un-OPS area related issues.
> Otherwise we fall back to where we were before there was a home for 
> the cloud drafts.  Please advise.
>  
> Best regards,
>  
> Ning So
> [email-masked]; [email-masked]; [email-masked]; Ron 
> Bonica; Scott Bradner; Chris Liljenstolpe
> specifications related to existing work in the area. I think it is 
> fine to bring here all clouds and data center operational and 
> management issues, but things that are not related to the OPS area 
> scope should be brought some other place.
>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 30 Mar 2011 12:15:41 +0200

Can anybody please summarize the available drafts and their goal in a mail before we start many threads at once, which might end up in a chaotic discussion.

I would like to understand first which drafts are there, their aim and goals and their relationship to operations and management.

May be it would be interesting if the OPSAWG chairs would filter them somehow into two sets: relevant for OPS area and not relevant for OPS area.

Cheers, 
Mehmet 

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Bhumip Khasnabish
Sent: Wednesday, March 30, 2011 12:59 AM
To: Christopher LILJENSTOLPE
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Sumit Naiksatam (snaiksat); [email-masked]; [email-masked]; [email-masked]; [email-masked]; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked]; [email-masked]; [email-masked]; Clive E Webber; [email-masked]; [email-masked]; [email-masked]; Zeltsan,Zachary; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Steiner,Moritz; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Subir Das; shige!
 [email-masked]; Daryl A Bourke; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on Monday-28-March2011 in Barcelona/Berlin

Thanks Chris. Yes agreed, and have requested all of the data center operations and management related ID owners (and developers) to do so immediately.

We'll also announce the conf call invitation to the operations wg mailing list. 

Thanks again.

Best.

Bhumip

On Tue, Mar 29, 2011 at 7:38 AM, Christopher LILJENSTOLPE <[email-masked]> wrote:

	Greetings Ning et al, 

	Thank's,

	Chris

		All,

		

		Best regards,
		
		Ning So

		-----Original Message-----
		From: Keiichi SHIMA [mailto:[email-masked]] 
		Sent: Tuesday, March 29, 2011 1:54 AM
		To: Bhumip Khasnabish
		Cc: Keiichi SHIMA; So, Ning; [email-masked];
		[email-masked]; [email-masked]; [email-masked];
		[email-masked]; [email-masked]; [email-masked];
		[email-masked]; [email-masked]; [email-masked];
		[email-masked]; [email-masked]; [email-masked];
		[email-masked]; [email-masked];
		[email-masked]; [email-masked];
		[email-masked]; [email-masked];
		[email-masked]; [email-masked];
		
		Hi all,

		

		
		
		---
		Keiichi SHIMA

		

		 

			 

		 

		 

			Thanks.

			Best.

			Bhumip

	---

	李柯睿
	Check my PGP key here:
	https://www.asgaard.org/‾cdl/cdl.asc

---

From: Bhumip Khasnabish <[email-masked]>
Date: Wed, 30 Mar 2011 07:17:02 -0400

Mehmet,

Here is the list of the main ones that we originally prepared ...thoughts
and comments are welcome..others are being prepared .. Thanks..

1.
Draft Name:  Requirements and Framework for VPN‐Oriented Cloud Services (
http://datatracker.ietf.org/doc/draft-so-vpn-o-cs/)
Author/presenter: Ning So
Amount of time requested: 10 minutes
Abstract: This contribution addresses the service providers' requirements to
support VPN-Oriented Cloud services. It describes the characteristics of
VPN-oriented Cloud Service and specifies the requirement on how to maintain
and manage the data center resources for those services.

2.
Draft Name:  Network Abstraction for Enterprise and SP Class Cloud (
http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-rfc-seamless-Cloud-masum-01.txt)

Author/presenter: Masum Hasan
Amount of time requested: 10 minutes
Abstract: In this document we introduce a network related Cloud abstraction
called the Seamless Cloud, which facilitates secure and seamless extension
of an enterprise (Intranet) into an enterprise and SP grade Cloud. We also
introduce Cloud service interfaces and relevant parameters for on-demand
manipulation (Create, Read, Update, Delete) of Seamless Cloud.

3.
 Draft Name:  Protocol Considerations for Workload Mobility in Clouds (
http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Protocol%20Considerations%20for%20Workload%20Mobility%20in%20Clouds.txt)

Author/presenter: Sundar Iyer/Masum Hasan
Amount of time requested: 10 minutes
Abstract: This analysis considers the migration of application, OS, compute,
storage and policy (workloads) within and between service provider,
enterprise or 3rd party data centers. Intra-site migration is driven by
consolidation scenarios for power, administration and floorspace savings.
Inter-site workload migration is motivated by scenarios that exploit more
favourable cost structures at specific sites, the placement of workloads
closer to where they are consumed or processed to reduce latency, the
reduction of site-related downtime, and workload consolidation at fewer
sites for power savings. This memo describes how the complexity of the
solution is dependent on the characteristics of the workload, the need to
preserve policy and service-level information, and the existence, or
otherwise, of trust boundaries. This document posits a framework for
considering workload migration, in terms of entities involved, rationale for
migration, the types of workloads and protocols for migrating these
workloads that consider these factors.

4.
Draft Name:  Service Management for Virtualized Networks (
http://www.ietf.org/id/draft-yokota-cloud-service-mobility-01.txt)
Author/presenter: Hidetoshi YokotaAmount of time requested: 10 minutes
Abstract: Network virtualization technique leveraged by a virtual machine
makes it possible to dynamically relocate functional entities without
topological and physical constraints.  By tapping into this technique,
service mobility, which deals with not only functional entities but also
sessions established between those entities, will become possible and such
capability is especially longed for realizing more scalable and reliable
telecom networks.  This document provides the reference model for service
mobility in a virtual environment and defines the control protocol between
the virtualized platform and the managing controller to realize service
mobility.

5.
Draft Name:  Virtual Network Management Information Model (
http://tools.ietf.org/id/draft-okita-ops-vnetmodel-03.txt)
Author/presenter: Hideki OkitaAmount of time requested: 10 minutesAbstract:
Virtual switches on server virtualization platforms cause a
problem in managing data center networks containing several hundred
switches. Accordingly, a management information model for the network
structure of data center networks containing virtual switches is proposed.
The proposed model consists of a physical layer (which represents
connections between physical switches) and a virtual layer (which represents
connections between virtual switches).  These layers also represent the
association of the virtual switch with the corresponding physical switch.
This document also provides an example of the XML-based data model that is
implemented according to the proposed information model.

6.
Draft Name:  Syslog Extension for Cloud   (
http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-golovinsky-cloud-log-00.txt)

Author/presenter: Gene GolovinskyAmount of time requested: 10
minutesAbstract:  This document provides an open and extensible log format
to be used by any cloud entity or cloud application to log and trace
activities that occur in the cloud. It is equally applicable for cloud
infrastructure (IaaS), platform (PaaS), and application (SaaS) services.
CloudLog is different in content, but not in nature from the traditional
logging as it takes in account transient nature of identities and resources
in the cloud.

7.
Draft Name:  Cloud Service Broker (
http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-shao-cloud-CSB-00.txt)

Author/presenter:  Hu JieAmount of time requested: 10 minutesAbstract:  This
document introduces a Cloud Service Broker (CSB) entity to provide brokering
service between different Cloud Service Providers which can be based on
private cloud, community cloud, public cloud and hybrid cloud.

8.
Draft Name:  Cloud Reference Framework (
http://tools.ietf.org/id/draft-khasnabish-cloud-reference-framework-00.txt)
Author/presenter:  Bhumip Khasnabish Amount of time requested: 10
minutesAbstract:  This document presents a reference framework for Cloud
Services, based on the survey of Cloud-based systems and services.
Intra-cloud and inter-cloud reference frameworks are developed, and the
requirements for each layer are also identified and discussed.

2011/3/30 Ersue, Mehmet (NSN - DE/Munich) <[email-masked]>

>  Can anybody please summarize the available drafts and their goal in a
> mail before we start many threads at once, which might end up in a chaotic
> discussion.
>
> I would like to understand first which drafts are there, their aim and
> goals and their relationship to operations and management.
>
> May be it would be interesting if the OPSAWG chairs would filter them
> somehow into two sets: relevant for OPS area and not relevant for OPS area.
>
>
>
> Cheers,
> Mehmet
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of ext Bhumip Khasnabish
> Sent: Wednesday, March 30, ! 2011 12: 59 AM
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; Sumit Naiksatam (snaiksat);
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; Masum Hasan (masum); Sundar
> K Iyer; Jeff Young; [email-masked]; [email-masked];
> [email-masked]; Clive E Webber; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> Steiner,Moritz; [email-masked]; [email-masked]; chu.jun!
> [email-masked]; [email-masked]; Subir Das; shigeru.miyake.uy@
> hitachi.com; Daryl A Bourke; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on
> Monday-28-March2011 in Barcelona/Berlin*
>
>
>
> example.  Theory is great, practice is better! :)
>
>
>
> Thank's,
>
> Chris
>
>
>
>
>
>
>
> follow the IETF proc! edure and upload the drafts before deadline, and
> request th! e presen tation slots properly.
>
>
> me directly if you have any questions.  I will try my best to hel! p.
>
>
>
> Best regards,
>
> Ning So
> [email-masked].! cn; [email-masked]; [email-masked];
> [email-masked] <[email-masked]>;
> [email-masked];
> Michael.Fargano@qwes! t.com <[email-masked]>;
> [email-masked] <[email-masked]!+.cn>;
> [email-masked];
> break, if possible/needed, will let you know the room! number later.
>
> I wonder if the above meeting is still p! lanned o r not.  If planned, is
>
>  !
> *https://www.asgaard.org/~cdl/cdl.asc*
>
>
>
>
>
>
>

---

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Wed, 30 Mar 2011 22:22:23 +1100

That sounds like a good idea Mehmet.

	Chris

---
李柯睿
Check my PGP key here:

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 30 Mar 2011 13:47:26 +0200

Dear Bhumip,

thank you for the information. We know #5 already.

Cloud Services are not related to OPS area per se. Can you please argue shortly for each of the draft below why you think it is relevant for the operation and/or management of IP networks and should be taken care in OPS area and not somewhere else.

Cheers, 
Mehmet 

From: ext Bhumip Khasnabish [mailto:[email-masked]] 
Sent: Wednesday, March 30, 2011 1:17 PM
To: Ersue, Mehmet (NSN - DE/Munich)
Cc: Christopher LILJENSTOLPE; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Sumit Naiksatam (snaiksat); [email-masked]; [email-masked]; [email-masked]; [email-masked]; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked]; [email-masked]; [email-masked]; Clive E Webber; [email-masked]; [email-masked]; [email-masked]; Zeltsan,Zachary; [email-masked]; [email-masked]; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mail!
 to:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Steiner,Moritz; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Subir Das; [email-masked] <mailto:[email-masked]> ; Daryl A Bourke; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] !
 <mailto:[email-masked]> 
Subject: Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on Monday-28-March2011 in Barcelona/Berlin

Mehmet,

Here is the list of the main ones that we originally prepared ...thoughts and comments are welcome..others are being prepared .. Thanks..

1.
Draft Name:  Requirements and Framework for VPN‐Oriented Cloud Services ( 
http://datatracker.ietf.org/doc/draft-so-vpn-o-cs/ <http://datatracker.ietf.org/doc/draft-so-vpn-o-cs/> )
Author/presenter: Ning So
Amount of time requested: 10 minutes
Abstract: This contribution addresses the service providers' requirements to support VPN-Oriented Cloud services. It describes the characteristics of VPN-oriented Cloud Service and specifies the requirement on how to maintain and manage the data center resources for those services.
 
2.
Draft Name:  Network Abstraction for Enterprise and SP Class Cloud (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-rfc-seamless-Cloud-masum-01.txt <http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-rfc-seamless-Cloud-masum-01.txt> ) 
Author/presenter: Masum Hasan
Amount of time requested: 10 minutes
Abstract: In this document we introduce a network related Cloud abstraction called the Seamless Cloud, which facilitates secure and seamless extension of an enterprise (Intranet) into an enterprise and SP grade Cloud. We also introduce Cloud service interfaces and relevant parameters for on-demand manipulation (Create, Read, Update, Delete) of Seamless Cloud.
 
3.
 Draft Name:  Protocol Considerations for Workload Mobility in Clouds (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Protocol%20Considerations%20for%20Workload%20Mobility%20in%20Clouds.txt <http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Protocol%20Considerations%20for%20Workload%20Mobility%20in%20Clouds.txt> )   
Author/presenter: Sundar Iyer/Masum Hasan
Amount of time requested: 10 minutes
Abstract: This analysis considers the migration of application, OS, compute, storage and policy (workloads) within and between service provider, enterprise or 3rd party data centers. Intra-site migration is driven by consolidation scenarios for power, administration and floorspace savings. Inter-site workload migration is motivated by scenarios that exploit more favourable cost structures at specific sites, the placement of workloads closer to where they are consumed or processed to reduce latency, the reduction of site-related downtime, and workload consolidation at fewer sites for power savings. This memo describes how the complexity of the solution is dependent on the characteristics of the workload, the need to preserve policy and service-level information, and the existence, or otherwise, of trust boundaries. This document posits a framework for considering workload migration, in terms of entities involved, rationale for migration, the types of workloads and protocols f!
 or migrating these workloads that consider these factors.
 
4. 
Draft Name:  Service Management for Virtualized Networks (http://www.ietf.org/id/draft-yokota-cloud-service-mobility-01.txt <http://www.ietf.org/id/draft-yokota-cloud-service-mobility-01.txt> ) 
Author/presenter: Hidetoshi YokotaAmount of time requested: 10 minutes
Abstract: Network virtualization technique leveraged by a virtual machine 
makes it possible to dynamically relocate functional entities without topological and physical constraints.  By tapping into this technique, service mobility, which deals with not only functional entities but also sessions established between those entities, will become possible and such capability is especially longed for realizing more scalable and reliable telecom networks.  This document provides the reference model for service mobility in a virtual environment and defines the control protocol between the virtualized platform and the managing controller to realize service mobility.
 
5. 
Draft Name:  Virtual Network Management Information Model (http://tools.ietf.org/id/draft-okita-ops-vnetmodel-03.txt <http://tools.ietf.org/id/draft-okita-ops-vnetmodel-03.txt> )
Author/presenter: Hideki OkitaAmount of time requested: 10 minutesAbstract:  Virtual switches on server virtualization platforms cause a 
problem in managing data center networks containing several hundred switches. Accordingly, a management information model for the network structure of data center networks containing virtual switches is proposed.  The proposed model consists of a physical layer (which represents connections between physical switches) and a virtual layer (which represents connections between virtual switches).  These layers also represent the association of the virtual switch with the corresponding physical switch.  This document also provides an example of the XML-based data model that is implemented according to the proposed information model.

6. 
Draft Name:  Syslog Extension for Cloud   (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-golovinsky-cloud-log-00.txt <http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-golovinsky-cloud-log-00.txt> ) 
Author/presenter: Gene GolovinskyAmount of time requested: 10 minutesAbstract:  This document provides an open and extensible log format to be used by any cloud entity or cloud application to log and trace activities that occur in the cloud. It is equally applicable for cloud infrastructure (IaaS), platform (PaaS), and application (SaaS) services. CloudLog is different in content, but not in nature from the traditional logging as it takes in account transient nature of identities and resources in the cloud.
 
7. 
Draft Name:  Cloud Service Broker (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-shao-cloud-CSB-00.txt <http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-shao-cloud-CSB-00.txt> ) 
Author/presenter:  Hu JieAmount of time requested: 10 minutesAbstract:  This document introduces a Cloud Service Broker (CSB) entity to provide brokering service between different Cloud Service Providers which can be based on private cloud, community cloud, public cloud and hybrid cloud.

8.
Draft Name:  Cloud Reference Framework (http://tools.ietf.org/id/draft-khasnabish-cloud-reference-framework-00.txt <http://tools.ietf.org/id/draft-khasnabish-cloud-reference-framework-00.txt> ) 
Author/presenter:  Bhumip Khasnabish Amount of time requested: 10 minutesAbstract:  This document presents a reference framework for Cloud 
Services, based on the survey of Cloud-based systems and services. Intra-cloud and inter-cloud reference frameworks are developed, and the requirements for each layer are also identified and discussed.

Cheers, 
Mehmet 

From: [email-masked] <mailto:[email-masked]>  [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of ext Bhumip Khasnabish
Sent: Wednesday, March 30, ! 2011 12: 59 AM
To: Christopher LILJENSTOLPE
Cc: [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Sumit Naiksatam (snaiksat); [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Clive E Webber; [email-masked] <mailto:[email-masked]> ; [email-masked]; [email-masked]; Zeltsan,Zachary; [email-masked]; [email-masked]; [email-masked]; TSridhar@ieee.!
 org; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Steiner,Moritz; [email-masked]; [email-masked]; chu.jun! [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Subir Das; shigeru.miyake.uy <http://shigeru.miyake.uy/> @hitachi.com <http://hitachi.com/> ; Daryl A Bourke; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
Subject: Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on Monday-28-March2011 in Barcelona/Berlin

Thanks again.

Best.

Bhumip

On Tue, Mar 29, 2011 at 7:38 AM, Christopher LILJENSTOLPE <[email-masked] <mailto:[email-masked]> > wrote:

	Greetings Ning et al, 

	Please do start the activity on the mailing list sooner rather later (so we can gauge the level of activity here).  Also, as this is the operations wg, we would really like to see input from operators who are using (or attempting) to use this technology in anger, and what the issues are, for example.  Theory is great, practice is better! :)

	Thank's,

	Chris

		All,

		

		
		
		Best regards,
		
		Ning So
		Network Evolution Planning
		Verizon, Inc.
		(office) 972-729-7905 <tel:972-729-7905> 
		(Cell) 972-955-0914 <tel:972-955-0914> 

		-----Original Message-----
		From: Keiichi SHIMA [mailto:[email-masked] <mailto:[email-masked]> ] 
		Sent: Tuesday, March 29, 2011 1:54 AM
		To: Bhumip Khasnabish
		Cc: Keiichi SHIMA; So, Ning; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> .! cn; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;

		Michael.Fargano@qwes! t.com <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; 

		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]!+.cn> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Subir Das; Steiner,
		Moritz; Zeltsan, Zachary
		Subject: Re: PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on
		Monday-28-March2011 in Barcelona/Berlin
		
		Hi all,

		
		---
		Keiichi SHIMA
		Research Laboratory, IIJ Innovation Institute  <[email-masked] <mailto:[email-masked]> > WIDE
		Project <[email-masked] <mailto:[email-masked]> >

			 http://www.ietf.org/proceedings/80/agenda/opsawg.txt <http://www.ietf.org/proceedings/80/agenda/opsawg.txt> 

			Thanks.

			!  

			Best.

			Bhumip

		_______________________________________________
		OPSAWG mailing list
		[email-masked] <mailto:[email-masked]> 
		https://www.ietf.org/mailman/listinfo/opsawg <https://www.ietf.org/mailman/listinfo/opsawg> 

	---

	李柯睿
	Check my PGP key here:
	https://www.asgaard.org/‾cdl/cdl.asc <https://www.asgaard.org/‾cdl/cdl.asc>

---

From: Keiichi SHIMA <[email-masked]>
Date: Wed, 30 Mar 2011 04:51:16 -0700

It seems our draft was not listed in the list Bhumip showed.

Here is the abstract of our draft, for our information.

9.
Draft Name: Network Portability Requirements and Models for Cloud Environment
Author: Keiichi Shima, Yuji Sekiya
Abstract: Recent progress of virtual machine technology made it possible to host various Internet service nodes in a so called cloud environment. The virtual machine hosting technology provides a method to migrate a virtual machine from one hypervisor to another.  However, such a technology is mainly focusing on a migration between hypervisors attached to the same link, and tend not to consider migration over the Internet.  This document mentions the purpose of that type of operation and describe several possible operation methods to provide network portability in cloud systems.

---
Keiichi SHIMA

On Mar 30, 2011, at 4:17 AM, Bhumip Khasnabish wrote:

> Draft Name:  Network Abstraction for Enterprise and SP Class Cloud (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-rfc-seamless-Cloud-masum-01.txt) 
>  Draft Name:  Protocol Considerations for Workload Mobility in Clouds (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Protocol%20Considerations%20for%20Workload%20Mobility%20in%20Clouds.txt)   
> Abstract: This analysis considers the migration of application, OS, compute, storage and policy (workloads) within and between service provider, enterprise or 3rd party data centers. Intra-site migration is driven by consolidation scenarios for power, administration and floorspace savings. Inter-site workload migration is motivated by scenarios that exploit more favourable cost structures at specific sites, the placement of workloads closer to where they are consumed or processed to reduce latency, the reduction of site-related downtime, and workload consolidation at fewer sites for power savings. This memo describes how the complexity of the solution is dependent on the characteristics of the workload, the need to preserve policy and service-level information, and the existence, or otherwise, of trust boundaries. This document posits a framework for considering workload migration, in terms of entities involved, rationale for migration, the types of workloads and protocols for migrating these workloads that consider these factors.
>  
> 4. 
> Draft Name:  Service Management for Virtualized Networks (http://www.ietf.org/id/draft-yokota-cloud-service-mobility-01.txt) 
> Draft Name:  Virtual Network Management Information Model (http://tools.ietf.org/id/draft-okita-ops-vnetmodel-03.txt)
> Draft Name:  Syslog Extension for Cloud   (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-golovinsky-cloud-log-00.txt) 
> Draft Name:  Cloud Service Broker (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-shao-cloud-CSB-00.txt) 
> Draft Name:  Cloud Reference Framework (http://tools.ietf.org/id/draft-khasnabish-cloud-reference-framework-00.txt) 
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Sumit Naiksatam (snaiksat); [email-masked]; [email-masked]; [email-masked]; [email-masked]; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked]; [email-masked]; [email-masked]; Clive E Webber; [email-masked]; [email-masked]; [email-masked]; Zeltsan,Zachary; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Steiner,Moritz; [email-masked]; [email-masked]; chu.jun! [email-masked]; [email-masked]; Subir Das; [email-masked]; Daryl A Bourke; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Michael.Fargano@qwes! t.com; [email-masked]; [email-masked];
>

---

From: "So, Ning" <[email-masked]>
Date: Wed, 30 Mar 2011 20:48:39 +0000

Mehmet,

It is probably better to have each draft’s authors to respond what network operation and management impact their draft may have.  

As the co-author of VPN-o-CS draft, I will list just a couple operations and management implications that draft has on the networks (although the list can be long).

One of the requirements is to have end-to-end VPN-based service management.  That’s in the area of network management.  Another requirement is to have VPN control of how data center resources to be associated to VPN.  Auto-resource provisioning/configuration is certainly a network management issue.

Please let me know if what I have provided is good enough.   

Best regards,

Ning So

Verizon, Inc.

(office) 972-729-7905

(Cell) 972-955-0914

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ersue, Mehmet (NSN - DE/Munich)
Sent: Wednesday, March 30, 2011 6:47 AM
To: ext Bhumip Khasnabish
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Sumit Naiksatam (snaiksat); [email-masked]; [email-masked]; [email-masked]; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked]; [email-masked]; [email-masked]; Clive E Webber; [email-masked]; [email-masked]; [email-masked]; Zeltsan, Zachary; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Christopher LILJENSTOLPE; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Steiner, Moritz; Subir Das; [email-masked]; chu.juns
 heng@zte
Subject: Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM onMonday-28-March2011 in Barcelona/Berlin

Dear Bhumip,

Cloud Services are not related to OPS area per se. Can you please argue shortly for each of the draft below why you think it is relevant for the operation and/or management of IP networks an! d should be taken care in OPS area and not somewhere else.

Cheers, 
Mehmet 

Cc: Christopher LILJENSTOLPE; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Sumit Naiksatam (snaiksat); [email-masked]; [email-masked]; [email-masked]; [email-masked]; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked] <mailto:[email-masked]!%0d%0a%20m> ; [email-masked]; [email-masked]; Clive E Webber; [email-masked]; [email-masked]; [email-masked]; Zeltsan,Zachary; [email-masked]; [email-masked]; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; carl! w@mcsr-l abs.org <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:henry.yu
 @twtelec

Mehmet,

1.
! Draft Na me:  Requirements and Framework for VPN‐Oriented Cloud Services ( 
 
2.
 
3.
 Draft Name:  Protocol Considerations for Workload Mobility in Clouds ( <http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-rfc-seamless-Cloud-masum-01.txt> http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Protocol%20Considerations%20for%20Workload%20Mobility%20in%20Clouds.txt <http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Protocol%20Considerations%20for%20Workload%20Mobility%20in%20Clouds.txt> )   
Author/presenter: Sundar Iyer/Masum Hasan
Amount of time requested: 10 minu! tes
Abstract: This analysis considers the migration of appl! ication, OS, compute, storage and policy (workloads) within and between service provider, enterprise or 3rd party data centers. Intra-site migration is driven by consolidation scenarios for power, administration and floorspace savings. Inter-site workload migration is motivated by scenarios that exploit more favourable cost structures at specific sites, the placement of workloads closer to where they are consumed or processed to reduce latency, the reduction of site-related downtime, and workload consolidation at fewer sites for power savings. This memo describes how the complexity of the solution is dependent on the characteristics of the workload, the need to preserve policy and service-level information, and the existence, or otherwise, of trust boundaries. This document posits a framework for considering workload migration, in terms of entities involved, rationale for migration, the types of workloads and protocols 
 for migr
&n! bsp;
4. 
Draft Name:  Service Management for Virtualized Networks (http://www.ietf.org/id/draft-yokota-cloud-service-mobility-01.txt <http://www.ietf.org/id/draft-yokota-cloud-service-mobility-01.txt> ) 
Author/presenter: Hidetoshi YokotaAmount of time requested: 10 minutes
Abstract: Network virtualization technique leveraged by a virtual machine 
makes it possible to dynamically relocate functional entities without topological and physical constraints.  By tapping into this technique, service mobility, which deals with not only functional entities but also sessions established between those entities, will become possible and such capability is especially longed for realizing more scalable and reliable telecom networks.  This document provides the reference model for service mobility in a virtual environment and defines the control protocol between the virtualized platform and the manag! ing controller to realize service mobility.
 
5. Draft Name:  Virtual Network Management Information Model (http://tools.ietf.org/id/draft-okita-ops-vnetmodel-03.txt <http://tools.ietf.org/id/draft-okita-ops-vnetmodel-03.txt> )
Author/presenter: Hideki OkitaAmount of time requested: 10 minutesAbstract:  Virtual switches on server virtualization platforms cause a 
problem in managing data center networks containing several hundred switches. Accordingly, a management information model for the network structure of data center networks containing virtual switches is proposed.  The proposed model consists of a physical layer (which represents connections between physical switches) and a virtual layer (which represents connections between virtual switches).  These layers also represent the association of the virtual switch with the corresponding physical switch.  This document also provides an example of the XML-based data model that is implement! ed according to the proposed information model.

6. 
 
7. 

8.
Draft Name:  Cloud Reference Framework (http://tools.ietf.org/id/draft-khasnabish-cloud-reference-framework-00.txt <http://tools.ietf.org/id/draft-khasnabish-cloud-reference-framework-00.txt> ) 
Author/presenter:  Bhumip Khasnabish Amount of time requested: 10 minutesAbstract:  This document presents a reference framework for Cloud 
Services, based on the survey of Cloud-based systems and services. Intra-clo! ud and inter-cloud reference frameworks are developed, and the requirements for each layer are also identified and discussed.

! 

Cheers, 
Mehmet 

Cc: ! [email-masked] <mailto:yokota@kddilabs!%0d%0a%20.jp> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Sumit Na! iksatam (snaiksat); [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked]! < /a>; <mailto:vishwas@ipinfusio!%0d%0a%20n.com> [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Clive E Webber; [email-masked] <mailto:[email-masked]> ; [email-masked]; [email-masked]; Zeltsan,Zachary; ma.suan@z! te.com.cn <mailto:[email-masked]
 .cn> ; m

Thanks again.

Best.

Bhumip

	Greetings Ning et al, 

	Thank's,

	Chris

		All,

		foll ow the IETF proc! edure and upload the drafts before deadline, and
		request th! e presen tation slots properly.   

		chann! els of unofficial communication.

		
		
		Best regards,
		
		Ning So

		-----Original Message-! ----
		From: Keiichi SHIMA [mailto:[email-masked] <mailto:kei!%0d%0a%20ichi@iij%0d%0alab.net> ] 
		Sent: Tuesday, March 29, 2011 1:54 AM
		To: Bhumip Khasnabish
		Cc: Keiichi SHIMA; So, Ning; [email-masked];
		[email-masked]; [email-masked]; [email-masked];
		[email-masked]; [email-masked]; [email-masked];
		[email-masked].! cn; [email-masked]; [email-masked];
		[email-masked]; [email-masked]; [email-masked];
		[email-masked]; [email-masked];
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ;
		[email-masked] <mailto:[email-masked]>  ; [email-masked] <mailto:[email-masked]> ;

		[email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; [email-masked];
		[email-masked]; [email-masked];
		[email-masked]; [email-masked];
		[email-masked]; [email-masked];
		s! hao.weix [email-masked] <mailto:[email-masked]!+.cn> ; [email-masked];
		[email-masked]; [email-masked]; [email-masked];
		[email-masked]; [email-masked]; Subir Das; Steiner,
		Moritz; Zeltsan, Zachary
		Subject: Re: PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM on
		Monday-28-March2011 in Barcelona/Berl! in
		
		Hi all,

		there any information ! of the room?
		
		---
		Keiichi SHIMA
		Research Laborator! y, IIJ I nnovation Institute  <[email-masked]> WIDE
		Project <[email-masked]>

			 

		break, if possible/needed, will le! t you know the room number later.

			Thanks.

			!  

			Best.

			Bhumip

		_______________________________________________
		OPSAWG mailing list
		[email-masked] <mailto:OPSAWG@iet!%0d%0a%20f.org> 
		https://www.ietf.org/mailman/listinfo/opsawg

	---

	李柯睿
	Check my PGP key here:
	https://! www.asga ard.org/‾cdl/cdl.asc <https://www.asgaa!%0d%0a%20rd.org/‾cdl/cdl.asc>

---

From: Bhumip Khasnabish <[email-masked]>
Date: Wed, 30 Mar 2011 21:00:56 -0400

Dear Mehmet,

We published a draft "Cloud Industry Workitem Survey Results
(draft-khasnabish-cloud-industry-workitems-survey-00.txt on 31Dec2011
(available at

http://tools.ietf.org/id/draft-khasnabish-cloud-industry-workitems-survey-00.txt)
to
take a snapshot of industry activities related to cloud for the purpose of
doing a gap analysis.

>From the list that I sent earlier, In fact you know about #1 (Ning
presented) and #5 already.

#2 deals with abstraction and extension of Cloud to Enterprise, and
discusses how on-demand operational manipulation (Create, Read, Update,
Delete) can help achieve Seamless Cloud service.

#3 covers operational aspects of migration of application, OS, compute,
storage and policy (workloads) within and between service provider,
enterprise or 3rd party data centers.
#4 covers dynamic operational management for service management in
virtualized Networks with objective to relocate functional entities without
topological and physical constraints.

#5, you already know.

#6 talks about SysLog extension for Cloud services like Infrastructure (IaaS),
platform (PaaS), and application (SaaS). Standardized Log format is required
for auditing and verification purposes which are important parts of
management and operations.

#7 covers Cloud Service Broker (CSB) entity that provides brokering service
between different Cloud Service Providers. Operations and management aspects
of brokering need to be discussed and standardized (
http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-shao-cloud-CSB-00.txt
)

#8 talks about a Cloud Reference Framework that can be utilized to identify
functional and interface points along which the operational and management
solutions/best-practices need to be developed (see e.g, slide 6 in
http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Yokota-Clouds-Telecom-Net-Virtualization-Sept10.pdf)

#9 talks about virtual resource management (
http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/JunSheng-et-al-IETF80-RESTful-based-API-for-VRM-30Mar2011.pdf
)

#10 discusses cloud security framework. It is being developed and we'll
bring it here when ready for publication. Right now only slides are
available
*( *
http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Karavettil-et-al-IETF-Cloud-Security-Framework-11Feb2011_v2.pdf
* )
*
PLS let me know if you need more information and/or clarification.

I encourage each of the authors to send more info if/as needed to you and
others as well.

Thanks a lot.

Best.

Bhumip

> Cloud Services are not related to OPS area per se. Can you please argue
> shortly for each of the draft below why you think it is relevant for the
> operation and/or management of IP networks an! d should be taken care in OPS
> area and not somewhere else.
>
>
>
> Cheers,
> Mehmet
>
>
>
> *From:* ext Bhumip Khasnabish [mailto:[email-masked]]
> *Sent:* Wednesday, March 30, 2011 1:17 PM
> *To:* Ersue, Mehmet (NSN - DE/Munich)
> *Cc:* Christopher LILJENSTOLPE; [email-masked];
> [email-masked]; [email-masked]; Sumit Naiksatam
> (snaiksat); [email-masked]; [email-masked];
> K Iyer; Jeff Young; [email-masked] <[email-masked]!+m>;
> [email-masked]; [email-masked]; Clive E Webber;
> [email-masked]; [email-masked]; [email-masked];
> Zeltsan,Zachary; [email-masked]; [email-masked]; [email-masked];
> [email-masked]; carl! w@mcsr-l abs.org <[email-masked]>;
> [email-masked]; [email-masked];
> [email-masked]; [email-masked] <henry.yu@twteleco!+m.com>;
> [email-masked]; shao.weixiang@! zte.com. cn;
> Steiner,Moritz; [email-masked]; [email-masked] <[email-masked]!+t>;
> [email-masked]; [email-masked]; Subir Das;
> [email-masked]; Daryl A Bourke; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]! ; [email-masked]
>
> *Subject:* Re: [OPSAWG] PLS attend OPSAWG Mtg. between 9 AM and 10:15 AM
> Abstract: This contribution addresses the service providers' requirements
> to support VPN-Oriented Cloud services. It describes the characteristics of
> Abstract: This analysis considers the migration of appl! ication, OS,
> compute, storage and policy (workloads) within and between service provider,
> the virtualized platform and the manag! ing controller to realize service
> mobility.
>
>
> 5. Draft Name:  Virtual Network Management Information Model (
> Author/presenter: Hideki OkitaAmount of time requested: 10
> minutesAbstract:  Virtual switches on server virtualization platforms cause
> a
> implement! ed according to the proposed information model.
>
>
>
> 6.
> Author/presenter:  Hu JieAmount of time requested: 10 minutesAbstract:
> This document introduces a Cloud Service Broker (CSB) entity to provide
> brokering service between different Cloud Service Providers which can be
> based on private cloud, community cloud, public cloud and hybrid cloud.
>
>
> 8.
> Intra-clo! ud and inter-cloud reference frameworks are developed, and the
> requirements for each layer are also identified and discussed.<http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-rfc-seamless-Cloud-masum-01.txt>
>
> Can anybody please summarize the available drafts and their goal in a mail
> before we start many threads at once, which might end up in a chaotic
> discussion.
>
> *From:* [email-masked] [mailto:[email-masked]
> ] *On Behalf Of ext Bhumip Khasnabish
>
> Cc: **! [email-masked] <yokota@kddilabs!+.jp>**; **
> [email-masked]**; [email-masked]**; **
> [email-masked]**; [email-masked]**; Sumit Na!
> iksatam (snaiksat); [email-masked]**; **
> [email-masked]**; [email-masked]**; [email-masked]**;
> Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked]! <
> /a> <vishwas@ipinfusio!+n.com>**; [email-masked]**; **
> [email-masked]**; Clive E Webber; [email-masked]**; **
> [email-masked]; [email-masked]; Zeltsan,Zachary; ma.suan@z!
> te.com.cn <[email-masked]>; [email-masked]; [email-masked];
> [email-masked] <[email-masked]>**; [email-masked]**;
> Subir Das; **shigeru.miyake.uy**@**hitachi.com**; Daryl A Bourke; **
> [email-masked]**; [email-masked]**; [email-masked]**; **
> [email-masked]**; [email-masked]<Zhengping.You@aforesolutions.!+com>
> **; [email-masked]*
> *
> From: Keiichi SHIMA [mailto:[email-masked] <[email-masked]>]
> [email-masked] <[email-masked]>;
> [email-masked];
> [email-masked] ; [email-masked];
>
> s! hao.weix [email-masked] <[email-masked]!+.cn>;
> [email-masked];
> [email-masked] <OPSAWG@iet!+f.org>
> *https://! www.asga ard.org/~cdl/cdl.asc<https://www.asgaa!+rd.org/~cdl/cdl.asc>
> *
>
>
>
>
>
>
>
>
>
>
>

---

From: Keiichi SHIMA <[email-masked]>
Date: Thu, 31 Mar 2011 08:10:57 +0200

Dear Bhmuip, Mehmet, and all

On Mar 31, 2011, at 3:00 AM, Bhumip Khasnabish wrote:

> I encourage each of the authors to send more info if/as needed to you and others as well.

Our draft 'draft-shima-clouds-net-portability-reqs-and-models-00' talks about network resource mobility technology between data centers to provide transparent network environment to virtual machines when migrating one hypervisor to other hypervisor located in a different data center.

There are several ways to achieve the above objective.  So we are trying to define requirements for that kind of operations and categorize possible deployment patterns that can be used for the operation.  Also the draft tries to list some of the actual deployment scenarios to have some kind of consensus of parameters of the network migration operation.  If we can have consensus, we will achieve flexible management of VM migration in a VM service provider and even between different VM service providers when resource is not enough temporarily.

I think the above topic fits to opsawg (or at least ops & mgmt area).  I want to know what other people think.

Best Regards,
---
Keiichi SHIMA

On Mar 31, 2011, at 3:00 AM, Bhumip Khasnabish wrote:

> Dear Mehmet,
>  
> We published a draft "Cloud Industry Workitem Survey Results (draft-khasnabish-cloud-industry-workitems-survey-00.txt on 31Dec2011 (available at
> http://tools.ietf.org/id/draft-khasnabish-cloud-industry-workitems-survey-00.txt ) to take a snapshot of industry activities related to cloud for the purpose of doing a gap analysis.  
>  
> From the list that I sent earlier, In fact you know about #1 (Ning presented) and #5 already.
>  
> #2 deals with abstraction and extension of Cloud to Enterprise, and discusses how on-demand operational manipulation (Create, Read, Update, Delete) can help achieve Seamless Cloud service.
>  
> #3 covers operational aspects of migration of application, OS, compute, storage and policy (workloads) within and between service provider, enterprise or 3rd party data centers.
> #4 covers dynamic operational management for service management in virtualized Networks with objective to relocate functional entities without topological and physical constraints.
>  
> #5, you already know.
>  
> #6 talks about SysLog extension for Cloud services like Infrastructure (IaaS), platform (PaaS), and application (SaaS). Standardized Log format is required for auditing and verification purposes which are important parts of management and operations.
>  
> #7 covers Cloud Service Broker (CSB) entity that provides brokering service between different Cloud Service Providers. Operations and management aspects of brokering need to be discussed and standardized (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/draft-shao-cloud-CSB-00.txt)
> 
> #8 talks about a Cloud Reference Framework that can be utilized to identify functional and interface points along which the operational and management solutions/best-practices need to be developed (see e.g, slide 6 in
> #9 talks about virtual resource management (http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/JunSheng-et-al-IETF80-RESTful-based-API-for-VRM-30Mar2011.pdf)
>  
> #10 discusses cloud security framework. It is being developed and we'll bring it here when ready for publication. Right now only slides are available
> ( http://trac.tools.ietf.org/area/app/trac/attachment/wiki/Clouds/Karavettil-et-al-IETF-Cloud-Security-Framework-11Feb2011_v2.pdf )
> I encourage each of the authors to send more info if/as needed to you and others as well.
>  
> Thanks a lot.
>  
> Best.
>  
> Bhumip
> 
> 
>  
> Cc: Christopher LILJENSTOLPE; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Sumit Naiksatam (snaiksat); [email-masked]; [email-masked]; [email-masked]; [email-masked]; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked]; [email-masked]; [email-masked]; Clive E Webber; [email-masked]; [email-masked]; [email-masked]; Zeltsan,Zachary; [email-masked]; [email-masked]; [email-masked]; [email-masked]; carl! w@mcsr-l abs.org; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; shao.weixiang@! zte.com. cn; [email-masked]; [email-masked]; Steiner,Moritz; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Subir Das; [email-masked]; Daryl A Bourke; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]! ; [email-masked]
> 
> 
> Abstract: This analysis considers the migration of appl! ication, OS, compute, storage and policy (workloads) within and between service provider, enterprise or 3rd party data centers. Intra-site migration is driven by consolidation scenarios for power, administration and floorspace savings. Inter-site workload migration is motivated by scenarios that exploit more favourable cost structures at specific sites, the placement of workloads closer to where they are consumed or processed to reduce latency, the reduction of site-related downtime, and workload consolidation at fewer sites for power savings. This memo describes how the complexity of the solution is dependent on the characteristics of the workload, the need to preserve policy and service-level information, and the existence, or otherwise, of trust boundaries. This document posits a framework for considering workload migration, in terms of entities involved, rationale for migration, the types of workloads and protocols for migrating these workloads that consider these factors.
> &n! bsp;
> 
> 4. 
> Cc: ! [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Sumit Na! iksatam (snaiksat); [email-masked]; [email-masked]; [email-masked]; [email-masked]; Masum Hasan (masum); Sundar K Iyer; Jeff Young; [email-masked]! < /a>; [email-masked]; [email-masked]; Clive E Webber; [email-masked]; [email-masked]; [email-masked]; Zeltsan,Zachary; ma.suan@z! te.com.cn; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Steiner,Moritz; [email-masked]; [email-masked]; chu.jun! [email-masked]; [email-masked]; Subir Das; [email-masked]; Daryl A Bourke; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
> 
> s! hao.weix [email-masked]; [email-masked];
> https://! www.asga ard.org/~cdl/cdl.asc
> 
>  
> 
> 
>  
> 
> 
> 
>  
> 
> 
>