Subject: Re: [OPSAWG] Using YANG and its extension for Complex Types in draft-okita-ops-vnetmodel

From: <[email-masked]>
Date: Wed, 30 Mar 2011 19:57:51 +0900

Mehmet,

Many thanks for your announcement about "Yang extension".
As you said, we can now get the draft as RFC 6095 from following URL.

http://tools.ietf.org/html/rfc6095
or final draft from
http://tools.ietf.org/html/draft-linowski-netmod-yang-abstract-05

As you told me, several classes in the "Physical Network Resource 
Model", for example, "PhysicalResource" and "PhysicalLink" have 
similar meanings with the classes in my draft. It seems that
I can reuse these classes.

I will try to make a YANG(-extension) datamodel with the method 
provided in the RFC.

Best regards,

Hideki Okita

>Dear Hideki,
>
>as I commented in the OPSAWG session on Monday morning I would see it
>valuable if you would use YANG as the modeling language for the
>information model in your draft.
>
>I believe the YANG extension for Complex Types, which has been published
>today (a few hours ago :) as RFC 6095, will further ease your life as it
>supports the top-down modeling approach with class inheritance. Base
>classes you are using are already defined in this RFC and can be further
>reused.
>
>Please let me and Bernd know if you need help for modeling with YANG and
>its extensions.
>
>PS: Please check http://code.google.com/p/pyang-ct/ for an open source
>validation tool for YANG Complex Types.
>
>Cheers, 
>Mehmet 
>
>
>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]] On Behalf Of ext
>[email-masked]
>Sent: Tuesday, March 29, 2011 10:51 AM
>To: [email-masked]; [email-masked]
>Cc: [email-masked]
>Subject: RFC 6095 on Extending YANG with Language Abstractions
>
>
>A new Request for Comments is now available in online RFC libraries.
>
>        
>        RFC 6095
>
>        Title:      Extending YANG with Language Abstractions 
>        Author:     B. Linowski, M. Ersue,
>                    S. Kuryla
>        Status:     Experimental
>        Stream:     IETF
>        Date:       March 2011
>        Mailbox:    [email-masked], 
>                    [email-masked], 
>                    [email-masked]
>        Pages:      75
>        Characters: 140259
>        Updates/Obsoletes/SeeAlso:   None
>
>        I-D Tag:    draft-linowski-netmod-yang-abstract-05.txt
>
>        URL:        http://www.rfc-editor.org/rfc/rfc6095.txt
>
>YANG -- the Network Configuration Protocol (NETCONF) Data Modeling
>Language -- supports modeling of a tree of data elements that
>represent the configuration and runtime status of a particular
>network element managed via NETCONF.  This memo suggests enhancing
>YANG with supplementary modeling features and language abstractions
>with the aim to improve the model extensibility and reuse.  
>This document defines an Experimental Protocol for the Internet
>community.
>
>
>EXPERIMENTAL: This memo defines an Experimental Protocol for the
>Internet community.  It does not specify an Internet standard of any
>kind. Discussion and suggestions for improvement are requested.
>Distribution of this memo is unlimited.
>
>This announcement is sent to the IETF-Announce and rfc-dist lists.
>To subscribe or unsubscribe, see
>  http://www.ietf.org/mailman/listinfo/ietf-announce
>  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
>
>For searching the RFC series, see
>http://www.rfc-editor.org/rfcsearch.html.
>For downloading RFCs, see http://www.rfc-editor.org/rfc.html.
>
>Requests for special distribution should be addressed to either the
>author of the RFC in question, or to [email-masked].  Unless
>specifically noted otherwise on the RFC itself, all RFCs are for
>unlimited distribution.
>
>
>The RFC Editor Team
>Association Management Solutions, LLC
>
>
>_______________________________________________
>IETF-Announce mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ietf-announce
>

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 30 Mar 2011 13:11:25 +0200

Dear Hideki,

please use RFC 6095 only as this the official document and 
has quite a few corrections compared to the draft version.

We would be happy to help or review your draft model. 

Cheers, 
Mehmet 

> From: ext [email-masked]
> [mailto:[email-masked]]
> Sent: Wednesday, March 30, 2011 12:58 PM
> To: Ersue, Mehmet (NSN - DE/Munich)
> Cc: [email-masked]; [email-masked]; Linowski,
Bernd
> (EXT-Other - DE)
> Subject: Re:Using YANG and its extension for Complex Types in draft-
> okita-ops-vnetmodel
> 
> Mehmet,
> 
>

---

From: <[email-masked]>
Date: Wed, 30 Mar 2011 20:33:26 +0900

Mehmet,

Thank you for your notice. I will refer RFC 6095.

Regards,

Hideki Okita