Subject: Re: [OPSAWG] WGLC draft-ietf-opsawg-mib-floats

From: Dave Shield <[email-masked]>
Date: Fri, 1 Apr 2011 12:54:59 +0100

On Thu, 31 Mar 2011 17:15:58 +0200 Juergen wrote:
JQ> I have read the draft and have only one question:
JQ> Would the byte order (endianness) in the octet arrays be obvious to an
JQ> implementor? Or could there be incompatibilities between big-endian and
JQ> little-endian implementations?

On 31 March 2011 17:28, Robert Story <[email-masked]> wrote:
RS> I asked about this back in December

Given that two (more-than-averagely-clueful) readers of the draft
have come up with the same question,  perhaps this is an indication
that the answer could do with being a little clearer.

On Mon, 6 Dec 2010 13:07:18 -0800 Randy wrote:
RP>  I specifically said "interchange format"
RP> for IEEE floats, since that *does* specify that the sign bit comes
RP> first.  For a freely-available secondary reference, see
RP> http://en.wikipedia.org/wiki/IEEE_754-2008#Interchange_formats

I can't help feeling that I'm missing something here,
but I'm not sure whether this actually answers the question.

That wikipedia reference says

    "The encoding scheme for these binary interchange formats
     [of floating point data] is the same as that of IEEE 754-1985:
     a sign bit, followed by w exponent bits that describe the exponent
     offset by a bias, and p-1 bits that describe the significand. "

So the sign bit comes first, followed by the exponent
and finally the significand.
    But are the exponent and significand bits in LSB or MSB
order?   Or is this implementation specific?

As far as I can tell from
   http://en.wikipedia.org/wiki/Endianness#Floating-point_and_endianness
the IEEE spec is ambiguous here:

      "..the widespread IEEE 754 floating point standard does not specify
      endianness. Theoretically, this means that not even standard IEEE
      floating point data written by one machine may be readable by another."

If the intention is that floating point values should be represented in
network byte order  (which seems the most natural approach), then
shouldn't this document say so explicitly?

Dave

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 10 Apr 2011 21:01:14 -0700

Hi -

As editor, I'd like to propose the following text to address the comments
about endianness, to be added at the end of section 1:

  <t>
  All of these textual conventions employ the binary interchange format
  defined in <xref target="IEEE.754.2008"></xref>.
  Specifically, this means that for all of them, the highest-order bit of
  the first byte is the sign bit, with the remaining bits of the octet string
  corresponding to the exponent and fraction parts, in network byte order.
  </t>

As a technical contributor, I'd like to propose the following addition
to the end of the bullet list in section 3:
  <t>
  Whenever these textual conventions are used in a MIB mopdule, the
  associated DESCRIPTION clause  MUST clearly specify whether
  denormalized numbers, NaNs ("not a number") or infinities are
  permitted, along with any special semantics associated  with these
  cases.  This is especially important for writeable objects.
  </t>

Comments?

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 13 Apr 2011 11:56:06 -0700

Hi -

We've reached the end of the time allocated for WG last call
on this document.

Two changes (see below) were proposed.

Are there any objections to including these two changes in an
update to draft-ietf-opsawg-mib-floats- at this time?
I do not believe that either of these changes would
necessitate a second WG last call, and that we should
then be ready for hand-off to the IESG.

(I've already noted the need for the editorial correction of
"mopdule" to "module" :-)

Randy

----- Original Message ----- 
> From: "Randy Presuhn" <[email-masked]>
> To: <[email-masked]>
> Sent: Sunday, April 10, 2011 9:01 PM
> Subject: Re: [OPSAWG] WGLC draft-ietf-opsawg-mib-floats
>
> Hi -
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Robert Story <[email-masked]>
Date: Wed, 13 Apr 2011 22:52:35 -0400

On Wed, 13 Apr 2011 11:56:06 -0700 Randy wrote:
RP> We've reached the end of the time allocated for WG last call
RP> on this document.
RP> 
RP> Two changes (see below) were proposed.
RP> 
RP> Are there any objections to including these two changes in an
RP> update to draft-ietf-opsawg-mib-floats- at this time?
RP> I do not believe that either of these changes would
RP> necessitate a second WG last call, and that we should
RP> then be ready for hand-off to the IESG.

I support both changes.

--
Senior Software Engineer
SPARTA (dba Cobham Analytic Soloutions)