Subject: [OPSAWG] Fw: I-D Action:draft-khasnabish-cloud-industry-workitems-survey-00.txt

From: Bhumip Khasnabish <[email-masked]>
Date: Sat, 16 Apr 2011 17:10:58 -0400

*FYI and comments, if any.. Thanks.*
**
*===================================================================*

   - *To*: i-d-announce at ietf.org <[email-masked]>
   - *Subject*: I-D
   Action:draft-khasnabish-cloud-industry-workitems-survey-00.txt
   - *From*: Internet-Drafts at ietf.org <[email-masked]>
   - * *

 ------------------------------

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Cloud Industry Workitem Survey Results
	Author(s)       : B. Khasnabish, et al.
	Filename        : draft-khasnabish-cloud-industry-workitems-survey-00.txt
	Pages           : 164
	Date            : 2010-12-31

At the IETF 77 Clouds Bar BoF, it was suggested that an internet
draft on survey of standard organizations and working groups that are
focusing on cloud-based systems and services be prepared.  The
objective is to take a snapshot of industry activities related to
cloud features and functions for the purpose of creating a gap
analysis.  This document is that survey on industry work items.  At
the end of this survey a section on work item analysis is presented.

A URL for this Internet-Draft
is:http://www.ietf.org/internet-drafts/draft-khasnabish-cloud-industry-workitems-survey-00.txt

Internet-Drafts are also available by anonymous FTP
at:ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

<ftp://ftp.ietf.org/internet-drafts/draft-khasnabish-cloud-industry-workitems-survey-00.txt><ftp://ftp.ietf.org/internet-drafts/draft-khasnabish-cloud-industry-workitems-survey-00.txt>

---

From: Ronald Bonica <[email-masked]>
Date: Mon, 18 Apr 2011 13:05:52 -0400

Bhumip,

In the abstract, you say:

  At the IETF 77 Clouds Bar BoF, it was suggested that an internet
  draft on survey of standard organizations and working groups that are
   focusing on cloud-based systems and services be prepared.

That would have been a laudable goal. Such a draft would give the IETF insight regarding SDOs with which the it needs to interact regarding clouds work. However, I don't see mention of another SDO in the body of the document. I do, however, see mention of many cloud vendors. What is the real purpose of this document? Why are so many bits dedicated to advertising specific vendors? (At the risk of ignoring others?)

In Section 3 of your document, you enumerate the work items associated with the clouds effort. In my mind, this is very interesting, but probably not for the reasons that you would expect. I think that it would be very helpful if a group of cloud operators were to get together to determine which of those items were proper object of standardization and which were best left for proprietary innovation.

In any event, in its current state, I don't think that this draft is in good enough condition to be adopted as a WG work item.

                                                                                                                Ron
                                                                                                                / speaking as individual contributor

---

From: Bhumip Khasnabish <[email-masked]>
Date: Mon, 18 Apr 2011 13:45:00 -0400

Ron,

Thanks for looking into this. PLS note that there is another draft surveying

the  other clouds related SDOs
(
http://www.ietf.org/internet-drafts/draft-khasnabish-cloud-sdo-survey-00.txt )

I agree that I should have sent that doc/draft earlier.

PLS note that there is no intention to exclude any specific Cloud suppliers
or operators.
We'll update the document based on comments and inputs.
We are just trying to capture the major relevant work items and issues.

Once again thanks and look fwd to you further comments and suggestions.

==============================================================

   - *To*: i-d-announce at ietf.org <[email-masked]>
   - *Subject*: I-D Action:draft-khasnabish-cloud-sdo-survey-00.txt
   - *From*: Internet-Drafts at ietf.org <[email-masked]>
   - * *
   ------------------------------

	Title           : Cloud SDO Activities Survey and Analysis
	Author(s)       : B. Khasnabish, C. JunSheng
	Filename        : draft-khasnabish-cloud-sdo-survey-00.txt
	Pages           : 49
	Date            : 2010-12-30

At the IETF 77 Clouds Bar BoF, it was suggested that an internet
draft on survey of standard organizations and working groups that are
focusing on cloud-based systems and services be prepared.  The
objective is to take a snapshot of industry activities related to
cloud features and functions for the purpose of creating a gap
analysis.  This document is that survey.  At the end of this survey a
section on gap analysis is presented.

A URL for this Internet-Draft
is:http://www.ietf.org/internet-drafts/draft-khasnabish-cloud-sdo-survey-00.txt

<ftp://ftp.ietf.org/internet-drafts/draft-khasnabish-cloud-sdo-survey-00.txt><ftp://ftp.ietf.org/internet-drafts/draft-khasnabish-cloud-sdo-survey-00.txt>

==============================================================

On Mon, Apr 18, 2011 at 1:05 PM, Ronald Bonica <[email-masked]> wrote:

> That would have been a laudable goal. Such a draft would give the IETF
> insight regarding SDOs with which the it needs to interact regarding clouds
> work. However, I don’t see mention of another SDO in the body of the
> document. I do, however, see mention of many cloud vendors. What is the real
> purpose of this document? Why are so many bits dedicated to advertising
> specific vendors? (At the risk of ignoring others?)
>
>
>
> In Section 3 of your document, you enumerate the work items associated with
> the clouds effort. In my mind, this is very interesting, but probably not
> for the reasons that you would expect. I think that it would be very helpful
> if a group of cloud operators were to get together to determine which of
> those items were proper object of standardization and which were best left
> for proprietary innovation.
>
>
>
> In any event, in its current state, I don’t think that this draft is in
> good enough condition to be adopted as a WG work item.
>
>
>
>
>                                                                                                          Ron
>
>

---

From: Ronald Bonica <[email-masked]>
Date: Mon, 18 Apr 2011 14:53:15 -0400

Bhumip,

In that case, what is the goal of the industry-workitems-survey. It is very odd for an IETF draft to enumerate all of the vendors working in a specific area.

I think that this draft would make more sense if you did the following:

-          Expand Section 3 to describe what each work item is.

-          Delete Section 4, with all of its references to vendors

-          Write a new Section 4, which discusses whether each work item should be the object of standardization.

                                                                                                                           Ron
                                                                                                                          /still speaking as an individual contributor

From: Bhumip Khasnabish [mailto:[email-masked]]
Sent: Monday, April 18, 2011 1:45 PM
To: Ronald Bonica
Cc: [email-masked]
Subject: Re: [OPSAWG] Fw: I-D Action:draft-khasnabish-cloud-industry-workitems-survey-00.txt

Ron,

Thanks for looking into this. PLS note that there is another draft surveying
the  other clouds related SDOs
( http://www.ietf.org/internet-drafts/draft-khasnabish-cloud-sdo-survey-00.txt )
I agree that I should have sent that doc/draft earlier.

PLS note that there is no intention to exclude any specific Cloud suppliers or operators.
We'll update the document based on comments and inputs.
We are just trying to capture the major relevant work items and issues.

 *   To: i-d-announce at ietf.org<mailto:[email-masked]>
 *   Subject: I-D Action:draft-khasnabish-cloud-sdo-survey-00.txt
 *   From: Internet-Drafts at ietf.org<mailto:[email-masked]>
 *

________________________________

        Pages           : 49

        Date            : 2010-12-30

A URL for this Internet-Draft is:

http://www.ietf.org/internet-drafts/draft-khasnabish-cloud-sdo-survey-00.txt

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/

Internet-Draft.

==============================================================
On Mon, Apr 18, 2011 at 1:05 PM, Ronald Bonica <[email-masked]<mailto:[email-masked]>> wrote:
Bhumip,

                                                                                                                Ron

---

From: Bhumip Khasnabish <[email-masked]>
Date: Mon, 18 Apr 2011 18:57:00 -0400

Ron,

Thanks for this suggestion.

Sure, in the new version of the workitem draft, we'll expand Sec.3 descibing
each proposed/potentail work item in details,and will put info on advantages
of standarizing these items in the new Sec.4.

On Mon, Apr 18, 2011 at 2:53 PM, Ronald Bonica <[email-masked]> wrote:

>  Bhumip,
>
>
>
> In that case, what is the goal of the industry-workitems-survey. It is very
> odd for an IETF draft to enumerate all of the vendors working in a specific
> area.
>
>
>
> *From:* Bhumip Khasnabish [mailto:[email-masked]]
> *Sent:* Monday, April 18, 2011 1:45 PM
> *To:* Ronald Bonica
> *Cc:* [email-masked]
> *Subject:* Re: [OPSAWG] Fw: I-D

---

From: Christopher Liljenstolpe <[email-masked]>
Date: Mon, 18 Apr 2011 19:24:50 -0500

Greetings,

I agree with Ron here.  The number of vendors entering and leaving this space would makemany such list immediately dated, and therefore the wg item would have a very short relevance period.  Couple that with the fact that the ietf does not work with vendors but with concepts and individuals, and no other draft I can remember enumerating vendors, would lead to the existing section 4 being lethal.  Other operators on this list, please speak up if I am off base

Chris

Sent from a slightly less silly keyboard.

On 18 Apr 2011, at 13:53, Ronald Bonica <[email-masked]> wrote:

> To: i-d-announce at ietf.org
> Subject: I-D Action:draft-khasnabish-cloud-sdo-survey-00.txt
> From: Internet-Drafts at ietf.org
>  
> <ftp://ftp.ietf.org/internet-drafts/draft-khasnabish-cloud-sdo-survey-00.txt>
> 
>  
> 
>  
> 
> That would have been a laudable goal. Such a draft would give the IETF insight regarding SDOs with which the it needs to interact regarding clouds work. However, I don’t see mention of another SDO in the body of the document. I do, however, see mention of many cloud vendors. What is the real purpose of this document? Why are so many bits dedicated to advertising specific vendors? (At the risk of ignoring others?)
> 
>  
> 
> In any event, in its current state, I don’t think that this draft is in good enough condition to be adopted as a WG work item.
> 
>  
> 
>                                                                                                                 Ron
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Melinda Shore <[email-masked]>
Date: Mon, 18 Apr 2011 16:50:13 -0800

On Mon, Apr 18, 2011 at 4:24 PM, Christopher Liljenstolpe
<[email-masked]> wrote:
> Greetings,
> I agree with Ron here.  The number of vendors entering and leaving this
> space would makemany such list immediately dated, and therefore the wg item
> would have a very short relevance period.

I'm having a hard time with the entire document. With the whole project,
to be honest.  It seems like a fishing expedition to try and figure out
something that somebody can work on to get a document published, rather
than being driven by a problem that someone's identified and wants to
solve collaboratively.  Section 4 is obviously not something that belongs
in an IETF document, but Section 3 could use significant refinement (and
a pair of scissors) as well.

You'd think that some sort of architecture with defined interfaces would
drive the work, or that at least there'd be some reference to the work being
done out of NIST, but there's really nothing, just a massive amount of text
with a distinctly marketing-ish tone.  If this is intended to lead to cloud
standards/BCPs/whatever being developed in the IETF I think it really needs to
ditch the marketing-speak, identify an architecture and interfaces, and
focus, focus, focus.

Melinda

---

From: Bhumip Khasnabish <[email-masked]>
Date: Tue, 19 Apr 2011 11:57:57 -0400

Thanks Chris. Yes, planning to update the doc. using Ron's suggestions
(update sec 3 and new Sec. with relevance to IETF).
We look forward to both suggestions and contributions from others (suppliers
and operators in this effort.

On Mon, Apr 18, 2011 at 8:24 PM, Christopher Liljenstolpe
<[email-masked]>wrote:

> would have a very short relevance period.  Couple that with the fact that
> the ietf does not work with vendors but with concepts and individuals, and
> no other draft I can remember enumerating vendors, would lead to the
> existing section 4 being lethal.  Other operators on this list, please speak
> up if I am off base
>
>
>
> Chris
>
> <
> ftp://ftp.ietf.org/internet-drafts/draft-khasnabish-cloud-sdo-survey-00.txt

---

From: Bhumip Khasnabish <[email-masked]>
Date: Tue, 19 Apr 2011 12:06:34 -0400

We look forward to you contributions in this effort Melinda.

Kindly note that *we recently prepared and published a document related to
Cloud reference architecture *(see below for details). We look forward to
your *contributions* to take it to the next level.. (by the way NIST refers
to this doc as well).

==============================================================
  *To*: i-d-announce at ietf.org <[email-masked]>

   - *Subject*: I-D Action:draft-khasnabish-cloud-reference-framework-00.txt

	Title           : Cloud Reference Framework
	Author(s)       : B. Khasnabish, et al.
	Filename        : draft-khasnabish-cloud-reference-framework-00.txt
	Pages           : 27
	Date            : 2010-12-31

During IETF 78 Clouds Bar BoF, it was observed that there is no
standard reference framework for Cloud Services.  Based on the survey
of Cloud-based systems and services (draft-Khasnabish-cloud-sdo-
survey-00, draft-khasnabish-cloud-Industry-workitems-survey-00),
intra-cloud and inter-cloud reference frameworks are developed and
presented in this document.  The requirements of each layer are also
identified and discussed.

A URL for this Internet-Draft
is:http://www.ietf.org/internet-drafts/draft-khasnabish-cloud-reference-framework-00.txt

<ftp://ftp.ietf.org/internet-drafts/draft-khasnabish-cloud-reference-framework-00.txt><ftp://ftp.ietf.org/internet-drafts/draft-khasnabish-cloud-reference-framework-00.txt>
================================================================

---

From: Melinda Shore <[email-masked]>
Date: Tue, 19 Apr 2011 08:33:46 -0800

On 4/19/11 8:06 AM, Bhumip Khasnabish wrote:
> Kindly note that /*we recently prepared and published a document related
> to Cloud reference architecture*/

Good!  Put a reference to it into your other documents, and figure out
how to turn the "work items" document into a technical document (or
drop it in favor of a problem definition/statement).  I  note that your
framework draft contains no references, either, and given the work
being done by/with NIST that seems like a serious oversight,
particularly since your premise appears to be (??) that there's work
needed on cloud standards that's being unaddressed elsewhere.

 > We look forward to you contributions in this effort Melinda.

Honestly, I'm not sure that there's that much here that's appropriate
for the IETF.  As I mentioned the ARP problem looks relevant but you've
buried it in a lot of random stabbing around.  Maybe it would be a good
idea to find someone with more IETF experience to help you get the
documents narrowed, scoped, and focused.

Melinda

---

From: Bhumip Khasnabish <[email-masked]>
Date: Tue, 19 Apr 2011 12:43:46 -0400

Thanks for your comments, suggestion, and inputs. Yes, NIST is aware of
these drafts, and they continue to monitor what we are doing in IETF in this
area. We are working on 'getting the documents narrowed, scoped, and
focused." Your contributions would be highly appreciated.

---

From: Melinda Shore <[email-masked]>
Date: Tue, 19 Apr 2011 08:52:56 -0800

On 4/19/11 8:43 AM, Bhumip Khasnabish wrote:
> these drafts,  [ ... ]

No, no.  What I wrote:

"I  note that your
framework draft contains no references, either, and given the work
being done by/with NIST that seems like a serious oversight,
particularly since your premise appears to be (??) that there's work
needed on cloud standards that's being unaddressed elsewhere."

There's nothing in your documents to either point the reader at
other work or to suggest that you're familiar with other ongoing
work, let alone any attempt to describe a relationship between work
being done elsewhere and what you're apparently thinking about.

Melinda

---

From: Bhumip Khasnabish <[email-masked]>
Date: Tue, 19 Apr 2011 13:03:04 -0400

There are other drafts/work-in-progress-docs that describe these... PLS see
the following email in this distribution list

*http://www.ietf.org/mail-archive/web/opsawg/current/msg01593.html *
**
and the follwing
*http://tools.ietf.org/id/draft-khasnabish-cloud-sdo-survey-00.txt*
<http://www.ietf.org/mail-archive/web/opsawg/current/msg01511.html>

---

From: Melinda Shore <[email-masked]>
Date: Tue, 19 Apr 2011 09:18:59 -0800

On 4/19/11 9:03 AM, Bhumip Khasnabish wrote:
> There are other drafts/work-in-progress-docs that describe these... PLS
> see the following email in this distribution list
> _http://www.ietf.org/mail-archive/web/opsawg/current/msg01593.html _

All I'm asking is that you provide references/citations in your
documents, both to provide some context and to suggest that there
is, in fact, some familiarity and even possibly some relationship
to other ongoing work.  There's no way you're going to get these
published without references, anyway, but assuming that what
you're trying to do here is make a case for the work, you need to
actually try to make a case for the work, and that includes
providing context.

Melinda

---

From: Bhumip Khasnabish <[email-masked]>
Date: Tue, 19 Apr 2011 16:10:49 -0400

Sure, will do this (that is add ref/citations) in the next version of this
draft. Other suggestions are also welcome.