Subject: [OPSAWG] Problem statement on setting up dynamic virtual network

From: MichaelKo <[email-masked]>
Date: Tue, 14 Jun 2011 20:59:32 -0700

I have submitted a new IETF draft titled "Problem Statement for Setting Up Dynamic Virtual Networks". 

Link to the draft is here: http://datatracker.ietf.org/doc/draft-ko-dvn-problem-statement/

The abstract is as follows:

"This document examines the problems and challenges associated with the process of setting up secure virtual network connections among authorized network nodes.  The network nodes can be located anywhere in a private or public network, directly connected or behind one or more levels of NAT.  Setting up a secure virtual network in this environment entails the resolution of various issues such as authentication, peer discovery, virtual network address management, and connection parameters determination."

Some background information:  At the OPSAWG meeting in IETF 79, Margaret Wasserman presented materials related to the IETF drafts (*) that she co-authored.  She was subsequently asked to produce a problem statement and to continue the work within OPSAWG.  This IETF draft is a continuation of that work.

Your comments and suggestions are most welcome.

Mike

(*) "Dynamic Virtual Network Engine (DVNE) Protocol" (draft-mrw-dvne-prot-00) and "Dynamic Virtual Network Engine (DVNE) Framework" (draft-mrw-dvne-fw-00)

---

From: Tina Tsou <[email-masked]>
Date: Wed, 15 Jun 2011 00:16:18 -0600

Michael,
Let me know whether this draft targeted to Routing Area is relevant to
yours.
https://datatracker.ietf.org/doc/draft-yu-ircat-problem-statement/

We keep our promises with one another - no matter what!

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
MichaelKo
Sent: Tuesday, June 14, 2011 10:00 PM
To: [email-masked]; [email-masked]
Subject: [OPSAWG] Problem statement on setting up dynamic virtual network

I have submitted a new IETF draft titled "Problem Statement for Setting Up
Dynamic Virtual Networks". 

Link to the draft is here:
http://datatracker.ietf.org/doc/draft-ko-dvn-problem-statement/

"This document examines the problems and challenges associated with the
process of setting up secure virtual network connections among authorized
network nodes.  The network nodes can be located anywhere in a private or
public network, directly connected or behind one or more levels of NAT.
Setting up a secure virtual network in this environment entails the
resolution of various issues such as authentication, peer discovery, virtual
network address management, and connection parameters determination."

Some background information:  At the OPSAWG meeting in IETF 79, Margaret
Wasserman presented materials related to the IETF drafts (*) that she
co-authored.  She was subsequently asked to produce a problem statement and
to continue the work within OPSAWG.  This IETF draft is a continuation of
that work.

Mike

(*) "Dynamic Virtual Network Engine (DVNE) Protocol"
(draft-mrw-dvne-prot-00) and "Dynamic Virtual Network Engine (DVNE)
Framework" (draft-mrw-dvne-fw-00)
_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: Michael Ko <[email-masked]>
Date: Wed, 15 Jun 2011 16:18:00 -0700

Tina,

If I understand it correctly, the "IRCAT Problem Statement" draft discusses the problem of forming a cooperative router group from heterogeneous routers so that routers from different companies can interoperate.  The emphasis is the need for a protocol to manage and coordinate this cooperative router group.

My draft deals with the problem on setting up dynamic virtual networks among authorized network nodes.  Conceptually, a relevant model is the iSNS which defines a protocol and a server to coodinate the setting up of connections among storage nodes by emulating Fibre Channel fabric services.  This is the model which would be useful for setting up connections among authorized network nodes from a scalability viewpoint.

Mike
  ----- Original Message ----- 
  From: Tina Tsou 
  To: 'MichaelKo' ; [email-masked] 
  Sent: Tuesday, June 14, 2011 11:16 PM
  Subject: RE: [OPSAWG] Problem statement on setting up dynamic virtual network

  Michael,

  Best Regards,
  Tina TSOU

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]] On Behalf Of
  MichaelKo
  Sent: Tuesday, June 14, 2011 10:00 PM
  To: [email-masked]; [email-masked]
  Subject: [OPSAWG] Problem statement on setting up dynamic virtual network

  Mike