Subject: Re: [OPSAWG] WGLC draft-ietf-opsawg-management-stds

From: David Harrington <[email-masked]>
Date: Thu, 02 Feb 2012 09:12:27 -0500

That's better.
Thanks,
--
David Harrington
Director, Transport Area
Internet Engineering Task Force (IETF)
[email-masked]
+1-603-828-1401

On 1/30/12 2:30 PM, "Ersue, Mehmet (NSN - DE/Munich)"
<[email-masked]> wrote:

>Hi David,
>
>> >> NEW:
>> >> An agent entity can restrict access to a certain portion of its
>MIB,
>> >> e.g.
>> >> restrict some manager principals to view performance-related
>statistics,
>> >>
>> >> allow only a single designated manager principal to view or update
>> >> configuration parameters or disallow other manager principals to
>read
>> >> the performance-related statistics.
>> >
>> >OK
>> 
>> I agree with making the text examples. I think one example should be
>that
>> some managers might only be allowed read-only access while others are
>> allowed read-write access.
>> The new text mixes operations and specific views (perf stats), so the
>RO
>> vs RW example is not very clearly shown.
>
>Would this work for you? If not please provide some NEW text.
>
>NEW: 
>An agent entity can restrict access to a certain portion of its MIB,
>e.g. restrict 
>some manager principals to view only performance-related statistics, or
>disallow 
>other manager principals to read those performance-related statistics.
>An agent entity can also restrict to monitoring (read-only) as opposed
>to monitoring 
>and configuration (read-write) of a certain portion of its MIB, e.g.
>allowing only a 
>single designated manager principal to update configuration parameters.
>
>Cheers,
>Mehmet
>

---

From: "t.petch" <[email-masked]>
Date: Sat, 4 Feb 2012 15:18:37 +0100

[RFC4001] defines a 4 byte zone index for IPv6 with a display hint of 'd'

 "InetAddressIPv6z ::= TEXTUAL-CONVENTION
     DISPLAY-HINT "2x:2x:2x:2x:2x:2x:2x:2x%4d"
     DESCRIPTION
         "Represents a non-global IPv6 network address, together
          with its zone index:
            Octets   Contents         Encoding
             1-16    IPv6 address     network-byte order
            17-20    zone index       network-byte order

Is this in use?

I ask because 
draft-carpenter-6man-uri-zoneid-00.txt
under discussion on the 6man list, has ABNF of
 ZoneID = 1*15unreserved
which is a bit different (well, completely different:-(

Tom Petch

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 4 Feb 2012 18:19:39 +0100

> which is a bit different (well, completely different:-(

You can identify an interface by a number (ifIndex in SNMP land) or by
a name. In other words, you can either identify an interfaces by using
the result of if_nametoindex() [RFC3493] or its argument.

On command lines and in URLs, systems and humans usually prefer names
- internally systems usually prefer numbers (and SNMP land is
typically closer to internal APIs and uses ifIndex values natively to
identify interfaces).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 05 Feb 2012 08:27:41 +1300

> typically closer to internal APIs and uses ifIndex values natively to

Exactly, and the mapping between the two forms is a host-specific function.
We'll mention this in the next version of draft-carpenter-6man-uri-zoneid.

   Brian