Subject: [OPSAWG] ICMP blackhole problem ID.

From: Ludovic Jacquin <[email-masked]>
Date: Wed, 11 Jul 2012 14:42:08 +0200

Hi,

we have submitted an ID for the 84th IETF meeting, here is a quick summary:

ICMP is a key protocol to exchange control and error messages over the 
Internet.  Unfortunately it is frequent that some routers along a given 
path do not correctly process this protocol.  This document provides a 
taxonomy of the problem in order to help an end user who suspects 
ICMP-related problems to better understand the situation, and possibly 
identify the faulty router(s).

2 usefull links if you are interested:
the ID: 
http://datatracker.ietf.org/doc/draft-jacquin-opsawg-icmp-blackhole-problem/
the globecom'12 paper: http://hal.inria.fr/hal-00695746/en/

Feedbacks are welcome.

Cheers,
Ludovic.

---

From: joel jaeggli <[email-masked]>
Date: Wed, 11 Jul 2012 07:13:01 -0700

Seems like there is substantial overlap with

http://tools.ietf.org/html/draft-ietf-opsec-icmp-filtering-03

On 7/11/12 5:42 AM, Ludovic Jacquin wrote:
> Internet.  Unfortunately it is frequent that some routers along a 
> given path do not correctly process this protocol.  This document 
> provides a taxonomy of the problem in order to help an end user who 
> suspects ICMP-related problems to better understand the situation, and 
> possibly identify the faulty router(s).
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: Vincent Roca <[email-masked]>
Date: Thu, 12 Jul 2012 08:30:42 +0200

Hello Joel,

Thanks a lot for the pointer to the filtering draft, it's useful.

This I-D discusses with a lot of details, for each and every ICMP(v4/v6) message type, why and how
a router should filter out (or rate-limit)  this message, as well as the consequences of such rules. This
is very useful to understand some of the ICMP related policies that network administrators may deploy.

In our I-D we take the opposite standpoint. We try to understand, from the end-user point of view,
what's going on when ICMP malfunctions on a given path. This end-user tries to infer as much
information as possible (by default using only his own host, without any vantage points in the core
network), for instance to localize the router/ISP(s) that produce the problems. Whether the network
administrators have good reason to apply such filtering policies is a different matter, especially as it
can also result from configuration errors. So we think that these two documents nicely complement
each other. Do you agree with us?

In any case, thanks for the feedback!

Cheers,

  The authors

On July 11, 2012, 16:13, joel jaeggli wrote:

>> ICMP is a key protocol to exchange control and error messages over the Internet.  Unfortunately it is frequent that some routers along a given path do not correctly process this protocol.  This document provides a taxonomy of the problem in order to help an end user who suspects ICMP-related problems to better understand the situation, and possibly identify the faulty router(s).
>> 
>> the ID: http://datatracker.ietf.org/doc/draft-jacquin-opsawg-icmp-blackhole-problem/

---

From: joel jaeggli <[email-masked]>
Date: Mon, 16 Jul 2012 11:07:49 -0700

> each other. Do you agree with us?
Detecting the existence of path mtu discovery failure is important. I 
believe they are complementary, probably to the  point of overlap.