Subject: Re: [OPSAWG] Yet another hypervisor MIB

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 2 Jul 2012 14:41:42 +0200

On Tue, Apr 24, 2012 at 02:18:35PM -0700, Michael MacFaden wrote:
> js wrote:
> > I will look at this in more detail tomorrow but it is clear already
> > that this is not a valid MIB module. SMIv2 does not allow SEQUENCES
> > inside of SEQUENCES. Anyway, I will try to figure out what the
> > modeling differences are.
> 
> Re: http://hg.scyphus.co.jp/virtsnmp
> 
> The vm nic state is represented by copying selected objects
> from ifTable/ifXTable. 

I do not think this is a desirable model.
 
> Designing how to model the plumbing of a vm's nic
> needs to support quite a few configurations.
> 
> a) hypervisors that plumb a virtual machines set of nics directly to one or
> more virtual layer 2 switches : (IEEE8021-BRIDGE-MIB / index
> ieee8021BridgeBasePortComponenId and IEEE8021BridgePortNumber)
> for the up/down state, source vm's nic mac address, and per vm/per port/per q-vlan 
> in/out/error byte/packet stats.
> 
> b) virtualization software that plumbs to pseudo interfaces in host OS
> visible in ifTable/ifStackTable. (seen with ifconfig -a)
> 
> c) virtualization software that shunts nics directly to the host os nic 
> (no pseudo device).

I think a) and b) fit the IETF model of interfaces, c) is a bit more
"magic behind the scenes" and I am not sure a standards-track IETF
specification should endorse this. Even if the OS has no pseudo
device, would it be too hard to still export at the management
interface a pseudo interface?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Hirochika Asai <[email-masked]>
Date: Thu, 12 Jul 2012 18:27:31 +0900

Hi folks,

Thanks to the comments from Juergen and Mike, I've removed invalid MIB
definitions from my document and updated it.  In addition to the MIB
update, I've worked on developing an snmp agent as a net-snmp
subagent.  Note that the previous implementation was not good because it
seems to contain memory leak problems, perhaps with the libvirt's python
binding API, so I then started to use C from this verison.

You can find my new implementation at the following page;
Archive: http://dist.scyphus.co.jp/virtsnmpd/virtsnmpd-0.1.0b.tar.gz
Repository: http://hg.scyphus.co.jp/virtsnmp/
MIB: http://hg.scyphus.co.jp/virtsnmp/index.cgi/file/42970a0fd0ae/mibs/VMM-MIB.txt

My MIB document itself is similar to <draft-schoenw-opsawg-vm-mib-00>,
but I found some differences from mine.  Now I've started to
summarize the differences and considerations from the viewpoint of
implementors.  (I think it will take some time...)

Thanks,
Hirochika

On Jul 2, 2012, at 9:41 PM, Juergen Schoenwaelder wrote:

> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
> 

-- 
Hirochika Asai <[email-masked]>, The University of Tokyo