Subject: [OPSAWG] draft-schoenw-opsawg-vm-mib scaling question

From: "Aamer Akhter (aakhter)" <[email-masked]>
Date: Thu, 2 Aug 2012 23:30:51 +0000

Hi there,

There was a question regarding scaling in the case of hundreds of VMs etc.

In cases if a full dump is not needed, does it make sense to have the ability to create flag setting thresholds that represent an aggregation and portion of a MIB tree? This might provide a more lightweight polling mechanism than a scan of large spans of the MIB.

However, Chris made a really good question regarding if MIBs are really relevant given the

Regards,aa

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 3 Aug 2012 01:42:04 +0200

> In cases if a full dump is not needed, does it make sense to have the ability to create flag setting thresholds that represent an aggregation and portion of a MIB tree? This might provide a more li…

Can you perhaps elaborate using an example what "create flag setting
thresholds that represent an aggregation and portion of a MIB tree"
means? BTW, there are generic thresholding and even expression MIBs.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Aamer Akhter (aakhter)" <[email-masked]>
Date: Fri, 3 Aug 2012 04:04:46 +0000

Again, these are for cases where a full dump is not needed across the VMs. It is similar to Solution #02-01 but where #02-01 just indicates a change in value, the idea here is to quantify & threshold the change to see if it is meaningful of further data capture.

Examples:

	(I'm simplifying quite a bit)
	1. create a histogram representing all CPU loads of the VMs on the machine. The buckets of the histogram could represent a CPU load of 0-25, 26-50, 51-75.. etc). Rather than the poller grabbing each of the individual CPUs it could just look at the histogram to see if there is any high level change worth investigating more. 

	2. select 5-6 KPI within a MIB tree (lets' say in if-mib it's items like ifOperStatus, %change in InOctets, %OutErrors, etc) if any of these exceed configured thresholds indicate a change via a new object for that specific VM.

You could also group the 100's of VMs into buckets where each bucket has an indicator object representing significant change. This would ease the need to scan through each of the VMs.

hth

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Thursday, August 02, 2012 7:42 PM
To: Aamer Akhter (aakhter)
Cc: [email-masked]; [email-masked]
Subject: Re: [OPSAWG] draft-schoenw-opsawg-vm-mib scaling question

> In cases if a full dump is not needed, does it make sense to have the ability to create flag setting thresholds that represent an aggregation and portion of a MIB tree? This might provide a more li…

Can you perhaps elaborate using an example what "create flag setting thresholds that represent an aggregation and portion of a MIB tree"
means? BTW, there are generic thresholding and even expression MIBs.

/js