Subject: [OPSAWG] INET-ADDRESS-MIB doesn't define v4 in 6 -- see what happens in TCP-MIB rfc 4022?

From: Michael MacFaden <[email-masked]>
Date: Fri, 1 Mar 2013 11:16:35 -0800 (PST)

Given: 

/usr/sbin/snmpd --version 

NET-SNMP version: 5.3.2.2 
Web: http://www.net-snmp.org/ Email: [email-masked] 

snmpwalk | grep established 

TCP-MIB::tcpConnectionState.ipv6."00:00:00:00:00:00:00:00:00:00:ff:ff:0a:14:66:67".22.ipv6."00:00:00:00:00:00:00:00:00:00:ff:ff:0a:14:64:c6".51349 = INTEGER: established(5) * 
TCP-MIB::tcpConnectionState.ipv6."00:00:00:00:00:00:00:00:00:00:ff:ff:0a:14:66:67".22.ipv6."00:00:00:00:00:00:00:00:00:00:ff:ff:0a:14:64:c6".59585 = INTEGER: established(5) * 
TCP-MIB::tcpConnectionState.ipv6."fc:00:00:10:00:20:01:02:00:00:00:00:00:00:01:03".22.ipv6."fc:00:00:10:00:20:01:03:02:23:32:ff:fe:de:c1:24".52684 = INTEGER: established(5) 

The INET-ADDRESS-MIB does not define a v4 in 6 enumeration, was there any discussion about that? 

To me net-snmp should be reporting the above as ipv4 entries not IPv6 though admittedly /proc/net/tcp6 is where the data are being sourced. 

Mike

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 4 Mar 2013 09:07:47 +0100

On Fri, Mar 01, 2013 at 11:16:35AM -0800, Michael MacFaden wrote:

[...]

> The INET-ADDRESS-MIB does not define a v4 in 6 enumeration, was there any discussion about that? 

It is too long ago for me to remember. It could be that we decided to
stay away from modeling special IPv6 address formats since this is
difficult to version.
 
/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>