Subject: [OPSAWG] Fwd: New Version Notification for draft-nishizuka-cgn-deployment-considerations-00.txt

From: kaname nishizuka <[email-masked]>
Date: Tue, 02 Apr 2013 16:39:26 +0900

Dear all,

As I mentioned before, we are testing CGN under the support of Japanese Government.
Now, we've uploaded a new draft based on the result of our verification.
The useful information about the average consumption of the ports are available on the document.
Please look through it and all kind of feedback are welcome.
We mentioned Victor's draft "CGN Deployment with BGP/MPLS IP VPNs Draft" in introduction
because part of our research shares the same motivations with it.

The document is *NOT* intended to be Standards Track. It's for Informational.
The wrong description is just mere mistake, so we'll soon correct it in the next revision.

The full report of our work will be available soon on the Web.
We've just finished writing.

Best regards,

kaname

-------- Original Message --------
Subject: 	New Version Notification for 
draft-nishizuka-cgn-deployment-considerations-00.txt
Date: 	Thu, 28 Mar 2013 07:12:25 -0700
From: 	[email-masked]
To: 	[email-masked]

A new version of I-D, draft-nishizuka-cgn-deployment-considerations-00.txt
has been successfully submitted by Kaname Nishizuka and posted to the
IETF repository.

Filename:	 draft-nishizuka-cgn-deployment-considerations
Revision:	 00
Title:		 Carrier-Grade-NAT (CGN) Deployment Considerations.
Creation date:	 2013-03-29
Group:		 Individual Submission
Number of pages: 16
URL:             http://www.ietf.org/internet-drafts/draft-nishizuka-cgn-deployment-considerations-00.txt
Status:          http://datatracker.ietf.org/doc/draft-nishizuka-cgn-deployment-considerations
Htmlized:        http://tools.ietf.org/html/draft-nishizuka-cgn-deployment-considerations-00

Abstract:
    This document provides deployment considerations for Carrier-Grade-
    NAT (CGN) based on the verification result include the investigation
    of the number of sessions of applications.  The verification was
    conducted in StarBED which is one of the largest scale network
    experiment environment in Japan.  A million of subscribers was
    emulated and it revealed the realistic behavior of CGN.

The IETF Secretariat

---

From: GangChen <[email-masked]>
Date: Thu, 11 Apr 2013 11:49:10 +0800

Hello authors,

Thanks for sharing your tests.
Some comments are below.

Section 5.2 provides two formulas to estimate the address multiplexing.
If the formula of static assigment is intended to align with
I-D.donley-behave-deterministic-cgn, it may be amended by adding
active subscriber's coefficient. CGN may only assign static port block
to active users.Meanwhile, log just needs to add one record for each
user.

Section 6.1 states the MCS is highly dependent with retention time of
NAT table. It would be intereted to add some discussions if CGN could
interact with PCP.

BTW, the table shown CGN sets retention time for DNS. would you do DNS
filter on CGN to identify DNS package?  I saw you also described DNS
bypass CGN. Are those related?

Many thanks

Gang

2013/4/2, kaname nishizuka <[email-masked]>:
> URL:
> http://www.ietf.org/internet-drafts/draft-nishizuka-cgn-deployment-considerations-00.txt
> Status:
> http://datatracker.ietf.org/doc/draft-nishizuka-cgn-deployment-considerations
> Htmlized:
> http://tools.ietf.org/html/draft-nishizuka-cgn-deployment-considerations-00
>
>
> Abstract:

---

From: kaname nishizuka <[email-masked]>
Date: Thu, 11 Apr 2013 15:03:38 +0900

Thank you for your comments.

> to active users.Meanwhile, log just needs to add one record for each
It is dynamic assignment of port block.

We are describing the static assignment case.
In that case, the same active subscriber's coefficient can not be used.

There are potential users who have been assigned an internal IP address 
(and thus external address and port range) but are not generating any 
packet.
In the dynamic assignment of port block, they don't consume external 
ports so they are not active subscribers.
On the other hand, in the static assignment, they are reserving the 
external address and port range resources.
If there is a mapping rule, that is the static assignment.

> bypass CGN. Are those related?
Thanks for your suggestion.
Yes, those are related.
The point is that DNS query almost does not affect the performance of 
the CGN because
retention time for DNS is sufficiently short (3 sec.).
I think we need not to bypass DNS queries.

regards,
kaname

-- 
----
Kaname Nishizuka
Innovative Architecture Center
NTT Communications Corporation
+81-50-3812-4704

---

From: GangChen <[email-masked]>
Date: Thu, 11 Apr 2013 15:54:40 +0800

Kaname-san,

> It is dynamic assignment of port block.

That is correct. In some senses, a bulk of port is *statically*
reserved to a particular user. It's worth to be noted several
implementations are doing deterministic NAT behavior just following
those rules.

> I think we need not to bypass DNS queries.

When I read the section at first time, I thought bypass DNS queries is
recommended since there is additional load(e.g. translation and logs)
to CGN. I guess the statement may be more clear if you could add
discussions what is the loss of bypass DNS queires.

Best Regards

Gang

>>> We mentioned Victor's draft "CGN Deployment with BGP/MPLS IP VPNs Draft"
>>> in
>>> introduction
>>> The wrong description is just mere mistake, so we'll soon correct it in
>>> the
>>> next revision.
>>>
>>> A new version of I-D,