Subject: [OPSAWG] Fwd: I-D Action: draft-nishizuka-cgn-deployment-considerations-00.txt

From: Shishio Tsuchiya <[email-masked]>
Date: Fri, 05 Apr 2013 16:02:32 +0900

I read this documents.
I think this draft would be useful to consider CGP deployment for service providers.

And I have question.

http://tools.ietf.org/html/draft-nishizuka-cgn-deployment-considerations-00#section-4
Figure 1: The number of sessions of applications.

Q.Which browser did you use in your investigation?

Our investigation shows that the average number of session of active subscriber is 400.

Q.Can you show more detail information? The investigation in the commercial network? or test bed?

http://tools.ietf.org/html/draft-nishizuka-cgn-deployment-considerations-00#section-5.2
(a) was estimated to be 25% at the value during the busy hour of traffic (21:00 pm to 1:00am).

Q.Does the estimation come from your investigation on real network? or erlang and someting?
 What kind of network?Wireless or Wireline?IPv6 enabled network?

http://tools.ietf.org/html/draft-nishizuka-cgn-deployment-considerations-00#section-6.1

Q.Is current RFC not enough to measure CGN performance?
RFC 3511 Benchmarking Methodology for Firewall Performance
http://tools.ietf.org/html/rfc3511
RFC6645 IP Flow Information Accounting and Export Benchmarking Methodology
http://tools.ietf.org/html/rfc6645

Regards,
-Shishio

-------- Original Message --------
Subject: I-D Action: draft-nishizuka-cgn-deployment-considerations-00.txt
Date: Thu, 28 Mar 2013 07:12:24 -0700
From: <[email-masked]>
Reply-To: <[email-masked]>
To: <[email-masked]>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Carrier-Grade-NAT (CGN) Deployment Considerations.
	Author(s)       : Kaname Nishizuka
	Filename        : draft-nishizuka-cgn-deployment-considerations-00.txt
	Pages           : 16
	Date            : 2013-03-28

Abstract:
   This document provides deployment considerations for Carrier-Grade-
   NAT (CGN) based on the verification result include the investigation
   of the number of sessions of applications.  The verification was
   conducted in StarBED which is one of the largest scale network
   experiment environment in Japan.  A million of subscribers was
   emulated and it revealed the realistic behavior of CGN.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-nishizuka-cgn-deployment-considerations

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-nishizuka-cgn-deployment-considerations-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
.

---

From: kaname nishizuka <[email-masked]>
Date: Fri, 05 Apr 2013 19:03:21 +0900

Shishio-san
Thanks,

In response to your questions,

> Q.Which browser did you use in your investigation?
We used the latest Chrome and FireFox.

> Q.Can you show more detail information? The investigation in the commercial network? or test bed?
We captured traffic of our normal activities. So the answer is "in test 
bed".
In a commercial network, the common people activities could be somehow 
different from researchers:)
However, the existing study is showing that our assumption is not extreme.
http://www.wand.net.nz/~salcock/someisp/flow_counting/result_page.html

>   What kind of network?Wireless or Wireline?IPv6 enabled network?
It's from investigation on the real ISP network.
It's mainly wireline network and partly IPv6-enabled.

> http://tools.ietf.org/html/rfc6645
Maybe not, though I've not closely read them.
As I described in the draft, the CGN performance is limited by the 
combination of throughput, Max Concurrent Sessions and Connection Per Sec.
Thus we used the test bed(StarBED) with powerful calculation power to 
emulate all subscribers.
The assumption of the average subscriber was important for setting up 
the environment.

Best regards,
kaname

(2013/04/05 16:02), Shishio Tsuchiya wrote:
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

-- 
----
Kaname Nishizuka
Innovative Architecture Center
NTT Communications Corporation
+81-50-3812-4704

---

From: Shishio Tsuchiya <[email-masked]>
Date: Fri, 05 Apr 2013 20:21:39 +0900

Kaname-san
> We used the latest Chrome and FireFox.

I think, previous version than IE10.0 does not support both Websocket and SPDY.
But the share is pretty high.
So it would be more useful if you could add the result of old version of IE and latest IE.

And cisco and IDC published White Paper of "The Business Case for Delivering IPv6 Service Now".
http://www.cisco.com/en/US/solutions/collateral/ns341/ns525/ns1017/idc_ipv6_economics.pdf

If you could add result of IPv6 access to your selected site, it would be more powerful.
Your investigation result would be more adaptable in all of deployment stage.(NAT44 only,NAT44 + NAT64 and NAT44 and IPv6 native.)

> We captured traffic of our normal activities. So the answer is "in test bed".
> In a commercial network, the common people activities could be somehow different from researchers:)

Thanks for information.

> It's mainly wireline network and partly IPv6-enabled.

Thank you for useful information.
Do you know the trend of mobile network?

> As I described in the draft, the CGN performance is limited by the combination of throughput, Max Concurrent Sessions and Connection Per Sec.
> Thus we used the test bed(StarBED) with powerful calculation power to emulate all subscribers.
> The assumption of the average subscriber was important for setting up the environment.

Yes,I thought you might write another draft for BMWG wg.:-)

Regards,
-Shishio

---

From: kaname nishizuka <[email-masked]>
Date: Tue, 09 Apr 2013 20:56:40 +0900

Shishio-san

> So it would be more useful if you could add the result of old version
of IE and latest IE.

Exactly.

> Your investigation result would be more adaptable in all of deployment
stage.(NAT44 only,NAT44 + NAT64 and NAT44 and IPv6 native.)

I'd like to do that. Thanks for your useful suggestion.

> Do you know the trend of mobile network?

Examining mobile network is our future work.

> Yes,I thought you might write another draft for BMWG wg.:-)

It's been always on my mind.:-)

Regards,
kaname