Subject: Re: [OPSAWG] Start of WGLC for draft-ietf-opsawg-capwap-hybridmac

From: Dorothy Stanley <[email-masked]>
Date: Fri, 9 May 2014 19:20:05 -0700

Hi -

Some additional, largely editorial comments on the -04 version:

1. In Figures 1,2, and 3, change from "IEEE 802.1X/EWTP" to ""IEEE
802.1X/EAP"

2. Some suggestions on the abstract wording:

From

CAPWAP defines two entities: Wireless Transmission Point (WTP) and
   Access Controller (AC).  CAPWAP also defines two MAC (Medium Access
   Control) modes for IEEE 802.11 WTPs: Split and Local MAC . For each
   MAC mode, CAPWAP describes how the MAC functionality is split between
   the WTP and AC.  However, certain functions have not been clearly
   defined.  For example in the Split MAC mode description, the IEEE
   802.11 encryption is specified as located in either the AC or the WTP
   with no clear way for the AC to inform the WTP where it should be.
   This lack of specification leads to interoperability especially when
   AC and WTP come from different vendors.  To solve the problem, this
   specification defines a IEEE 802.11 MAC profile where each profile
   specifies an unambiguous division of functionality between the WTP
   and AC.  The IEEE 802.11 MAC profile is used as follows: the WTP
   informs the AC of the supported profiles during the discovery or join
   process and the AC configures the WTP with one of the supported
   profiles while configuring the WLAN.

to

The CAPWAP protocol defines two entities: a Wireless Transmission
Point (WTP) and an
   Access Controller (AC).  The CAPWAP protocol binding for IEEE
802.11 defines two MAC (Medium Access
   Control) modes for IEEE 802.11 WTP: Split and Local MAC, and
describes the required functionality split between
   the WTP and AC for each mode.  However, in the split MAC mode, the
partitioning of encryption/decryption functions are not been clearly
   clearly defined.  In the Split MAC mode description, IEEE
   802.11 encryption is specified as located in either at the AC or the WTP
   with no clear way for the AC to inform the WTP of where the
encryption functionality should be located.
   This lack of specification leads to interoperability issues,
especially when the
   AC and WTP come from different vendors.  To prevent
interoperability issues, this
   specification defines an IEEE 802.11 MAC profile message element in
which each profile
   specifies an unambiguous division of encryption functionality between the WTP
   and AC.  The IEEE 802.11 MAC profile is used as follows: the WTP
   informs the AC of the supported profiles during the discovery or join
   process and the AC configures the WTP with one of the supported
   profiles when configuring the WLAN.

3. In section 1, end of first paragraph, change from "

"operators will experience difficulty in interoperating WTPs and ACs
from different vendors."

to
"operators will experience interoperability issues with WTPs and ACs
from different vendors."

4. In section 1, end of second paragraph, insert a comma after "WTP/AC":
"is specified as WTP/AC implying to "is specified as WTP/AC, implying"

Thanks,

Dorothy

On Tue, Apr 22, 2014 at 9:16 PM, Rajesh Pazhyannur (rpazhyan) <
[email-masked]> wrote:

> Hello Warren,
>
> I will address the nits and submit a new version.
>
> Thanks for shepherding this through.
>
> Regards
>
> Rajesh
> -----Original Message-----
> From: Warren Kumari [mailto:[email-masked]]
> Sent: Tuesday, April 22, 2014 11:19 AM
> To: [email-masked]; [email-masked]
> Subject: Re: Start of WGLC for draft-ietf-opsawg-capwap-hybridmac
>
> On Mon, Apr 7, 2014 at 12:44 PM, Warren Kumari <[email-masked]> wrote:
> > Dear opsawg WG,
> >
> > The authors of draft-ietf-opsawg-capwap-hybridmac have indicated that
> > they believe that the document is ready, and have asked for Working
> > Group Last Call.
> >
> > The draft is available here:
> > https://datatracker.ietf.org/doc/draft-ietf-opsawg-capwap-hybridmac/
> >
> > Please review this draft to see if you think it is ready for
> > publication and send comments to the list, clearly stating your view.
> >
> > This WGLC ends Mon 21-Apr-2014.
>
> This WGLC has concluded, thanks to everyone for the feedback.
>
> The chairs just met, and have decided that there is sufficient support to
> progress this.
> Authors, please spin another version with the nits addressed (some typo's,
> the nits checker made grumpyface, etc) -- this will help speed it through
> the IESG.
> Once you resubmit with these done, please poke me / us to submit to the
> IESG.
>
> Thanks for all the hard work.
> W
>
>
>
> >
> > Thanks,
> > Warren Kumari
> > (as opsawg WG co-chair)
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: "Rajesh Pazhyannur (rpazhyan)" <[email-masked]>
Date: Mon, 12 May 2014 17:04:56 +0000

Hello Dorothy

Thanks for the comments. Will incorporate them.

Regards

Rajesh
From: Dorothy Stanley [mailto:[email-masked]]
Sent: Friday, May 09, 2014 7:20 PM
To: Rajesh Pazhyannur (rpazhyan)
Cc: Warren Kumari; [email-masked]; [email-masked]
Subject: Re: [OPSAWG] Start of WGLC for draft-ietf-opsawg-capwap-hybridmac

Hi -

Some additional, largely editorial comments on the -04 version:
1. In Figures 1,2, and 3, change from "IEEE 802.1X/EWTP" to ""IEEE 802.1X/EAP"
2. Some suggestions on the abstract wording:
From

to

The CAPWAP protocol defines two entities: a Wireless Transmission Point (WTP) and an

   Access Controller (AC).  The CAPWAP protocol binding for IEEE 802.11 defines two MAC (Medium Access

   Control) modes for IEEE 802.11 WTP: Split and Local MAC, and describes the required functionality split between

   the WTP and AC for each mode.  However, in the split MAC mode, the partitioning of encryption/decryption functions are not been clearly

   with no clear way for the AC to inform the WTP of where the encryption functionality should be located.

   This lack of specification leads to interoperability issues, especially when the

   AC and WTP come from different vendors.  To prevent interoperability issues, this

   specification defines an IEEE 802.11 MAC profile message element in which each profile

"operators will experience difficulty in interoperating WTPs and ACs from different vendors."

to
"operators will experience interoperability issues with WTPs and ACs from different vendors."

Dorothy

On Tue, Apr 22, 2014 at 9:16 PM, Rajesh Pazhyannur (rpazhyan) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Warren,

Regards

Rajesh
-----Original Message-----
From: Warren Kumari [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, April 22, 2014 11:19 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Start of WGLC for draft-ietf-opsawg-capwap-hybridmac

The chairs just met, and have decided that there is sufficient support to progress this.
Authors, please spin another version with the nits addressed (some typo's, the nits checker made grumpyface, etc) -- this will help speed it through the IESG.
Once you resubmit with these done, please poke me / us to submit to the IESG.

_______________________________________________
OPSAWG mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/opsawg