Subject: Re: [OPSAWG] Fwd: New Version Notification for draft-hmac-sha-2-usm-snmp-01.txt

From: Johannes Merkle <[email-masked]>
Date: Wed, 18 Jun 2014 10:51:46 +0200

Another try to gather some feedback. Some people have already expressed their support for adopting the draft and have
provided feedback to previous version, so I put them on cc. Please indicate, if you see any issues.

Johannes

Johannes Merkle wrote on 26.05.2014 11:21:
> so far, there has been no feedback on the new version, but the discussion on the previous one indicated considerable
> interest. Does the silence indicate "no objections" or are there still issues?
> 
> Should the draft be adopted by the WG?
> 
> Johannes
> 
> Johannes Merkle wrote on 06.05.2014 12:56:
>> Hi,
>>
>> after a fruitful discussion on the first version (http://www.ietf.org/mail-archive/web/opsawg/current/msg03022.html), we
>> have updated draft-hmac-sha-2-usm-snmp.
>>
>> Major changes are:
>>
>> - Protocol names unified to usmHMACXXXSHAYYYAuthProtocol.
>>
>> - Definition of mandatory (usmHMAC192SHA256AuthProtocol) and recommended (usmHMAC256SHA512AuthProtocol) protocols.
>> (I just noticed that the abstract and introduction still talk about "new optional authentication protocols"; this is an
>> error I will fix in the next revision)
>>
>> - Key word reference (RFC 2119) added
>>
>> - MIB biolerplate added (Sections on The Internet-Standard Management Framework, Structure of the MIB Module,
>> Relationship to Other MIB Modules)
>>
>> - Security Considerations considerably extended (guidance on cryptographic strength, key derivation from passwords,
>> access to MIB)
>>
>> - IANA considerations clarified and comments for RFC Ed in MIB definition added
>>
>> Comments are welcome. There was considerable interest in adoption by the WG, so please stand up if you have issues.
>>
>> Johannes
>>
>> -------- Original Message --------
>> Betreff: New Version Notification for draft-hmac-sha-2-usm-snmp-01.txt
>> Datum: Tue, 6 May 2014 02:38:29 -0700
>> Von: <[email-masked]>
>> An: Johannes Merkle <[email-masked]>, Manfred Lochter <[email-masked]>, Manfred Lochter
>> <[email-masked]>, Johannes Merkle <[email-masked]>
>>
>>
>> A new version of I-D, draft-hmac-sha-2-usm-snmp-01.txt
>> has been successfully submitted by Johannes Merkle and posted to the
>> IETF repository.
>>
>> Name:		draft-hmac-sha-2-usm-snmp
>> Revision:	01
>> Title:		HMAC-SHA-2 Authentication Protocols in USM for SNMP
>> Document date:	2014-05-06
>> Group:		Individual Submission
>> Pages:		14
>> URL:            http://www.ietf.org/internet-drafts/draft-hmac-sha-2-usm-snmp-01.txt
>> Status:         https://datatracker.ietf.org/doc/draft-hmac-sha-2-usm-snmp/
>> Htmlized:       http://tools.ietf.org/html/draft-hmac-sha-2-usm-snmp-01
>> Diff:           http://www.ietf.org/rfcdiff?url2=draft-hmac-sha-2-usm-snmp-01
>>
>> Abstract:
>>    This memo specifies new optional HMAC-SHA-2 authentication protocols
>>    for the User-based Security Model (USM) for SNMPv3 defined in RFC
>>    3414.
>>
>>
>>
>>
> 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
> 
> 

-- 
Mit freundlichen Grüßen,
Dr. Johannes Merkle
Principal Beratung, Elektronische Identitäten
Public Sector
secunet Security Networks AG
Mergenthaler Allee 77
65760 Eschborn
Germany
Telefon +49 201 54 54-3091
Telefax +49 201 54 54-1325
Mobil   +49 175 2224439
[email-masked]
www.secunet.com

---

From: David Reid <[email-masked]>
Date: Wed, 18 Jun 2014 09:36:18 -0400

> Another try to gather some feedback. Some people have already expressed 
> their support for adopting the draft and have provided feedback to 
> previous version, so I put them on cc. Please indicate, if you see any 
> issues.
> 
> Johannes

I support adopting the draft. I have read the current version and it looks
good.

-David Reid