Subject: [OPSAWG] YANG models for OAM

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Tue, 10 Jun 2014 19:03:28 +0000

All

We have published YANG model for OAM. #1 draft below place the generic framework for OAM, that can be augmented for different technologies. #2 and #3 are application of the concept to NVO3 and TRILL,

1.      http://datatracker.ietf.org/doc/draft-tissa-netmod-oam/

2.      http://datatracker.ietf.org/doc/draft-tissa-nvo3-yang-oam/

3.      http://datatracker.ietf.org/doc/draft-tissa-trill-yang-oam/

Please review and share your comments

Thanks
Tissa

---

From: Qin Wu <[email-masked]>
Date: Wed, 11 Jun 2014 04:21:59 +0000

Hi, Tissa:
Thanks for initiating discussion on this topic.
Unified OAM for multi-Layer network is a good idea to me.
draft-ww-opsawg-multi-layer-oam-00 we proposed in opsawg laid out the an initial description of the problem.
The question to draft-tissa-netmod-oam is
I am wondering how this generic Yang Model can be applied to SFC environment?
How do you support the case where two endpoints support different layer OAM or doesn’t support any OAM at that layer.

BTW: I have cc’ed time mailing list since I believe this mailing list is purposed to look for generic and integrated OAM covering various heterogeneous networking technologies.
Regards!
-Qin
发件人: netmod [mailto:[email-masked]] 代表 Tissa Senevirathne (tsenevir)
发送时间: 2014年6月11日 3:03
收件人: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
主题: [netmod] YANG models for OAM

All

Thanks
Tissa

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Wed, 11 Jun 2014 16:05:53 +0000

All of The YANG code is included in drafts. Or are you referring to backend implementations or XML encoding ?

From: Thomas Nadeau [mailto:[email-masked]]
Sent: Wednesday, June 11, 2014 6:51 AM
To: Tissa Senevirathne (tsenevir)
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [netmod] YANG models for OAM

Are these models based on any implementation/s or proof-of-concept code that anyone can look at?

Tom

On Jun 10, 2014, at 12:03 PM, "Tissa Senevirathne (tsenevir)" <[email-masked]<mailto:[email-masked]>> wrote:
All

Thanks
Tissa

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 11 Jun 2014 06:51:09 -0700

Tom 

> On Jun 10, 2014, at 12:03 PM, "Tissa Senevirathne (tsenevir)" <[email-masked]> wrote:
> 
> All
>  
> [email-masked]

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Sun, 29 Jun 2014 16:20:29 +0000

Hi Qin

There are several way this is applicable to SFC

1.      SFC is underlayer independent , which means it can have all sorts of encap types underneath, the model presented in tissa-netmod-oam, address exactly that issue. Instead of re-inventing and re-implementing various different OAM the draft propose to integrate them at the management layer.

2.      In this draft we define a flow-entropy as an opaque element that each of the technology type can specify and include. If we look at draft-quinn-sfc-nsh-02.txt, it define a block that specifies SFC. SFC version of YANG  can specify this as part of its flow entropy. The beauty is that it is all up to the technology to specify that (size and shape is technology dependent) and base model is still intact.

With the above in mind , can you please review draft-tissa-netmod-oam and see it is flexible and extensible enough to for the purpose. If things are missing we can add and extend.

I have requested netmod WG chairs for a presentation slot for further discussion of the draft.

From: Qin Wu [mailto:[email-masked]]
Sent: Tuesday, June 10, 2014 9:22 PM
To: Tissa Senevirathne (tsenevir); [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: YANG models for OAM

Hi, Tissa:

BTW: I have cc’ed time mailing list since I believe this mailing list is purposed to look for generic and integrated OAM covering various heterogeneous networking technologies.
Regards!
-Qin
发件人: netmod [mailto:[email-masked]] 代表 Tissa Senevirathne (tsenevir)
发送时间: 2014年6月11日 3:03
收件人: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: [netmod] YANG models for OAM

All

Thanks
Tissa