Subject: [OPSAWG] EAP metadata. YANG to XML and JSON, but which to pick?

From: Rok Papež <[email-masked]>
Date: Tue, 20 Jan 2015 13:34:07 +0100

Hello!

Arnes (http://www.arnes.si) is developing a Windows EAP plugin wireless
supplicant for 802.1x and we are very interested in standardised EAP
metadata:
https://tools.ietf.org/html/draft-winter-opsawg-eap-metadata-01

The draft-specification definitions are in YANG and we can derive both
XML and JSON format files. Which end format is it better to use: XML or
JSON?

Supporting (consuming) both would be a duplicate effort we are not going
to implement. My personal preference is always JSON over XML.

-- 
regards,
Rok Papež.

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 20 Jan 2015 13:55:24 +0100

Hi Rok,

> On 20 Jan 2015, at 13:34, Rok Papež <[email-masked]> wrote:
> 
> Hello!
> 

Tough luck, if you want to use RESTCONF: “A [RESTCONF] server MUST support XML encoding and MAY support JSON encoding." (draft-ietf-netconf-restconf-03). See also this juicy thread in the NETCONF mailing list:

http://www.ietf.org/mail-archive/web/netconf/current/msg09218.html

If you don’t plan to use RESTCONF, then choose whichever encoding suits you better.

Lada

> 
> -- 
> regards,
> Rok Papež.
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C