Subject: Re: [OPSAWG] New Version Notification for draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

From: "Aijun Wang" <[email-masked]>
Date: Tue, 27 Oct 2015 10:16:08 +0800

Hi, Hao:

I think this draft is useful for the service provider to deploy virtual network related VAS within DC and can be extended beyond to cover WAN domain further.  After standardizing the fabric services model, the complex of the VAS application development and the network management can be relieved largely.  It is also coincide with the efforts of various Yang model definitions that are undergoing in several IETF WG.

>From the viewpoint of service provider, the VN2PN mapping architecture is one example of network model deployment scenario. if we can clarify and make consensus on this use case, then we can move forward further, define the related Yang model and accelerate the deployment of VAS services for tenant.

NVO3 WG and L3SM WG are now working on the similar topics, you can also contact them for more deeper discussion.

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute 

Intelligent Network Product Line

From: OPSAWG [mailto:[email-masked]] On Behalf Of Chenhao (philips)
Sent: Tuesday, October 20, 2015 5:13 PM
To: [email-masked]
Subject: [OPSAWG] FW: New Version Notification for draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

Dear all,

This is a new draft for opsawg. It mainly analysis the issues existed in deploying the virtual network to the underneath physical network in DataCenter network . The basic idea is to abstract the underneath physical network as several fabrics, which can provide the fabric services to the upper-layer application/network administrator, to facilitate the whole configuration procedure.

We would like to hear your comments, thanks.

Best regards,

Hao

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 19, 2015 5:21 PM
To: Liyizhou; Chenhao (philips); Xingjun Chu; Yapeng Wu; Yapeng Wu; Liyizhou; Chenhao (philips); Xingjun Chu
Subject: New Version Notification for draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

A new version of I-D, draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

has been successfully submitted by Hao Chen and posted to the IETF repository.

Name:               draft-chen-opsawg-dcn-vn2pn-mapping

Revision:  00

Title:                  Virtual Network to Physical Network Mapping in DataCenter Network

Document date:       2015-10-18

Group:               Individual Submission

Pages:               12

URL:             <https://www.ietf.org/internet-drafts/draft-chen-opsawg-dcn-vn2pn-mapping-00.txt> https://www.ietf.org/internet-drafts/draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

Status:          <https://datatracker.ietf.org/doc/draft-chen-opsawg-dcn-vn2pn-mapping/> https://datatracker.ietf.org/doc/draft-chen-opsawg-dcn-vn2pn-mapping/

Htmlized:        <https://tools.ietf.org/html/draft-chen-opsawg-dcn-vn2pn-mapping-00> https://tools.ietf.org/html/draft-chen-opsawg-dcn-vn2pn-mapping-00

Abstract:

   Cloud tenant needs virtual network to interconnect their VMs on

   server. In order to effectively and efficiently map virtual network

   to physical network, certain mechanism should be employed.

   This memo analysis the existing VN2PN mapping technique employed in

   DataCenter and point out the potential shortcomings lie in it. This

   memo also try to provide a generic mechanism to facilitate the VN2PN

   mapping in DataCenter network.

 

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Chenhao (philips)" <[email-masked]>
Date: Tue, 27 Oct 2015 08:43:47 +0000

Hi Aijun,

Really appreciate for your comments. Yes, this draft describes the VN2PN mapping architecture which focuses on a fabric based service model (aka FaaS - Fabric as a Service).  This work has wiki page in ODL at https://wiki.opendaylight.org/view/Project_Proposals:FaaS and has running code at https://github.com/opendaylight/faas . Currently two YANG models are being developed: 1) the fabric  service YANG model , 2) the device config YANG model. We will submit them for discussion later.

So far we focus on the intra-DC scenario but I think it is extendable. We would like to discuss more with you on the WAN extension. This work is not limited to overlay such as VXLAN. VLAN and TRILL are also included. So in my opinion it is more generic compared to NVO3 overlay network. For sure we will cross check with the experts there. L3SM focuses on L3 VPN which is less related to this work.

Best regards,

Hao

From: OPSAWG [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Tuesday, October 27, 2015 10:16 AM
To: [email-masked]
Subject: Re: [OPSAWG] New Version Notification for draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

Hi, Hao:

Best Regards.

Aijun Wang

From: OPSAWG [mailto:[email-masked]] On Behalf Of Chenhao (philips)
Sent: Tuesday, October 20, 2015 5:13 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [OPSAWG] FW: New Version Notification for draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

Dear all,

Best regards,

Hao

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, October 19, 2015 5:21 PM
To: Liyizhou; Chenhao (philips); Xingjun Chu; Yapeng Wu; Yapeng Wu; Liyizhou; Chenhao (philips); Xingjun Chu
Subject: New Version Notification for draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

Revision:  00

Pages:               12

URL:            https://www.ietf.org/internet-drafts/draft-chen-opsawg-dcn-vn2pn-mapping-00.txt

Status:         https://datatracker.ietf.org/doc/draft-chen-opsawg-dcn-vn2pn-mapping/

Htmlized:       https://tools.ietf.org/html/draft-chen-opsawg-dcn-vn2pn-mapping-00

Abstract:

The IETF Secretariat