Subject: Re: [OPSAWG] FW: New Version Notification for draft-dahm-opsawg-tacacs-01.txt

From: Warren Kumari <[email-masked]>
Date: Fri, 13 Nov 2015 13:37:01 -0500

We would really appreciate any feedback on this document. Personally I
think it is really useful, but we need the WG to review and provide
feedback.

Over the years I've heard a number of people kvetch that TACACS+ isn't
documented -- well, now you can, you know, actually do something about
this...

W

On Sun, Oct 4, 2015 at 4:18 PM, Douglas Gash (dcmgash)
<[email-masked]> wrote:
> Dear Opsawg List,
>
> We have uploaded a second revision of the TACACS+ protocol specification
> which we believe is ready for publication subject subject to port
> allocation.
>
> Please see details below.
>
> The essential difference from the first revision is the change of TLS
> option support using a separate port as opposed to the original Start TLS
> mechanism.
>
> We would be very grateful for the opinion of the list regarding the
> suitability of document for publication as an RFC.
>
> Many thanks,
>
> Thorsten, Andrej, Doug.
>
>
> On 02/10/2015 16:25, "[email-masked]" <[email-masked]>
> wrote:
>
>>
>>A new version of I-D, draft-dahm-opsawg-tacacs-01.txt
>>has been successfully submitted by Douglas C. Medway Gash and posted to
>>the
>>IETF repository.
>>
>>Name:          draft-dahm-opsawg-tacacs
>>Revision:      01
>>Title:         The TACACS+ Protocol
>>Document date: 2015-10-02
>>Group:         Individual Submission
>>Pages:         38
>>URL:
>>https://www.ietf.org/internet-drafts/draft-dahm-opsawg-tacacs-01.txt
>>Status:         https://datatracker.ietf.org/doc/draft-dahm-opsawg-tacacs/
>>Htmlized:       https://tools.ietf.org/html/draft-dahm-opsawg-tacacs-01
>>Diff:
>>https://www.ietf.org/rfcdiff?url2=draft-dahm-opsawg-tacacs-01
>>
>>Abstract:
>>   TACACS+ provides access control for routers, network access servers
>>   and other networked computing devices via one or more centralized
>>   servers.  TACACS+ provides separate authentication, authorization and
>>   accounting services.  This document describes the protocol that is
>>   used by TACACS+.
>>
>>
>>
>>
>>
>>Please note that it may take a couple of minutes from the time of
>>submission
>>until the htmlized version and diff are available at tools.ietf.org.
>>
>>The IETF Secretariat
>>
>

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: heasley <[email-masked]>
Date: Fri, 13 Nov 2015 18:44:04 +0000

> think it is really useful, but we need the WG to review and provide

I have read this draft and support publication.

---

From: Tim Wicinski <[email-masked]>
Date: Sun, 15 Nov 2015 01:17:45 -0500

Okay, I spent some time reviewing this document and yes, it's actually 
useful stuff.  it should be adopted.

tim

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 16 Nov 2015 12:27:04 +0000

Important document indeed.

I have a comment on section 7.1 where "ip" as a protocol (the double
quotes are from the I-D) is mentioned but does it mean IPv4 or IPv6 or
both?

In the same section, may I suggest to describe the syntax of the 'addr'
field?

Hope this helps to increase the quality of this important I-D

-éric

On 13/11/15 19:37, "OPSAWG on behalf of Warren Kumari"
<[email-masked] on behalf of [email-masked]> wrote:

>>>Status:         
>>>https://datatracker.ietf.org/doc/draft-dahm-opsawg-tacacs/
>_______________________________________________
>OPSAWG mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/opsawg

---

From: Owen DeLong <[email-masked]>
Date: Mon, 16 Nov 2015 11:17:57 -0800

> On Nov 16, 2015, at 04:27 , Eric Vyncke (evyncke) <[email-masked]> wrote:
> 

Surely one would hope that it’s meaning is contextual to the time of reading
and that today it would mean {IPv4, IPv6} and that sometime in the future,
it will likely mean {IPv6} and beyond that come to mean {IPv6,…}.

> In the same section, may I suggest to describe the syntax of the 'addr'

Wouldn’t the syntax of the addr field be inherently dependent on the
RFC defining the IP version in question in the previous context?

Owen

---

From: Joe Clarke <[email-masked]>
Date: Mon, 16 Nov 2015 14:48:34 -0500

> documented -- well, now you can, you know, actually do something about

I may be biased, but I have read the doc, and I support the WG working 
on it.  I agree with your last sentiment that this would be good to 
final document this with industry consensus.

One thing I wonder is if there shouldn't be some version change for the 
support of TLS, or if the Type of 0x00 is enough?

Joe

---

From: Warren Kumari <[email-masked]>
Date: Tue, 01 Dec 2015 00:14:48 +0000

Dear OpsAWG,

The chairs believe that there is sufficient interest and support to adopt
this document as an OpsAWG document.

Authors, please resubmit as draft-ietf-opsawg-tacacs-01

Working group:
We would like to see this document progress, and are hoping to WGLC it
soon. Please review this and provide feedback....

W