Subject: Re: [OPSAWG] automatic attachment of applications and services at the edge

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Mon, 22 Feb 2016 14:38:36 +0000

Then would it be practical to have one protocol that managed carries both kinds of data?

Sent from my BlackBerry 10 smartphone on the Verizon Wireless 4G LTE network.
From: Romascanu, Dan (Dan)
Sent: Monday, February 22, 2016 09:19
To: Linda Dunbar; [email-masked]
Subject: Re: [OPSAWG] automatic attachment of applications and services at the	edge

Hi Linda,
 
Thanks for your interest and comment. From a topology and architecture point of view the idea is indeed similar to ES-IS. The difference is in the content of the information that is being exchanged between the end-station and the edge router.
 
Regards,
 
Dan

From: Linda Dunbar [mailto:[email-masked]]
Sent: Saturday, February 20, 2016 2:04 AM
To: Romascanu, Dan (Dan); [email-masked]
Subject: RE: [OPSAWG] automatic attachment of applications and services at the edge
 
Dan,
 
Thank you very much for bringing attention to this draft.
What being proposed by the draft is almost like ES-IS protocol, isn’t it?
 
I think it is quite useful.
 
Thanks, Linda Dunbar

 
From: OPSAWG [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Monday, February 15, 2016 9:10 AM
To: [email-masked]
Cc: Unbehagen Jr, Paul E (Paul)
Subject: [OPSAWG] automatic attachment of applications and services at the edge
 
Hi,
 
I would like to draw the attention of the participants in the OPSAWG on an individual submission that I am co-authoring. The problem we are trying to solve is the optimization / minimizing of the amount of configuration that an operator needs to do when new applications require the creation of paths or tunnels in the core network. In order to avoid the reconfiguration of the core or heavy configuration at the edge the proposed method which we call auto-attachment allows for the usage of a protocol running between the end stations and the first (edge) router that adds the information and characteristics of the new path according to the policies or mapping tables of the operators. A first implementation that we have running code for and is deployed is described in https://datatracker.ietf.org/doc/draft-unbehagen-lldp-spb/ and uses the Link Layer Discovery Protocol (LLDP) with an IEEE 802.1aq Shortest Path Bridging (SPB) network.
 
Please have a look and let me know if there is interest and/or similar on-going work. If there is enough interest I plan to request a short slot to discuss the idea at the OPSAWG meeting at IETF 95.
 
Thanks and Regards,
 
Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 22 Feb 2016 15:05:33 +0000

The problem is scaling. Or one of the problems. Overloading the routing protocol with service/application information does not scale well.

Regards,

Dan

From: Blumenthal, Uri - 0553 - MITLL [mailto:[email-masked]]
Sent: Monday, February 22, 2016 4:39 PM
To: Romascanu, Dan (Dan); Linda Dunbar; [email-masked]
Subject: Re: [OPSAWG] automatic attachment of applications and services at the edge

To: Linda Dunbar; [email-masked]<mailto:[email-masked]>

Hi Linda,

Regards,

Dan

From: Linda Dunbar [mailto:[email-masked]]
Sent: Saturday, February 20, 2016 2:04 AM
To: Romascanu, Dan (Dan); [email-masked]<mailto:[email-masked]>
Subject: RE: [OPSAWG] automatic attachment of applications and services at the edge

Dan,

Thanks, Linda Dunbar

To: [email-masked]<mailto:[email-masked]>

Hi,

I would like to draw the attention of the participants in the OPSAWG on an individual submission that I am co-authoring. The problem we are trying to solve is the optimization / minimizing of the amount of configuration that an operator needs to do when new applications require the creation of paths or tunnels in the core network. In order to avoid the reconfiguration of the core or heavy configuration at the edge the proposed method which we call auto-attachment allows for the usage of a protocol running between the end stations and the first (edge) router that adds the information and characteristics of the new path according to the policies or mapping tables of the operators. A first implementation that we have running code for and is deployed is described in https://datatracker.ietf.org/doc/draft-unbehagen-lldp-spb/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dunbehagen-2Dlldp-2Dspb_&d=BQMFAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=4FmIWSKBRnE6zY9ggkgew5D49GThDIc8XavqN60u6Ik&s=ndtG2fQS76MemknhEwx7nICI3zcFPTlS-5Xm_DDwH3s&e=> and uses the Link Layer Discovery Protocol (LLDP) with an IEEE 802.1aq Shortest Path Bridging (SPB) network.

Thanks and Regards,

Dan

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 22 Feb 2016 17:11:37 +0000

It makes more sense for service related information to be exchanged between network controller and the edge routers and have the reachability information exchanged directly between edge router and the end device.

OIF had spent many years working on UNI (User  Network Interface), but seen very little deployment. Many operators expressed that their OSS/Billing systems have to be involved in enabling/disabling services because of the trust issues to the end devices attached. So it is more practically for end device to interface with the network controller for their desired feature. The network controller then disseminate the policy/information to the edge routers.

In addition, sometimes, it is not feasible to update some of the edge routers deployed at the edge to support the newly developed protocol.

My two cents.

Linda

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Monday, February 22, 2016 9:06 AM
To: Blumenthal, Uri - 0553 - MITLL; Linda Dunbar; [email-masked]
Subject: RE: [OPSAWG] automatic attachment of applications and services at the edge

Regards,

Dan

From: Blumenthal, Uri - 0553 - MITLL [mailto:[email-masked]]
Sent: Monday, February 22, 2016 4:39 PM
To: Romascanu, Dan (Dan); Linda Dunbar; [email-masked]<mailto:[email-masked]>
Subject: Re: [OPSAWG] automatic attachment of applications and services at the edge

Hi Linda,

Regards,

Dan

Dan,

Thanks, Linda Dunbar

Hi,

Thanks and Regards,

Dan