Subject: [OPSAWG] automatic attachment of applications and services at the edge

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 15 Feb 2016 15:09:51 +0000

Hi,

I would like to draw the attention of the participants in the OPSAWG on an individual submission that I am co-authoring. The problem we are trying to solve is the optimization / minimizing of the amount of configuration that an operator needs to do when new applications require the creation of paths or tunnels in the core network. In order to avoid the reconfiguration of the core or heavy configuration at the edge the proposed method which we call auto-attachment allows for the usage of a protocol running between the end stations and the first (edge) router that adds the information and characteristics of the new path according to the policies or mapping tables of the operators. A first implementation that we have running code for and is deployed is described in https://datatracker.ietf.org/doc/draft-unbehagen-lldp-spb/ and uses the Link Layer Discovery Protocol (LLDP) with an IEEE 802.1aq Shortest Path Bridging (SPB) network.

Please have a look and let me know if there is interest and/or similar on-going work. If there is enough interest I plan to request a short slot to discuss the idea at the OPSAWG meeting at IETF 95.

Thanks and Regards,

Dan

---

From: joel jaeggli <[email-masked]>
Date: Mon, 15 Feb 2016 22:04:33 -0800

Am I correct in understanding that the goal is to not have to implment
spb on the client device? so this takes the place of an isis
implementation that would do the signaling per 802.1aq.

On 2/15/16 7:09 AM, Romascanu, Dan (Dan) wrote:
> Hi,
> 
>  
> 
> I would like to draw the attention of the participants in the OPSAWG on
> an individual submission that I am co-authoring. The problem we are
> trying to solve is the optimization / minimizing of the amount of
> configuration that an operator needs to do when new applications require
> the creation of paths or tunnels in the core network. In order to avoid
> the reconfiguration of the core or heavy configuration at the edge the
> proposed method which we call auto-attachment allows for the usage of a
> protocol running between the end stations and the first (edge) router
> that adds the information and characteristics of the new path according
> to the policies or mapping tables of the operators. A first
> implementation that we have running code for and is deployed is
> described in https://datatracker.ietf.org/doc/draft-unbehagen-lldp-spb/
> and uses the Link Layer Discovery Protocol (LLDP) with an IEEE 802.1aq
> Shortest Path Bridging (SPB) network.
> 
>  
> 
> Please have a look and let me know if there is interest and/or similar
> on-going work. If there is enough interest I plan to request a short
> slot to discuss the idea at the OPSAWG meeting at IETF 95.
> 
>  
> 
> Thanks and Regards,
> 
>  
> 
> Dan
> 
>  
> 
> 
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 16 Feb 2016 12:47:19 +0000

Hi Joel,

This is correct. Legacy devices or devices constrained in resources (think IoT) would have a problem to implement ISIS and the full signaling stack. The proposed solution requires them only to support LLDP or some other one-hop auto-attach protocol. 

Regards,

Dan

> -----Original Message-----
> From: joel jaeggli [mailto:[email-masked]]
> Sent: Tuesday, February 16, 2016 8:05 AM
> To: Romascanu, Dan (Dan); [email-masked]
> Cc: Unbehagen Jr, Paul E (Paul)
> Subject: Re: [OPSAWG] automatic attachment of applications and services at
> the edge
> 
> Am I correct in understanding that the goal is to not have to implment spb on
> the client device? so this takes the place of an isis implementation that would
> do the signaling per 802.1aq.
> 
> > I would like to draw the attention of the participants in the OPSAWG
> > on an individual submission that I am co-authoring. The problem we are
> > configuration that an operator needs to do when new applications
> > require the creation of paths or tunnels in the core network. In order
> > to avoid the reconfiguration of the core or heavy configuration at the
> > edge the proposed method which we call auto-attachment allows for the
> > usage of a protocol running between the end stations and the first
> > (edge) router that adds the information and characteristics of the new
> > path according to the policies or mapping tables of the operators. A
> > first implementation that we have running code for and is deployed is
> > described in
> > https://datatracker.ietf.org/doc/draft-unbehagen-lldp-spb/

---

From: Linda Dunbar <[email-masked]>
Date: Sat, 20 Feb 2016 00:03:43 +0000

Dan,

Thank you very much for bringing attention to this draft.
What being proposed by the draft is almost like ES-IS protocol, isn't it?

I think it is quite useful.

Thanks, Linda Dunbar

From: OPSAWG [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Monday, February 15, 2016 9:10 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Unbehagen Jr, Paul E (Paul)
Subject: [OPSAWG] automatic attachment of applications and services at the edge

Hi,

I would like to draw the attention of the participants in the OPSAWG on an individual submission that I am co-authoring. The problem we are trying to solve is the optimization / minimizing of the amount of configuration that an operator needs to do when new applications require the creation of paths or tunnels in the core network. In order to avoid the reconfiguration of the core or heavy configuration at the edge the proposed method which we call auto-attachment allows for the usage of a protocol running between the end stations and the first (edge) router that adds the information and characteristics of the new path according to the policies or mapping tables of the operators. A first implementation that we have running code for and is deployed is described in https://datatracker.ietf.org/doc/draft-unbehagen-lldp-spb/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dunbehagen-2Dlldp-2Dspb_&d=BQMFAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=4FmIWSKBRnE6zY9ggkgew5D49GThDIc8XavqN60u6Ik&s=ndtG2fQS76MemknhEwx7nICI3zcFPTlS-5Xm_DDwH3s&e=> and uses the Link Layer Discovery Protocol (LLDP) with an IEEE 802.1aq Shortest Path Bridging (SPB) network.

Thanks and Regards,

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 22 Feb 2016 14:19:26 +0000

Hi Linda,

Thanks for your interest and comment. From a topology and architecture point of view the idea is indeed similar to ES-IS. The difference is in the content of the information that is being exchanged between the end-station and the edge router.

Regards,

Dan

From: Linda Dunbar [mailto:[email-masked]]
Sent: Saturday, February 20, 2016 2:04 AM
To: Romascanu, Dan (Dan); [email-masked]
Subject: RE: [OPSAWG] automatic attachment of applications and services at the edge

Dan,

Thanks, Linda Dunbar

Hi,

Thanks and Regards,

Dan