Subject: [OPSAWG] BTW draft-wu-opsawg-service-model-explained now at rev -01

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 19 Jul 2016 09:40:37 +0100

We only made a small change, but one thing we did was try to highlight a distinction between the model on the interface between customer and operator (a la L3SM) and the model on the interface between OSS/BSS/etc. and network orchestrator (which is what we see as YANG models in BESS, for example).
 
Have a look at Figure 3.
 
Adrian
 
From: OPSAWG [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 19 July 2016 09:28
To: 'Benoit Claise'; 'Qin Wu'; [email-masked]'
Subject: Re: [OPSAWG] New Version Notification for draft-wu-opsawg-service-model-explained-00.txt
 
Benoit,
 
I think that you mean to say "is *an* objective of". That is, the draft you point at has a far wider scope and purpose.
 
No problem with that.
 
Doing our work in L3SM we repeatedly encountered confusion about what a service model is and where it fits in the "hierarchy". So we wrote some text.
 
Looking at our draft and Figure 1 in the yang-model-classification there is not complete coherence.
 
Which way would like to go forward?
Roll our text into yang-model-classification?
Push forward separately?
 
Adrian
 
From: OPSAWG [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: 19 July 2016 09:18
To: Qin Wu; [email-masked]
Subject: Re: [OPSAWG] New Version Notification for draft-wu-opsawg-service-model-explained-00.txt
 
Qin,

Explaining the difference between a service and network element YANG modules is the objective of https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-model-classification/
Abstract
 
   The YANG [RFC6020] data modeling language is currently being
   considered for a wide variety of applications throughout the
   networking industry at large.  Many standards-defining organizations
   (SDOs), open source software projects, vendors and users are using
   YANG to develop and publish YANG modules of configuration, state data
   and operations for a wide variety of applications.  At the same time,
   there is currently no well-known terminology to categorize various
   types of YANG modules.
 
   A consistent terminology would help with the categorization of YANG
   modules, assist in the analysis the YANG data modeling efforts in the
   IETF and other organizations, and bring clarity to the YANG-related
   discussions between the different groups.
 
   This document describes a set of concepts and associated terms to
   support consistent classification of YANG modules.
Regards, Benoit
Hi,
We have submitted a new I-D that discusses the scope and purpose of service models within
the IETF and describes how a service model can be used by a network
operator.
https://datatracker.ietf.org/doc/draft-wu-opsawg-service-model-explained/
 
In addition, this draft clarifies the role and position of service model in the SDN architecture and
Clear several misconception on the service model.
 
Your questions and comments are welcome.
 
Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2016年7月5日 19:55
收件人: Liushucheng (Will); Adrian Farrel; Liushucheng (Will); Qin Wu
主题: New Version Notification for draft-wu-opsawg-service-model-explained-00.txt

A new version of I-D, draft-wu-opsawg-service-model-explained-00.txt
has been successfully submitted by Qin Wu and posted to the IETF repository.
 
Name:          draft-wu-opsawg-service-model-explained
Revision:      00
Title:         Service Models Explained
Document date: 2016-07-05
Group:         Individual Submission
Pages:         12
URL:            https://www.ietf.org/internet-drafts/draft-wu-opsawg-service-model-explained-00.txt
Status:         https://datatracker.ietf.org/doc/draft-wu-opsawg-service-model-explained/
Htmlized:       https://tools.ietf.org/html/draft-wu-opsawg-service-model-explained-00

Abstract:
   The IETF has produced a considerable number of data models in the
   YANG modelling language.  The majority of these are used to model
   devices and they allow access for configuration and to read
   operational status.
 
   A small number of YANG models are used to model services (for
   example, the Layer Three Virtual Private Network Service Model
   produced by the L3SM working group).
 
   This document briefly sets out the scope of and purpose of an IETF
   service model, and it shows where a service model might fit into a
   Software Defined Networking architecture or deployment.

 
Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
 
The IETF Secretariat
 
_______________________________________________
OPSAWG mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsawg

---

From: Qin Wu <[email-masked]>
Date: Tue, 19 Jul 2016 17:59:59 +0000

Exactly, this was what I stressed in the today’s meeting, to clarify the difference between the model which is used between customer and service orchestrator and the model used between OSS/BSS and network orchestrator.
Even the model used between customer and service orchestrator and the model used between service orchestrator and network orchestrator doesn’t need to be same.

-Qin
发件人: OPSAWG [mailto:[email-masked]] 代表 Adrian Farrel
发送时间: 2016年7月19日 16:41
收件人: [email-masked]'
主题: [OPSAWG] BTW draft-wu-opsawg-service-model-explained now at rev -01

Have a look at Figure 3.

Adrian

Benoit,

No problem with that.

Adrian

From: OPSAWG [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: 19 July 2016 09:18
To: Qin Wu; [email-masked]<mailto:[email-masked]>
Subject: Re: [OPSAWG] New Version Notification for draft-wu-opsawg-service-model-explained-00.txt

Qin,

Abstract

   types of YANG modules.

Hi,

operator.

Regards!

-Qin

-----邮件原件-----

发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

发送时间: 2016年7月5日 19:55

Revision:      00

Pages:         12

Abstract:

   operational status.

The IETF Secretariat

OPSAWG mailing list

[email-masked]<mailto:[email-masked]>