Subject: [OPSAWG] Fwd: New Version Notification for draft-ietf-opsawg-mud-10.txt

From: Eliot Lear <[email-masked]>
Date: Fri, 15 Sep 2017 13:00:58 +0200

Hi,

This update addresses both of Benoit's issues:

  * The dates on the YANG files are now consistent.
  * There is a statement of conformance as to which features are
    expected to be implemented.
  * One or two small editorials.

Note that the draft DOES produce a yanglint warning which is expected. 
This is because yanglint does not know what to expect in terms of what
features are implemented in the ACL model.  Thus the above statement.

Eliot

Subject: New Version Notification for draft-ietf-opsawg-mud-10.txt
From: <[email-masked]>
To: Eliot Lear <[email-masked]>, Ralph Droms <[email-masked]>, Dan Romascanu <[email-masked]>
Date: Fri, 15 Sep 2017 03:27:48 -0700

A new version of I-D, draft-ietf-opsawg-mud-10.txt
has been successfully submitted by Eliot Lear and posted to the
IETF repository.

Name:		draft-ietf-opsawg-mud
Revision:	10
Title:		Manufacturer Usage Description Specification
Document date:	2017-09-15
Group:		opsawg
Pages:		53
URL:            https://www.ietf.org/internet-drafts/draft-ietf-opsawg-mud-10.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-opsawg-mud/
Htmlized:       https://tools.ietf.org/html/draft-ietf-opsawg-mud-10
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-mud-10
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-mud-10

Abstract:
   This memo specifies a component-based architecture for manufacturer
   usage descriptions (MUD).  The goal of MUD is to provide a means for
   Things to signal to the network what sort of access and network
   functionality they require to properly function.  The initial focus
   is on access control.  Later work can delve into other aspects.

   This memo specifies two YANG modules, IPv4 and IPv6 DHCP options, an
   LLDP TLV, a URL suffix specification, an X.509 certificate extension
   and a means to sign and verify the descriptions.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "M. Ranganathan" <[email-masked]>
Date: Mon, 18 Sep 2017 11:59:25 -0400

I tried compiling the YANG model. I had to make the following corrections:

  /* augment "/acl:access-lists/acl:acl/acl:aces/acl:ace/acl:matches" */
     augment
"/acl:access-lists/acl:acl/acl:access-list-entries/acl:ace/acl:matches"

 /*augment
"/acl:access-lists/acl:acl/acl:aces/acl:ace/acl:matches/acl:tcp-acl" */
     augment
"/acl:access-lists/acl:acl/acl:access-list-entries/acl:ace/acl:matches/acl:tcp-acl"

I am basing this on [email-masked], which I
believe to be the latest draft of the ietf-access-control-list

Perhaps I am mistaken (in which case please correct me).

Thanks,

Ranga

On Fri, Sep 15, 2017 at 7:00 AM, Eliot Lear <[email-masked]> wrote:

>    - The dates on the YANG files are now consistent.
>    - There is a statement of conformance as to which features are
>    - One or two small editorials.
>
> ---------- Forwarded message ----------
> Cc:
> Bcc:
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>
>

-- 
M. Ranganathan

---

From: Eliot Lear <[email-masked]>
Date: Mon, 18 Sep 2017 18:58:05 +0200

Rang,

The ACL model is currently dated [email-masked].

Eliot

On 9/18/17 5:59 PM, M. Ranganathan wrote:
> On Fri, Sep 15, 2017 at 7:00 AM, Eliot Lear <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     Note that the draft DOES produce a yanglint warning which is
>     expected.  This is because yanglint does not know what to expect
>     in terms of what features are implemented in the ACL model.  Thus
>     the above statement.
>
>     Eliot
>
>
>
>     From: <[email-masked] <mailto:[email-masked]>>
>     To: Eliot Lear <[email-masked] <mailto:[email-masked]>>, Ralph
>     Droms <[email-masked] <mailto:[email-masked]>>, Dan Romascanu
>     <[email-masked] <mailto:[email-masked]>>
>     Cc: 
>     Bcc: 
>     URL:           
>     https://www.ietf.org/internet-drafts/draft-ietf-opsawg-mud-10.txt
>     <https://www.ietf.org/internet-drafts/draft-ietf-opsawg-mud-10.txt>
>     Status:       
>      https://datatracker.ietf.org/doc/draft-ietf-opsawg-mud/
>     <https://datatracker.ietf.org/doc/draft-ietf-opsawg-mud/>
>     Htmlized:     
>      https://tools.ietf.org/html/draft-ietf-opsawg-mud-10
>     <https://tools.ietf.org/html/draft-ietf-opsawg-mud-10>
>     Htmlized:     
>      https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-mud-10
>     <https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-mud-10>
>     Diff:         
>      https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-mud-10
>     <https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-mud-10>
>
>     Abstract:
>     until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>
>     The IETF Secretariat
>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/opsawg>
>
>
>
>
> -- 
> M. Ranganathan