Subject: Re: [OPSAWG] New Version Notification for draft-ietf-opsawg-mud-09.txt

From: Eliot Lear <[email-masked]>
Date: Mon, 11 Sep 2017 10:02:31 +0200

Hi everyone,

This draft takes into account comments received from early reviews.  The
changes include the following:

  * Resolution of Security Area review, IoT directorate review, GenART
    review, YANG doctors review;
  * change of YANG structure to address mandatory nodes;
  * Terminology cleanup;
  * specify out extra portion of MUD-URL;
  * consistency changes;
  * improved YANG descriptions;
  * Remove extra revisions;
  * Track ACL model changes;
  * Additional cautions on use of ACL model;
  * Further clarifications on extensions;
  * Improved text on certificate validation;
  * An extension example; and
  * Additional guidance on "controller" URIs and URNs.

The examples should be correct.

I am aware of one error that is in the current ACL model draft at this
point that may generate warnings (there is an xpath error, the authors
are aware).

Please review.

Eliot

On 9/11/17 9:54 AM, [email-masked] wrote:
> A new version of I-D, draft-ietf-opsawg-mud-09.txt
> has been successfully submitted by Eliot Lear and posted to the
> IETF repository.
>
> Name:		draft-ietf-opsawg-mud
> Revision:	09
> Title:		Manufacturer Usage Description Specification
> Document date:	2017-09-11
> Group:		opsawg
> Pages:		52
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-opsawg-mud-09.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-opsawg-mud/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-opsawg-mud-09
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-opsawg-mud-09
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-opsawg-mud-09
>
> Abstract:
>    This memo specifies a component-based architecture for manufacturer
>    usage descriptions (MUD).  The goal of MUD is to provide a means for
>    Things to signal to the network what sort of access and network
>    functionality they require to properly function.  The initial focus
>    is on access control.  Later work can delve into other aspects.
>
>    This memo specifies two YANG modules, IPv4 and IPv6 DHCP options, an
>    LLDP TLV, a URL suffix specification, an X.509 certificate extension
>    and a means to sign and verify the descriptions.
>
>                                                                                   
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>

---

From: Eliot Lear <[email-masked]>
Date: Mon, 11 Sep 2017 10:05:21 +0200

Also, www.mudmaker.org now generates to this draft.  The old version can
be found at https://www.mudmaker.org/v08.

Eliot

On 9/11/17 10:02 AM, Eliot Lear wrote:
>
> Hi everyone,
>
> This draft takes into account comments received from early reviews. 
> The changes include the following:
>
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg