Subject: [OPSAWG] New Liaison Statement, "LS to IETF Operations and Management Area WG (OPSAWG) regarding use of MUD to indicate network usage requirements in cellular networks."

From: Liaison Statement Management Tool <[email-masked]>
Date: Thu, 03 May 2018 12:05:42 -0700

Title: LS to IETF Operations and Management Area WG (OPSAWG) regarding use of MUD to indicate network usage requirements in cellular networks.
Submission Date: 2018-05-03
URL of the IETF Web page: https://datatracker.ietf.org/liaison/1574/
Please reply by 2018-06-07
From: Paul Gosden <[email-masked]>
To: Joe Clarke <[email-masked]>,Tianran Zhou <[email-masked]>
Cc: Joe Clarke <[email-masked]>,Ignas Bagdonas <[email-masked]>,Operations and Management Area Working Group Discussion List <[email-masked]>,Tianran Zhou <[email-masked]>,Warren Kumari <[email-masked]>
Response Contacts: 
Technical Contacts: 
Purpose: For action

Body: 1	Summary
GSMA TSGIoT is studying options for keeping track of how IoT devices and IoT applications make use of the cellular network, so that network operators may both adapt resource allocation based on the device’s anticipated needs, as well as detect anomalous behavior that deviates from those needs, and take appropriate action to protect the network and customer.
 
An overview of IETF MUD was submitted for consideration in this context and there was interest both in studying MUD’s usage in a cellular network over TCP/IP after the data connection is established, as it is defined today in its current draft, and also exploring together with IETF OSAWG the possibility of leveraging MUD during the initial provisioning of an IoT device onto the 3GPP network, well before it ever attempts to establish an IP data connection. 

This study item could possibly lead to extensions such as an alternative delivery of the MUD URI to the network, alternate retrieval of the MUD file, and possibly extensions to YANG-NETCONF to express cellular-specific resource requests, and we would like to engage with IETF OPSAWG to explore the possibilities.

2	Request for Action
GSMA TSGIoT kindly requests a reply from IETF OPSAWG indicating your interest in discussing this further in a joint conference call.
If you can indicate who would be interested in having a call we will set up a Doodle poll to find a suitable date and time.

3	Contact
In the case of any questions and/or feedback these can be directed to Paul Gosden Terminals Director, looking after TSG and TSGIoT groups [[email-masked]].

4	Next Meetings
GSMA TSGIoT#08 Meeting	7th June 2018			Conference Call
Attachments:

    TSGIoT07_004 LStoIETF_OPSAWG
    https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-05-03-gsma-opsawg-ls-to-ietf-operations-and-management-area-wg-opsawg-regarding-use-of-mud-to-indicate-network-usage-requirements-i-attachment-1.DOCX

---

From: Tianran Zhou <[email-masked]>
Date: Fri, 4 May 2018 03:09:34 +0000

Hi Eliot,

I feel this is an interesting work. What's your thoughts?

Tianran

> -----Original Message-----
> From: Liaison Statement Management Tool [mailto:[email-masked]]
> Sent: Friday, May 04, 2018 3:06 AM
> To: Joe Clarke <[email-masked]>; Tianran Zhou <[email-masked]>
> Cc: Joe Clarke <[email-masked]>; Ignas Bagdonas <[email-masked]>;
> Operations and Management Area Working Group Discussion List
> <[email-masked]>; Warren Kumari <[email-masked]>; Tianran Zhou
> <[email-masked]>
> Subject: New Liaison Statement, "LS to IETF Operations and Management Area
> WG (OPSAWG) regarding use of MUD to indicate network usage requirements in
> cellular networks."
> 
> Title: LS to IETF Operations and Management Area WG (OPSAWG) regarding use
> of MUD to indicate network usage requirements in cellular networks.
> Cc: Joe Clarke <[email-masked]>,Ignas Bagdonas
> <[email-masked]>,Operations and Management Area Working Group
> Discussion List <[email-masked]>,Tianran Zhou
> <[email-masked]>,Warren Kumari <[email-masked]> Response
> Contacts:
> Technical Contacts:
> Purpose: For action
> 
> Body: 1	Summary
> GSMA TSGIoT is studying options for keeping track of how IoT devices and IoT
> applications make use of the cellular network, so that network operators may
> both adapt resource allocation based on the device’s anticipated needs, as
> well as detect anomalous behavior that deviates from those needs, and take
> appropriate action to protect the network and customer.
> 
> An overview of IETF MUD was submitted for consideration in this context and
> there was interest both in studying MUD’s usage in a cellular network over
> TCP/IP after the data connection is established, as it is defined today in
> its current draft, and also exploring together with IETF OSAWG the possibility
> of leveraging MUD during the initial provisioning of an IoT device onto the
> 3GPP network, well before it ever attempts to establish an IP data connection.
> 
> This study item could possibly lead to extensions such as an alternative
> delivery of the MUD URI to the network, alternate retrieval of the MUD file,
> and possibly extensions to YANG-NETCONF to express cellular-specific
> resource requests, and we would like to engage with IETF OPSAWG to explore
> the possibilities.
> 
> 2	Request for Action
> GSMA TSGIoT kindly requests a reply from IETF OPSAWG indicating your interest
> in discussing this further in a joint conference call.
> If you can indicate who would be interested in having a call we will set up
> a Doodle poll to find a suitable date and time.
> 
> 3	Contact
> In the case of any questions and/or feedback these can be directed to Paul
> Gosden Terminals Director, looking after TSG and TSGIoT groups
> [[email-masked]].
> 
> 4	Next Meetings
> https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-05-03-gsma-op
> sawg-ls-to-ietf-operations-and-management-area-wg-opsawg-regarding-use-o
> f-mud-to-indicate-network-usage-requirements-i-attachment-1.DOCX

---

From: "Eliot Lear (elear)" <[email-masked]>
Date: Fri, 4 May 2018 12:19:01 +0000

Will have some when I get back from holiday next week :-)

Thanks!

Eliot

> On May 3, 2018, at 11:09 PM, Tianran Zhou <[email-masked]> wrote:
> 
> Hi Eliot,
>