Subject: [OPSAWG] 转发: New Version Notification for draft-li-opsawg-address-pool-management-arch-01

From: "[email-masked]" <[email-masked]>
Date: Tue, 3 Jul 2018 10:30:42 +0800

Hi all,
 
We have updated the new version of I-D, draft-li-opsawg-address-pool-management-arch-01.txt, the revision was made based on the comments raised in London meeting, 
Telecom Italia also provided a new use case afterwards, which was also included in this new draft.

Here is the  link of the draft .  wish for your comments, Thanks.
https://datatracker.ietf.org/doc/draft-li-opsawg-address-pool-management-arch/

Best Regards,

Chen Li

==============================
Chen  Li
Network Evolution and Planning Center
Network Technology & Planning Department
China Telecom Corporation Limited Beijing Research Institute
Email：[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955
 
发件人： [email-masked]
发送时间： 2018-07-03 10:05
收件人： casm
抄送： lichen.bri; zhoutianran; jclarke; xiechf.bri; 孙雪媛
主题： New Version Notification for draft-li-opsawg-address-pool-management-arch-01
Hi all,
 
We have updated the new version of I-D, draft-li-opsawg-address-pool-management-arch-01.txt, the revision was made based on the comments raised in London meeting, 
Telecom Italia also provided a new use case afterwards, which was also included in this new draft.

Here is the  link of the draft .  wish for your comments, Thanks.
https://datatracker.ietf.org/doc/draft-li-opsawg-address-pool-management-arch/

Best Regards,

Chen Li

==============================
Chen  Li
Network Evolution and Planning Center
Network Technology & Planning Department
China Telecom Corporation Limited Beijing Research Institute
Email：[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 3 Jul 2018 09:23:43 +0000

Hi there,

I have some quick comments on this draft:

1. There is a typo in section 1
“Another factor which drive this work is that tThe network
architectures are rapidly changing with the migration toward private
and public clouds.”

tThe->the

2. In section 1, you have 
"A series of use cases are defined in "Use Case Draft"."

But there is no reference to these use cases. 
Or how about use a section to include the use case within this draft?

3. In section 3, " 1) CASM Application "

The figure 1 shows several CASM Applications. It's better to clarify how these applications may act differently.
If only for different users, based on the reading of this part, it's better to have just one "CASM Client" in the figure. 

4. In section 3, "2) CASM Coordinator"

Figure 1 shows two components "pool management" and "address management". It's better to clarify these two functional components in this section.

5. In section 4, in the first procedure, how about enabling the operators to indicate the address allocation policies or so?

6. In section 5, it's better to address how the required interfaces can map to the "pool management", "address management" and "address database" as in the CASM Coordinator.

7. Section 6. What's the relationship between this use case and the mentioned use cases in section 1?

Regards,
Tianran

----------------------------------------------------------------------
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, July 03, 2018 10:31 AM
To: opsawg <[email-masked]>
Cc: lichen.bri <[email-masked]>; Tianran Zhou <[email-masked]>; xiechf.bri <[email-masked]>
Subject: 转发: New Version Notification for draft-li-opsawg-address-pool-management-arch-01

Hi all,

Best Regards,

Chen Li

 

Best Regards,

Chen Li

---

From: <[email-masked]>
Date: Wed, 4 Jul 2018 13:21:17 +0000

Hi Chen,

FWIW, you may find some comments at: 

* pdf: https://github.com/boucadair/IETF-Drafts-Reviews/blob/master/draft-li-opsawg-address-pool-management-arch-01-rev%20Med.pdf 
* doc: https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-li-opsawg-address-pool-management-arch-01-rev%20Med.doc 

Cheers,
Med

> Cc: lichen.bri <[email-masked]>; Tianran Zhou
> <[email-masked]>; xiechf.bri <[email-masked]>
> We have updated the new version of I-D, draft-li-opsawg-address-pool-
> management-arch-01.txt, the revision was made based on the comments raised in
> London meeting,
> We have updated the new version of I-D, draft-li-opsawg-address-pool-
> management-arch-01.txt, the revision was made based on the comments raised in
> London meeting,
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 4 Jul 2018 22:50:08 +0800

Hi, Tianran,

Thanks for your comments. Please refer to my reply inline,  and we could modify some errors and submit a new version , when the submisson open again.

Best Regards,
Chen Li

-----------------------------------------------------
1. There is a typo in section 1
“Another factor which drive this work is that tThe network
architectures are rapidly changing with the migration toward private
and public clouds.”
 
tThe->the
 <Chen> delete t

<Chen> add the draft to the reference which is expired.  https://www.ietf.org/archive/id/draft-xie-ps-centralized-address-management-02.txt
3. In section 3, " 1) CASM Application "
 
The figure 1 shows several CASM Applications. It's better to clarify how these applications may act differently.
If only for different users, based on the reading of this part, it's better to have just one "CASM Client" in the figure. 
 <Chen> CASM Application refers to various address applications, such as address service management and address log management. Application may be more appropriate than the client.
4. In section 3, "2) CASM Coordinator"
 
Figure 1 shows two components "pool management" and "address management". It's better to clarify these two functional components in this section.
 <Chen> the  "pool management" is to manage an address block, and the "address management" is to manage address blocks and some specific addresses.  
"pool management" is  a way to achieve "address management".
5. In section 4, in the first procedure, how about enabling the operators to indicate the address allocation policies or so?
 <Chen> “This is a very good point,  the address allocation policies should be added in later version. “
6. In section 5, it's better to address how the required interfaces can map to the "pool management", "address management" and "address database" as in the CASM Coordinator.
 <Chen>  we plan to write  another draft  about the YANG model of the interfaces mapping to the components  mentioned in this draft .  Do I get the point of  the comment ?
7. Section 6. What's the relationship between this use case and the mentioned use cases in section 1?
 <Chen>  if we want to add the new cases to the use case draft, do you think it is ok ? 
 
Regards,
Tianran

Hi all,

 
Best Regards,
 
Chen Li

 

Best Regards,
 
Chen Li

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 5 Jul 2018 12:53:22 +0800

Hi, Mohamed,
Thanks for your comments. we will update the draft according to your suggestions.

Best Regards，
Chen

李  晨  Li Chen
中国电信北京研究院 网络技术与规划部 网络规划中心
电话：010-50902891/18910853955
邮箱：[email-masked]
只为成功找方法，不为失败找借口
==============================
Chen  Li
Network Evolution and Planning Center
Network Technology & Planning Department
China Telecom Corporation Limited Beijing Research Institute
Email：[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955
 
From: [email-masked]
Date: 2018-07-04 21:21
To: [email-masked]; opsawg
Subject: RE: New Version Notification for draft-li-opsawg-address-pool-management-arch-01
Hi Chen,

 
Cheers,
Med

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 12 Jul 2018 21:04:15 +0800

Hi, Med
Thanks for your comments. Besides those editorial comments that we will fix in next version, some questions are answered as below:
 
Page5, Q: What does that mean? (pointing to “maintain the CASM Coordinator”)
A: This paragraph clarifies the role and function of the CASM Application. CASM Application manages, maintains, and the operates address pool in the CASM coordinator. 
Page6: Q: What is the difference between an address pool and addresses? (pointing to “address pools”)
A: Address pool is a bunch of addresses configured somewhere in the network for a common purpose,   addresses means multiple addressing units instead of a single one. 
 Page6: Q: How it knows this? (pointing to “the condition”)
A: The DA module in the device collects the utilization of the address resource. Under certain policy conditions, the address is applied to make up for the shortage of the address. Otherwise, the address resource is released when the address is redundant.
Page7: Q: That is? (pointing to “user plane devices”)
A: This is a statement about the device module. The BRAS consists of a user plane and a control plane. The user plane refers to forwarding, user session in data plane, and the control plane refers to control functions, such as address management.
Page7: Q: Does this means that a permanent session is required to be maintained? (pointing to “When the connection of the CASM Coordinator is lost or it needs the status information of certain applications, it may proactively query”)
A: Yes, It need to monitor the session. If the session fails, It need to get the status from the DA again to avoid data incomplete.
Page15: Q: What is the motivation for having this use case? Are there unique requirements that can be derived from it? (pointing to “Services SDN Management Use Cases”)
A: This is a new use case from Telecom Italia.  It describes End-to-end services building in private or public clouds. It will be discussed at this IETF meeting and decide what to do with it.

Best Regards,
Chen

李  晨  Li Chen

 
 
Cheers,
Med

---

From: Joe Clarke <[email-masked]>
Date: Sun, 15 Jul 2018 13:30:57 -0400

On 7/2/18 22:30, [email-masked] wrote:
> Hi all,
>  
> We have updated the new version of I-D,
> draft-li-opsawg-address-pool-management-arch-01.txt, the revision was
> made based on the comments raised in London meeting, 

I took a page out of Med's book and did an inline individual review
using Word and saved to PDF.  Please see:

https://github.com/xorrkaz/draft-li-opsawg-address-pool-management-arch

Overall, I think the problem space is interesting, and it would benefit
from more specifics as to data models and specific protocol interactions
(and of course, security).  This draft is very high-level, and I think
it conflates a number of things, and adds complexity where it doesn't
seem to be needed.

Joe

>     *发件人：* [email-masked]
>     <mailto:[email-masked]>
>     *发送时间：* 2018-07-03 10:05
>     *收件人：* casm <mailto:[email-masked]>
>     *抄送：* lichen.bri <mailto:[email-masked]>; zhoutianran
>     <mailto:[email-masked]>; jclarke <mailto:[email-masked]>;
>     xiechf.bri <mailto:[email-masked]>; 孙雪媛
>     <mailto:[email-masked]>
>     *主题：* New Version Notification for
>     draft-li-opsawg-address-pool-management-arch-01
>     Hi all,
>      
>     We have updated the new version of I-D,
>     draft-li-opsawg-address-pool-management-arch-01.txt, the revision
>     was made based on the comments raised in London meeting,