Subject: Re: [OPSAWG] [Casm] New Version Notification for draft =?utf-8?Q?-li-opsawg-address-pool-management-arch-01

From: "[email-masked]" <[email-masked]>
Date: Tue, 17 Jul 2018 16:19:31 +0800

Hi, Georgios,
Thanks for your comments.
My answers are blow.

Best Regards,
Chen Li

发自我的华为手机

发件人：Georgios Karagiannis

收件人：[email-masked],xiechf.bri,

抄 送：[email-masked],[email-masked],

时间：2018-07-16 13:48:05

主 题：Re: [Casm] New Version Notification for draft-li-opsawg-address-pool-management-arch-01

Hi Chen Li,

From what I understand, by using CASM you would like to enhance the operation of IPAM (IP Address Space Management) tools by defining standardized
interfaces for a centralized management of IP addresses.

Are you planning to work in IETF on specifying both the interfaces that are mentioned in the draft?

·
CASM App-facing Interface

·
CASM device-facing Interface

If that will be the case are you then planning to use NETCONF/YANG data models?

Are you also willing to prioritize any of these two interfaces?

<Answer>
Yes. Both interfaces of the Coordinator are in the working scope. We think that they all play an important role. As stated in the architecture, the
Coordinator should cooperate with various CASM apps to implement address management, operation and maintenance. Similarly, it must cooperate with various network devices through device-facing interface to realize the shared use of IP address resources.

It might be possible that CASM could work use in addition to the address management attributes also on other attributes, e.g., billing. Are you also
willing to consider other attributes  than address management attributes in this work?

<Answer> We want to consider the various attribute, the CASM architecture is flexible to supports centralized management of various resources.
Currently, IP address is the primary initial focus, and other attributes are considered in the future.

Best regards,

Georgios

From: CASM [mailto:casm-bounces@ietf..org]
On Behalf Of [email-masked]

Sent: Tuesday, July 03, 2018 4:05 AM

To: casm <[email-masked]>

Cc: lichen.bri <[email-masked]>;
Tianran Zhou <[email-masked]>;
jclarke <[email-masked]>;
孙雪媛 <[email-masked]>;
xiechf.bri <[email-masked]>

Subject: [Casm] New Version Notification for draft-li-opsawg-address-pool-management-arch-01

Hi all,

We have updated the new version of I-D, draft-li-opsawg-address-pool-management-arch-01.txt, the revision was made based on the comments
raised in London meeting,

Telecom Italia also provided a new use case afterwards, which was also included in this new draft.

Here is the  link of the draft .  wish for your comments, Thanks.

https://datatracker.ietf.org/doc/draft-li-opsawg-address-pool-management-arch/

Best Regards,

Chen Li

==============================

Chen  Li

Network Evolution and Planning Center

Network Technology & Planning Department

China Telecom Corporation Limited Beijing Research Institute

Email：[email-masked]

Tel: +86-10-50902891

Mobile: +86-18910853955

---

From: Georgios Karagiannis <[email-masked]>
Date: Tue, 17 Jul 2018 15:52:47 +0000

Hi Chen Li,

Okay, thanks.
Are you then  planning to use NETCONF/YANG data models for these interfaces?

Best regards,
Georgios

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 17, 2018 10:20 AM
To: opsawg <[email-masked]>; Georgios Karagiannis <[email-masked]>
Cc: xiechf.bri <[email-masked]>; Xuweiping (David) <[email-masked]>
Subject: Re: [Casm] New Version Notification for draft =?utf-8?Q?-li-opsawg-address-pool-management-arch-01

Hi, Georgios,

Best Regards,
Chen Li

发自我的华为手机

发件人：Georgios Karagiannis

收件人：[email-masked],xiechf.bri<mailto:[email-masked],xiechf.bri>,

抄 送：[email-masked],[email-masked]<mailto:[email-masked],[email-masked]>,

时间：2018-07-16 13:48:05

Hi Chen Li,

From what I understand, by using CASM you would like to enhance the operation of IPAM (IP Address Space Management) tools by defining standardized interfaces for a centralized management of IP addresses.

•         CASM App-facing Interface

•         CASM device-facing Interface

 <Answer> Yes. Both interfaces of the Coordinator are in the working scope. We think that they all play an important role. As stated in the architecture, the Coordinator should cooperate with various CASM apps to implement address management, operation and maintenance. Similarly, it must cooperate with various network devices through device-facing interface to realize the shared use of IP address resources.

It might be possible that CASM could work use in addition to the address management attributes also on other attributes, e.g., billing. Are you also willing to consider other attributes  than address management attributes in this work?

<Answer> We want to consider the various attribute, the CASM architecture is flexible to supports centralized management of various resources. Currently, IP address is the primary initial focus, and other attributes are considered in the future.

Best regards,

Georgios

From: CASM [mailto:casm-bounces@ietf..org] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, July 03, 2018 4:05 AM
To: casm <[email-masked]<mailto:[email-masked]>>
Cc: lichen.bri <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; jclarke <[email-masked]<mailto:[email-masked]>>; 孙雪媛 <[email-masked]<mailto:[email-masked]>>; xiechf.bri <[email-masked]<mailto:[email-masked]>>
Subject: [Casm] New Version Notification for draft-li-opsawg-address-pool-management-arch-01

Hi all,

We have updated the new version of I-D, draft-li-opsawg-address-pool-management-arch-01.txt, the revision was made based on the comments raised in London meeting,

Best Regards,

Chen Li

Chen  Li

Email：[email-masked]<mailto:lichen.bri@chinatelecom..cn>

Tel: +86-10-50902891

Mobile: +86-18910853955

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 18 Jul 2018 16:34:04 +0800

Hi, Georgios,
My answer is blow, thanks

<Answer> Yes. China Telecom has implemented an address management system that uses NETCONF/YANG on both interfaces of the Coordinator.

Best Regards,
Chen Li

李  晨  Li Chen
中国电信北京研究院 网络技术与规划部 网络规划中心
电话：010-50902891/18910853955
邮箱：[email-masked]
只为成功找方法，不为失败找借口
==============================
Chen  Li
Network Evolution and Planning Center
Network Technology & Planning Department
China Telecom Corporation Limited Beijing Research Institute
Email：[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955
 
From: Georgios Karagiannis
Date: 2018-07-17 23:52
To: [email-masked]; opsawg
CC: xiechf.bri; Xuweiping (David)
Subject: RE: [Casm] New Version Notification for draft-li-opsawg-address-pool-management-arch-01
Hi Chen Li,
 
Okay, thanks.
 
Best regards,
Georgios

Hi, Georgios,

Best Regards,
Chen Li

发自我的华为手机

发件人：Georgios Karagiannis
 
Hi Chen Li,

Are you planning to work in IETF on specifying both the interfaces that are mentioned in the draft?
·         CASM App-facing Interface
·         CASM device-facing Interface
If that will be the case are you then planning to use NETCONF/YANG data models?

 
From: CASM [mailto:casm-bounces@ietf..org] On Behalf Of [email-masked]
Sent: Tuesday, July 03, 2018 4:05 AM
To: casm <[email-masked]>
Cc: lichen.bri <[email-masked]>; Tianran Zhou <[email-masked]>; jclarke <[email-masked]>; 孙雪媛 <[email-masked]>; xiechf.bri <[email-masked]>
Subject: [Casm] New Version Notification for draft-li-opsawg-address-pool-management-arch-01
 
Hi all,

 
Best Regards,
 
Chen Li