Subject: Re: [OPSAWG] Mirja Kühlewind's No Objection on draft-ietf-opsawg-ipfix-bgp-community-11: (with COMMENT)

From: Stewart Bryant <[email-masked]>
Date: Tue, 4 Dec 2018 12:07:13 +0000

On 30/11/2018 19:23, Spencer Dawkins at IETF wrote:
> This is Mirja's comment, but ...
>
> On Fri, Nov 30, 2018 at 10:12 AM Mirja Kühlewind <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Mirja Kühlewind has entered the following ballot position for
>     draft-ietf-opsawg-ipfix-bgp-community-11: No Objection
>
>     When responding, please keep the subject line intact and reply to all
>     email addresses included in the To and CC lines. (Feel free to cut
>     this
>     introductory paragraph, however.)
>
>
>     Please refer to
>     https://www.ietf.org/iesg/statement/discuss-criteria.html
>     for more information about IESG DISCUSS and COMMENT positions.
>
>
>     The document, along with other ballot positions, can be found here:
>     https://datatracker.ietf.org/doc/draft-ietf-opsawg-ipfix-bgp-community/
>
>
>
>     ----------------------------------------------------------------------
>     COMMENT:
>     ----------------------------------------------------------------------
>
>     One comment on section 1:
>     "For example, they can shift some flows
>       from congested links to low utilized links through an SDN controller
>        or PCE [RFC4655]."
>     I'm not aware that ipfix information is commonly used for dynamic
>     traffic
>     adaptation and I'm not sure that is recommendable. C
>
>
> I'm agreeing with Mirja here.
>
> We've spent a LOT of time not recommending dynamic traffic adaptation. 
> Probably half my responsibility as AD for ALTO was repeating "you 
> can't react based on changes to that attribute without taking chances 
> on oscillation" like it was a mystical incantation, and I wasn't the 
> first AD to have that conversation repeatedly.

Yes, I understand the ARPA net had exactly that problem at one stage and 
had to be converted from using a delay based metric to a fixed metric.

>
> I would be happy to hear that all those problems are solved, but I 
> haven't heard that yet. Do the right thing, of course.
>
> Even "can shift some flows from persistently congested links to 
> underutilized links" would cause me less heartburn.

There is no such thing as permanent in network paths!

Like many control problems the first order solution is to damp with a 
suitably long time constant, but  infinity, i.e. permanent, is not a 
satisfactory choice either.

- Stewart

> Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 4 Dec 2018 09:59:20 -0600

Hi, Stewart,

On Tue, Dec 4, 2018 at 6:07 AM Stewart Bryant <[email-masked]>
wrote:

> On Fri, Nov 30, 2018 at 10:12 AM Mirja Kühlewind <[email-masked]>
> wrote:
>
>> email addresses included in the To and CC lines. (Feel free to cut this
>> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
>> I'm not aware that ipfix information is commonly used for dynamic traffic
> Probably half my responsibility as AD for ALTO was repeating "you can't
> react based on changes to that attribute without taking chances on
> oscillation" like it was a mystical incantation, and I wasn't the first AD
> to have that conversation repeatedly.
>
>
> I would be happy to hear that all those problems are solved, but I haven't
> heard that yet. Do the right thing, of course.
>

Yeah, that's where I was headed (stated more coherently).

Saying "I should do something, because the network path is STILL congested"
is safer than "I should do something because the network path is
congested", so now we're talking about suitable definitions of "STILL". I
was shooting for that with "persistent", and agree that "permanent" path
characteristics is a happy idea we aren't likely to see in practice.

Do the right thing, of course ;-)

Spencer

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 4 Dec 2018 11:02:49 -0500

The conclusion earlier work on congestive response routing reached was 
that one needed to pin the specific routing decision until the selected 
path became infeasible.

Yours,
Joel

On 12/4/18 10:59 AM, Spencer Dawkins at IETF wrote:
> Hi, Stewart,
> 
> On Tue, Dec 4, 2018 at 6:07 AM Stewart Bryant <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
> 
>>     On Fri, Nov 30, 2018 at 10:12 AM Mirja Kühlewind
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     We've spent a LOT of time not recommending dynamic traffic
>>     adaptation. Probably half my responsibility as AD for ALTO was
>>     repeating "you can't react based on changes to that attribute
>>     without taking chances on oscillation" like it was a mystical
>>     incantation, and I wasn't the first AD to have that conversation
>>     repeatedly.
> 
>     Yes, I understand the ARPA net had exactly that problem at one stage
>     and had to be converted from using a delay based metric to a fixed
>     metric.
> 
>>
>     Like many control problems the first order solution is to damp with
>     a suitably long time constant, but  infinity, i.e. permanent, is not
>     a satisfactory choice either.
> 
> 
> Saying "I should do something, because the network path is STILL 
> congested" is safer than "I should do something because the network path 
> is congested", so now we're talking about suitable definitions of 
> "STILL". I was shooting for that with "persistent", and agree that 
> "permanent" path characteristics is a happy idea we aren't likely to see 
> in practice.
> 
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 6 Dec 2018 07:43:01 +0000

Hi Mirja, 

Thanks a lot for your review and comments. 

How about we replace that sentence with something like:

"For example, the collected information could be used for traffic monitoring, and could optionally be used for traffic optimization according to operator's policy."

Best regards,
Jie

> -----Original Message-----
> From: Mirja Kühlewind [mailto:[email-masked]]
> Sent: Saturday, December 01, 2018 12:13 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Tianran Zhou
> <[email-masked]>; [email-masked]; Tianran Zhou
> <[email-masked]>; [email-masked]
> Subject: Mirja Kühlewind's No Objection on
> draft-ietf-opsawg-ipfix-bgp-community-11: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> adaptation and I'm not sure that is recommendable. Can you maybe choose a
> different example. E.g use of IPFIX for troubleshooting or more generally
> network monitoring? Thanks!
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 6 Dec 2018 07:55:04 +0000

Hi Spencer, Stewart, Joel, 

Thanks for the discussion about the congestion adaptation. We agree the reactive congestion adaptation may need further investigation. 

Thus in order to solve Mirja's comment, we plan to make that example more generic with something like:

Best regards,
Jie

> From: Joel M. Halpern [mailto:[email-masked]]
> Sent: Wednesday, December 05, 2018 12:03 AM
> To: Spencer Dawkins at IETF <[email-masked]>; Stewart
> Bryant <[email-masked]>
> Cc: [email-masked]; [email-masked]; Mirja Kuehlewind
> <[email-masked]>; IESG <[email-masked]>;
> [email-masked]
> Subject: Re: [OPSAWG] Mirja Kühlewind's No Objection on
> The conclusion earlier work on congestive response routing reached was that
> one needed to pin the specific routing decision until the selected path became
> infeasible.
> 
> Yours,
> Joel
> 
> > On Tue, Dec 4, 2018 at 6:07 AM Stewart Bryant
> > <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >
> >
> > congested" is safer than "I should do something because the network
> > path is congested", so now we're talking about suitable definitions of
> > "permanent" path characteristics is a happy idea we aren't likely to
> > see in practice.
> >

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 6 Dec 2018 13:18:45 +0000

> "For example, the collected information could be used for traffic monitoring, and could optionally be used for traffic optimization according to operator's policy."

Sounds much better.

Stewart

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 6 Dec 2018 08:08:13 -0600

On Thu, Dec 6, 2018 at 7:18 AM Stewart Bryant <[email-masked]>
wrote:

> > Thanks for the discussion about the congestion adaptation. We agree the
> reactive congestion adaptation may need further investigation.
> >
> > "For example, the collected information could be used for traffic
> monitoring, and could optionally be used for traffic optimization according
> to operator's policy."
>
> Sounds much better.
>

I defer to Mirja since this is her ballot, but that sounds much more sane
to me :-)

Thanks for considering my comment on Mirja's comment!

Spencer

> that
> >>>>          When responding, please keep the subject line intact and
> reply
> >>>>          to all
> >>>>          email addresses included in the To and CC lines. (Feel free
> to
> >>>>          cut this

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Thu, 6 Dec 2018 16:46:22 +0100

Thanks. Much better!

> Am 06.12.2018 um 15:08 schrieb Spencer Dawkins at IETF <[email-masked]>:
> 
> 
> 
> On Thu, Dec 6, 2018 at 7:18 AM Stewart Bryant <[email-masked]> wrote:
> 
> 
> I defer to Mirja since this is her ballot, but that sounds much more sane to me :-)
>