Subject: Re: [OPSAWG] Questions regarding the draft-wu-model-driven-management-virtualization

From: Greg Mirsky <[email-masked]>
Date: Tue, 18 Jun 2019 08:20:45 +0900

Hi Med,
much appreciate your kind consideration of my comments, detailed responses
to all questions. Few followup notes in-line tagged GIM2>>.

Regards,
Greg

On Mon, Jun 17, 2019 at 8:22 PM <[email-masked]> wrote:

> Hi Greg,
>
>
>
> Thank you for the comments.
>
>
>
> Please see inline.
>
>
>
> Cheers,
>
> Med
>
>
>
> *De :* Greg Mirsky [mailto:[email-masked]]
> *Envoyé :* mardi 9 avril 2019 15:33
> *À :* [email-masked]; RTGWG
> *Objet :* Questions regarding the
> draft-wu-model-driven-management-virtualization
>
>
>
> Dear Authors,
>
> I have some questions related to OAM aspect of service and network
> management automation and much appreciate your consideration:
>
>    - I couldn't find Networking Working Group to which the draft seems to
>    be attributed. In your opinion, in which of IETF WGs you see this work to
>    be the most relevant?
>
> [Med] OPSAWG is a candidate target.
>
>    - I couldn't find any reference to the process of Sevice Activation
>    Testing (SAT) in the document. Are you planning to cover it later or
>    see the absence of any SAT work at IETF as an obstacle to completing the
>    closed-loop lifecycle for a service?
>
> [Med] We do explicitly refer to:
>
>    o  Dynamic feedback mechanisms that are meant to assess how
>
>       efficiently a given policy (or a set thereof) is enforced from a
>
>       service fulfillment and assurance perspective.
>
> Models that fall under that item can be listed, if any.
>
>    - Figure in Section 3 "Network Service and Resource Models" refers to
>    OAM and PM separately. Do you see PM not being part of overall OAM
>    toolset?
>
> [Med] It is part of OAM. A better name could be used. That’ said, the
> intent was to cover connectivity check matters separately from PM.
>
GIM2>> I'd propose to use "Fault Management OAM". Continuity Check and
Connectivity Verification tools usually viewed as part of a Fault
Management OAM toolset. These tools can further be characterized as
proactive or on-demand (some may be used in both modes). An example of the
former in IETF is, clearly, BFD, and in the latter group are all variances
of echo request/reply method.

>
>    - in Section 3.1.2 in regard to LIME models, you've stated: "These three
>    models can be used to provide consistent reporting, configuration and
>    representation." Do you have evidence in support of this statement?
>
> [Med] That is what the lime effort was about; hence the “can”.
>
GIM2>> Without the evidence of its use (I recall that the LIME WG published
three models) I'd use less assertive language. Perhaps "may be" or "is
intended to".

>
>    - Figure 2 lists BFD, LSP Ping, and MPLS-TP models under OAM. In your
>    opinion, are these three models sufficient to perform 'F' and 'P' of FCAPS
>    network management, i.e., Fault Management and Performance Monitoring,
>    adequately? (Should note that LSP Ping and MPLS-TP YANG models are only
>    individual drafts);
>
> [Med] Obviously, that list is not exhaustive.
>
> Regards,
>
> Greg
>

---

From: <[email-masked]>
Date: Tue, 18 Jun 2019 05:29:40 +0000

Hi Greg,

Please see inline.

Cheers,
Med

De : Greg Mirsky [mailto:[email-masked]]
Envoyé : mardi 18 juin 2019 01:21
À : BOUCADAIR Mohamed TGI/OLN
Cc : [email-masked]; RTGWG; [email-masked]
Objet : Re: Questions regarding the draft-wu-model-driven-management-virtualization

Hi Med,
much appreciate your kind consideration of my comments, detailed responses to all questions. Few followup notes in-line tagged GIM2>>.

Regards,
Greg

On Mon, Jun 17, 2019 at 8:22 PM <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

Please see inline.

Cheers,
Med

De : Greg Mirsky [mailto:[email-masked]<mailto:[email-masked]>]
Envoyé : mardi 9 avril 2019 15:33
À : [email-masked]<mailto:[email-masked]>; RTGWG
Objet : Questions regarding the draft-wu-model-driven-management-virtualization

Dear Authors,
I have some questions related to OAM aspect of service and network management automation and much appreciate your consideration:

  *   I couldn't find Networking Working Group to which the draft seems to be attributed. In your opinion, in which of IETF WGs you see this work to be the most relevant?
[Med] OPSAWG is a candidate target.

  *   I couldn't find any reference to the process of Sevice Activation Testing (SAT) in the document. Are you planning to cover it later or see the absence of any SAT work at IETF as an obstacle to completing the closed-loop lifecycle for a service?

  *   Figure in Section 3 "Network Service and Resource Models" refers to OAM and PM separately. Do you see PM not being part of overall OAM toolset?
[Med] It is part of OAM. A better name could be used. That’ said, the intent was to cover connectivity check matters separately from PM.
GIM2>> I'd propose to use "Fault Management OAM". Continuity Check and Connectivity Verification tools usually viewed as part of a Fault Management OAM toolset. These tools can further be characterized as proactive or on-demand (some may be used in both modes). An example of the former in IETF is, clearly, BFD, and in the latter group are all variances of echo request/reply method.
[Med] FM is better indeed.

  *   in Section 3.1.2 in regard to LIME models, you've stated: "These three models can be used to provide consistent reporting, configuration and representation." Do you have evidence in support of this statement?
[Med] That is what the lime effort was about; hence the “can”.
GIM2>> Without the evidence of its use (I recall that the LIME WG published three models) I'd use less assertive language. Perhaps "may be" or "is intended to".
[Med] “is intended to” works for me. Will be fixed in the next iteration.

  *   Figure 2 lists BFD, LSP Ping, and MPLS-TP models under OAM. In your opinion, are these three models sufficient to perform 'F' and 'P' of FCAPS network management, i.e., Fault Management and Performance Monitoring, adequately? (Should note that LSP Ping and MPLS-TP YANG models are only individual drafts);
[Med] Obviously, that list is not exhaustive.
Regards,
Greg