Subject: Re: [OPSAWG] I-D Action: draft-wu-model-driven-management-virtualization-04.txt

From: Qin Wu <[email-masked]>
Date: Fri, 21 Jun 2019 02:37:35 +0000

Hi, Folks:
We have submitted an v-04 of draft-wu-model-driven-management-virtualization based on feedback on the ML and last IETF meeting discussion
https://datatracker.ietf.org/doc/html/draft-wu-model-driven-management-virtualization-04
And would like to solicit more feedback on this draft.

The goal of this draft is to discuss how top down top down built model
(e.g., customer-facing data models) interact with bottom up built model (network resource-facing data models) in the context of service
delivery and assurance.

The document identifies a comprehensive list of modules to exemplify the proposed approach, but the document does not claim to be
exhaustive.

Further Comments, suggestions, input are welcome.

-Qin (on behalf of coauthors)
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2019年6月19日 20:14
收件人: [email-masked]
主题: I-D Action: draft-wu-model-driven-management-virtualization-04.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : A Framework for Automating Service and Network Management with YANG
        Authors         : Qin Wu
                          Mohamed Boucadair
                          Young Lee
	Filename        : draft-wu-model-driven-management-virtualization-04.txt
	Pages           : 37
	Date            : 2019-06-19

Abstract:
   Model-driven service and network management provides a programmatic
   and standard-based approach for representing (virtual) services or
   networks and configuration to the network device that are used to
   build and deliver the service.  Models can be used at various phases
   of service and network management life cycle such as service
   instantiation, service provisionning, optimization, monitoring, and
   diagnostic.  Also, models can be designed to automate network
   management and provide closed-loop control for the sake of adaptive
   and deterministic service creation, delivery, and maintenance.

   This document provides a framework that describes and discusses an
   architecture for service and network management automation with YANG
   modeling technologies.  An applicability of YANG data models to
   automation of virtualized network service is also investigated.

   The document aims to exemplify an approach to illustrate the journey
   from technology-agnostic services to technology-specific actions.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-wu-model-driven-management-virtualization/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-wu-model-driven-management-virtualization-04
https://datatracker.ietf.org/doc/html/draft-wu-model-driven-management-virtualization-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-wu-model-driven-management-virtualization-04

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Tianran Zhou <[email-masked]>
Date: Fri, 21 Jun 2019 03:11:00 +0000

Hi Qin and the authors,

I think this is a valuable work as a comprehensive thinking on the model driven work in IETF.
I am very interested on the architecture, the classification, the mapping methodology, etc.

Some points may be useful:
1. When I am looking at the " Figure 1: An overview of IETF YANG Modules", I think it's better not to list the specific models in "Network Service Models". Or you can use for example. Otherwise people may think those are the only considered service models in IETF.

2. While I think it's really good to investigate "all" the current models in IETF, you may not need to list them in the main content. You can keep the classification, the introduction to each category, the inter-connectivity description. But I suggest to move the "document:introduction" to the appendix. As you mentioned, the document identifies a comprehensive list of modules to exemplify the proposed approach, but the document does not claim to be exhaustive. The list may keep exploding and make the document not stable.

More comments will come later.

Cheers,
Tianran
> -----Original Message-----
> From: OPSAWG [mailto:[email-masked]] On Behalf Of Qin Wu
> Sent: Friday, June 21, 2019 10:38 AM
> To: [email-masked]
> Subject: Re: [OPSAWG] I-D Action:
> draft-wu-model-driven-management-virtualization-04.txt
> 
> Hi, Folks:
> We have submitted an v-04 of
> draft-wu-model-driven-management-virtualization based on feedback on the ML
> and last IETF meeting discussion
> The goal of this draft is to discuss how top down top down built model (e.g.,
> customer-facing data models) interact with bottom up built model (network
> resource-facing data models) in the context of service delivery and
> assurance.
> 
> The document identifies a comprehensive list of modules to exemplify the
> proposed approach, but the document does not claim to be exhaustive.
> 
> 	Filename        :
> draft-wu-model-driven-management-virtualization-04.txt
> 	Pages           : 37
> 	Date            : 2019-06-19
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg