Subject: [OPSAWG] WG adoption poll for draft-zheng-opsawg-tacacs-yang-02

From: Tianran Zhou <[email-masked]>
Date: Sun, 7 Jul 2019 07:58:58 +0000

Hi WG,

This document was presented in Prague. The authors have addressed all the comments and believe it's ready for further working group discussion.

https://tools.ietf.org/html/draft-zheng-opsawg-tacacs-yang-02

This email starts a two weeks poll for adoption.

If you support adopting this document please say so, and please give an indication of why you think it is important. Also please say if you will be willing to review and help the draft.

If you do not support adopting this document as a starting point for work on this topic, please say why.

This poll will run until 22nd July.

Regards,

Tianran & Joe

---

From: Eliot Lear <[email-masked]>
Date: Mon, 8 Jul 2019 14:12:41 +0200

Hi Tianran,

I have two concerns about this draft.  First is the intended status of this document.  It currently calls out draft-ietf-opsawg-tacacs as an informational reference.  I think the question here is really whether this draft should also be informational.  As a practical matter you really do need to have implemented the other draft for this one to be implemented.  And that means that really it should be a normative reference.  But it would be a downref.  To address this, I suggest just making this document an informational draft, rather than targeting for standards, and make the reference normative.

In addition, I have another question.  Is there interest or appetite for creating a standardized and more version of T+?  If so, is the timing of a standardized YANG model appropriate?

Eliot

> On 7 Jul 2019, at 09:58, Tianran Zhou <[email-masked]> wrote:
> 
> Hi WG,
> 
> This document was presented in Prague. The authors have addressed all the comments and believe it’s ready for further working group discussion.
> https://tools.ietf.org/html/draft-zheng-opsawg-tacacs-yang-02 <https://tools.ietf.org/html/draft-zheng-opsawg-tacacs-yang-02>
> 
> 
> If you do not support adopting this document as a starting point for work on this topic, please say why..
> _______________________________________________
> OPSAWG mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/opsawg <https://www.ietf.org/mailman/listinfo/opsawg>

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 9 Jul 2019 02:35:28 +0000

Hi Eliot,

Thanks for your suggestions. Please see inline.

Tianran

From: Eliot Lear [mailto:[email-masked]]
Sent: Monday, July 08, 2019 8:13 PM
To: Tianran Zhou <[email-masked]>
Cc: [email-masked]; OpsAWG Chairs <[email-masked]>
Subject: Re: [OPSAWG] WG adoption poll for draft-zheng-opsawg-tacacs-yang-02

Hi Tianran,

[Tianran] Yes, I have the same concern. You provided a good approach. On the other hand, I think RFC3967 described this case.
“2.  The Need for Downward References
    …
   o  A standards document may need to refer to a proprietary protocol,
      and the IETF normally documents proprietary protocols using
      informational RFCs.”

[Tianran] I would like to see how the WG would like to approach.

Eliot

On 7 Jul 2019, at 09:58, Tianran Zhou <[email-masked]<mailto:[email-masked]>> wrote:

Hi WG,

Regards,
Tianran & Joe

_______________________________________________
OPSAWG mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/opsawg

---

From: john heasley <[email-masked]>
Date: Tue, 9 Jul 2019 15:49:33 +0000

> If you support adopting this document please say so, and please give an indication of why you think it is important. Also please say if you will be willing to review and help the draft.

I support adoption.  As with RADIUS, a model is necessary to configure
Tacacs+ servers on Tacacs+ client devices.

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 23 Jul 2019 19:42:15 +0000

Hi WG,
Now we conclude the poll and adopt this document as WG draft. There are reasonable supports. And it relates to the existing tacacs+ work in this WG.

Authors,
Please republish draft-zheng-opsawg-tacacs-yang-02 as draft-ietf-opsawg-tacacs-yang-00 with only the date and file name changed.
Please also address the questions raised during the poll and report on the meeting slot.

Cheers,
Tianran and Joe

________________________________
发件人: OPSAWG [[email-masked]] 代表 Tianran Zhou [[email-masked]]
发送时间: 2019年7月7日 15:58
收件人: [email-masked]
抄送: OpsAWG Chairs
主题: [OPSAWG] WG adoption poll for draft-zheng-opsawg-tacacs-yang-02

Hi WG,

Regards,

Tianran & Joe