Subject: [OPSAWG] Fwd: New Version Notification for draft-reddy-opswg-mud-tls-00.txt

From: tirumal reddy <[email-masked]>
Date: Mon, 8 Jul 2019 19:33:03 +0530

This draft https://tools.ietf.org/html/draft-reddy-opswg-mud-tls-00
discusses Manufacturer Usage Description (MUD) extension to model (D)TLS
profile on IoT devices. This allows a firewall to notice abnormal DTLS or
TLS usage, which has been a strong indicator of other software running on
the endpoint, typically malware.

Comments, suggestions, and questions are more than welcome.

Cheers,
-Tiru

---------- Forwarded message ---------
From: <[email-masked]>
Date: Mon, 8 Jul 2019 at 19:18
Subject: New Version Notification for draft-reddy-opswg-mud-tls-00.txt
To: Tirumaleswar Reddy <[email-masked]>, Dan Wing <[email-masked]>

A new version of I-D, draft-reddy-opswg-mud-tls-00.txt
has been successfully submitted by Tirumaleswar Reddy and posted to the
IETF repository.

Name:           draft-reddy-opswg-mud-tls
Revision:       00
Title:          MUD (D)TLS profiles for IoT devices
Document date:  2019-07-08
Group:          Individual Submission
Pages:          16
URL:
https://www.ietf.org/internet-drafts/draft-reddy-opswg-mud-tls-00.txt
Status:         https://datatracker.ietf.org/doc/draft-reddy-opswg-mud-tls/
Htmlized:       https://tools.ietf.org/html/draft-reddy-opswg-mud-tls-00
Htmlized:
https://datatracker.ietf.org/doc/html/draft-reddy-opswg-mud-tls

Abstract:
   This memo extends Manufacturer Usage Description (MUD) to model DTLS
   and TLS usage.  This allows a network element to notice abnormal DTLS
   or TLS usage which has been strong indicator of other software
   running on the endpoint, typically malware.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Eliot Lear <[email-masked]>
Date: Mon, 8 Jul 2019 16:32:54 +0200

I think this is a pretty cool idea.  You should talk about it if you can make the side meeting, or otherwise if you can get time at opsawg.

Eliot

> On 8 Jul 2019, at 16:03, tirumal reddy <[email-masked]> wrote:
> 
> This draft https://tools.ietf.org/html/draft-reddy-opswg-mud-tls-00 <https://tools.ietf.org/html/draft-reddy-opswg-mud-tls-00> discusses Manufacturer Usage Description (MUD) extension to model (D)TLS profile on IoT devices. This allows a firewall to notice abnormal DTLS or TLS usage, which has been a strong indicator of other software running on the endpoint, typically malware.
> 
> From: <[email-masked] <mailto:[email-masked]>>
> To: Tirumaleswar Reddy <[email-masked] <mailto:[email-masked]>>, Dan Wing <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
> URL:            https://www.ietf.org/internet-drafts/draft-reddy-opswg-mud-tls-00.txt <https://www.ietf.org/internet-drafts/draft-reddy-opswg-mud-tls-00.txt>
> Status:         https://datatracker.ietf.org/doc/draft-reddy-opswg-mud-tls/ <https://datatracker.ietf.org/doc/draft-reddy-opswg-mud-tls/>
> Htmlized:       https://tools.ietf.org/html/draft-reddy-opswg-mud-tls-00 <https://tools.ietf.org/html/draft-reddy-opswg-mud-tls-00>
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-reddy-opswg-mud-tls <https://datatracker.ietf.org/doc/html/draft-reddy-opswg-mud-tls>
> 
> 
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
> 
> --
> Mud mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mud

---

From: tirumal reddy <[email-masked]>
Date: Tue, 9 Jul 2019 15:23:00 +0530

Thanks Eliot, glad to present the draft.

-Tiru

On Mon, 8 Jul 2019 at 20:02, Eliot Lear <[email-masked]> wrote:

> I think this is a pretty cool idea.  You should talk about it if you can
> make the side meeting, or otherwise if you can get time at opsawg.
>
> Eliot
>
> Status:
> https://datatracker.ietf.org/doc/draft-reddy-opswg-mud-tls/