Subject: [OPSAWG] The future of MUD work

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 29 Jul 2019 21:44:34 +0000

OpsAWG members and our Ops ADs, it was discussed in opsawg at IETF 105 that with the amount of MUD work being proposed (and discussions happening outside of opsawg) that perhaps MUD should evolve into its own WG.  Some cons to this approached were discussed (maybe it would be too heavy-weight with a charter, milestones, etc.).  However, I wanted to take this conversation to the list so we can close on it publicly.

Speaking as WG co-chair, I am happy to continue to support the MUD work in opsawg, but I want to make sure the WG feels compelled to work on it; and I want to make sure the full community that is interested in MUD can follow and discuss items here.  That said, it was mentioned in 105 that perhaps a bigger “on-boarding” set of work would be better served in its own WG.  I think if the scope of MUD grows beyond the definition and its extensions (as we’ve been seeing the work progress thus far) it might be better served in its own WG space.

Thoughts?

Joe

---

From: Michael Richardson <[email-masked]>
Date: Mon, 29 Jul 2019 20:15:41 -0400

Thank you for this thread.

Joe Clarke (jclarke) <[email-masked]> wrote:
    > Speaking as WG co-chair, I am happy to continue to support the MUD work
    > in opsawg, but I want to make sure the WG feels compelled to work on
    > it; and I want to make sure the full community that is interested in
    > MUD can follow and discuss items here.  That said, it was mentioned in
    > 105 that perhaps a bigger “on-boarding” set of work would be better
    > served in its own WG.  I think if the scope of MUD grows beyond the
    > definition and its extensions (as we’ve been seeing the work progress
    > thus far) it might be better served in its own WG space.

I think that MUD and MUD extensions is a pretty clear scope.
I think that the bigger on-boarding work is too nebulous to scope easily.

Perhaps a WG could be created with a name/scope like:
        Security Operations for Constrained Devices

(except that won't be a cool enough acronym)

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Eliot Lear <[email-masked]>
Date: Tue, 30 Jul 2019 11:09:10 +0200

Hi Joe,

> On 29 Jul 2019, at 23:44, Joe Clarke (jclarke) <[email-masked]> wrote:
> 

I think it is probably time for at least one WG to spring from OPSAWG.  We didn’t really complete the agenda at the IETF, and a good reason of that was MUD.  There are at least four active drafts on that one subject, one of which we didn’t really talk about (bw-profile).  For me it’s a matter of what can reasonably be coded, tested, and be useful for manufacturers.  In as much as we can bring a bit more focus to manufacturers by offering them more of a venue for discussion, the additional WG would be welcome.  On the other hand, if we find that we’re not making progress, or if we progress extensions quickly, we can close the WG and continue the mailing list, and move back to OPSAWG.  I don’t see a MUD working group as a long term activity (famous last words), but targeted more at producing the necessary for broader adoption and then going out of business.

Eliot

> 
> Joe
> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg

---

From: Eliot Lear <[email-masked]>
Date: Wed, 31 Jul 2019 10:45:23 +0200

On the other hand, it shouldn’t just be me.  It’d be a very small working group ;-) If others are interested, they should speak up.

> On 30 Jul 2019, at 11:09, Eliot Lear <[email-masked]> wrote:
> 
> Signed PGP part
> Hi Joe,
> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/opsawg <https://www.ietf.org/mailman/listinfo/opsawg>
> 
> 
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 31 Jul 2019 06:14:36 -0400

> On the other hand, it shouldn’t just be me.  It’d be a very small working group ;-) If others are interested, they should speak up.

I don’t think I would necessarily initiate work, but I suspect if there were a MUD WG I would show up for it and review documents.  The fact that MUD is in OPSAWG has meant that I don’t go because that’s not a WG I normally go to, and I didn’t realize that was where the MUD work was happening.

---

From: tom petch <[email-masked]>
Date: Wed, 31 Jul 2019 11:35:40 +0000

----- Original Message -----
From: "Joe Clarke (jclarke)" <[email-masked]>
Sent: Monday, July 29, 2019 10:44 PM

> OpsAWG members and our Ops ADs, it was discussed in opsawg at IETF 105
that with the amount of MUD work being proposed (and discussions
happening outside of opsawg) that perhaps MUD should evolve into its own
WG.  Some cons to this approached were discussed (maybe it would be too
heavy-weight with a charter, milestones, etc.).  However, I wanted to
take this conversation to the list so we can close on it publicly.
>
> Speaking as WG co-chair, I am happy to continue to support the MUD
work in opsawg, but I want to make sure the WG feels compelled to work
on it; and I want to make sure the full community that is interested in
MUD can follow and discuss items here.  That said, it was mentioned in
105 that perhaps a bigger “on-boarding” set of work would be better
served in its own WG.  I think if the scope of MUD grows beyond the
definition and its extensions (as we’ve been seeing the work progress
thus far) it might be better served in its own WG space.
> Thoughts?

I think that a WG has a cost, needing chairs (and I think that WG chairs
are in short supply), a different mailing list, different archive,
different name for I-Ds (which create a lack of continuity, making it
hard to track the history of work) another meeting to squeeze into an
IETF meeting.  Splitting off part of a task puts focus on it provided
that there are those interested in focussing on it; I am not sure that
there is here.

And it would focus on the name, as in 'Your name is mud' which, in my
culture, does not have a positive association.

Tom Petch