Subject: Routing bit set on sho ip ospf database

From: Javed Syed <[email-masked]>
Date: Sun, 2 Jun 2002 13:38:35 -0400

Hi,

I have question on " sho ip ospf database " output command. One of the line from the output has a routing bit set. Can somebody explain me the importance of this field. I have not seen this line when I do above command on ASBR router.
I think I know the answer but still would like to have good explanation from this alias.

regards
js

---

From: Acee Lindem <[email-masked]>
Date: Sun, 2 Jun 2002 13:48:18 -0400

> I think I know the answer but still would like to have good explanation from this alias.

Syed,

I believe this is a vendor specific question and you'd better
served by directing it to your vendor. Having said that, if your
vendor's implementation is similiar to ours the router bits
in the "show ospf database detail" output corresponding directly
to the type LSA 1 router bits as documented in section A.4.2 of
RFC 2328.

[local]SE1#show ospf database router detail

   --- OSPF Link State Database for Instance 1/Router ID 193.10.25.7 ---

         --- Router LSA 193.10.25.7 (Area 0.0.0.0) ---

Link State Id     : 193.10.25.7        Advertising Router   : 193.10.25.7
Sequence Number   : 0x80000004         Checksum             : 0xfc53
Options           : E,DC,O             Length               : 36
RouterBits        : B                  LinkCount            : 1
Age               : 290

Link Type    : stub        Network Number (Link id)  : 193.4.0.0
Link Metric  : 1           Network Mask (Link data)  : 255.255.0.0

         --- Router LSA 193.10.25.7 (Area 0.0.0.1) ---

Link State Id     : 193.10.25.7        Advertising Router   : 193.10.25.7
Sequence Number   : 0x80000006         Checksum             : 0x6387
Options           : E,DC,O             Length               : 48
RouterBits        : B                  LinkCount            : 2
Age               : 290

Link Type    : stub        Network Number (Link id)  : 10.1.0.0
Link Metric  : 1           Network Mask (Link data)  : 255.255.0.0

Link Type    : stub        Network Number (Link id)  : 10.3.0.0
Link Metric  : 1           Network Mask (Link data)  : 255.255.0.0

--
Acee

---

From: Alex Zinin <[email-masked]>
Date: Wed, 12 Jun 2002 18:35:36 -0700

In the case of that particular vendor, whose implementation
I just happen to have worked with a bit ;), the "routing bit"
means that the advertising router is reachable through SPF.
Cool for network troubleshooting, saved me hours many times.

Alex

---

From: Acee Lindem <[email-masked]>
Date: Fri, 14 Jun 2002 17:40:48 -0400

> Cool for network troubleshooting, saved me hours many times.

I implemented the same hack but with the more intuitive :^)
"show ospf border-routers all" command.

--
Acee