Subject: Re: broadcas network definition

From: Ruth Fax <[email-masked]>
Date: Thu, 27 Jun 2002 10:04:33 -0400

Hi Beatriz,

Broadcast packets are not forwarded off subnets.  With broadcast
you reach all the hosts on your subnet.
A broadcast network can be implemented in H/W or S/W.  Within N3
all hosts on the same subnet should receive broadcasts that originate on
that subnet.

--Ruth

-----Original Message-----
From: Beatriz Silva [mailto:[email-masked]]
Sent: Thursday, June 27, 2002 6:18 AM
To: [email-masked]
Subject: broadcas network definition

Hi !

According to RFC 2328 broadcast networks are defined as follows:

Broadcast networks
Networks supporting many (more than two) attached routers,
together with the capability to address a single physical
message to all of the attached routers (broadcast).
Neighboring routers are discovered dynamically on these nets
using OSPF's Hello Protocol.  The Hello Protocol itself
takes advantage of the broadcast capability.  The OSPF
protocol makes further use of multicast capabilities, if
they exist.  Each pair of routers on a broadcast network is
assumed to be able to communicate directly. An ethernet is
an example of a broadcast network.

And there is also a drawing example where, as far as I understood N3 could
be a broadcast network.

                 +
                 | 3+---+                     N12      N14
               N1|--|RT1|\ 1                    \ N13 /
                 |  +---+ \                     8\ |8/8
                 +         \ ____                 \|/
                            /    \   1+---+8    8+---+6
                           *  N3  *---|RT4|------|RT5|--------+
                            \____/    +---+      +---+        |
                  +         /   |                  |7         |
                  | 3+---+ /    |                  |          |
                N2|--|RT2|/1    |1                 |6         |
                  |  +---+    +---+8            6+---+        |
                  +           |RT3|--------------|RT6|        |
                              +---+              +---+        |

My question is what physically would be a broadcast network (or what could
be inside N3 ?)?

I understand that only one ethernet cable (or ethernet cables connected
through hubs) with some computers connected to it would be a broadcast
network: every message sent on this network could be listenned by any
computer and router. But, what if there are some switches connecting the
ethernet cables ? In that case some ethernet segments might not receive the
packet sent to hosts in other segments. It still an broadcast network ?

Obs: As far as I understood, N3 is a broadcast network containing only 4
routers: RT1, RT2, RT3 and RT4. Inside the hexagon written N3 would exit
only ethernet cables connected by switches (?) or hubs. Is that right ?

I would really appreciate if somebody could answer my question.

Thanks,
Beatriz

--
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Save up to $160 by signing up for NetZero Platinum Internet service.
http://www.netzero.net/?refcd=N2P0602NEP8

---

From: Andrew Lange <[email-masked]>
Date: Thu, 27 Jun 2002 12:12:58 -0700

Beatriz,

To follow up on your switch question, if a frame is forwarded to a switch
with a broadcast destination, it is forwarded out all ports on the switch.
This assumes that there are no vlans configured.  If there are vlans,
then the frame is only forwarded out all ports in the vlan.

Andrew

On Thu, Jun 27, 2002 at 10:04:33AM -0400, Ruth Fax wrote:
> X-Mailer: Internet Mail Service (5.5.2653.19)
> Date:         Thu, 27 Jun 2002 10:04:33 -0400
> Reply-To: Mailing List <[email-masked]>
> From: Ruth Fax <[email-masked]>
> Subject: Re: broadcas network definition
> Precedence: list
> X-OriginalArrivalTime: 27 Jun 2002 14:05:37.0264 (UTC) FILETIME=[B6465700:01C21DE3]
>
> Hi Beatriz,
>