Subject: Re: OSPF Retransmission Doubt

From: "Manral, Vishwas" <[email-masked]>
Date: Tue, 18 Jun 2002 08:07:13 -0400

Hi Amit,

You may like to look at the RFC1765 - OSPF Database Overflow.
http://www.ietf.org/rfc/rfc1765.txt This RFC tells a way to deal with such
overflow when it occurs in OSPF.

Also as the RFC lists as enhancements, if the number of summary LSA's
increases we could as well flush type3/4 also and originate default routes
in the domain instead, which could lead to suboptimal routing or blackholing
however.

However in ur case if a router does not accept and acknowledge an LSA, it
will be continuously retransmitted as long as the adjacency is up. If this
is not done, the databases would have no way to come back to synch as the
adjacency itself would not be broken.

Thanks,
Vishwas

-----Original Message-----
From: Amit Srivastava [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 5:26 PM
To: [email-masked]
Subject: OSPF Retransmission Doubt

Hi All,
   I have the doubt which is described below:-
Suppose a router is there whose database is full.Now
it can send and receive hello packets but discards any
new LSA coming to it(as database is full) and hence it
will not ack that LSA.Now my doubt is that RFC 2328
says the the retransmission will continue till the
adjacency is broken.
    Does that mean if the database does not have space
for accomodating the new LSA infinite number of
retransmission would result???
Regards
Amit

---

From: Amit Srivastava <[email-masked]>
Date: Tue, 18 Jun 2002 07:05:22 -0700

Hi Vishwas!
          Actually after reading the RFC 1765 only i got this doubt.Here i feel once the OSPFEXTLSDBLinit variable is exceeded the router should indicate other routers that its database is full and they should not keep on retransmitting the LSA which will clog the n/w bandwidth.Once the router comes out of the database overflow state it should indicate to the other router that now they should send the LSA.
      What do you say about this??
Regards
Amit

  "Manral, Vishwas" <[email-masked]> wrote: Hi Amit,

Thanks,
Vishwas

-----Original Message-----
From: Amit Srivastava [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 5:26 PM
To: [email-masked]
Subject: OSPF Retransmission Doubt

Hi All,

---------------------------------
Do You Yahoo!?
Sign-up for Video Highlights of 2002 FIFA World Cup

---

From: Amit Srivastava <[email-masked]>
Date: Tue, 18 Jun 2002 23:13:21 -0700

Hi Erblich and Vishwas,
      Erblich I got your point but is there any Draft or RFC which
states
this??
     And Vishwas thanks for your help i would also like to know if
there is any draft which states that we can withdraw Summary 3 and 4
non-default LSA.Because The RFC 2370 specks very little about it.
Regards
Amit

  Amit Srivastava <[email-masked]> wrote:
Hi Vishwas!
          Actually after reading the RFC 1765 only i got this doubt.Here i feel once the OSPFEXTLSDBLinit variable is exceeded the router should indicate other routers that its database is full and they should not keep on retransmitting the LSA which will clog the n/w bandwidth.Once the router comes out of the database overflow state it should indicate to the other router that now they should send the LSA.
      What do you say about this??
Regards
Amit

Thanks,
Vishwas

-----Original Message-----
From: Amit Srivastava [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 5:26 PM
To: [email-masked]
Subject: OSPF Retransmission Doubt

Hi All,