Subject: Re: Database Over Flow Doubt

From: "Manral, Vishwas" <[email-masked]>
Date: Mon, 24 Jun 2002 13:16:23 -0400

Amit,

You can do it either way, as long as you are somehow able to get back the
LSA's that you wanted to originate and that you could not originate, when
you come out of overflow state.

Thanks,
Vishwas

-----Original Message-----
From: Amit Srivastava [mailto:[email-masked]]
Sent: Monday, June 24, 2002 11:32 AM
To: [email-masked]
Subject: Database Over Flow Doubt

Hi Vishwas!!
  I have one more doubt the RFC 1765 say in example
(section 3) that when the OSPF timer expires then it
tries to come out of the database overflow state and
originates all the 400 non default AS-Exteranl LSA.Is
it that before flushing the LSA it keeps the LSA in a
linklist form and after the timer expires it
originates the LSA again!!If this is the case then i
have small doubt :-
             We have flushed the link state database
because we think that we cannot accomodate any other
LSA.Now keeping the log of all the flushed LSA would
not be a good idea what i feel!!!
What do u say??
Regards
Amit

--- "Manral, Vishwas" <[email-masked]> wrote:
> Amit,
>
> When the administrator finds that a domain is
> getting "Overflows" he has to
> change the policies so that the number of routes
> imported into the domain is
> reduced. The routes to be imported are all an
> administrative
> decision/policies and the OSPF packets etc do not
> come into picture at all.
>
> The RFC in this point talks about importing routes
> from other domains and
> not about received LSA's from other routers in the
> domain.
>
> Thanks,
> Vishwas
>
> -----Original Message-----
> From: Amit Srivastava [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 4:35 PM
> To: [email-masked]
> Subject: Re: OSPF Retransmission Doubt
>
>
>  Hi Vishwas!!
>       The RFC 1765 section 4 last point states that
> if
> the administrator cannot incresase the value of
> ospfExtlsdbLimit then he can make sure that more
> important routes continue to be imported ; this is
> accomplished by turning off the importing of less
> important routes.
>       Now my doubt is ->is it that the administrator
> configures paticular n/w coming in the AS-external
> packet as important or unimportant or does it mean
> that routes learned by a paticular router-id are
> important and will stay in the database while all
> the
> others will be flushed or is it implementation
> specific!!!
> Regards
> Amit
>
>
>
>
> --- "Manral, Vishwas" <[email-masked]> wrote:
> > Hi Amit,
> >
> > The case would not occur if all the routers would
> > have the same value of
> > ExtLSDBLimit except in the transient condition.
> > Section 2.2 first part would
> > only occur if the value is not the same this may
> be
> > required. Its always
> > better to check the condition, if we are exceeding
> > the limit and accordingly
> > take action to get over any such a case.
> >
> > Section 2.3 states that the flooding modification
> > would only be invoked
> > during a "short period of convergence" for same
> > value of LSDBLimit. Such a
> > case would only occur say when two routers are
> > symultaneously originating
> > AS-External LSA's. So when they are originating
> the
> > LSA's the LSDB limit is
> > not exceeded however when they are receiving the
> > LSA's from the other the
> > LSDB limit is exceeded. However as the RFC states
> > this would be a transient
> > condition.
> >
> > Thanks,
> > Vishwas
> >
> > -----Original Message-----
> > From: Amit Srivastava [mailto:[email-masked]]
> > Sent: Thursday, June 20, 2002 10:24 AM
> > To: [email-masked]
> > Subject: Re: OSPF Retransmission Doubt
> >
> >
> > Hi Vishwas,
> >    I have a small doubt .If u refer to section 2.2
> > and
> > 2.3 of RFC 1765 it states that during flooding
> also
> > the variable count of non-default AS_external LSA
> is
> > incremented( if we receive a non-default
> AS-external
> > LSA during flooding).But if we have a common
> thresh
> > hold limit i.e variable ospfExtlsdbLimit is same
> for
> > all the router how come this condition will be
> > encountered???
> > Regards
> > Amit
> >
> >
> >
> >
> > --- "Manral, Vishwas" <[email-masked]>
> wrote:
> > > Hi Amit,
> > >
> > > I do not think any RFC which talks about
> > non-default
> > > type-3 LSA's exists.
> > > The RFC1765 only talks about type-5 LSA's
> however
> > it
> > > could be extended for
> > > other type of LSA's i.e. type-7, type-11.
> > >
> > > Thanks,
> > > Vishwas
> > >
> > > -----Original Message-----
> > > From: Amit Srivastava
> [mailto:[email-masked]]
> > > Sent: Wednesday, June 19, 2002 11:43 AM
> > > To: [email-masked]
> > > Subject: Re: OSPF Retransmission Doubt
> > >
> > >
> > >
> > >  Hi Erblich and Vishwas,
> > >       Erblich I got your point but is there any
> > > Draft or RFC which
> > > states
> > > this??
> > >      And Vishwas thanks for your help i would
> also
> > > like to know if
> > > there is any draft which states that we can
> > withdraw
> > > Summary 3 and 4
> > > non-default LSA.Because The RFC 2370 specks very
> > > little about it.
> > > Regards
> > > Amit
> > >
> > >
> > >
> > >   Amit Srivastava <[email-masked]> wrote:
> > >
> > >
> > > Hi Vishwas!
> > >
> > >
> > >           Actually after reading the RFC 1765
> only
> > i
> > > got this doubt.Here i
> > > feel once the OSPFEXTLSDBLinit variable is
> > exceeded
> > > the router should
> > > indicate other routers that its database is full
> > and
> > > they should not keep on
> > > retransmitting the LSA which will clog the n/w
> > > bandwidth.Once the router
> > > comes out of the database overflow state it
> should
> > > indicate to the other
> > > router that now they should send the LSA.
> > >
> > >
> > >       What do you say about this??
> > >
> > >
> > > Regards
> > >
> > >
> > > Amit
> > >
> > >   "Manral, Vishwas" <[email-masked]>
> wrote:
> > >
> > >
> > > Hi Amit,
> > >
> > > You may like to look at the RFC1765 - OSPF
> > Database
> > > Overflow.
> > > http://www.ietf.org/rfc/rfc1765.txt This RFC
> tells
> > a
> > > way to deal with such
> > > overflow when it occurs in OSPF.
> > >
> > > Also as the RFC lists as enhancements, if the
> > number
> > > of summary LSA's
>

---

From: Amit Srivastava <[email-masked]>
Date: Mon, 24 Jun 2002 21:01:02 -0700

Hi Vishwas ,
        That is my point how can u store all the
LSA(400 in the example of RFC) when we are flushing
the LSA's from the database just bcoz we think that
there is no space for the other LSA's.
         The purpose of writing the RFC here itself is
being hamperred if we store the flushed alway LSA
again the same memory problem will persist!!
Hope i made my self clear!!
Regards
Amit
> > > > non-default LSA.Because The RFC 2370 specks
=== message truncated ===

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com