Subject: DR & BDR Election??

From: Amit Srivastava <[email-masked]>
Date: Sun, 2 Jun 2002 20:20:23 -0700

Hi Yasu,
        When you say that DR(Router A) has resigned from DR what exactly do you mean??? Is it that A goes down.In that case also it would take 40 seconds( Usual router dead interval) for the BDR to detect that the router has gone down and by that time there would again be the 2nd DR and BDR election.
                    I hope i am clear!! If you have explanation of this please let me know the answer!!
Regards
Amit

  Yasuhiro Ohara <[email-masked]> wrote: > Question
> ---------
> I have doubt with (ii) and (iii). Should router A have placed itself in BDR
> candidates list before recalculating steps (2) and (3) or just allow router
> C to retain its BDR post?

In my understanding, an implementation strictly following RFC2328 will
do latter: just allow router C to retain its BDR post. The next BDR
view of the segment depends on whether A will declare itself as BDR or
not.

> I can understand why a newly designated DR needs to repeat steps (2) and
> (3). Those steps avoid the router from claiming to be DR and BDR at one
> time. However I cannot see why *repetition* of those steps are required for
> a router that self-nominate as BDR, resigning from BDR, or resigning from
> DR, as indicated by step (4) because even after the recalculation, its view
> will never change. Do I miss any important point here?

I can't think of a situation where the 2nd calculation of DR (2nd (3))
is necessary ... (I want someone to teach me ...)

But obviously 2nd calculation of BDR (2nd (2)) is necessary, see
below:

# note: RFC2328 9.4 (2) describes BDR calculation, (3) describes DR
# calculation

new comer
+-+-+ +-+-+ +-+-+
|A|1| |B|0| |C|2|
+-+-+ +-+-+ +-+-+
| A | | A | | C |
+---+ +---+ +---+
| - | | - | | - |
+---+ +---+ +---+

after C
1st (2)(3) -

after C
2nd (2) A

Router B has priority 0 so he is not eligible to become neither DR nor
BDR. So before the newcomer comes, the segment's DR is A and BDR is
none.

Looking into A's calculation, After the newcomer has come and just
after 1st calculation of DR/BDR, A has just resigned DR but he's
yet eligible to become BDR. If we don't recalculate BDR/DR again,
A cannot realize that he can be BDR.

regards.
yasu

---------------------------------
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup

---

From: Yasuhiro Ohara <[email-masked]>
Date: Mon, 3 Jun 2002 20:12:09 +0900

No, I don't mean "router down" by "resigning DR".

In that situation cited below, 1st DR calculation of "A" results that
"A" is not DR anymore. This means "resigning DR".

Again, if "A" does not do the 2nd DR Calculation, "A" cannot find that
he can be BDR. If "A" does not declare himself as BDR, there's still
no BDR on the segment, which is not nice.

regards.
yasu

> Hi Yasu,
> 
>         When you say that DR(Router A) has resigned from DR what exactly do
> you mean??? Is it that A goes down.In that case also it would take 40 seconds(
> Usual router dead interval) for the BDR to detect that the router has gone
> down and by that time there would again be the 2nd DR and BDR election.
> 
>   Yasuhiro Ohara <[email-masked]> wrote:
> 
>     > Question
>     > ---------
> ------------------------------------------------------------------------------
> Do You Yahoo!?