Subject: Re: mtu in DD exchange.

From: "Manral, Vishwas" <[email-masked]>
Date: Fri, 21 Jun 2002 14:11:12 -0400

Mitchell,

I would just like to add a few things now that you have raised the issue.
Firstly I guess you have a valid point of catching the MTU mismatch in
hellos.

However even in hellos we could as well do by just sending the value of MTU
and not padding, the reason we pad in ISIS is in case we have a bridged
sublink in between which has a lower MTU than the two ends. Also the Hello
padding does not solve the MTU problem in ISIS, as we require a globally
synched MTU in ISIS unlike in OSPF.

Thanks,
Vishwas

-----Original Message-----
From: Erblichs [mailto:[email-masked]]
Sent: Friday, June 21, 2002 9:19 PM
To: [email-masked]
Subject: Re: mtu in DD exchange.

Group, my two cents..

This "problem" was actually fixed in another LS protocol, ISIS
with its HELLO PDU. The hellos were padded to within 1 byte/octet
of the MTU. This allowed the perspective link partners to
implictly specify their MTUs. Else, no link partners with less
of a chance that a DR won't be able to send the proper CSNPs..

This was a tradeoff of bandwidth consumption versus forming
an adjacency that possibly would drop PDUs/ LSAs in the
future due to different MTUs.

I actually always thought that the MTU matching in OSPF should
be done with the Hello packet. You may ask why. This would
increase the chance that all 2-ways that could then be involved in
a DR or BDR election can actually form full adjacencies...

Where currently it is done later with the OSPF dbase descr packet..

Or did I miss something?....

Mitchell Erblich
======================

"Manral, Vishwas" wrote:
>
> Prashant/Daniel,
>
> Besides what Alex has already sent you may like to have a look at the
> discussions in the archives. This thing has been discussed a lot of times
in
> the past.
>
> Check
> http://discuss.microsoft.com/SCRIPTS/WA-MSD.EXE?A2=ind0008&L=OSPF&P=R2394
> and
> http://discuss.microsoft.com/SCRIPTS/WA-MSD.EXE?A2=ind0008&L=OSPF&P=R2279
.
>
> Besides the MTU check is (from RFC2328)
>
>         If the Interface MTU field in the Database Description packet
>         indicates an IP datagram size that is larger than the router can
>         accept on the receiving interface without fragmentation, the
>         Database Description packet is rejected.
>
> So if we did not want an MTU mismatch in any case, we could always send a
> value 0 for the Interface MTU, as is done on virtual links.
>
> Thanks,
> Vishwas
>
> -----Original Message-----
> From: Daniel Gryniewicz [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 12:07 AM
> To: [email-masked]
> Subject: Re: mtu in DD exchange.
>
> True, and it'll be resent forever, taking 9000 bytes of bandwidth every
> time.
> :(  And I'll still use it in my SPF, and so the black hole will still
> occure.
>
> Daniel
>
> On Thu, 20 Jun 2002 11:35:20 -0700
> prashant desai <[email-masked]> wrote:
>
> > that makes sense :-)
> > but the drop lsa will not be acked....never reachd ospf
> >
> > thanks
> > Prashant
> >
> >
> > >From: Daniel Gryniewicz <[email-masked]>
> > >Reply-To: Mailing List <[email-masked]>
> > >To: [email-masked]
> > >Subject: Re: mtu in DD exchange.
> > >Date: Thu, 20 Jun 2002 14:30:58 -0400
> > >
> > >So, I send you the 9000 byte packet.  My IP layer thinks it's fine.
Your
> > >IP
> > >layer drops it.  An adjacency never forms.  Or, worse yet, the
adjacency
> > >formed (the HELLOs and DDs were all small enough) and then I get and
> flood
> > >a
> > >huge LSA from someone else.  You drop it, but I assume you have it.  My
> SPF
> > >puts a route from this LSA through you, but you don't have it, so
> > >blackhole.
> > >I *have* to know that every packet I send to you can make it.  The MTU
> > >agreement assures that packets won't get dropped because of MTU
mismatch.
> > >
> > >Daniel
> > >
> > >On Thu, 20 Jun 2002 11:27:52 -0700
> > >prashant desai <[email-masked]> wrote:
> > >
> > > > exactly..the ip layer should drop the packet..why should OSPF care
> about
> > > > it..dont you think its the ip layers job to check mtu conformance of
> > > > incomming packets ?
> > > >
> > > >
> > > > >From: Daniel Gryniewicz <[email-masked]>
> > > > >Reply-To: Mailing List <[email-masked]>
> > > > >To: [email-masked]
> > > > >Subject: Re: mtu in DD exchange.
> > > > >Date: Thu, 20 Jun 2002 13:59:07 -0400
> > > > >
> > > > >What fragments?  All OSPF (baring virtual links) traffic is only on
> one
> > > > >link.
> > > > >What the MTU agreement assures is that everyone on the link agrees
> what
> > >the
> > > > >MTU *for that link* should be.  If I think the MTU is 9000, and you
> > >think
> > > > >the
> > > > >MTU is 1500, you'll silently drop all my packets.  My IP layer
won't
> > > > >fragment,
> > > > >because it thinks the MTU is large enough.
> > > > >
> > > > >Daniel
> > > > >
> > > > >On Thu, 20 Jun 2002 10:45:44 -0700
> > > > >prashant desai <[email-masked]> wrote:
> > > > >
> > > > > > Hi,
> > > > > > Can anyone give me a good reason why OSPF routers have to agree
on
> > > > > > the MTU size during DD exchange process..
> > > > > > As OSPF runs over IP..fragmentation or reassembly should not be
> its
> > > > > > concern..and they will be transparently handled by the IP
layer..
> > > > > > Prashant

---

From: Erblichs <[email-masked]>
Date: Mon, 24 Jun 2002 09:17:14 -0700

Vishwas and group,

        A MTU comparison in the hellos is really
        what I was suggesting and didn't know why
        it wasn't done...

        Mitchell Erblich
        -----------------