Subject: Link state data base example

From: praveendas e <[email-masked]>
Date: Wed, 24 Jul 2002 05:09:22 +0000

Hai all
    i am new to this group ,hope somebody will clear my doubt

My question is
In RFC 2328 ,section 2.1.2 An Example link-state database ,figure 2
The router R6 had an interface to Ia ,it is a stub network,
when the router RT6 calculate the routing table it is used RT10 as the
next hope to the stub network Ia having a cost of 12( i.e in section 2.2 The
shortest -path tree)
eventhough the router RT6 is directly connected to Ia with cost 7 ...

1.why it is using RT10 as next hope to Ia (the stub network)?
2.Why RT6 is adverising its direct interface,with other router as next hop?

Thanks in Advance
Regards
Praveendas

_________________________________________________________________
Join the world’s largest e-mail service with MSN Hotmail.
http://www.hotmail.com

---

From: Acee Lindem <[email-masked]>
Date: Wed, 24 Jul 2002 10:14:20 -0400

Praveendas,

This is in fact the route table that will result using Option 1
for describing point-to-point numbered interfaces (section
12.4.1.1). This is because RT10 is the only router advertising
a /32 prefix to Ia (RT6's local address).  If Option 2 is used,
  the OSPF computed route will be the same as the direct (i.e.,
connected) route.

Good Luck,
Acee

praveendas e wrote:

> Join the world's largest e-mail service with MSN Hotmail.
> http://www.hotmail.com
>

--
Acee