Subject: OSPFv3 route calculation

From: Taisuke Sasaki <[email-masked]>
Date: Fri, 12 Jul 2002 20:07:13 +0900

I have a question about the OSPFv3 route calculation.
Suppose the network and condition below:

1) R1: interface cost to the Network N1 is 10.
2) R2: interface cost to the Network N1 is 1.
3) Network N1: R1 is DR and R2 is BDR.
4) prefix C is assigned in R1, but not in R2.
5) all interfaces belong to the OSPFv3 backbone area.

     ----+---------------+----- Network N1
prefix A |               |prefix A
prefix C |               |
       +-+-+           +-+-+
       |R1 |           |R2 |
       +-+-+           +-+-+
         |               |
     ----+------+--------+----- Network N2
                |
              +-+-+
              |R3 |
              +---+

R1 originates a Network-LSA and an Intra-Area-Prefix-LSA like this:
  Network-LSA has 2 active neighbors(R1 and R2).
  Intra-Area-Prefix-LSA has 2 prefixes(prefix A and prefix C).

When R3 calculates the nexthop to the prefix C,
R3 selects the R2 because R2's interface cost is smaller than R1's.
However, R2 doesn't know the nexthop to the prefix C.

I think it is necessary for R2 to calculate the nexthop to the
prefix C from its R1's Link-LSA, but I cannot find the corresponding
statement in rfc2740.

---
Taisuke Sasaki

---

From: Yasuhiro Ohara <[email-masked]>
Date: Fri, 12 Jul 2002 21:54:00 +0900

sasaki> I have a question about the OSPFv3 route calculation.
sasaki> Suppose the network and condition below:
sasaki>
sasaki> 1) R1: interface cost to the Network N1 is 10.
sasaki> 2) R2: interface cost to the Network N1 is 1.
sasaki> 3) Network N1: R1 is DR and R2 is BDR.
sasaki> 4) prefix C is assigned in R1, but not in R2.
sasaki> 5) all interfaces belong to the OSPFv3 backbone area.
sasaki>
sasaki>      ----+---------------+----- Network N1
sasaki> prefix A |               |prefix A
sasaki> prefix C |               |
sasaki>        +-+-+           +-+-+
sasaki>        |R1 |           |R2 |
sasaki>        +-+-+           +-+-+
sasaki>          |               |
sasaki>      ----+------+--------+----- Network N2
sasaki>                 |
sasaki>               +-+-+
sasaki>               |R3 |
sasaki>               +---+
sasaki>
sasaki> R1 originates a Network-LSA and an Intra-Area-Prefix-LSA like this:
sasaki>   Network-LSA has 2 active neighbors(R1 and R2).
sasaki>   Intra-Area-Prefix-LSA has 2 prefixes(prefix A and prefix C).
sasaki>
sasaki> When R3 calculates the nexthop to the prefix C,
sasaki> R3 selects the R2 because R2's interface cost is smaller than R1's.
sasaki> However, R2 doesn't know the nexthop to the prefix C.
sasaki>
sasaki> I think it is necessary for R2 to calculate the nexthop to the
sasaki> prefix C from its R1's Link-LSA, but I cannot find the corresponding
sasaki> statement in rfc2740.

Hi.

I think there's no detailed statement in RFC. I thought R2 should use
NDP to resolve the actual nexthop on N1 in this case (since it's
attached network), and am doing do so in Zebra.

regards.
yasu

---

From: Sina Mirtorabi <[email-masked]>
Date: Fri, 12 Jul 2002 12:46:36 -0700

Taisuke

>      ----+---------------+----- Network N1

R2 does know R1's next hop through Link-LSA ( each router generate a
link-LSA  for each attached segment )
once R2 knows the next hop which is a link-local address, ND will take
care of layer3- layer2 mapping to send the packet

Sina