Subject: Database synchronization during hitless restart

From: Jason Chen <[email-masked]>
Date: Wed, 10 Jul 2002 17:12:27 -0700

Hi, 
As I understand from the John's hitless-restart draft, the helper side always maintains a FULL state for the restarted neighbor. Once the restarted router resume operation, it will operate the same as any other OSPF router. It will perform the database exchange procedure. 
My question is that how a restarted router to request database from his helper since the neighbor state is FULL from the helper point of view. Is there a conflict to RFC2328 ? 
Thanks for the help,
Jason

---

From: Acee Lindem <[email-masked]>
Date: Wed, 10 Jul 2002 23:21:38 -0400

Jason  wrote:

> Hi,
> As I understand from the John's hitless-restart draft, the helper side
> always maintains a FULL state for the restarted neighbor.

Jason,
The helper router does not maintain FULL state - it continues originating
router and network LSAs as if the restarting neighbor were in FULL state.

> Once the
> restarted router resume operation, it will operate the same as any other
> OSPF router. It will perform the database exchange procedure.
>
> My question is that how a restarted router to request database from his
> helper since the neighbor state is FULL from the helper point of view.
> Is there a conflict to RFC2328 ?
>
> Thanks for the help,
> Jason
>

--
Acee