Subject: Re: OSPF-TE link parameters

From: "Joyal, Daniel R (Daniel)" <[email-masked]>
Date: Wed, 21 Aug 2002 12:31:36 -0400

Ben, Acee,

 Since the TE Opaque LSAs are of area scope, I think the
RFC1850 MIB should work as Acee describes. The MIB update
does not invent a new area LSDB table for opaque LSAs. It
just specifies a textual identifier for type-10s in the existing
Area LSDB table so that management systems or MIB browsers can
translate the type number 10 to "type-10" for display. Type-11s go
in the extLSDB table. The update does define a new LSDB table for
type-9s, though, because the other two tables don't have
a link/interface index component.

-Dan

-----Original Message-----
From: Acee Lindem [mailto:[email-masked]]
Sent: Wednesday, August 21, 2002 12:06 PM
To: [email-masked]
Subject: Re: OSPF-TE link parameters

Ben Niven-Jenkins wrote:

> draft-katz-yeung-ospf-traffic describes a Link TLV that contains various
TE
> parameters such Resource colour & TE metric.  I would like to know if
there
> is a current MIB that can be used to extract this information from a
> router/LSR using SNMP?
>
> If a MIB doesn't already exist is any work being done on a MIB that will
> contain this information.

Ben,

The update to the OSPF MIB (draft-ietf-ospf-mib-update-05.txt)
supports the retrieval of opaque LSAs. An application would need
to parse ospfLsdbAdvertisement to exact the TE TLVs.

Has anyone implemented this MIB update?

> Thanks
> Ben

--
Acee

---

From: Acee Lindem <[email-masked]>
Date: Wed, 21 Aug 2002 12:46:32 -0400

> a link/interface index component.

Dan,

RFC 1850 doesn't include the area scoped opaque LSA type in the
ospfLsdbType enumeration (although it could be possible that
some implementations support it anyway).

   ospfLsdbType OBJECT-TYPE
        SYNTAX   INTEGER    {
                    routerLink (1),
                    networkLink (2),
                    summaryLink (3),
                    asSummaryLink (4),
                    asExternalLink (5), -- but see ospfExtLsdbTable
                    multicastLink (6),
                    nssaExternalLink (7)
                  }

Thanks,
Acee

--
Acee