Subject: 2 ospf link on the same physical link

From: Sandor Ecker <[email-masked]>
Date: Wed, 7 Aug 2002 14:33:53 +0200

Hello!

I have tried the following on zebra (redhat linux), and on cisco routers too.
I had a simple ip link (for example r1_e0/1--r2_e0/1), i added a network entry
to the ospf, to bring the adj. up, this was ok. I added a secondary ip address
(in another subnet) to the interfaces in every router, and the corresponding
network entry for the ospf. But the second ospf link didn't grow up... :(

I made a topology like this:

                +---+           +---+
                |   |e0/1   e0/1|   |
                |   |----Ar0----|   |
                |   |           |   |
                | r1|sec     sec| r2|
                |   |----Ar1----|   |
                |   |           |   |
                +---+           +---+

r1:
The interface config:
!
interface Ethernet0/1
 ip address 10.211.92.1 255.255.255.0 secondary
 ip address 10.211.192.1 255.255.255.0
 no ip directed-broadcast
 ip ospf network point-to-point

The ospf config:
router ospf 1
 network 10.211.92.0 0.0.0.255 area 1
 network 10.211.192.0 0.0.0.255 area 0
!

On this router the ospf showed just the original interface with the original ip
address...

r1#show ip ospf interface
Ethernet0/1 is up, line protocol is up
  Internet Address 10.211.192.1/24, Area 0
  Process ID 1, Router ID 10.211.192.1, Network Type POINT_TO_POINT, Cost: 10
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:00
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.211.192.8
  Suppress hello for 0 neighbor(s)

r2:
Interface config:
!
interface Ethernet0/1
 ip address 10.211.92.8 255.255.255.0 secondary
 ip address 10.211.192.8 255.255.255.0
 no ip directed-broadcast
 ip ospf network point-to-point

The ospf config:
router ospf 1
 network 10.211.92.0 0.0.0.255 area 1
 network 10.211.192.0 0.0.0.255 area 0
!

On this router like the first, just the original ip address occur.

r2#show ip ospf interface
Ethernet0/1 is up, line protocol is up
  Internet Address 10.211.192.8/24, Area 0
  Process ID 1, Router ID 10.211.192.8, Network Type POINT_TO_POINT, Cost: 10
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:03
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.211.192.1
  Suppress hello for 0 neighbor(s)

Kozos volt a kovetkezo:

The adj. was the same on each router.

r1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.211.192.8      1   FULL/  -        00:00:32    10.211.192.8    Ethernet0/1

The secondary ip address work, i can ping it. (for ex.: from r1 10.211.92.8)

The experience with zebras was the same. They haven't seen the eth2:0 as ospf
interface.
show ip ospf interface  shows nothing about eth2:0.

Hello packets were send just between the primary interfaces, so neighboring grow
up just between them.

Has anybody any idea, experience? Thanks a lot!

Sincerely,
Sandor Ecker

---

From: Acee Lindem <[email-masked]>
Date: Wed, 7 Aug 2002 21:33:58 -0400

Sandor,

Some vendors support OSPF on secondary IP addresses and others
do not. Refer to the list post below.

http://discuss.microsoft.com/SCRIPTS/WA-MSD.EXE?A2=ind0203&L=ospf&T=0&F=&S=&P=3918

The draft below proposes a way of supporting a single link in multiple
areas as a way of getting around the primary address limitation (among
other benefits).

http://www.ietf.org/internet-drafts/draft-ietf-ospf-mlinks-03.txt

Thanks,
Acee

--
Acee