Subject: Question about injecting default route by ASBR

From: Mani Devarajan <[email-masked]>
Date: Tue, 20 Aug 2002 12:21:56 -0700

Hi all,

How important is for ASBR to inject a default route into
AS. Is it MUST/OPTIONAL. RFC 2328 doesnt say its MUST
or NOT.

Does live network needs this option. And whether it make
any difference in reducing the traffic with in AS.

Thanks & Regards,
<Mani

---

From: Acee Lindem <[email-masked]>
Date: Tue, 20 Aug 2002 18:13:48 -0400

> AS. Is it MUST/OPTIONAL. RFC 2328 doesnt say its MUST

Hello Mani,

In general, RFC 2328 doesn't deal with origination of external
defaults or the redistribution (aka, import) of routes from
other protocols. However, it does describe the composition of
an OSPF AS external LSA for a default route.

Most OSPF implementations provide the capability to
originate a default route under configuration control.

> any difference in reducing the traffic with in AS.

It depends on the situation. In any case, this should be a
configurable option.

--
Acee