Subject: Data Description Packet Sequence

From: Sriram Saravanan <[email-masked]>
Date: Thu, 1 Aug 2002 09:59:14 -0400

Hi,

I have a question regarding Data Description Sequence Generation and any comments/suggestions on this is welcome.

My Question:
I am trying to use one of my SUN Interface as OSPF Emulator.

I try to send OSPF hello packets periodically to OSPF Network where I have one or two switches which has been configured to handle OSPF routing.

When the routers see the hello packets coming out from my SUN, they try to update LS by sending Data Description Packets.

While trying to ack. the packets, I try to send DD Sequence packet and trying to claim myself as Master.

But, while doing so, for some reason, I couldn't establish master-slave relationship and both my Sun Workstation and Router claim as master. (Router ID of Hello Packets generated from SUN is greater than OSPF Routers)

Any idea what I am doing wrong here ....

Thanks and have a great day!

- G

---

From: Acee Lindem <[email-masked]>
Date: Thu, 1 Aug 2002 12:13:35 -0400

> Any idea what I am doing wrong here ....

Sriram,

Both sides will send the initial DD packet with the M bit set. Try re-sending the
DD packet from you emulation code once you determine your router-ID is
greater (refer to figure 14 on page 106 in RFC 2329). Also, make use you
are don't have any little endian issues with the packets you are sending
from the Sun. You could check your router vendor's debug output (but don't
put vendor specific debug output to this list ;^).

--
Acee