Subject: How many changes can be in one LSA

From: Beatriz Silva <[email-masked]>
Date: Thu, 15 Aug 2002 11:31:53 -0500

Hi everybody!

Thanks for the answer about the topic "new LSA".

But I also want to know the following:
If more than one change occurs in a router for instance: one link changes cost and another link goes down simutaneously, will this two changes be signalled in one LSA or two LSAs will be generated for that ? I mean, is the LSA limited to one change at a time ?

Thanks,
Beatriz

--
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

---

From: Acee Lindem <[email-masked]>
Date: Fri, 16 Aug 2002 01:00:32 -0400

> If more than one change occurs in a router for instance: one link changes cost and another link goes down simutaneously, will this two changes be signalled in one LSA or two LSAs will be generated…

Hello Beatriz,

This is somewhat implementation dependent but in general simultaneous
events should result in a single router LSA re-origination. There is
no limit to the number of changes that can be contained in a single
LSA.

--
Acee

---

From: Alex Zinin <[email-masked]>
Date: Fri, 16 Aug 2002 15:44:32 -0700

Thursday, August 15, 2002, 10:00:32 PM, Acee Lindem wrote:
>> If more than one change occurs in a router for instance: one link changes cost
>> and another link goes down simutaneously, will this two changes be signalled in
>> one LSA or two LSAs will be generated for that ? I mean, is the LSA limited to
>> one change at a time ?

> no limit to the number of changes that can be contained in a single

Right, and the reason for this is that LSAs do not contain
_changes_, they contain a snapshot of the router's curren state
(the link state in the router-LSA case.)
Just making sure we all are on the same page.

Alex