Subject: Re: basic DR/BDR question!

From: armstrong mathiayalagan <[email-masked]>
Date: Thu, 8 Aug 2002 23:09:47 -0500

Mani and Vijay,
   The router which is started first in the broadcast IP network always becomes
a DR ( if it is eligible ) , the second router becomes BDR..
   ( After waiting timer expires, if no DR is found it declares itself as a DR,
 Waiting timer will expire first for the first started router !!),
In case if BDR fails ( waiting timer will not play any role), so the proper election takes place considering priority and Rtr ID.

Regards,
Armstrong

----- Original Message -----
From: Manikantan Srinivasan <[email-masked]>
Date:         Thu, 8 Aug 2002 09:58:00 -0700
To: [email-masked]
Subject: Re: basic DR/BDR question!

> Hello Vijaya Bhaskar
>
> The Router priority is important in the DR/BDR election.
>
> Second if there is more than one router in a network
> with same priority then the Router with highest
> Router ID becomes DR/BDR.
>
> Detailed information is available in sections 7.3, 7.4 and 9.4
> in RFC 2328.
>
> regards
> mani
>
> -----Original Message-----
> From: Mailing List [mailto:[email-masked]]On Behalf Of
> Vijaya Bhaskar
> Sent: Thursday, August 08, 2002 9:08 AM
> To: [email-masked]
> Subject: basic DR/BDR question!
>
>
> On what basis an OSPF  router on a particular interface declares itself as
> DR or BDR?
>
>

--
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

---

From: Vijaya Bhaskar <[email-masked]>
Date: Fri, 9 Aug 2002 09:56:42 -0400

I got the answer as follows, correct me if I am wrong.
When a routers comes up
1. If it is the only router on a broadcast network, it declares itself as DR
after wait timer is expired.
2. If it doe not receive any hellos(even though there may be neibhors on the
network)
   till its wait times expires, it declares itself as DR.
3. If the DR field is 0.0.0.0 in all the hellos it has received from
neighbors,
   and no DR is elected after wait timer is expires(i.e after DR/BDR
election is over),
   it declares itself as DR.
4. If all the other routers on the network are ineligible to become
DR/BDR(i.e router priority zero),
   it declares itself as DR after DR/BDR election is over.
5. If a DR already exists on the network, it just accepts the same as DR
irrespective of router priority
   or router ID.

There may be other possible cases!

-----Original Message-----
From: armstrong mathiayalagan [mailto:[email-masked]]
Sent: Friday, August 09, 2002 12:10 AM
To: [email-masked]
Subject: Re: basic DR/BDR question!

Mani and Vijay,
   The router which is started first in the broadcast IP network always
becomes
a DR ( if it is eligible ) , the second router becomes BDR..
   ( After waiting timer expires, if no DR is found it declares itself as a
DR,
 Waiting timer will expire first for the first started router !!),
In case if BDR fails ( waiting timer will not play any role), so the proper
election takes place considering priority and Rtr ID.

Regards,
Armstrong