Subject: Re: NSSA Problem

From: "Pat Murphy - (650)329-4044" <[email-masked]>
Date: Thu, 15 Aug 2002 17:52:59 -0700

Amit,

Sorry to be slow late with this posting. I have been
unavailable lately due to USGS security concerns.

Consider the following example. A0, B0, C0 are area 0
routers. A0 and B0 are ABRs for NSSA 1, both of which
translate Type 7 LSAs into Type 5 LSAs. D1 is an ASBR for
NSSA 1 which learns an external route for N1 from E1, an
EIGRP peer.

                        C0
                       .   .
                     .       .
            10Mbps .           . T1
                 .    Area 0     .
               .                   .
             A0     - - - - -      B0
               .                   .
                 .    NSSA 1     .
           128Kbps .           . T1
            ISDN     .       .
           backup     .   .
                        D1
                        .
                        .
                        .
                        E1
                        .
                        .
                        N1

If D1 sets a 0.0.0.0 forwarding address for N1 in its type
7 LSA, A0 and B0 would have to do the same in the Type 5
translation of this LSA. Thus C0 would see, via the Type 5
LSA translation, the 10Mbps path through A0 as the shortest
path to N1. If D1 sets a non-zero forwarding addess, C0
correctly computes the shortest path to N1 as the T1 link
through B0.

Note that even if both A0 and B0 originated a type 4
summary link for D1, the same logic would still hold, as
the type 5 LSA advertisement for N1 originates from A0 and
B0, not D1.

Pat

---

From: Amit Srivastava <[email-masked]>
Date: Thu, 15 Aug 2002 21:19:48 -0700

Hi Pat and Acee,
    Thanks a lot for your help i really understood the
concept.
Regards
Amit

> the type 5 LSA advertisement for N1 originates from

__________________________________________________
Do You Yahoo!?
HotJobs - Search Thousands of New Jobs
http://www.hotjobs.com