Subject: new LSA

From: Beatriz Silva <[email-masked]>
Date: Wed, 14 Aug 2002 03:50:42 -0500

Hi everybody !

I would like to know if it is possible (in OSPF v2) to identify, just by examining the LSA, what is the change the LSA is signaling. I want to identify if for example an router LSA was sent because the cost of one of the links was changed, or if it was because one of the links went down .... This, without having the previous LSAs, just by looking at the newly received LSA. Is it possible ? How  ?

Thank you very much,
Beatriz

--
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

---

From: Acee Lindem <[email-masked]>
Date: Wed, 14 Aug 2002 23:31:18 -0400

> I would like to know if it is possible (in OSPF v2) to identify, just by examining the LSA, what is the change the LSA is signaling. I want to identify if for example an router LSA was sent because…

Beatriz,

AFAIK, there is no way to determine what has changed without a previous version
of the LSA.

--
Acee

---

From: Erblichs <[email-masked]>
Date: Wed, 14 Aug 2002 23:28:08 -0700

Acee,

        Lets assume that we modify the LSA comparison code sections
        and we keep the older LSA versions for a short time assuming
        we have the memory available.

        What would you say we can now do with this additional information?

        Mitchell Erblich
        ===================

---

From: Acee Lindem <[email-masked]>
Date: Thu, 15 Aug 2002 02:29:05 -0400

>         we have the memory available.

Mitchell,

Wasn't the original question whether this could be done without the
previous LSA?

>         What would you say we can now do with this additional information?

If you had the previous LSA you could definitely determine what had
changed between the two versions.

--
Acee

---

From: Erblichs <[email-masked]>
Date: Thu, 15 Aug 2002 00:19:46 -0700

Acee,

        Then what would / could you do with this information? Could it
        be useful in anyway? Have you ever heard of anyone really
        interested in this type of information?

        Mitchell Erblich
        ======================

---

From: Naiming Shen <[email-masked]>
Date: Thu, 15 Aug 2002 00:35:27 -0700

I can think of some ways to use this info. For example, if we know
there is a link down from that new LSA, then we may want to trigger
an immediate calculation for the fast convergence purpose; if we know
there is an interface IP address change, who cares, data usually
are not forwarded to a backbone link anyway, we'll run the spf when
we have spare time; if we know A to B has two ECMP links and one of
them is up/down, there is nothing needs to be done, since even we
re-run the calculation, the results are got to be the same.

Now whether if people want to take such an "active" approach is up to
the implementors. we can argue either ways to the pros and cons.

cheers.

 ] Acee,
 ]
 ]         Then what would / could you do with this information? Could it
 ]         be useful in anyway? Have you ever heard of anyone really
 ]         interested in this type of information?
 ]
 ]         Mitchell Erblich
 ]         ======================
 ]
 ]
 ] Acee Lindem wrote:
 ] >
 ] > Erblichs wrote:
 ] >
 ] > > Acee,
 ] > >
 ] > >         Lets assume that we modify the LSA comparison code sections
 ] > >         and we keep the older LSA versions for a short time assuming
 ] > >         we have the memory available.
 ] >
 ] > Mitchell,
 ] >
 ] > Wasn't the original question whether this could be done without the
 ] > previous LSA?
 ] >
 ] > >
 ] > >         What would you say we can now do with this additional informatio
n?
 ] >
 ] > If you had the previous LSA you could definitely determine what had
 ] > changed between the two versions.
 ] >
 ] > >
 ] > >         Mitchell Erblich
 ] > >         ===================
 ] > >
 ] > >
 ] > > Acee Lindem wrote:
 ] > >
 ] > >>Beatriz Silva wrote:
 ] > >>
 ] > >>
 ] > >>>Hi everybody !
 ] > >>>
 ] > >>>I would like to know if it is possible (in OSPF v2) to identify, just b
y examining the LSA, what is the change the LSA is signaling. I want to identif
y if for example an router LSA was sent because the cost of one of the links wa
s changed, or if it was because one of the links went down .... This, without h
aving the previous LSAs, just by looking at the newly received LSA. Is it possi
ble ? How  ?
 ] > >>>
 ] > >>>
 ] > >>Beatriz,
 ] > >>
 ] > >>AFAIK, there is no way to determine what has changed without a previous
version
 ] > >>of the LSA.
 ] > >>
 ] > >>
 ] > >>>Thank you very much,
 ] > >>>Beatriz
 ] > >>>
 ] > >>>--
 ] > >>>__________________________________________________________
 ] > >>>Sign-up for your own FREE Personalized E-mail at Mail.com
 ] > >>>http://www.mail.com/?sr=signup
 ] > >>>
 ] > >>>
 ] > >>>
 ] > >>--
 ] > >>Acee
 ] > >>
 ] > >
 ] >
 ] > --
 ] > Acee

- Naiming

---

From: Acee Lindem <[email-masked]>
Date: Thu, 15 Aug 2002 09:25:52 -0400

Erblichs wrote:

>         be useful in anyway?

Mitchell,

Both the reasons that Naiming (adjusting SPF delay based on change type) and
Vishwas (doing an incremental SPF for stub networks) noted are reasonable.

>         Have you ever heard of anyone really

I can't say that I ever worked on an implementation that processed different
types of changes to individual LSAs differently.

--
Acee

---

From: Dave Katz <[email-masked]>
Date: Thu, 15 Aug 2002 08:46:19 -0700

Not a whole lot, since you cannot rely upon hearing every version of
every LSA, only the latest one.  There are a number of scenarios
in which an LSA being flooded can be overtaken by a newer version,
and thus the older one may not be delivered to everyone.

---

From: Naiming Shen <[email-masked]>
Date: Thu, 15 Aug 2002 09:56:57 -0700

]         Lets assume that we modify the LSA comparison code sections
 ]         and we keep the older LSA versions for a short time assuming
 ]         we have the memory available.
 ]
 ]         What would you say we can now do with this additional information?
 ]
 ] Not a whole lot, since you cannot rely upon hearing every version of
 ] every LSA, only the latest one.  There are a number of scenarios
 ] in which an LSA being flooded can be overtaken by a newer version,
 ] and thus the older one may not be delivered to everyone.

If router X received LSAs from router A with version a, b, c and d;
router Y only received a and d. If both X and Y decide to do version/
content comparison, it just means X is going to do 3 times, and Y
is going to do one time only. But the end result should be the same
since they all get the finally version of d. Unless the version/
content comparison code has problem.

thanks.
- Naiming