Subject: Re: ospf limits...

From: "Manral, Vishwas" <[email-masked]>
Date: Sun, 9 Mar 2003 23:40:25 -0500

Hi Yasu,

Just one small point I want to make.

Using
http://www.ietf.org/internet-drafts/draft-pillay-esnault-ospf-flooding-04.tx
t , we can reduce the Refresh-Rate.

Thanks,
Vishwas

-----Original Message-----
From: Yasuhiro Ohara [mailto:[email-masked]]
Sent: Monday, March 10, 2003 5:31 AM
To: [email-masked]
Subject: Re: ospf limits...

All I meant is that you can control refresh rate of IS-IS.

In larger system, OSPF LSA refresh and/or IS-IS LSP refresh
can be several tens of times per second. Then you can reduce
the refresh rate only when you use IS-IS, but you can't reduce
the refresh rate if you use OSPF.

Does that matter the scalability of network, doesn't it ?

I don't know actual parameter to enlarge the duration of LSP's life
(the time till the LSP expires), because I haven't touched
any working IS-IS ...

regards,
yasu

From: Rohit Gupta <[email-masked]>
Subject: Re: ospf limits...
Date: Sun, 9 Mar 2003 19:52:28 -0800

> Yasu,
> I could not understand as to how this will help in
> building larger ISIS areas vis-a-vis OSPF!
>
> Rohit
>
> --- Yasuhiro Ohara <[email-masked]> wrote:
> > Hi,
> >
> > Though I haven't read (or don't remember) any
> > document mentions
> > that, I guess it comes from the capability of
> > controlling the rate
> > of bandwidth consumption used by LSA refresh.
> >
> > Because IS-IS ages LSP by counting down the age and
> > expires them
> > when the age is 0, IS-IS's "IS" can decide when to
> > refresh his LSP
> > individually. OSPF specifies when to refresh and/or
> > expire LSA
> > explicitly, so OSPF system's refresh rate is
> > affected by the
> > network-size (precisely # of LSA), and can't be
> > reduced by
> > human manipulation.
> >
> > regards,
> > yasu
> >
> > From: Rohit Gupta <[email-masked]>
> > Subject: Re: ospf limits...
> > Date: Fri, 7 Mar 2003 01:00:14 -0800
> >
> > > I remember reading somewhere that ISIS can support
> > > bigger areas than OSPF though i am not sure as to
> > how
> > > exactly, given that both are link state and almost
> > > similar.
> > >
> > > So if you cant scale well with OSPF then you can
> > > consider ISIS also.
> > >
> > > ----- Original Message -----
> > > From: "klara moser" <[email-masked]>
> > > To: <[email-masked]>
> > > Sent: Thursday, March 06, 2003 11:41 PM
> > > Subject: Re: ospf limits...
> > >
> > >
> > > > Hi Ravi,
> > > >
> > > > As far as I know the OSPF protocol has only one
> > > limitation on the topologies
> > > > size - the Network and Router LSA size. The max
> > is
> > > 64KB. This limits the number
> > > > of links the router can have in a single area,
> > > because it has to advertise them
> > > > in a single Router LSA. You can do the math. It
> > is
> > > something like 5 000 links.
> > > >
> > > > Klara
> > > >
> > > > Quaizar Vohra wrote:
> > > >
> > > > > I think the main factor is the amount of
> > flooding
> > > a router has to do
> > > > > which depends on how many adjacencies you have
> > and
> > > how many LSAs you
> > > > > have to flood to each adjacency. So it is
> > useful
> > > to divide your
> > > > > network into multiple areas so as to reduce
> > > flooding. Also large
> > > > > no. of adjacencies in a single area can result
> > in
> > > rather large router
> > > > > LSAs which causes a lots of fragmentation and
> > adds
> > > to the flooding
> > > > > load.
> > > > >
> > > > > Quaizar
> > > > >
> > > > >  > I am in the midst of redesigning an OSPF
> > > network to accommodate
> > > > >  > significant growth, especially in the Area
> > 0
> > > backbone. There has been
> > > > >  > some concern about the size of the OSPF
> > > topology that would result and
> > > > >  > whether the routing protocol would remain
> > > robust, able to handle the odd
> > > > >  > flapping link or memory leak. The network
> > in
> > > question is using high-end
> > > > >  > routers with high speed links (at least
> > DS-3).
> > > > >  >
> > > > >  > Are there any heuristics that someone has
> > which
> > > may give us an idea of
> > > > >  > the comfort zone in terms of the database
> > size,
> > > number of neighbors,
> > > > >  > routers, etc?
> > > > >  >
> > > > >  > Or, could someone share information on the
> > size
> > > of large OSPF
> > > > >  > implementations that they are aware of?
> > > > >  >
> > > > >  > I know that this issue is rather vague
> > (clouded
> > > in too many unknowns)
> > > > >  > and may only result in rather ambiguous
> > > > >  > answers, but, one never knows.
> > > > >  >
> > > > >  > Thanks,
> > >
> > >
> > > __________________________________________________
> > > Do you Yahoo!?
> > > Yahoo! Tax Center - forms, calculators, tips, more
> > > http://taxes.yahoo.com/
>
>
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Tax Center - forms, calculators, tips, more
> http://taxes.yahoo.com/

---

From: Yasuhiro Ohara <[email-masked]>
Date: Mon, 10 Mar 2003 09:19:44 +0900

Thanks Singh, Manral,

I agree, OSPF has DoNotAge bit about LSA refresh.
I forgot about that.

And so what I said might be wrong, there'll be no scalability issues
in terms of refresh rate. sorry.

regards,
yasu

From: "Manral, Vishwas" <[email-masked]>
Subject: Re: ospf limits...
Date: Sun, 9 Mar 2003 23:40:25 -0500