Subject: Re: ospf limits...

From: "Naidu, Venkata" <[email-masked]>
Date: Mon, 10 Mar 2003 15:12:54 -0500

->   Manav, if ISIS design allows implementer to choose index trees
->   such that all *reachability* resides in the leaves (in the tree) -
->   including the reachability of non-leaf (transit) routers resides
->   on leaf nodes in the tree - then YES, it is very easy to skip
->   the Full-SPF when *reachability* information alone changes
->   (with out even going to Partial-SPF - just by updating the parent
->   - pi - links). What I mean by reachability here is: some address
->   in a leaf node in the tree (including some transit router's
->   address in the graph) changed from x to y.

  I am not satisfied with what I wrote. Let me re-phrase.

  If an ISIS implementation stores reachability information only
  in leaf-nodes (in a tree) then the amount of work we need to
  do will be less if the reachability alone changes.

  If OSPFv2 (not OSPFv3) stores reachability information in
  internal nodes as well, then the amount of work is little
  more (very little) when compared to index trees above.
  All we need to do is, walk all the (immediate) children
  and ask them "eh! I am the new parent for you, nothing
  changed, just point to me".

  So, where we store reachability information in the tree
  is irrelevant to the size of the tree (that is, the size
  of the area). It is all implementation dependent.

Venkata.

---

From: Dave Katz <[email-masked]>
Date: Mon, 10 Mar 2003 16:01:44 -0800

It is all implementation dependent.

This pretty much sums up most of the discussions on this list.  Maybe
I should set up a cron job.  ;-)