Subject: wait timer, ExStart, and adj formation

From: Erblichs <[email-masked]>
Date: Tue, 11 Mar 2003 09:58:36 -0800

Group,

        I have an issue dealing with the interaction of the wait timer,
        adjacency formation, and the reception of the DBD packet to
        move into the ExStart of the nbr state machine. This is
        in a Ethernet environment.

        What is occuring is simply stated as the ending of the
        wait timer on one system, an election of DR/BDR and
        the sending of a DBD packet out.

        However, the 2nd system still hadn't ended its wait
        timer and thus no adj has formed. Due to this, the
        rec'd DBD is normally dropped.

        This is going on at a customer site after they have
        mucked with the OSPF code. I know of a simple fix
        to patch the problem, but was looking to get a consensus
        on the frequency of this timing issue being seen.

Thanks,
        Mitchell Erblich
        Sr. Software Engineer

---

From: Dave Katz <[email-masked]>
Date: Tue, 11 Mar 2003 11:11:52 -0800

So what operational problem are you trying to solve?  It will all come
up with the next DBD packet anyhow.  Bringing up multiple systems on
a LAN more-or-less simultaneously will always be a little ugly, but
why do you care?

---

From: Acee Lindem <[email-masked]>
Date: Tue, 11 Mar 2003 14:29:11 -0500

Mitchell,

This is normal operation. The router coming out of interface wait
state first will continue to resend the initial database packet every
retransmit interval seconds. The router in wait state will exit
wait state when he receives a hello from the other guy (assuming these are
the only guys on the ethernet and the first has elected himself DR).

--
Acee

---

From: "Farshad (Sean) Tavallaei" <[email-masked]>
Date: Wed, 11 Mar 1998 11:38:47 -0800

Mitchell,

The period of the wait timer is the same as the RouterDeadInterval. One
thing they might have done is that they forgot to set that correctly in
their code (maybe they set it to a default constant value), and if they
configured the Dead timer to be different then they do not match any more...

If the system is not going to ExStart, it is possible that both systems are
claiming to be master and the master/slave negotiation never completes (e,g,
they both have the same Route ID, etc.)

Hope I could help,

Farshad

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of Erblichs
Sent: Tuesday, March 11, 2003 9:59 AM
To: [email-masked]
Subject: wait timer, ExStart, and adj formation

Group,

Thanks,
        Mitchell Erblich
        Sr. Software Engineer

---

From: Erblichs <[email-masked]>
Date: Tue, 11 Mar 2003 17:01:05 -0800

Thanks,

        I guess I don't remember seeing a msg that
        that a DBD pkt is dropped due to nbr state
        being less than ExStart.

        Mitchell Erblich
        -----------------------

---

From: Erblichs <[email-masked]>
Date: Tue, 11 Mar 2003 17:28:27 -0800

Dave,

        I care in this case because the customer cares
        and sees an error msg.

        In addition, where the proto-adj may have been in
        ExStart state maybe 1ms later, the adj won't be
        in ExStart until the DBD pkt is re-xmit'ed.

        Mitchell Erblich
        =================

---

From: Dave Katz <[email-masked]>
Date: Tue, 11 Mar 2003 22:19:01 -0800

Something I learned a long time ago about building products is to not
issue error messages when there's no error, as it always frightens
the customers.

Like I asked, what is the operational problem?  One packet time later
it comes up.

--Dave