Subject: Re: OSPFv3 Applications Support

From: "Naidu, Venkata" <[email-masked]>
Date: Wed, 12 Mar 2003 17:34:18 -0500

Quaizer,

-> As things stand, i.e. seperate protocols for IPv4 and
-> IPv6, work well enough currently. What's your techical
-> reason for modiyfing OSPFv3 to carry IPv4 prefixes.

  Some of the features in OSPFv2 can't be changed -
  just for example, representation of p2p links.
  There are lot of such refinements in OSPFv3 which
  can't go into OSPFv2 (even though they are applicable
  to IPv4) because of backward compatibility.

-> think my objections in the last mail were technical enough.
-> I don't see any merits in modifying a protocol (a complete
-> redesign, let alone just a simple change) just to be able to
-> run one instance of the protocol.

  I am assuming that the re-design will be simple, and
  you are assuming that the re-design is complicated.
  How much time did Ross Callon spent when he thought
  that ISIS can be used for IPv4 ? Is RFC1195 the
  complete re-design of ISIS protocol? If so, I agree
  with you.

-> Your ISIS argument holds if that was the case with OSPF
-> from the start. That is not the case. People already
-> have deployed OSPFv2. They will have to run OSPFv2
-> for a long time no matter what.

  Yes. If the deployment is the basis then I have to agree
  only with that. But, all my argument is, why are we
  stuck with old protocol. Let us evolve and refine
  protocols. Give better versions to customers. Don't you
  think that is the good intension?!?

Venkata.

---

From: Dave Katz <[email-masked]>
Date: Wed, 12 Mar 2003 14:46:53 -0800

If such refinements are operationally important, the vendors will
be pressured by the customers to take care of the problem, and
people will vote with their feet and pocketbooks.

I hosted the meeting (on a very cold December day in Ann Arbor) when
the IP extensions to ISIS were worked out.  The situation there was
different; the only IGP available for IPv4 at the time was RIP (OSPF
was also under design at the time.)  ISIS was trivially extensible.

If you want to play this game, a better parallel would be to instead
try to extend OSPFv2 to carry v6 info.  The OSPF Founding Fathers were
quite explicit in making OSPFv2 extremely IPv4 centric (I thought it
was a mistake then, and I still do now.)

Deployment is a *huge* issue.  If the customers feel "stuck" they will
clamor for the new and improved version.  However, nobody in their
right mind will switch protocols unless there's a *really* compelling
reason to do so.

--Dave

---

From: Quaizar Vohra <[email-masked]>
Date: Wed, 12 Mar 2003 15:19:30 -0800

Venkata,

 >   to IPv4) because of backward compatibility.

Well, I am not arguing for porting the v3 refinements to v2.
Precisely for the reason you mentioned, but in reverse,
if there are semantic differences between carrying IPv4
prefixes in OSPFv3 and carrying IPv4 prefixes in OSPFv2, you
will have a translation nightmare when translating OSPFv2
LSAs into OSPFv3 LSAs and vice-versa. You will need such
translation when transitioning from OSPFv2 to OSPFv3 because
part of your network will still be OSPFv2.

 >   complete re-design of ISIS protocol? If so, I agree

Even if the redesign is simple. It means more code.
For what ?

 >   think that is the good intension?!?

Isn't deployment a big issue ? Isn't IPv6 vs IPv4 war over
the same reason.

Quaizar