Subject: Un-numbered point to point - OSPFv3

From: Yenyi Fu <[email-masked]>
Date: Thu, 6 Mar 2003 11:09:08 -0800

Hi all,

A follow on question, more specific to OSPFv3 for
unnumbered point-to-point interfaces.

Looking at RFC 2740, the generation of IntraAreaPrefix
Lsa - referencing the router specifies:

point-to-point link which has not been assigned a
prefix,then the site-local and global scope IPv6
addresses associated with the interface (if any) are
copied into the intra-area-prefix-LSA, setting the
LA-bit in the PrefixOptions field, and setting the
PrefixLength to 128 and the Metric to 0.

What happens if the router does not have any
site-local or global scope IPv6 associated with it?
Is an IntraAreaPrefixLsa - Referencing the router
still sent out for this router?  What would be in the
prefix, prefix option, and prefix length fields?

Thanks,
Yenyi

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/

---

From: Yasuhiro Ohara <[email-masked]>
Date: Fri, 7 Mar 2003 09:50:33 +0900

> prefix, prefix option, and prefix length fields?

Hi, my interpretation is that the router should not send
any Intra-Area-Prefix-LSA which refers the router itself,
in that case. It is not needed, and further it will corrupt
routing someway because of the bogus prefix field, and because
of the consequence that every other router will consume his CPU
to calculate the bogus prefix's route.

There's no way for a router to detect if other routers have some
stub prefixes, other than to check whether the routers originate
any Intra-Area-Prefix-LSA or not.

regards,
yasu