Subject: draft-mirtorabi-ospfv3-af-00.txt and MOSPF

From: John Smith <[email-masked]>
Date: Wed, 19 Mar 2003 13:19:55 +0000

How different is the draft-mirtorabi-ospfv3-af-00.txt from the existing MOSPF
specifications given that i can advertise MULTICAST routes using the former. I can always
use this new draft to advertise the different multicast routes and inject the best ones
into the LSDB dedicated to the multicast RPF topology, run the SPF and use these best
routes thus derived for RPF checks by other multicasting protocols.

I am getting a little confused and would appreciate if somebody could help me out.

TIA,
Smith

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

---

From: Sina Mirtorabi <[email-masked]>
Date: Wed, 19 Mar 2003 15:38:46 -0800

Smith,

> -----Original Message-----
> From: Mailing List [mailto:[email-masked]] On
> Behalf Of John Smith
> Sent: Wednesday, March 19, 2003 5:20 AM
> To: [email-masked]
> Subject: draft-mirtorabi-ospfv3-af-00.txt and MOSPF
>
>
> How different is the draft-mirtorabi-ospfv3-af-00.txt from
> the existing MOSPF specifications given that i can advertise
> MULTICAST routes using the former. I can always use this new
> draft to advertise the different multicast routes and inject
> the best ones into the LSDB dedicated to the multicast RPF
> topology, run the SPF and use these best routes thus derived
> for RPF checks by other multicasting protocols.
>

The difference is the choice of your multicast routing protocol, which
is a comparison between MOSPF and other multicast protocols such as PIM.
MOSPF builds a distribution tree for each source/group pair and computes
a tree for active sources sending to the group therefore there is a
scaling issue but let's not enter a multicast discussion

With this new draft you can have a incongruent topology for your unicast
and multicast IPv6 to do the RPF check and use other multicast protocols
(e.g PIM) to create your tree (source based, shared distribution etc )
for forwarding multicast packets

Sina

> from News and Sport to Email and Music Charts http://uk.my.yahoo.com
>

---

From: Sina Mirtorabi <[email-masked]>
Date: Wed, 19 Mar 2003 15:55:14 -0800

Smith

> With this new draft you can have a incongruent topology for
> your unicast and multicast IPv6 to do the RPF check and use
> other multicast protocols (e.g PIM) to create your tree
> (source based, shared distribution etc ) for forwarding
> multicast packets
>
> Sina

Not sure if I mentioned clearly in my last e-mail, but let me emphasis
that this new draft allow you to have an incongruent topology by having
distinct unicast routing table for multicasts RPF check, so your
multicst routing protocol can be what ever you want _including_ MOSPF

Sina