Subject: MIB v2 draft

From: "Banwari, Amit" <[email-masked]>
Date: Tue, 25 Mar 2003 11:49:49 -0500

Hello,

I have a comment on draft-ietf-ospf-mib-update-05.txt.

According to RFC 3101.

   "Like stub areas, NSSA border routers optionally import summary routes
   into their NSSAs as Type-3 summary-LSAs.  If the import is disabled,
   particular care should be taken to ensure that summary routing is not
   obscured by an NSSA's Type-7 AS-external-LSAs.  This may happen when
   the AS's other IGPs, like RIP and ISIS, leak routing information into
   the NSSA.  In these cases all summary routes should be imported into
   the NSSA. The recommended default behavior is to import summary routes
into NSSAs."

but the draft-ietf-ospf-mib-update-05.txt as well as RFC 1850 states default
behaviour for ospfAreaSummary as noAreaSummary.

shouldn't the value in the MIB be changed to reflect values in the RFC3101.
 ospfAreaSummary OBJECT-TYPE
        SYNTAX       INTEGER {
                        noAreaSummary (1),
                        sendAreaSummary (2)
                        }
        MAX-ACCESS   read-create
        STATUS       current
        DESCRIPTION
           "The variable ospfAreaSummary controls the im-
           port of summary LSAs into stub and NSSA areas.
           It has no effect on other areas.

           If it is noAreaSummary, the router will neither
           originate nor propagate summary LSAs into the
           stub or NSSA area. It will rely entirely on its
           default route.

           If it is sendAreaSummary, the router will both
           summarize and propagate summary LSAs."
        DEFVAL { noAreaSummary }
        ::= { ospfAreaEntry 9 }

Thanks and Regards
Amit Banwari

---

From: Acee Lindem <[email-masked]>
Date: Tue, 25 Mar 2003 11:52:18 -0500

Yes. Dan Joyal is in the process of updating this MIB.

--
Acee