Subject: OSPFv3 and IPv6 on-link router advertisements

From: Mike Fox <[email-masked]>
Date: Mon, 31 Mar 2003 10:23:10 -0500

How are IPv6 on-link router advertisements treated in OSPFv3?  Does a router that advertises on-link prefixes in router advertisements also
advertise them in link-lsas? And if these prefixes are not also advertised in link-lsas, how should  they be treated by OSPFv3?  Are they
treated as AS-external desinations, or as if they had been received on a link-lsa (i.e., AS internal)?

Mike

---

From: Acee Lindem <[email-masked]>
Date: Mon, 31 Mar 2003 11:02:55 -0500

Hello Mike,

Mike Fox wrote:
> How are IPv6 on-link router advertisements treated in OSPFv3?
 > Does a router that advertises on-link prefixes in router advertisements also
> advertise them in link-lsas?

On-link prefixes are NOT advertised in router LSAs - only link-LSAs
and Intra-area prefix LSAs.

> And if these prefixes are not also advertised in link-lsas,
 > how should  they be treated by OSPFv3?  Are they

They are considered to be OSPF Intra-area routes.

I've left out a lot of details - it is probably best to just re-read
RFC 2740 and ask specific questions.

--
Acee