Subject: Re: ospf limits...

From: Rohit Gupta <[email-masked]>
Date: Fri, 7 Mar 2003 01:00:14 -0800

I remember reading somewhere that ISIS can support
bigger areas than OSPF though i am not sure as to how
exactly, given that both are link state and almost
similar.

So if you cant scale well with OSPF then you can
consider ISIS also.

----- Original Message -----
From: "klara moser" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, March 06, 2003 11:41 PM
Subject: Re: ospf limits...

> Hi Ravi,
>
> As far as I know the OSPF protocol has only one
limitation on the topologies
> size - the Network and Router LSA size. The max is
64KB. This limits the number
> of links the router can have in a single area,
because it has to advertise them
> in a single Router LSA. You can do the math. It is
something like 5 000 links.
>
> Klara
>
> Quaizar Vohra wrote:
>
> > I think the main factor is the amount of flooding
a router has to do
> > which depends on how many adjacencies you have and
how many LSAs you
> > have to flood to each adjacency. So it is useful
to divide your
> > network into multiple areas so as to reduce
flooding. Also large
> > no. of adjacencies in a single area can result in
rather large router
> > LSAs which causes a lots of fragmentation and adds
to the flooding
> > load.
> >
> > Quaizar
> >
> >  > I am in the midst of redesigning an OSPF
network to accommodate
> >  > significant growth, especially in the Area 0
backbone. There has been
> >  > some concern about the size of the OSPF
topology that would result and
> >  > whether the routing protocol would remain
robust, able to handle the odd
> >  > flapping link or memory leak. The network in
question is using high-end
> >  > routers with high speed links (at least DS-3).
> >  >
> >  > Are there any heuristics that someone has which
may give us an idea of
> >  > the comfort zone in terms of the database size,
number of neighbors,
> >  > routers, etc?
> >  >
> >  > Or, could someone share information on the size
of large OSPF
> >  > implementations that they are aware of?
> >  >
> >  > I know that this issue is rather vague (clouded
in too many unknowns)
> >  > and may only result in rather ambiguous
> >  > answers, but, one never knows.
> >  >
> >  > Thanks,

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/

---

From: klara moser <[email-masked]>
Date: Fri, 7 Mar 2003 09:21:41 -0500

I think that the limit for the ISIS topologies comes from the fact that
there could be only 256 LSPs generated and this is for all route types.
It is still very big database (256 x 1470bytes)...

Klara

---

From: Yasuhiro Ohara <[email-masked]>
Date: Sat, 8 Mar 2003 07:02:01 +0900

Hi,

Though I haven't read (or don't remember) any document mentions
that, I guess it comes from the capability of controlling the rate
of bandwidth consumption used by LSA refresh.

Because IS-IS ages LSP by counting down the age and expires them
when the age is 0, IS-IS's "IS" can decide when to refresh his LSP
individually. OSPF specifies when to refresh and/or expire LSA
explicitly, so OSPF system's refresh rate is affected by the
network-size (precisely # of LSA), and can't be reduced by
human manipulation.

regards,
yasu

From: Rohit Gupta <[email-masked]>
Subject: Re: ospf limits...
Date: Fri, 7 Mar 2003 01:00:14 -0800

---

From: Rohit Gupta <[email-masked]>
Date: Sun, 9 Mar 2003 19:51:23 -0800

A draft by Amir Hermelin
(draft-ietf-isis-ext-lsp-frags-02.txt) now changes
that and we can have LSP fragments > 256

Rohit

---

From: Rohit Gupta <[email-masked]>
Date: Sun, 9 Mar 2003 19:52:28 -0800

Yasu,
I could not understand as to how this will help in
building larger ISIS areas vis-a-vis OSPF!

Rohit

---

From: Yasuhiro Ohara <[email-masked]>
Date: Mon, 10 Mar 2003 09:00:48 +0900

All I meant is that you can control refresh rate of IS-IS.

In larger system, OSPF LSA refresh and/or IS-IS LSP refresh
can be several tens of times per second. Then you can reduce
the refresh rate only when you use IS-IS, but you can't reduce
the refresh rate if you use OSPF.

Does that matter the scalability of network, doesn't it ?

I don't know actual parameter to enlarge the duration of LSP's life
(the time till the LSP expires), because I haven't touched
any working IS-IS ...

regards,
yasu

From: Rohit Gupta <[email-masked]>
Subject: Re: ospf limits...
Date: Sun, 9 Mar 2003 19:52:28 -0800

---

From: Dave Katz <[email-masked]>
Date: Sun, 9 Mar 2003 21:05:14 -0800

For all practical purposes, the designs of the OSPF and ISIS protocols
will not be the limiting factor in the size of an area, unless (a) you
have a really good implementation, and (b) you feel the need to dump
excessive numbers (many thousands) of external and stub routes into
the protocol.

Most implementations will crash and burn before the topology gets
big enough to become an issue, and most people don't dump externals
into their IGPs (they use BGP instead.)

Architecturally, OSPF limits the inter-router topology and stub routes
due to the 64KB limit on the Router LSA, and ISIS limits the total amount
of information due to the 256 LSP "fragment" limit.  One could come up
with various hacks for either protocol if these limits were actually,
well, limiting, but this has never been the case in (sane) practice.

Historically, the ISIS implementation from a particular major vendor has
had better scaling characteristics than the OSPF implementation of that
particular major vendor, but this this isn't really the case for another
major vendor.  ;-)

--Dave

---

From: Manav Bhatia <[email-masked]>
Date: Mon, 10 Mar 2003 10:36:38 +0530

I think ISIS might be preferred to support larger networks because all the
IP prefixes align as leaves in the SPF tree, meaning full SPF is not run in
most cases where a link failure does not impact the core topology. In OSPF,
all IP link failures in an area trigger LSA updates, which, in turn, cause
full SPF runs. Therefore, a large OSPF area would be more demanding on
processing resources on the average than an ISIS network of comparable
size.

Regards,
Manav

---

From: Dave Katz <[email-masked]>
Date: Sun, 9 Mar 2003 21:12:44 -0800

This is an implementation detail that is not necessarily true.

---

From: Manav Bhatia <[email-masked]>
Date: Mon, 10 Mar 2003 10:57:25 +0530

Dave,
I believe in ISIS all IP reachability ends up as leaf nodes and thus any
changes in the IP reachability alone results, only in a partial SPF run
(Partial Route Calculation, or PRC); the routers in the tree need to
calculate only the parts of the tree in which the leaf node for that
destination network resides. They need not run the entire SPF.

Whereas in OSPF one may run partial SPF only in case of changes in
inter-area routes.

Am i missing something?

Regards,
Manav

---

From: Dave Katz <[email-masked]>
Date: Sun, 9 Mar 2003 22:49:50 -0800

Am i missing something?

Yes.  Fundamentally the problem is the same in both--if the actual
link topology changes, an SPF is required.  If leaf connectivity
changes, it is not.  Determining the difference is an exercise for the
implementor.