Subject: Re: OSPF-V3 Instance ID

From: Vishwas Manral <[email-masked]>
Date: Tue, 21 Sep 2004 10:59:47 -0700

Hi Nic,
 
I think the draft was posted in April so should expire in October. 
 
Yes, we will refresh the draft and take care of all comments that we have got.
 
Thanks,
Vishwas

________________________________

From: Mailing List on behalf of Nic Neate
Sent: Tue 9/21/2004 9:29 AM
To: [email-masked]
Subject: Re: OSPF-V3 Instance ID

Guys,

Acee indicated below that the ospfv3IfTable should be indexed by both
ospfv3IfIndex and ospfv3InstId.

I think it follows that the ospfv3NbrTable, ospfv3NbmaNbrTable and
ospfv3LinkLsdbTable (which are all currently indexed on their interface
index) also need new interface instance index fields.  Is that right?

Incidentally, I notice that draft-ietf-ospf-ospfv3-mib-08 expired in April.
Are there plans to make updates and refresh it?

Thanks,

Nic

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of Acee
Lindem
Sent: Friday, July 09, 2004 4:15 AM
To: [email-masked]
Subject: Re: OSPF-V3 Instance ID

Hi Dilip,

----- Original Message -----
From: "Dilip Kumar" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, July 08, 2004 10:37 PM
Subject: OSPF-V3 Instance ID

> Hello,
>     I have couple of doubts w.r.to OSPF-V3's Instance ID interpretation
> 1. Can one router interface have more than one "Instance ID"
> configured simultaneously ?

Yes.  However,  there may be implementations that only support one to
be configured.

> OSPF-V3 MIB draft (draft-ietf-ospf-ospfv3-mib-08) indicates that it is
> not possible.

This is wrong. ospfv3IfTable should be indexed by both ospfv3IfIndex
and ospfv3InstId.

> However, RFC-2740 indirectly points that it is possible.
> Following is the excerpt from the RFC-2740
>
>   "Another use for running multiple OSPF instances is if you want, for
>    one reason or another, to have a single link belong to two or more
>    OSPF areas."

This is one application of multiple instance IDs.

>
> 2. Can LSAs received from a neighbor 'A' which has instance ID=2 be
> flooded to another neighbor B that has instance ID=5 ?
>
>        InstanceID=2                  InstanceID=5
> A=================R================B

The base OSPFv3 specification (RFC 2740) certainly doesn't preclude this
since the interface instance ID only has significance for that interface.
In case of draft-mirtorabi-ospf-multi-area-adj-00.txt, the instance ID has
significance beyond the scope of the interface and you would not.

Hope this helps,
Acee

>
>
> Thanks in advance for any help.
> -- Dilip

---

From: Acee Lindem <[email-masked]>
Date: Tue, 21 Sep 2004 14:58:55 -0400

RE: OSPF-V3 Instance IDHi Dan,

I think the OSPFv3 interface instance ID is somewhat different than multiple 
protocol instances and, as such, should be considered separately:

   1. Unlike multiple OSPF(v3) instances, the instance ID is specified
       explicitly by the OSPF 2740.

   2. OSPFv3 runs on a link while OSPFv2 runs on a subnet. As such,
       the instance ID can be used so that a link can be configured in 
       multiple OSPFv3 instances or for the link to be part of multiple areas. 

Thanks,
Acee 
--- Original Message ----- 
  From: Daniel Joyal 
  To: 'Nic Neate' ; 'Mailing List' ; [email-masked]' ; [email-masked]' 
  Sent: Tuesday, September 21, 2004 2:06 PM
  Subject: RE: OSPF-V3 Instance ID

  If we are talking about support for multiple instances of OSPFv3 
  I think the MIB should be handled the same way as the OSPFv2 MIB and 
  the IS-IS MIB in that neither have explicit instance ID objects 
  (all of the instance index objects in the IS-IS MIB have recently been 
  removed). The syntax of the ospfv3InstId object should be changed to 
  read-only to provide a view of the system allocated instance ID. 

  Yes, the MIB will be refreshed. 

  -Dan  

  > From: Nic Neate [mailto:[email-masked]] 
  > Sent: Tuesday, September 21, 2004 12:29 PM 
  > To: 'Mailing List'; [email-masked]'; Joyal, Daniel 
  > [BL60:NP31:EXCH]; [email-masked]' 
  > Subject: RE: OSPF-V3 Instance ID 
  > 
  > 
  > Guys, 
  > 
  > Acee indicated below that the ospfv3IfTable should be indexed 
  > by both ospfv3IfIndex and ospfv3InstId. 
  > 
  > I think it follows that the ospfv3NbrTable, 
  > ospfv3NbmaNbrTable and ospfv3LinkLsdbTable (which are all 
  > currently indexed on their interface 
  > Incidentally, I notice that draft-ietf-ospf-ospfv3-mib-08 
  > expired in April. Are there plans to make updates and refresh it? 
  > 
  > Thanks, 
  > 
  > Nic 
  > 
  > 
  > From: Mailing List [mailto:[email-masked]]On 
  > Behalf Of Acee Lindem 
  > >     I have couple of doubts w.r.to OSPF-V3's Instance ID 
  > > interpretation 1. Can one router interface have more than one 
  > > "Instance ID" configured simultaneously ? 
  > 
  > Yes.  However,  there may be implementations that only 
  > support one to be configured. 
  > 
  > This is wrong. ospfv3IfTable should be indexed by both 
  > The base OSPFv3 specification (RFC 2740) certainly doesn't 
  > preclude this since the interface instance ID only has 
  > significance for that interface. In case of 
  > draft-mirtorabi-ospf-multi-area-adj-00.txt, the instance ID 
  > has significance beyond the scope of the interface and you would not. 
  > 
  > Hope this helps, 
  > Acee 
  > 
  > > 
  > >