Subject: Re: OSPF-V3 Instance ID

From: Nic Neate <[email-masked]>
Date: Tue, 21 Sep 2004 17:29:20 +0100

Guys,

Acee indicated below that the ospfv3IfTable should be indexed by both
ospfv3IfIndex and ospfv3InstId.

I think it follows that the ospfv3NbrTable, ospfv3NbmaNbrTable and
ospfv3LinkLsdbTable (which are all currently indexed on their interface
index) also need new interface instance index fields.  Is that right?

Incidentally, I notice that draft-ietf-ospf-ospfv3-mib-08 expired in April.
Are there plans to make updates and refresh it?

Thanks,

Nic

-----Original Message-----
From: Mailing List [mailto:[email-masked]]On Behalf Of Acee
Lindem
Sent: Friday, July 09, 2004 4:15 AM
To: [email-masked]
Subject: Re: OSPF-V3 Instance ID

Hi Dilip,

----- Original Message -----
From: "Dilip Kumar" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, July 08, 2004 10:37 PM
Subject: OSPF-V3 Instance ID

> Hello,
>     I have couple of doubts w.r.to OSPF-V3's Instance ID interpretation
> 1. Can one router interface have more than one "Instance ID"
> configured simultaneously ?

Yes.  However,  there may be implementations that only support one to
be configured.

> OSPF-V3 MIB draft (draft-ietf-ospf-ospfv3-mib-08) indicates that it is
> not possible.

This is wrong. ospfv3IfTable should be indexed by both ospfv3IfIndex
and ospfv3InstId.

> However, RFC-2740 indirectly points that it is possible.
> Following is the excerpt from the RFC-2740
>
>   "Another use for running multiple OSPF instances is if you want, for
>    one reason or another, to have a single link belong to two or more
>    OSPF areas."

This is one application of multiple instance IDs.

>
> 2. Can LSAs received from a neighbor 'A' which has instance ID=2 be
> flooded to another neighbor B that has instance ID=5 ?
>
>        InstanceID=2                  InstanceID=5
> A=================R================B

The base OSPFv3 specification (RFC 2740) certainly doesn't preclude this
since the interface instance ID only has significance for that interface.
In case of draft-mirtorabi-ospf-multi-area-adj-00.txt, the instance ID has
significance beyond the scope of the interface and you would not.

Hope this helps,
Acee

>
>
> Thanks in advance for any help.
> -- Dilip

---

From: Acee Lindem <[email-masked]>
Date: Tue, 21 Sep 2004 12:43:02 -0400

----- Original Message -----
From: "Nic Neate" <[email-masked]>
To: "'Mailing List'" <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Tuesday, September 21, 2004 12:29 PM
Subject: RE: OSPF-V3 Instance ID

> index) also need new interface instance index fields.  Is that right?

Hi Nic,
I would think so.
Thanks,
Acee