Subject: some doubt about use of instance-id with vlink in OSPFV3

From: prasanna <[email-masked]>
Date: Thu, 30 Sep 2004 11:39:53 +0530

While sending the OSPFv3 packet for virtual-link, those packets will
have instance-id zero (if the virtual-link is not configured with
instance-id).

If there are multiple processes attached to an incoming interface, to
which process the hello packet is delivered?

To all the process/ only to the process to which the interface is
attached with instance-id zero?

One more doubt. When I configure a virtual-link with instance-id (n),
should both sender's and receiver's interfaces should be configured with
same instance-id(n)

---

From: Santosh Esale <[email-masked]>
Date: Thu, 30 Sep 2004 17:05:31 +0530

Hey prasanna,

                         If there are multiple process attached to an
incoming interface, the hello packet will be delivered to all the process,
and will be accepted by the process in which Vlink has been configured with
peer router id which is equal to router id in the received packet.

To answer second question, its implementation specific, but I think there is
no use of instance id on virtual-link, our implementation won't care of
instance id.

Regards

Santosh

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of prasanna
Sent: Thursday, September 30, 2004 11:40 AM
To: [email-masked]
Subject: some doubt about use of instance-id with vlink in OSPFV3

While sending the OSPFv3 packet for virtual-link, those packets will have
instance-id zero (if the virtual-link is not configured with instance-id).

If there are multiple processes attached to an incoming interface, to which
process the hello packet is delivered?

To all the process/ only to the process to which the interface is attached
with instance-id zero?

One more doubt. When I configure a virtual-link with instance-id (n), should
both sender's and receiver's interfaces should be configured with same
instance-id(n)

---

From: Acee Lindem <[email-masked]>
Date: Thu, 30 Sep 2004 08:23:59 -0400

> ----- Original Message -----
> From: prasanna
> Sent: Thursday, September 30, 2004 2:09 AM
> While sending the OSPFv3 packet for virtual-link, those packets will have instance-id zero (if the virtual-link is not configured
> with instance-id).

Yes.

> If there are multiple processes attached to an incoming interface, to which process the hello packet is delivered?

The virtual link interface - you DON'T match instance ID on the incoming interface. Just assure that it is
configured in the transit area for the virtual link.

> To all the process/ only to the process to which the interface is attached with instance-id zero?
>
> One more doubt. When I configure a virtual-link with instance-id (n), should both sender's and receiver's interfaces should be
> configured with same > instance-id(n)

Of course.

Hope this helps,
Acee

---

From: Acee Lindem <[email-masked]>
Date: Thu, 30 Sep 2004 08:38:01 -0400

Hi Santosh,
I think that the instance IDs should match for virtual links. If you want to 
support multiple instances within the same routing to domain then you
need it to demux packets (e.g., to support unicast and multicast topologies). 

Thanks,
Acee 
  ----- Original Message ----- 
  From: Santosh Esale 
  To: [email-masked] 
  Sent: Thursday, September 30, 2004 7:35 AM
  Subject: Re: some doubt about use of instance-id with vlink in OSPFV3

  Hey prasanna,

                           If there are multiple process attached to an incoming interface, the hello packet will be delivered to all the process, and will be accepted by the process in which Vlink has been configured with peer router id which is equal to router id in the received packet.

  To answer second question, its implementation specific, but I think there is no use of instance id on virtual-link, our implementation won't care of instance id.

  Regards

  Santosh

  -----Original Message-----
  From: Mailing List [mailto:[email-masked]] On Behalf Of prasanna
  Sent: Thursday, September 30, 2004 11:40 AM
  To: [email-masked]
  Subject: some doubt about use of instance-id with vlink in OSPFV3

  While sending the OSPFv3 packet for virtual-link, those packets will have instance-id zero (if the virtual-link is not configured with instance-id).

  One more doubt. When I configure a virtual-link with instance-id (n), should both sender's and receiver's interfaces should be configured with same instance-id(n)

---

From: prasanna <[email-masked]>
Date: Thu, 30 Sep 2004 18:21:53 +0530

Hi Acee
   Your answer is bit confusing
   In first case(where Vlink is configured without instance-id) you say
the instance-id is not matched. And in the second case (where Vlink is
configured with instance-id) you say the in/out interface's instance id
should match with the instance-id of the Vlink

Or You mean that instance id of the V-link configuration should be same
at both ends

I.e
For example consider I have configured vlink between RTA and RTB as
follows
! RTA
  ipv6 router ospf 1
       router-id 1.1.1.1
       area 1 v-link 2.2.2.2 instance-id y
! RTB
  ipv6 router ospf 1
       router-id 2.2.2.2
       area 1 v-link 1.1.1.1 instance-id x

Here in this case, x and y should be same. Am I right?

Thanx and Regards
Prasanna

-----Original Message-----
From: Mailing List [mailto:[email-masked]] On Behalf Of Acee
Lindem
Sent: Thursday, September 30, 2004 5:54 PM
To: [email-masked]
Subject: Re: some doubt about use of instance-id with vlink in OSPFV3

> While sending the OSPFv3 packet for virtual-link, those packets will
have instance-id zero (if the virtual-link is not configured

Yes.

The virtual link interface - you DON'T match instance ID on the incoming
interface. Just assure that it is
configured in the transit area for the virtual link.

> One more doubt. When I configure a virtual-link with instance-id (n),
should both sender's and receiver's interfaces should be

Of course.

Hope this helps,
Acee

---

From: Acee Lindem <[email-masked]>
Date: Thu, 30 Sep 2004 10:29:03 -0400

Hi Prasanna,

----- Original Message -----
From: "prasanna" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, September 30, 2004 8:51 AM
Subject: Re: some doubt about use of instance-id with vlink in OSPFV3

> should match with the instance-id of the Vlink

No confusion - in the first case the instance-id is 0 and in the second
case it is non-0.

> Or You mean that instance id of the V-link configuration should be same

Exactly.

> Here in this case, x and y should be same. Am I right?

Yes - packet will be delivered iff (x == y).