Subject: [OSPF] OSPFv3 MIB: InterfaceID in Vlink

From: "Ramana Koppula-G20085" <[email-masked]>
Date: Wed, 7 Jun 2006 17:19:46 +0800

hi,
 
Doubt: When Interface ID for normal interfaces is not made configurable,
why is Virtual Link's Interface ID made configurable in Virtual
Interface Table?
 
As Virtual Interface's Interface ID need to be unique amongst all the
Interface IDs within the router, the administrator had to check what all
interface IDs are in use at present and make a selection. All this is
not unavoidable.
 
I feel it would be better if we make it read-only object and leave the
selection of it to implementation.
 
thanx
ramana
_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: "Ramana Koppula-G20085" <[email-masked]>
Date: Thu, 15 Jun 2006 00:45:12 +0800

Hi Daniel,
 
Yes, removing VirtIfIndex is Ok. Which is not mandatory to show also as
we consistent with interface table also.
 
thanx
ramana

________________________________

From: Daniel Joyal [mailto:[email-masked]] 
Sent: Tuesday, June 13, 2006 9:06 PM
To: Ramana Koppula-G20085; [email-masked]
Cc: [email-masked]
Subject: RE: [REPOSTING] OSPFv3 MIB: InterfaceID in Vlink

Hi Ramana,
 
I think from recent WG discussions it has been established that
an OSPFv3 interface is identified by the interface InstanceID object.
So, for physical links we have an Interface index and for an OSPFv3
interface on that link (of possibly multiple OSPFv3 interfaces) we
have the interface InstanceID.
 
Currently, the Virtual Link table entry has both ospfv3VirtIfIndex 
and ospfv3VirtIfInstId objects. I believe that only the
ospfv3VirtIfInstId
object is necessary and its usage would be symmetric with that of
the ospfv3IfInstId object in the interface table. Since ospfv3IfInstId
is configurable for physical interfaces, it should remain configurable
for virtual interfaces. Does this make sense?
 
-Dan

	-----Original Message-----
	From: Ramana Koppula-G20085 [mailto:[email-masked]] 
	Sent: Tuesday, June 13, 2006 6:24 AM
	To: [email-masked]
	Cc: Joyal, Daniel [BL60:SF23:EXCH]; [email-masked]
	Subject: [REPOSTING] OSPFv3 MIB: InterfaceID in Vlink

	I am eagerly waiting for some comments, whether its valid to
keep a read-only or is there any issue if we make it read-only.
	 
	hi,
	 
	Doubt: When Interface ID for normal interfaces is not made
configurable, why is Virtual Link's Interface ID made configurable in
Virtual Interface Table?
	 
	As Virtual Interface's Interface ID need to be unique amongst
all the Interface IDs within the router, the administrator had to check
what all interface IDs are in use at present and make a selection. All
this is not unavoidable.
	 
	I feel it would be better if we make it read-only object and
leave the selection of it to implementation.
	 
	thanx
	ramana