Subject: [OSPF] update "draft-kou-ospf-immediately-replying-hello-00.txt"

From: Zengjie Kou <[email-masked]>
Date: Tue, 13 Jun 2006 17:47:34 +0800

hi,all
 I updated the draft "draft-kou-ospf-immediately-replying-hello-00.txt". The link is following:
http://tools.ietf.org/wg/ospf/draft-kou-ospf-immediately-replying-hello-01.txt
 In the new version, interoperation of immediate hello is added and the additional immediate hello
traffic is avoided by auto configuration.
 The abstract is following:
This memo documents an extension of the OSPF protocol to reach    
   "ExStart" state more quickly. Currently, the OSPF behavior requires    
   the Hello Packet to be sent between the neighbors every    
   HelloInterval. This document proposes to generalize the use of    
   Immediately Replying Hello which could reduce the time required to    
   reach the OSPF "ExStart" state and  expedite the routing table    
   convergence.  

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Fri, 16 Jun 2006 11:57:11 -0400

This draft was presented in Dallas. A show-of-hands poll in a
Dallas was mixed with more people against than for making it accepting
it as a working group document. We than tabled it to further discussion
on the OSPF WG list.

Speaking as a WG member, my personal opinion is that the WG should
accept this document an an informational of BCP track RFC.

1. This behavior is not new - there are several implementations
that already reply immediately in certain situations.
2. There are many ways of doing this and it is unlikely we will
agree on the exact details of how it should be done. I, for one,
have implemented it differently than documented in this draft.

Thanks,
Acee

---

From: Russ White <[email-masked]>
Date: Sat, 17 Jun 2006 08:56:35 -0400

> accept this document an an informational of BCP track RFC.

This sounds fine.... Count my vote in that direction, as well.

:-)

Russ

- --
[email-masked] CCIE <>< Grace Alone

---

From: Acee Lindem <[email-masked]>
Date: Sat, 17 Jun 2006 15:09:02 -0400

Hi Zengjie,
Russ White wrote:

>-----BEGIN PGP SIGNED MESSAGE-----
>Hash: SHA1
>
>
>  
>
Actually, I meant NOT accept as WG document I guess that what I get for
trying
to respond to E-mail sitting in the middle seat on a crowded plane. Here
is my
reasoning why:

1. This behavior is not new - there are several implementations that
already reply immediately in certain situations.
2. There are many ways of doing this and it is unlikely we will
agree on the exact details of how it should be done. I, for one,
have implemented it differently than documented in this draft.

I just don't think there is that much to be gained by documenting
this after the fact when there isn't agreement on the sudtleties of
operation.

Sorry for the confusion.

Thanks,
Acee

>-----BEGIN PGP SIGNATURE-----
>Version: GnuPG v1.4.2.2 (MingW32)
>Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
>iD8DBQFEk/wDER27sUhU9OQRAvY9AKCrebSk6VRgr6L/SJGB12m4ZErV0ACg1B+8
>UKcbdXfJwL/u5nzZERpS7HI=
>=8pvC
>-----END PGP SIGNATURE-----
>
>  
>

---

From: Zengjie Kou <[email-masked]>
Date: Mon, 19 Jun 2006 14:54:22 +0800

hi,Acee
 For immediately replying, I'd like to know what are other implementations(including yours).
Would you like to make them included in the dratf? I hope to discuss detailedly.
What's your opinion?

thanks
Zengjie.

---

From: mike shand <[email-masked]>
Date: Mon, 19 Jun 2006 10:56:24 +0100

>have implemented it differently than documented in this draft.

and more particularly it doesn't matter from an interoperability 
point of view which way you do it, so
this doesn't seem to be behaviour which it makes sense to standardize.

         Mike

---

From: Zengjie Kou <[email-masked]>
Date: Mon, 19 Jun 2006 19:29:20 +0800

hi, mike
 For interoperability of the immediate hello, i think it is necessary.
 If each implementation is independent, the mechanism will be not consistent and the effort of immediate hello will be small.
 If we standardize the implementation or mechanism, all the router supporting immediate hello will respond conformably. The
effort will be great.
 The experiment data in the draft shows some evident benefits with immediate hello consistent interoperability.

thanks
Zengjie

---

From: Alex Zinin <[email-masked]>
Date: Tue, 20 Jun 2006 03:47:33 -0700

Zengjie,

 I could only see two potential reasons for the IETF to publish a document
 of this kind:

  a) if proposed behavior affected interoperability and thus correct
     network behavior OR
  b) we wanted to encourage implementers to introduce certain optimizations
     so as to improve overall network experience for the user

 Unfortunately, the situation at hand doesn't qualify for either of the
 two:

   a) timing of hellos does not affect protocol correctness AND
   b) there's no need to encourage this behavior as people actually do
      that already.

 So, it has nothing to do with how good your idea is, but rather that
 there is no apparent need for a document.

 BTW, I personally don't see a need for this doc either.
 
-- 
Alex
http://www.psg.com/~zinin

Monday, June 19, 2006, 4:29:20 AM, Zengjie Kou wrote:
>  If each implementation is independent, the mechanism will be not
> consistent and the effort of immediate hello will be small.
>  If we standardize the implementation or mechanism, all the router
> supporting immediate hello will respond conformably. The
> effort will be great.
>  The experiment data in the draft shows some evident benefits with
> immediate hello consistent interoperability.

> Subject: Re: [OSPF] update
> "draft-kou-ospf-immediately-replying-hello-00.txt"

---

From: Acee Lindem <[email-masked]>
Date: Tue, 20 Jun 2006 13:06:31 -0400

Hi Zengjie,

> For immediately replying, I'd like to know what are other implementations(including yours).
The two that I've worked on most recently for sure. I also seem to
remember someone
saying their variant of Zebra had this modification. I'll let others
speak for their own
implementations.

>Would you like to make them included in the dratf? I hope to discuss detailedly.
As I previously stated, I'm not all the high on trying to standardize
the immediate
reply behavior.

Thanks,
Acee