Subject: [OSPF] Re:Question: Intra-area Prefix Lsa

From: "Vivek Dubey" <[email-masked]>
Date: 22 Jun 2006 11:59:34 -0000

Hi Acee,
"Router X" (Link L1): Associated addresses/Prefixes are defined below
	Linklocal Address: fe80::01/128
	IPV6 Global unicast address: 0202::1/128
	IPv6 Global unicast address: 0303::1/128
	IPv6 Global Prefix: 0303:0000:0000:0001/64

We have a multi-access link (with a DR "Router Y" present on the link)

When "Router X" originates a link LSA for "Link L1" it includes following Prefixes:
	Prefix1: 0303:0000:0000:0001/64 ; PrefixOption: 0
	Prefix2: 0303::1/128 ; PrefixOption: LA-bit set
	Prefix3: 0202::1/128 ; PrefixOption: LA-bit set

When "Router Y", DR in this case, originates a intra-area-prefix LSA associated with the transit link:
Prefixes of "Router X", that are included:
	Prefix1: 0303:0000:0000:0001/64 ; PrefixOption: 0

<vivek1> Since DR does not include prefixes with LA-bit set,in intra-area-prefix LSA associated with transit link, why to include them in link-lsa for multiaccess links

<vivek2> Since DR does not include a prefix with LA-bit set, in intra-area-prefix LSA associated with transit link, the 

Prefix 0202::1/128, remains unreachable in Ospf domain (suppose no VL is present). Is that right?

Thanks
Vivek  
_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Thu, 22 Jun 2006 15:34:17 -0400

Hi Vivek,

>Prefix 0202::1/128, remains unreachable in Ospf domain (suppose no VL is present). Is that right?
I'll state that these LA-bit set prefixes SHOULD be advertised in the
intra-area-prefix-LSA associated with the router. It doesn't really make 
sense to
advertisement them in an intra-area-prefix LSA associated with the 
network-LSA.

I still don't think I want to prune the contents of Link-LSAs. I've 
added the "knob" to
suppress origination where they aren't needed and I think that will 
satisfy any requirement
for overhead reduction.

Thanks,
Acee