Subject: [OSPF] Re: Question: Intra-area Prefix Lsa

From: "Vivek Dubey" <[email-masked]>
Date: 23 Jun 2006 05:01:04 -0000

Hi Acee,
Pls check inline.  

On Fri, 23 Jun 2006 Acee Lindem wrote :
>Hi Vivek,
>
>Vivek Dubey wrote:
>
>>Hi Acee,
>>"Router X" (Link L1): Associated addresses/Prefixes are defined below
>>Linklocal Address: fe80::01/128
>>IPV6 Global unicast address: 0202::1/128
>>IPv6 Global unicast address: 0303::1/128
>>IPv6 Global Prefix: 0303:0000:0000:0001/64
>>
>>We have a multi-access link (with a DR "Router Y" present on the link)
>>
>>When "Router X" originates a link LSA for "Link L1" it includes following Prefixes:
>>Prefix1: 0303:0000:0000:0001/64 ; PrefixOption: 0
>>Prefix2: 0303::1/128 ; PrefixOption: LA-bit set
>>Prefix3: 0202::1/128 ; PrefixOption: LA-bit set
>>
>>When "Router Y", DR in this case, originates a intra-area-prefix LSA associated with the transit link:
>>Prefixes of "Router X", that are included:
>>Prefix1: 0303:0000:0000:0001/64 ; PrefixOption: 0
>>
>><vivek1> Since DR does not include prefixes with LA-bit set,in intra-area-prefix LSA associated with transit link, why to include them in link-lsa for multiaccess links
>>
>><vivek2> Since DR does not include a prefix with LA-bit set, in intra-area-prefix LSA associated with transit link, the 
>>Prefix 0202::1/128, remains unreachable in Ospf domain (suppose no VL is present). Is that right?
>>  
>I'll state that these LA-bit set prefixes SHOULD be advertised in the
>intra-area-prefix-LSA associated with the router. It doesn't really make sense to
>advertisement them in an intra-area-prefix LSA associated with the network-LSA.
>

Agreed. But as of now it's not allowed as per "draft-9". 
To quote
"If the interface has been reported in RTX's router-LSA as a Type 2 link description (link to transit network), its prefixes are not included (they will be included in the intra-area-prefix-LSA for the link instead)."

Should we re-phrase above?

>I still don't think I want to prune the contents of Link-LSAs. I've added the "knob" to
>suppress origination where they aren't needed and I think that will satisfy any requirement
>for overhead reduction.

Agreed. It takes care of my concern.

>Thanks,
>Acee
>>Thanks
>>Vivek  

-Vivek

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Fri, 23 Jun 2006 10:49:32 -0400

Hi Vivek,

>Should we re-phrase above?
Yes. I've changed this.

   o  Router RTX examines its list of interfaces to the area.  If the
      interface is in state Down, its prefixes are not included.  If the
      interface has been reported in RTX's router-LSA as a Type 2 link
      description (link to transit network), prefixes which will be be
      included in the intra-area-prefix-LSA for the link are skipped
      However, any prefixes which would normally have the LA-bit set
      SHOULD be advertised independent of whether or not the interface
      is advertised as a transit link. 

>Agreed. It takes care of my concern.
Great.
Thanks,
Acee