Subject: [OSPF] Re: OSPFv3: Vlink Instance Id

From: "Vivek Dubey" <[email-masked]>
Date: 8 Jun 2006 06:53:41 -0000

Hi Acee,

Consider the topology:
                            
                ---------(i0)R1(i1)------(i1)R2(i0)-----------

Ospf Instance 1 configuration (Ospf-domain-1)
-----------------------------------------------
Router R1:
----------
Interface i0: assocciated instance ID 1, Area 2.2.2.2
Interface i1: assocciated instance ID 1, Area 1.1.1.1
Vlink: Transit area 1.1.1.1, Nbr Rtr ID R2, ospfv3VirtIfInstId 2

Router R2:
----------
Interface i0: assocciated instance ID 1, Area 0.0.0.0
Interface i1: assocciated instance ID 1, Area 1.1.1.1
Vlink: Transit area 1.1.1.1, Nbr Rtr ID R1, ospfv3VirtIfInstId 2

<vivek1> 
Should this Vlink be made up, though the instance ID associated with Vlink is different than that of the physical interface, it would use.

<vivek2> 
If VLink is declared up, it is part of Ospf-domain-2 while rest of the interfaces are part of Ospf-domain-1. What purpose such a Vlink is accomplishing ?

<vivek3> 
MIB configuration for tables:
Area Table
Area-Scope LSDB
AS-Scope  LSDB
Host Table
Do not provide support for Ospf Multiple Instances

But for few other table:
Interface Table,
Link Scope LSDB
Explicit support of multiple instances is provided by making instance part of Index.

SNMP Community string (RFC 4133) concept would be used for tables not having instance id as part of index?

If so, why to make instance id as part of index for any table?

Thanks
Vivek

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Thu, 08 Jun 2006 09:32:10 -0400

Hi Vivek,
Ok - I see what you mean. The text was suppose to reference
"Interface ID" rather than "Instance ID". I've corrected this and moved
it in the -10 version.

Thanks,
Acee