Subject: [OSPF] Re:Whether to take the global prefixes from the LinkLsa or Intra-area-prefix Lsa

From: "badvel vishnu reddy" <[email-masked]>
Date: 6 Jun 2006 05:31:07 -0000

Hi All
 
Suppose if by chance someone configures like this,all routers are on the same link.

                   R3(DR)      
                   | 55:55::/64
                   |
   R1 ----------------------------- R2
      65:65::/64                 75:75::/64

Eventhough all the routers are on the same link, still each one is different subnet, So from R1 to reach prefix 75:75:: we need to specify the next hop as R2's linklocal addresses. 

So in this scenario when the routers are on the same link should i use link lsa's for the global prefixes as well as next-hop addresses?

                             or
Should i use type-9 lsa (reference type network) generated by DR and 
add all the prefixes? and for each corresponding prefix go to the link lsa and get the next hop address?

Regards
Vishnu
_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Wed, 07 Jun 2006 11:52:12 -0400

Hi Vishnu,

>Suppose if by chance someone configures like this,all routers are on the same link.
Nope - all the IPv6 prefixes advertised by the DR in the
intra-area-prefix-LS(s) referencing the network-LSA inherit the
the next hop associated with the network vertex. If you are directly
attached to the network vertex, you have a direct or connected
IPv6 next hop. I don't know what you read in section 3.8.1 that
would lead you to believe otherwise.

>add all the prefixes? and for each corresponding prefix go to the link lsa and get the next hop address?
Neither - see above.

Hope this helps,
Acee

>Regards
>Vishnu
>
>  
>
>------------------------------------------------------------------------
>