Subject: RE: [OSPF] Link LSA generation in OSPFv3

From: "Khan Amir-G20247" <[email-masked]>
Date: Tue, 13 Jun 2006 18:59:04 +0800

Hi Fabien
 
As per my understanding Link LSA can be originated when any of the NBR
on the link reaches TWO-WAY state. 
 
Regards
Aamir

________________________________

From: fabien.verhaeghe [mailto:[email-masked]] 
Sent: Tuesday, June 13, 2006 3:00 PM
To: [email-masked]
Subject: [OSPF] Link LSA generation in OSPFv3

Hello All,
 
>From draft-ietf-ospf-ospfv3-update-09.txt section 3.4.3.6 "A router
originates a separate link-LSA
for each attached link that supports 2 or more (including the
originating router itself) routers"
I understand that a router originates a link LSA only if it has at least
one fully adjacent neighbor.
 
But in section 3.4.3 the link-lsa is note mentionned in the item:
 
   o  A neighbor transitions to/from "Full" state.  The router may need
      to (re)originate or flush the link's network-LSA and one or more
      router-LSAs and/or intra-area-prefix-LSAs.
 
Instead it is put in the first item about interface state change.

   o  The state or interface ID of one of the router's interfaces
      changes.  The router may need to (re)originate or flush its link-
      LSA and one or more router-LSAs and/or intra-area-prefix-LSAs.  If
      the router is DR, the router may also need to (re)originate and/or
      flush the network LSA corresponding to the interface.
 
Does this mean link LSA has to be originate when the interface is up and
not when a
first full neighbor appears?
 
Another point concerning network LSA origination. Shouldn't we have an
item stating that
network LSA may be re-originated upon receipt (or purged) of a link-LSA
because it may 
entail a change in the option field.
 
Thanks
Fabien Verhaeghe
Atos Origin 
_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Tue, 13 Jun 2006 16:51:07 -0400

Hi Fabien, Khan,

>on the link reaches TWO-WAY state. 
I'd say this is an implementation choice. However, the link-LSA must be 
originated in time to
be including in the database exchange. I've always found it to be 
simpler to originate it when
the link comes up. See one additional point below.

>Aamir
I agree, I'll add this to section 3.4.3 in the 10 version.

Thanks,
Acee

> 
>Thanks
>Fabien Verhaeghe
>Atos Origin 
>
>  
>
>------------------------------------------------------------------------
>