Subject: [OSPF] OSPF GR query

From: "Khan Amir-G20247" <[email-masked]>
Date: Fri, 15 Sep 2006 23:53:22 +0800

Hi 

I have query related to Strict LSA Checking in OSPF Graceful Restart.

Consider this scenario:

- Two Routers R1 and R2, connected with a Broadcast network.
- Where R1 is a DR and R2 as DR-other
- Now R2 wants to perform GR and R1 agrees to be its Helper.
- Now after restart R2 will try and form adjacency with R1.
- Lets say that R1 and R2 had reached Exstart state. Now at this time
another router R3 joins the network.
- This router R3 will effect the contents of R1 LSDB. 
- Now if Strict LSA Checking is enabled, R1 will quit from Helper mode.
- After quiting R1 will recalculate DR/BDR and will reoriginate router
LSA and network LSA. 

Considering above scenario, my doubts are:

- How will R2 come to know that its Helper has quit ?
- When will R2 exit GR ? 
- As the NBR state had reached to Exstart before R1 exited, will state
be back to Down and   
  the adjacency formation will start all over again, once R2 exits GR ? 

Regards
Aamir

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: "Don Goodspeed" <[email-masked]>
Date: Fri, 15 Sep 2006 10:44:56 -0700

Amir,

Per section 2.2 item 2, R2 will exit GR because it receives a router LSA
from 

R3.  Alternately, it will receive a new network LSA from the DR containing

R3.

When R2 receives ANY new router LSA during its restart, it will terminate.
This

clause should also probably extend to network LSAs as well.

Actions to take on exiting GR are described in section 2.3 and apply whether

the exit was "graceful" or "ungraceful".  There's no necessity to go back to
the

down state.  There will just be additional items to be exchanged.

-don

  _____  

From: Khan Amir-G20247 [mailto:[email-masked]] 
Sent: Friday, September 15, 2006 8:53 AM
To: [email-masked]
Subject: [OSPF] OSPF GR query

Hi 

Consider this scenario: 

- After quiting R1 will recalculate DR/BDR and will reoriginate router LSA
and network LSA. 

- How will R2 come to know that its Helper has quit ? 
- When will R2 exit GR ? 
- As the NBR state had reached to Exstart before R1 exited, will state be
back to Down and   
  the adjacency formation will start all over again, once R2 exits GR ? 

Regards 
Aamir

---

From: Acee Lindem <[email-masked]>
Date: Fri, 15 Sep 2006 16:46:03 -0400

Hi Amir,
See answers inline.
> - How will R2 come to know that its Helper has quit ?
When it receives its pre-restart LSA from any neighbor in the area, it 
will recognize
that it should terminate graceful restart.

> - When will R2 exit GR ? 
See above.
>   the adjacency formation will start all over again, once R2 exits GR ? 
No - there is no need to. R1 is the DR and should remain DR.

Thanks,
Acee