Subject: [OSPF] query on OSPF restart signalling RS-bit

From: sengottuvelan srirangan <[email-masked]>
Date: Sun, 3 Sep 2006 21:20:54 -0700 (PDT)

Hi all,
  
  I have doubt on OSPF restart signalling draft  http://tools.ietf.org/wg/ospf/draft-nguyen-ospf-restart-05.txt ,  section 2.1, The RS-bit must not be set in Hello packets longer than  RouterDeadInterval seconds.
  
  The dead interval is configured per interface basis, say , i have two  interfaces eth0, eth1 with configured dead interval as 40 and 160. Is  the RS bit cleared after 40 sec on eth0 and 160 sec on eth1?
  
  If the answer is yes, then what is the status of Restarting router?. Is the router exits restarting after 40sec or 160sec?
  
  Please clarify the same.
  
  Thanks
  Sengottuvelan

 		
---------------------------------
 All-new Yahoo! Mail - Fire up a more powerful email and get things done faster.

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Tue, 05 Sep 2006 19:48:31 -0400

Hi Sengottuvelan,
Note that these drafts are only being considered as individual experimental
contributions (with the exception of link-local signalling which is being
considered for other reasons).

>   The dead interval is configured per interface basis, say , i have two  interfaces eth0, eth1 with configured dead interval as 40 and 160. Is  the RS bit cleared after 40 sec on eth0 and 160 sec o…
Yes.
>   
>   If the answer is yes, then what is the status of Restarting router?.
It depends on if the neighbor receives/accepts the RS-bit Hellos or not;
the mechanism works in conjuction with the corresponding neighbor's 
'ResyncTimeout'
timer (2.2).  The neighbor could reset the adjacency with the restarting 
router;
that's one path.

>  Is the router exits restarting after 40sec or 160sec?
>   
It's implementation specific as far as other timers limiting restart.
Technically, the restart and oob-resync
(http://tools.ietf.org/wg/ospf/draft-nguyen-ospf-oob-resync-05.txt)
can occur on a per-interface basis.  If restart fails for one interface,
you can choose to terminate restart totally, or you can continue restart
on other interfaces because theoretically, transit flows on other interfaces
could be uninterrupted. Depending on the paranoid level, you may just
chose to terminate restart (also see 2.3).

Hope this helps,
Acee
> ------------------------------------------------------------------------
>