Subject: [OSPF] OSPF RS-bit in OSPF restart signalling

From: sengottuvelan srirangan <[email-masked]>
Date: Mon, 25 Sep 2006 03:24:47 -0700 (PDT)

Hi All,
   
  I have doubt on OSPF RS-bit in OSPF restart signalling.  The RS-bit must not be set in Hello packets longer than RouterDeadInterval seconds.

  Suppose i have two links one is configured with 20 sec as dead interval and another as 80 sec.
   
  1. Suppose a neighbor is reached to Full in 20sec configured link, what happens to RS-bit on the 80sec link?
  2. Suppose there is no neighbor in 20sec link  and there is a neighbor in 80sec link.
  3. Suppose 20 and 80 links have neighbors
   
  In these cases, what is the expected behavior of a restarting router?
   
  Thanks in advance.

---------------------------------
Do you Yahoo!?
 Get on board. You're invited to try the new Yahoo! Mail.

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Liem Nguyen <[email-masked]>
Date: Tue, 26 Sep 2006 09:51:33 -0700

Sengottuvelan,

>   1. Suppose a neighbor is reached to Full in 20sec configured link, what happens to RS-bit on the 80sec link?

The RS-bit is set and cleared on a per-interface basis.

>   In these cases, what is the expected behavior of a restarting router?

It depends on if the neighbor receives/accepts the RS-bit Hellos or not;
the mechanism works in conjuction with the corresponding neighbor's
'ResyncTimeout' timer (2.2).  The neighbor could reset the adjacency with 
the restarting router, for which the restarting need to recognize and react.

It's implementation specific as far as how you want to control/limit the
the restart.
Technically, the restart and oob-resync
(http://tools.ietf.org/wg/ospf/draft-nguyen-ospf-oob-resync-05.txt)
can occur on a per-interface basis.  If restart fails for one interface,
you can choose to terminate restart totally, or you can continue restart
on other interfaces because theoretically, transit flows on other interfaces
could be uninterrupted. Depending on the paranoid level, you may just
chose to terminate restart (also see 2.3) as a whole.

Liem

---

From: sengottuvelan srirangan <[email-masked]>
Date: Wed, 27 Sep 2006 01:01:44 -0700 (PDT)

Hi Liem,
   
  Thank you for your points.
   
  Regards
  Sengottuvelan

Liem Nguyen <[email-masked]> wrote:
  Sengottuvelan,

Liem

---------------------------------
Yahoo! Messenger with Voice. Make PC-to-Phone Calls to the US (and 30+ countries) for 2¢/min or less.