Subject: Re: [OSPF] IETF 67 OSPF WG Meeting minutes - Correct file appended

From: Acee Lindem <[email-masked]>
Date: Mon, 13 Nov 2006 13:28:47 -0500

Updated...
Manav Bhatia wrote:
> Acee,
>
> The minutes missed out my replies.
>
>   
>> Presentation: Manav Bhatia - Crypto Requirements Document
>>     
>
>   
>> NULL, MS5, sha1, cryptographic - refs in this doc 
>>    more algorithms keep coming eg des was once must, now is should ot 
>> 	
>>    What doc must, should, - running doc as algorithms come and go 
>>    uses 2119 terms should+ = should may become must 
>> 		
>>    See slides and draft for specific requirements. 
>> 		
>>    Acee: "should not" wording is problematic for NULL and other 
>>    existing requirements.  
>>     
>
> Manav: NULL authentication is a "should NOT" in case an admin requires OSPF
> security.
>
>   
>> Russ white: shold may become a must vs. should+ (better to say
>> what is meant)
>>     
>
> Manav: We have used these additional RFC2119 terms since the earlier
> cryptographic implementation requirement RFCs 4305, 4307 have used a similar
> language.
>
> Cheers,
> Manav    
>
>   
>> -----Original Message-----
>> From: Acee Lindem [mailto:[email-masked]] 
>> Sent: Monday, November 13, 2006 7:30 PM
>> To: OSPF List
>> Subject: [OSPF] IETF 67 OSPF WG Meeting minutes - Correct 
>> file appended 
>>
>> Here are the minutes from the 67th IETF OSPF WG meeting. Thanks
>> to Steve Nadas from Ericsson for taking them.
>>
>> There was quite a bit of dialog at the mike with respect to the
>> OSPF MANET direction. I've also appended Thomas Clausen's
>> jabber log. Please unicast corrections to me. IETF 67
>>
>> Please unicast any corrections to me.
>>
>> Thanks,
>> Acee
>>
>>     
>
> Send instant messages to your online friends http://uk.messenger.yahoo.com 
>
>   

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: "Bhatia, Manav \(Manav\)" <[email-masked]>
Date: Fri, 17 Nov 2006 14:31:24 +0530

Hi Phil,

> >    Some discussion on list already
> >
> >    Crypto - only md5 to date, can be attacked, some want 
> stronger algs
> >         perhaps should specify these
> >
> >    How - 2328 can add other algs w/o too much problem
> 
> Yes it does, but debugging would be a nightmare! :-)
>
> Let me not trigger a discussion again, i am ok with using the existing
> type code!

We had posted the revised text based on the comments that we had
received both on the list and offline and there was quite a discussion
that followed!

http://www1.ietf.org/mail-archive/web/ospf/current/mail6.html

The consensus that we all had reached on was that before this draft one
could only have a key mismatch. From this draft onwards we will have a
key/algorithm mismatch.

[clipped]

> 
> >
> 
> I dont see any show stopper comments, so what is the status of the
> auth drafts? There was a discussion on these drafts some time back and
> the consensus was that the drafts would not be changed and we would
> reuse the existing type code for additional authentication types.
> 
> If there are no further comments then should these be taken 
> up as a new items?

Yes we would like to progress these drafts as a WG items. 

Cheers,
Manav