Subject: [OSPF] OSPF GR query

From: "Khan Amir-G20247" <[email-masked]>
Date: Fri, 10 Nov 2006 17:52:17 +0800

Hi 

I have query related to OSPF Graceful Restart. 

 Consider this scenario: 

- Three Routers R1, R2 and R3 connected via Broadcast networks. 

- Where R1 is a DR on both the segments, where as R2 and R3 are in
DR-other
- Now R1 wants to perform GR, R2 and R3 agrees to be its Helpers. 
- Now after restart R1 will try to form adjacency with both R2 and R3. 
- Lets say R1 and R2  had become FULL, while R1 and R3 had reached
Exstart state. Now at this time(when R1 and R3 are in transition state)
the adjacency between R1 and  R2  goes down for some reson.  
 
 Considering above scenario, my doubts are: 

-  As the adjacency between R1 and R2 has gone down(which is a Topology
change) and R1 is still in GR mode, can R1 quit GR ? In general can a
NBR which was FULL and then later gone down can be treated as one of the
conditions for quiting GR ? 

Regards 
Aamir 

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: "Abhay D.S" <[email-masked]>
Date: Fri, 10 Nov 2006 18:11:40 +0800

dear amir,
There is nothing called as Quitting GR.

In the case below , the most desirable thing is to give a message or an 
SNMP trap for qualifying to a quit scenario.

There is a thin line between completion and quitting GR. Just imagine 
this happens when the last router was about to be
full and  re-starter was  just about the originate  old router LSA , 
perfectly as the old one and then this event happened ?

Would you quit GR or log a message.

Another is what is your idea of quit GR  ?.

Thanks,

Abhay

Khan Amir-G20247 wrote:
> Exstart state. Now at this time(when R1 and R3 are in transition 
> state) the adjacency between R1 and  R2  goes down for some reson.  
>  
> -  As the adjacency between R1 and R2 has gone down(which is a 
> Topology change) and R1 is still in GR mode, can R1 quit GR ? In 
> general can a NBR which was FULL and then later gone down can be 
> treated as one of the conditions for quiting GR ? 
>  
>
>  
>
> Regards
> Aamir
>
>  
>
> ------------------------------------------------------------------------
>

---

From: "sujay gupta" <[email-masked]>
Date: Sun, 12 Nov 2006 02:44:36 +0530

Hi Amir,
Adding  ;

If the link between R1-R2 toggles making the adjacency going down and then
come up.R1 should exit GR.
R2  should exit  helper  mode send an inconsistent LSA to R1, R1 on
examining this LSA should exit GR.
Or; alternately R1 could detect a Nbr Down event and immediately exit GR.

Regds,
-Sujay
( Ref
http://tools.ietf.org/wg/ospf/draft-holla-ospf-update-graceful-restart-02.txtSection
3.2.1(1))

On 11/10/06, Abhay D.S <[email-masked]> wrote:
> There is a thin line between completion and quitting GR. Just imagine this
> happens when the last router was about to be
> - Lets say R1 and R2  had become FULL, while R1 and R3 had reached Exstart
> state. Now at this time(when R1 and R3 are in transition state) the
> adjacency between R1 and  R2  goes down for some reson.
>
> change) and R1 is still in GR mode, can R1 quit GR ? In general can a NBR
> which was FULL and then later gone down can be treated as one of the
> ------------------------------
>
> [email-masked]://www1.ietf.org/mailman/listinfo/ospf
>
>

---

From: "Abhay D.S" <[email-masked]>
Date: Mon, 13 Nov 2006 10:02:02 +0800

hi ,

To say in non-technical terms, quit gr or not quit gr makes no 
difference. ( I mean my cup is atleast half full, instead of calling
it half empty).

There are many other protocols dependending on OSPFv2 GR, so we better 
not to a real Quit for the following reasons.

Here is the order of convergence required in major networks during 
graceful restart.

1) Layer 2 convergence (control plane information)
2) Layer 3 OSPF/ISIS -> MPLS (Shim Protocols) -> BGP
3) Final convergence of all protocols.

In step 2, if you quit GR what would happen to MPLS and BGP convergence 
?.(Dont forget the big deal BGP recursive
route selection )

GR will work even if you dont follow the RFC completely. ( You might 
consider both the Graceful re-start draft and update
to graceful restart draft as informational) to help you realize the GR 
which can work.

Abhay

P.S: Real quit might include restarting the router's software processes 
disgracefully.Again there is no difference is it ?

sujay gupta wrote:
> Hi Amir,
> Adding  ;
>
> If the link between R1-R2 toggles making the adjacency going down and 
> then come up.R1 should exit GR.
> http://tools.ietf.org/wg/ospf/draft-holla-ospf-update-graceful-restart-02.txt 
> <http://tools.ietf.org/wg/ospf/draft-holla-ospf-update-graceful-restart-02.txt> 
> Section 3.2.1(1))
>
>
>
> On 11/10/06, *Abhay D.S* <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     dear amir,
>     In the case below , the most desirable thing is to give a message
>     or an SNMP trap for qualifying to a quit scenario.
>
>     There is a thin line between completion and quitting GR. Just
>     imagine this happens when the last router was about to be
>     full and  re-starter was  just about the originate  old router LSA
>     , perfectly as the old one and then this event happened ?
>
>>     - Where R1 is a DR on both the segments, where as R2 and R3 are
>>     in DR-other
>>     - Lets say R1 and R2  had become FULL, while R1 and R3 had
>>     reached Exstart state. Now at this time(when R1 and R3 are in
>>     transition state) the adjacency between R1 and  R2  goes down for
>>     some reson.  
>>      
>>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>