Subject: [OSPF] RE: inconsistency in draft-ietf-ospf-mib-update-11.txt?

From: "Daniel Joyal" <[email-masked]>
Date: Thu, 16 Nov 2006 14:48:19 -0500

Lou,

It is inconsistent. Thanks for catching this.
I don't think there is a reason to make Opaque
LSA support configurable as it is a backwards
compatible extension to OSPF, so the verbiage
about persistence should be deleted.

Any objections?

-Dan 

> -----Original Message-----
> From: Lou Berger [mailto:[email-masked]] 
> Sent: Thursday, November 16, 2006 2:07 PM
> To: Joyal, Daniel (BL60:SF23); [email-masked]; 
> [email-masked]
> Cc: [email-masked]
> Subject: inconsistency in draft-ietf-ospf-mib-update-11.txt?
> 
> Hi,
> 
> So, the following is taken from your draft:
>     ospfOpaqueLsaSupport  OBJECT-TYPE
>           SYNTAX       TruthValue
>           MAX-ACCESS   read-only
>           STATUS       current
>           DESCRIPTION
>              "The router's support for Opaque LSA types.
> 
>               This object is persistent and when written
>               the entity SHOULD save the change to non-volatile
>               storage."
>           REFERENCE
>              "The OSPF Opaque LSA Option"
>           ::= { ospfGeneralGroup 16 }
> 
> The access and description seem inconsistent.  The 
> description implies that acess should be "read-write".  Am I 
> missing something?
> 
> Lou
> 
> 

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Thu, 16 Nov 2006 14:54:19 -0500

Dan,

> about persistence should be deleted.
FWIW, this would be my preference.

Thanks,
Acee

---

From: Lou Berger <[email-masked]>
Date: Thu, 16 Nov 2006 15:01:24 -0500

Dan,

Not from me.  This would also be consistent with 2370 which states:

      An Opaque-option-enabled object is needed to indicate if the Opaque
      option is enabled on the router.

Lou

PS Blame this on Acee, his comment to me forced me to reread your draft!