Subject: [OSPF] Anycast Extension to OSPFv3 draft-wang-aospf-00

From: "Yue Wang" <[email-masked]>
Date: Fri, 1 Dec 2006 17:06:37 +0800

This document describes AOSPF (Anycast Extensions to OSPFv3),
   a routing protocol which extends OSPFv3 to support anycast, which
   we implemented and tested successfully in our IPv6 test bed. And
   the performance analysis shows the overhead of AOSPF is low.

http://www.ietf.org/internet-drafts/draft-wang-aospf-00.txt

-- 
regards,
wang yue

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Tue, 12 Dec 2006 17:32:04 -0500

Speaking as WG Chair:

I'd like to initiate discussion on this draft so that we can let the authors
know whether the WG wants to presue it furthers.

Thanks,
Acee

---

From: Acee Lindem <[email-masked]>
Date: Tue, 12 Dec 2006 17:41:18 -0500

Speaking as a WG Member and author of the RFC 2740 respin:

My opinion is that the protocol extensions described in the draft
are completely unnecessary and the OSPFv3 (RFC 2740 and its
update) already can support anycast addresses as /128 prefixes.
One simply uses the lowest cost path. Note that the protocol
already support configuration of host routes as described in appendix
C.7.

Thanks,
Acee

---

From: Russ White <[email-masked]>
Date: Tue, 12 Dec 2006 19:34:34 -0500

> already support configuration of host routes as described in appendix

I would tend to agree with this analysis... One of the nice things about
anycast is that routers and routing don't have to change to make it
work. Specifying extensions to an IGP to "make it work" seems contrary
to the spirit of the thing....

:-)

Russ

- --
[email-masked] CCIE <>< Grace Alone

---

From: "Abhay D.S" <[email-masked]>
Date: Wed, 13 Dec 2006 10:19:08 +0800

hi acee,
Not very positive and encouraging, being on a WG chair.
It reminds me of  folks at the ATM forum in the past !!
Thanks,
Abhay

---

From: Acee Lindem <[email-masked]>
Date: Tue, 12 Dec 2006 21:39:45 -0500

Abhay,

> Not very positive and encouraging, being on a WG chair.
I clearly stated I was speaking a WG member and have just
as much right as anyone else to state my opinion as to whether or
not a specific piece of work is accepted by the WG. If you have
technical comments related to the draft as opposed to critiques of
character, I'd encourage you to share them.

Thanks,
Acee

---

From: "Vishwas Manral" <[email-masked]>
Date: Tue, 12 Dec 2006 18:54:05 -0800

Hi Abhay,

I agree with the analysis on Acee and Russ on the draft. I have myself
not read the draft yet though.

On another front I must state that Acee has been trying to help and
promote new people in the working group and I have seen that happen
explicitly in some cases and would want to vouch for that.

Thanks,
Vishwas

---

From: "Abhay D.S" <[email-masked]>
Date: Wed, 13 Dec 2006 11:27:10 +0800

hi vishwas,
I dont disagree fully either, however the new anycast specification is 
the first step
in OSPF where _non-vendor groups_ have demonstrated excellence.Moreover
it is a NSF science grant experiment. Good to have this on OSPF 
discussion group
to help them out.(To ppl who are interested).

The authors never "pressed" that it should replace the current 
specifications.

Thats all..
Thanks,
Abhay

---

From: "Abhay D.S" <[email-masked]>
Date: Wed, 13 Dec 2006 11:17:03 +0800

hi acee,
With due respect to your disposition, the Anycast draft is a NSF grant 
project
and it makes a good implementation, as good as OSPFv3 anycast capability.
The authors are definitely, trying out to reach people with other 
perspectives which is
probably different from ours.
Hope you take positive criticism positively.
Period.
Thanks,
Abhay

---

From: Acee Lindem <[email-masked]>
Date: Wed, 13 Dec 2006 05:51:24 -0500

Abhay,

> and it makes a good implementation, as good as OSPFv3 anycast capability.
On what technical grounds do you based this statement? I don't see any 
reason
to handle anycast addresses any differently from any other /128 prefix.

> Hope you take positive criticism positively.
Well that doesn't change the fact that protocol extensions are not 
automatically
accepted by the OSPF WG.

Acee

---

From: "Abhay D.S" <[email-masked]>
Date: Wed, 13 Dec 2006 19:29:59 +0800

hi acee,

We use OSPF as a TOOL which can be programmed for various styles.

For example:

I want one version of OSPFv3 version running WG approved stamp on it and 
inter-operating.

However I can have my own versions of OSPF probably with a different 
version number within
my network  "only to process anycasting". Probably because anycasting is 
bursty.

Precisely the new AOSPF draft does that and there is nothing wrong with 
it. Tell me what is

wrong in this requirement ?

Thanks,
Abhay

Acee Lindem wrote:
> Abhay,
>
> Abhay D.S wrote:
>> hi acee,
>> With due respect to your disposition, the Anycast draft is a NSF 
>> grant project

---

From: Russ White <[email-masked]>
Date: Wed, 13 Dec 2006 12:45:03 -0500

> my network  "only to process anycasting". Probably because anycasting is

Is anycast traffic bursty, or are the anycast routing updates bursty? If
the traffic, then OSPF doesn't really care, I don't think (?). If the
updates, then we could segregate the anycast updates into a separate
topology, perhaps, so we don't have to go so far as to have multiple
processes.

If multiple processes is the answer required, then why not approach the
problem from the perspective of "how do I get multiple process to work
across a single link," rather than specifically referring to anycast.
Generalizing the problem would be better, since a single solution might
fit more problems than just anycast....

Anyway, as it's written, I stand by my statement that this draft doesn't
fit, now. Perhaps if we break the problem down more, we can come up with
something that will fit.

:-)

Russ

---

From: "Abhay D.S" <[email-masked]>
Date: Thu, 14 Dec 2006 10:26:10 +0800

hi Russ,
No draft fits perfect, hence the WG existence.

Generalizing has more general problems to solve.

Limiting the scope of operation of important but insignificant anycast 
processing
narrows down possible issues.(Actually none as of now)

To be exact all WG members acceptance and rejection criteria should rise 
above
all the ignorance.

As you rightly said, perphaps break the problem down more, if WG has 
different agenda,
it might allow others to break problem down more and accept solutions.

Thanks and Regards,
Abhay

Russ White wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
>
>   
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.3 (Darwin)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
> iD8DBQFFgDwfER27sUhU9OQRAsdvAKDuRwIxdaBTA0indJpxq/LwIAVpzQCeNBaO
> W36cLvolRhEuZTI3Aymt0Qk=
> =flR/
> -----END PGP SIGNATURE-----
>