Subject: RE: [OSPF] Anycast Extension to OSPFv3 draft-wang-aospf-00

From: "Greg Mirsky" <[email-masked]>
Date: Wed, 13 Dec 2006 06:26:19 -0800

Dear Abhay,
I apologize for non-technical post below.
If an operator agrees with running someone's proprietary protocol would
operator care about IETF's and OSPF WG's seal of approval? But if such
seal is required then it's up to the group to decide whther to put it
down or not. Would you agree?
Any group can use any grant to re-work any existing interoperable
implementation to make it "different". And probably it will be fun and
educational experience to the group. Should OSPF WG or IETF as whole be
involved in such projects?

	Regards,
		Greg

-----Original Message-----
From: Abhay D.S [mailto:[email-masked]] 
Sent: Wednesday, December 13, 2006 3:30 AM
To: Acee Lindem
Cc: [email-masked]
Subject: Re: [OSPF] Anycast Extension to OSPFv3 draft-wang-aospf-00

hi acee,

We use OSPF as a TOOL which can be programmed for various styles.

For example:

I want one version of OSPFv3 version running WG approved stamp on it and

inter-operating.

However I can have my own versions of OSPF probably with a different 
version number within
my network  "only to process anycasting". Probably because anycasting is

bursty.

Precisely the new AOSPF draft does that and there is nothing wrong with 
it. Tell me what is

wrong in this requirement ?

Thanks,
Abhay

Acee Lindem wrote:
> Abhay,
>
> Abhay D.S wrote:
>> hi acee,
>> With due respect to your disposition, the Anycast draft is a NSF 
>> grant project
>> and it makes a good implementation, as good as OSPFv3 anycast 
>> capability.
> On what technical grounds do you based this statement? I don't see any

> reason
> to handle anycast addresses any differently from any other /128
prefix.
>
>> The authors are definitely, trying out to reach people with other 
>> perspectives which is
>> probably different from ours.
>> Hope you take positive criticism positively.
> Well that doesn't change the fact that protocol extensions are not 
> automatically
> accepted by the OSPF WG.
>
> Acee
>
>> Period.
>> Thanks,
>> Abhay
>>
>>
>>
>>
>> Acee Lindem wrote:
>>> Abhay,
>>>
>>> Abhay D.S wrote:
>>>> hi acee,
>>>> Not very positive and encouraging, being on a WG chair.
>>> I clearly stated I was speaking a WG member and have just
>>> as much right as anyone else to state my opinion as to whether or
>>> not a specific piece of work is accepted by the WG. If you have
>>> technical comments related to the draft as opposed to critiques of
>>> character, I'd encourage you to share them.
>>>
>>> Thanks,
>>> Acee
>>>
>>>> It reminds me of  folks at the ATM forum in the past !!
>>>> Thanks,
>>>> Abhay
>>>>
>>>>
>>>>
>>>> Acee Lindem wrote:
>>>>> Speaking as a WG Member and author of the RFC 2740 respin:
>>>>>
>>>>> My opinion is that the protocol extensions described in the draft
>>>>> are completely unnecessary and the OSPFv3 (RFC 2740 and its
>>>>> update) already can support anycast addresses as /128 prefixes.
>>>>> One simply uses the lowest cost path. Note that the protocol
>>>>> already support configuration of host routes as described in
appendix
>>>>> C.7.
>>>>>
>>>>> Thanks,
>>>>> Acee
>>>>>
>>>>> Acee Lindem wrote:
>>>>>> Speaking as WG Chair:
>>>>>>
>>>>>> I'd like to initiate discussion on this draft so that we can let 
>>>>>> the authors
>>>>>> know whether the WG wants to presue it furthers.
>>>>>>
>>>>>> Thanks,
>>>>>> Acee
>>>>>>
>>>>>> Yue Wang wrote:
>>>>>>> This document describes AOSPF (Anycast Extensions to OSPFv3),
>>>>>>>   a routing protocol which extends OSPFv3 to support anycast,
which
>>>>>>>   we implemented and tested successfully in our IPv6 test bed.
And
>>>>>>>   the performance analysis shows the overhead of AOSPF is low.
>>>>>>>
>>>>>>> http://www.ietf.org/internet-drafts/draft-wang-aospf-00.txt
>>>>>>>
>>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> OSPF mailing list
>>>>>> [email-masked]
>>>>>> https://www1.ietf.org/mailman/listinfo/ospf
>>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> OSPF mailing list
>>>>> [email-masked]
>>>>> https://www1.ietf.org/mailman/listinfo/ospf
>>>>>
>>>>>
>>>
>>> _______________________________________________
>>> OSPF mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/ospf
>>>
>>>
>
>

_______________________________________________
OSPF mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Wed, 13 Dec 2006 12:18:52 -0500

Hi Greg,
> involved in such projects?
Dependent on WG bandwidth, we could allow extensions to be documented as
experimental RFCs (let's ignore the statement about a separate version 
number below :^).
However, the WG would still need to agree the to accept the draft as a 
viable
solution to an accepted problem. In this case, my opinion is that this 
draft shouldn't
be accepted by the WG.

Thanks,
Acee

---

From: "Abhay D.S" <[email-masked]>
Date: Thu, 14 Dec 2006 10:13:41 +0800

dear all,
To conclude the discussion on this:

With due respect to your area of focus,values and limitations in WG.

I am sure you  might have come across proprietary versions of OSPF
are still  used in some big commercial  networks, with a separate 
version numbers.

Some OSPF versions were extended to an extent that they could exchange 
MPLS or Layer 2
labels !!

See, it is only about "Vision", and this vision is shared by people 
outside WG and I think WG is good
but it is still NOT the best.

Acee: It is appreciated if WG could accept all valid variations OSPF 
specs as experimental and bubble
it up slowly to standardization.

Thanks,
Abhay

Acee Lindem wrote:
>> From: Abhay D.S [mailto:[email-masked]] Sent: Wednesday, December 
>> 13, 2006 3:30 AM
>> To: Acee Lindem
>> Cc: [email-masked]
>> Precisely the new AOSPF draft does that and there is nothing wrong 
>> with it. Tell me what is
>>
>>>>>>>> I'd like to initiate discussion on this draft so that we can 
>>>>>>>> let the authors