Subject: Re: [OSPF] OSPF scalability

From: Erblichs <[email-masked]>
Date: Fri, 22 Feb 2008 09:37:21 -0800

Vincent Nogues,

         This email is intended to be vender neutral discussions
         wrt OSPF. IMO, if the more dynamic links are separated
         and associated with one or more separate areas, then
         convergence time should improve and the amount of CPU
         resources should decrease.

         I do not have a rule of thumb on the number of routers
         in an area, but without BMA type links, this number seems
         excessive for a single area.

         Mitchell Erblich
	------------------

> Vincent Nogues wrote:
> 
> Dears,
> 
> 
> 
> I have a network made up 180 Cisco routers (3825 series). They are
> meshed with about 300 links. These links are quite heterogeneous in
> terms of bandwidth (between 2Mb/s and 8Mb/s). The network is quite
> dynamic, i.e. some links are regularly added or removed. There are
> also about 500 external routes injected in this network. The routers
> implement the following services: access-list and route-map, QoS and
> shaping, dot1Q encapsulation, 4 OSPF processes, BGP, SNMP.
> 
> 
> 
> My questions are:
> 
> ü       Is it recommended to integrate these 180 routers in a single
> OSPF area (area 0.0.0.0)?
> 
> ü       Have someone already experienced such an issue and do you know
> if the 3825 routers are able to compute (in terms of CPU or memory)
> all these OSPF routes in a reasonable time (i.e. Convergence time less
> than 1 minute)?
> 
> 
> 
> I would like to know if my network will be reliable with such an
> important number of routers in a single area.
> 
> 
> 
> Thanks in advance,
> 
> 
> 
> ---------------------------------------------------
> 
> Vincent NOGUES
> 
> ---------------------------------------------------
> 
> TEAMLOG
> 
> 12A, rue du Pâtis Tatelin
> 
> 35700 RENNES
> 
> Standard : 02.99.12.71.71
> 
> Fax : 02.99.12.71.72
> 
> www.teamlog.com - [email-masked]
> 
> ---------------------------------------------------
> 
> Ligne directe : 02.99.12.53.60
> 
> ---------------------------------------------------
> 
> ATTENTION : Ce message et toutes les pičces jointes (ci-aprčs le
> "message") sont confidentiels et strictement réservés aux
> destinataires qui procčderont aux vérifications appropriées en matičre
> de virus. Toute utilisation ou diffusion non autorisée est interdite.
> Tout message électronique est susceptible d'altération. L'auteur de ce
> message et le Groupe TEAMLOG déclinent toute responsabilité au titre
> de ce message s'il a été altéré, déformé, falsifié ou indűment utilisé
> par des tiers, ou encore s'il a causé tout dommage ou perte de toute
> nature.
> Si vous n'ętes pas destinataire de ce message, merci de le détruire
> immédiatement et d'avertir l'expéditeur.
> ***********************************
> WARNING : This message and any attachments (the "message") are
> confidential and strictly intended for their addressees, who will
> conduct appropriate virus checks. Any unauthorised use or
> dissemination is prohibited.
> Messages are susceptible to alteration. The author of this message or
> TEAMLOG Group shall not be liable for the message if altered, changed,
> falsified or unduly used by third parties, or for any damage or loss.
> If you are not receiver of this message, please cancel it immediately
> and inform the sender.
> 
> 
> 
>     ---------------------------------------------------------------
> _______________________________________________
> OSPF mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/ospf
_______________________________________________
OSPF mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ospf

---

From: "Vincent Nogues" <[email-masked]>
Date: Mon, 25 Feb 2008 17:16:25 +0100

Dear,

Thank you for your answer. 

>         resources should decrease.

I agree with you that the separation of the dynamic links should improve the
performance. 

>         excessive for a single area.

What do you mean by < without BMA type links > ?

Thanks in advance

Vincent NOGUES