Subject: [OSPF] Reference LSID value for 2001 LS Type

From: "Faraz Shamim (sshamim)" <[email-masked]>
Date: Sat, 6 Sep 2008 08:39:44 -0700

Can someone please tell me why did we choose to have "0" as Ref LSID for
2001 LS type for intra-area prefix LSA? What was wrong in picking up the
interface ID value for the actual link itself?
 
Thanks,
 
Faraz
_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf

---

From: Paul Wells <[email-masked]>
Date: Sat, 06 Sep 2008 11:02:49 -0500

Hi Faraz,

I'm not sure I understand what you are suggesting. Intra-area 
prefixes with a referenced LS type of 2001 are stub networks 
associated with the router itself. For example loopbacks or 
non-transit links.

Each router originates a single logical router LSA into a given 
area (though this may be fragmented) so the LSID of the referenced 
router LSA isn't needed to identify it. In addition, each 
intra-area prefix LSA may contain multiple prefixes associated 
with different interfaces. Which one would we use?

Regards,
Paul

Faraz Shamim (sshamim) wrote:
> 2001 LS type for intra-area prefix LSA? What was wrong in picking up 
> the interface ID value for the actual link itself?
>  
> Thanks,
>  
> Faraz
> 
> 
> ------------------------------------------------------------------------
>

---

From: "Faraz Shamim (sshamim)" <[email-masked]>
Date: Sat, 6 Sep 2008 09:20:33 -0700

Hi Paul,

I think I got my answer. Thanks for your explanation.

Faraz 

-----Original Message-----
From: Paul Wells (pauwells) 
Sent: Saturday, September 06, 2008 11:03 AM
To: Faraz Shamim (sshamim)
Cc: [email-masked]
Subject: Re: [OSPF] Reference LSID value for 2001 LS Type

Hi Faraz,

I'm not sure I understand what you are suggesting. Intra-area prefixes
with a referenced LS type of 2001 are stub networks associated with the
router itself. For example loopbacks or non-transit links.

Each router originates a single logical router LSA into a given area
(though this may be fragmented) so the LSID of the referenced router LSA
isn't needed to identify it. In addition, each intra-area prefix LSA may
contain multiple prefixes associated with different interfaces. Which
one would we use?

Regards,
Paul