Subject: [OSPF] Applicability of RFC 5185 (Multi Area Adjacency) to OSPFv3

From: Rajesh Shetty <[email-masked]>
Date: Thu, 25 Sep 2008 12:21:04 +0530

Hi All,

For OSPFv3 there should not be Applicability (Section 4)of Multi Area Adjacency RFC (RFC 5185). In OSPFv3 we can achieve the same gracefully by using interface Instance-ID. Using Instance-ID we can make single link belong to two or more OSPF areas

Disadvantages of extending applicability of RFC 5185 to OSFV3 are:

1)      Receive packet processing in this mechanism is more complex compare to Instance-ID handling

2)      Here we should treat interface type as point to point irrespective of underlying physical link

Correct me if I am missing any information.

Thanks

Rajesh

This e-mail and attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient's) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Thu, 25 Sep 2008 06:06:23 -0400

Hi Rajesh,
There are other applications proposed for the OSPFv3 interface  
Instance-ID where it does, in fact, specify the OSPF instance.  
Extending the RFC 5185 functionality to OSPFv3 allows a link to be  
used in multiple areas when the Interface-ID is used for a different  
purpose.
Thanks,
Acee
On Sep 25, 2008, at 2:51 AM, Rajesh Shetty wrote:

> Hi All,
>
> For OSPFv3 there should not be Applicability (Section 4)of Multi  
> Area Adjacency RFC (RFC 5185). In OSPFv3 we can achieve the same  
> gracefully by using interface Instance-ID. Using Instance-ID we can  
> make single link belong to two or more OSPF areas
>
> This e-mail and attachments contain confidential information from  
> HUAWEI, which is intended only for the person or entity whose  
> address is listed above. Any use of the information contained  
> herein in any way (including, but not limited to, total or partial  
> disclosure, reproduction, or dissemination) by persons other than  
> the intended recipient's) is prohibited. If you receive this e-mail  
> in error, please notify the sender by phone or email immediately  
> and delete it!