Subject: [OSPF] OSPF HMAC-SHA Cryptographic Authentication

From: John Smith <[email-masked]>
Date: Mon, 16 Mar 2009 01:03:19 +0000 (GMT)

Hi OSPFers,

I was reading draft-ietf-ospf-hmac-sha-03.txt and i think its good and very readable.However, a small nit with the draft: All references to other draft sections are off by 1 - thus a reference to section 3 and 5 in section 5.1 should be 4 and 6 really. :-)

Its been around for a long time now and i have never seen any opposition/changes. Is there a reason why its not close to WG LC yet?

John

P.S.

It seems as Dave reflected some time back, that OSPF is lagging far behind IS-IS and RIP as these WGs
(i know there is none for RIP) have already come out with RFCs
extending ISIS/RIP for HMAC-SHA support, while OSPF is still struggling on.

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 16 Mar 2009 20:14:41 -0700

Hi John,

Thanks for pointing this out. We will work on it.

Thanks,
Vishwas

On Sun, Mar 15, 2009 at 6:03 PM, John Smith <[email-masked]> wrote:
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 19 Mar 2009 10:37:45 +0530

Hi John,

> 
> I was reading draft-ietf-ospf-hmac-sha-03.txt and i think its 
> good and very readable.However, a small nit with the draft: 
> All references to other draft sections are off by 1 - thus a 
> reference to section 3 and 5 in section 5.1 should be 4 and 6 
> really. :-)

Thanks. Will fix it.

> 
> Its been around for a long time now and i have never seen any 
> opposition/changes. Is there a reason why its not close to WG LC yet?

There are some folks who believe that we should align our crypto-mathematics with how its done in IS-IS and RIP (https://www.ietf.org/proceedings/08nov/slides/ospf-5.pdf). However, the other argument is that though it did make a trifle bit of sense in doing it for IS-IS and RIP, it makes none, none at all, for OSPF. 

It is only this that's stalling the document from moving ahead which is otherwise ready for WG LC.

Cheers, Manav

> 
> John
> 
> P.S.
> 
> It seems as Dave reflected some time back, that OSPF is 
> lagging far behind IS-IS and RIP as these WGs

---

From: Tony Li <[email-masked]>
Date: Mon, 23 Mar 2009 13:54:34 -0700

Bhatia, Manav (Manav) wrote:
> There are some folks who believe that we should align our crypto-mathematics with how its done in IS-IS and RIP (https://www.ietf.org/proceedings/08nov/slides/ospf-5.pdf). However, the other argument is that though it did make a 
 > trifle bit of sense in doing it for IS-IS and RIP, it makes none, 
none at all, for OSPF.

Except that it makes the end customer happy.  It doesn't hurt anything 
technically, so there are those that feel that this is worthwhile.

Tony

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Tue, 24 Mar 2009 06:36:34 +0530

> > There are some folks who believe that we should align our 
> crypto-mathematics with how its done in IS-IS and RIP 
> (https://www.ietf.org/proceedings/08nov/slides/ospf-5.pdf). 
> However, the other argument is that though it did make a 

The end customer is happy because he is under the impression that the new construct improves the strength of the crypto hash, which we all know is incorrect (especially in case of OSPF).

He may feel cheated and may not be so happy, when he learns that there was no value add.

Manav

---

From: Tony Li <[email-masked]>
Date: Mon, 23 Mar 2009 18:27:12 -0700

> He may feel cheated and may not be so happy, when he learns that there was no value add.

The customer has already heard your argument and rejected it.

Tony