Subject: [OSPF] Can replace the Virtual link into the Point-to-point link?

From: [email-masked]
Date: Wed, 10 Mar 2010 16:57:38 +0800

Hi all, 

  In the Router-LSA, can replace the Virtual link into the Point-to-point 
link, and obsolete the virtual link?
 
  In RFC4577 OSPF as the Provider/Customer Edge Protocol for BGP/MPLS IP 
Virtual Private Networks (VPNs)
  The sham link is an unnumbered point-to-point intra-area link and is 
advertised as a type 1 link in a type 1 LSA.
 
  So can I interpret it this way, the virtual link is an numbered 
point-to-point link and is advertised as a type 1 link in a type 1 LSA.

  I just want to know a separate type 4 link(Virtual link) in Router-LSA 
for virtual-link, what's for special applications?

  Thanks.

---

From: Acee Lindem <[email-masked]>
Date: Wed, 10 Mar 2010 05:57:52 -0500

HI Huang,
The virtual link and sham link are for different purposes. The virtual link allows one to use a transit area for backbone traffic. All the routers in the transit area must be able to route backbone traffic. Conversely, the  sham link is between two PEs in the same MPLS IP VPN and the traffic between uses an MPLS LSP. None of the P routers, need to be able to route this traffic. There are other differences as well but most are consequences of the different purposes virtual links and sham links serve.

Hope this helps,
Acee

On Mar 10, 2010, at 3:57 AM, <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

  In the Router-LSA, can replace the Virtual link into the Point-to-point link, and obsolete the virtual link?

  In RFC4577 OSPF as the Provider/Customer Edge Protocol for BGP/MPLS IP Virtual Private Networks (VPNs)
  The sham link is an unnumbered point-to-point intra-area link and is advertised as a type 1 link in a type 1 LSA.

  So can I interpret it this way, the virtual link is an numbered point-to-point link and is advertised as a type 1 link in a type 1 LSA.

  I just want to know a separate type 4 link(Virtual link) in Router-LSA for virtual-link, what's for special applications?

  Thanks.
_______________________________________________
OSPF mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ospf