Subject: [OSPF] Fwd: request for help in developing a tool that may be helpful to WG chairs

From: Acee Lindem <[email-masked]>
Date: Wed, 3 Mar 2010 14:04:55 -0500

FYI...

Begin forwarded message:

From: "Scott O. Bradner" <[email-masked]<mailto:[email-masked]>>
Date: March 3, 2010 10:36:19 AM EST
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: request for help in developing a tool that may be helpful to WG chairs

IETF working group chairs;

We are developing an open-source tool for monitoring the status and
progress of conflicts in on-line working groups (WG).  The tool works by
analyzing the WG mailing list.  When developed, this tool should be
helpful to WG chairs trying to understand the status of WG discussions
(how close to consensus is the WG, what is the distribution of
participation, etc).

As part of the development process we have been using a prototype tool
to analyze IETF WG mailing list archives to determine the amount of
conflict and how effective this conflict is being (has been) resolved.
As the first step, we need to understand the relationship between the
conflicts in a working group and the structure of the communication
network in that group. While having conflicts is not necessarily a bad
thing for a working group effort, some conflicts can escalate into
disasters. We are interested in finding the communication patterns
related to the evolution of group conflicts. Results from this study
will provide the base for the development of the tool that helps working
group chairs to decide when to intervene with an internal conflict
before it becomes irreversibly negative as well as being a tool that may
help determine where there is consensus on a particular topic.

We would like your help in understanding the level of conflicts within
your working groups and how the conflicts affect productivity and group
members’ perception on the working group. It will be greatly appreciated
if you could ask your WG members to anonymously fill a short survey at

https://spreadsheets.google.com/viewform?hl=en&formkey=dExTbEU5QmRncnhFbjhQUVR4bzBGMEE6MA

Thank you!

Best Regards,

Bin Zhu, Mark Gaynor, Scott Bradner, and Jialun Qin

---

From: "tom.petch" <[email-masked]>
Date: Sat, 6 Mar 2010 20:36:49 +0100

Acee

I am confused.

Can we only answer about OSPF or can we choose which group?  Only OSPF has been
singularly dispute free and not worth answering about, whereas I can think of
major and obstructive conflict in at least three WG in the past 12 months which
would be far better to talk about.

Tom Petch

----- Original Message -----
From: "Acee Lindem" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, March 03, 2010 8:04 PM
Subject: [OSPF] Fwd: request for help in developing a tool that may be helpful
to WG chairs

FYI...

Begin forwarded message:

From: "Scott O. Bradner" <[email-masked]<mailto:[email-masked]>>
Date: March 3, 2010 10:36:19 AM EST
To: "[email-masked]<mailto:[email-masked]>"
<[email-masked]<mailto:[email-masked]>>
Subject: request for help in developing a tool that may be helpful to WG chairs

https://spreadsheets.google.com/viewform?hl=en&formkey=dExTbEU5QmRncnhFbjhQUVR4b
zBGMEE6MA

Thank you!

Best Regards,

_______________________________________________
OSPF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ospf

---

From: Acee Lindem <[email-masked]>
Date: Sat, 6 Mar 2010 20:26:05 -0500

Hi Tom,

You can definitely answer with respect to another WG as this was an IETF wide query.

Note that OSPF has not been immune to conflict as we were not able to agree on a single mechanism to reduce flooding in MANET networks. 

Also, we could probably benefit from some more conflict on the base specifications and extensions. While it doesn't seem the router vendors have any problems with interoperable implementations, it seems the test tool vendors have many times misinterpreted the specifications and released invalid tests. It would be beneficial if the test tool vendors would review the specifications during the standardization process.   

Thanks,
Acee