Subject: [OSPF] Fwd: OSPF Link-Local Signaling

From: Glen Kent <[email-masked]>
Date: Wed, 30 Jun 2010 05:40:28 +0530

Hi,

I would appreciate if somebody could clarify why the following
doubts that i have in OSPF LLS:

o Why can this only be used for Hellos and DDs and not the other
protocol packets like LSAs, etc.

o Why is the delivery of LLS data in Hello packets not guaranteed? Is
it because of MTU? If its this, then the entire packet would not get
delivered, right?

Thanks,
Glen

---

From: Mitchell Erblich <[email-masked]>
Date: Tue, 29 Jun 2010 17:27:53 -0700

On Jun 29, 2010, at 5:10 PM, Glen Kent wrote:

> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

Let me take the 2nd item:

Independent of LLS, OSPF uses the IP protocol, and the IP protocol is
a best effort protocol. Second, even if the OSPF pkt is delivered to
a destination, the network interface may itself drop and or reject it,
because of exaustion of resources, i.e, recv descriptors and / or
socket or mbuf network buffers. 

This is even before the destination's OSPF recv's the pkt.

Mitchell Erblich

---

From: Glen Kent <[email-masked]>
Date: Wed, 30 Jun 2010 06:07:51 +0530

Mitchell,

> This is even before the destination's OSPF recv's the pkt.

Ok. I interpreted this as saying that while the receiver may receive
the Hello packet, it may still not be able to receive the LLS data,
which got me intrigued.

Glen

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 29 Jun 2010 18:22:31 -0700

Dear Glen,
the OSPF uses UDP which is unreliable IP transport, not like TCP which is
used by BGP. You've noticed that some LLS (DD and LSA) have reliability
support on protocol level while others (Hello) don't. If Hello goes through
(at least one of three to keep adjacency up) then all other exchanges will
work, even with retransmissions.

Regards,
Greg

---

From: Mitchell Erblich <[email-masked]>
Date: Tue, 29 Jun 2010 18:59:28 -0700

On Jun 29, 2010, at 6:22 PM, Greg Mirsky wrote:

> Dear Glen,
> the OSPF uses UDP which is unreliable IP transport, not like TCP which is used by BGP. You've noticed that some LLS (DD and LSA) have reliability support on protocol level while others (Hello) don't. If Hello goes through (at least one of three to keep adjacency up) then all other exchanges will work, even with retransmissions.
> 
> Regards,
> Greg
> 

Greg,

Sorry UDP is NOT a IP transport.
These last two words (IP transport) don't make sense.
UDP is a protocol, that in many current environments
 is layered below the IP protocol.
			
Yes, OSPF uses the UDP protocol. 
However, their should be no assumption of a lower reliability
with UDP. TCP adds overhead, fairness, and a ACK clocking 
probing mechanism, SS,, CA, etc. 

Most of these TCP items are included within
equivalents inside of some implementations of OSPF.
Which also adds a great deal of complexity.

The assumption is that the max orig 64k IPv4 datagram
was sufficent to send datagrams independently, than
inside a specific increasing rate data flow.

TCP actually decreases its data flows given short
periods of idleness after multiple pkts of connection
ESTABLISHMENT. This is a bad thing for a routing
protocol.

Mitchell Erblich

---

From: Claudio Jeker <[email-masked]>
Date: Wed, 30 Jun 2010 04:15:35 +0200

> Yes, OSPF uses the UDP protocol. 

No it does not. OSPF uses its own proto 89 on top of IP.
OSPF has its own reliability layer to make sure that the LSDB stay in
sync.

-- 
:wq Claudio

---

From: Mitchell Erblich <[email-masked]>
Date: Tue, 29 Jun 2010 19:45:18 -0700

> OSPF has its own reliability layer to make sure that the LSDB stay in

Sorry, I misspoke. :(

Some implementations of OSPF, can use UDP when certain
OSPF capabilities are enabled and/or used.

It is not a "normal" behaviour specified in the OSPF protocol
and it is normally not used as a transport for OSPF.

In one instance, UDP can be used when IP address/name and/or
DNS names are resolved within the CLI. Or when
some OSPF functions are executed when xmiting or recving
OSPF protocol pkts.

Mitchell Erblich

---

From: Acee Lindem <[email-masked]>
Date: Wed, 30 Jun 2010 23:11:10 -0400

OSPF WG members should not well that is not and never has been any variant of the OSPF protocol that runs over UDP (discounting UDP based tunneling mechanisms where there is an inner IPv4 packet).  The implementations referred to below are strictly proprietary. 
Thanks,
Acee (speaking as OSPF WG chair)

---

From: Acee Lindem <[email-masked]>
Date: Wed, 30 Jun 2010 23:13:45 -0400

OSPF WG members should note well that there is not and never has been any variant of the OSPF protocol that runs over UDP (discounting UDP based tunneling mechanisms where there is a complete inner IPv4 packet).  The implementations referred to below are strictly proprietary. 
Thanks,
Acee (speaking as OSPF WG chair)