Subject: Re: [OSPF] Working Group Last Call for "Advertising per-node administrative tags in OSPF" - draft-ietf-ospf-node-admin-tag-02

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 20 Aug 2015 23:50:42 +0000

Authors, 

In the “Elements of Procedure” section, please address how multiple
instances of the TLV will be handled. At a minimum, the following cases
must be handled:

     1. Multiple instances of the TLV in the same OSPF(v3) Router
Information LSA
     2. Multiple instances of the TLV in multiple OSPF(v3) Router
Information LSA instances
     3. Removal an instance of the TLV in an OSPF(v3) Router Information
LSA through re-origination
     4. Purge of an OSPF(v3) Router Information LSA containing the node
admin tags TLV. 

One possible interpretation (and probably the simplest) is that the set of
valid tags for a given OSPF(v3) router is the superset of the tags in all
the existing OSPF(v3) Router Information LSAs advertised by that router.

Thanks,
Acee  

On 7/23/15, 2:24 PM, "OSPF on behalf of Acee Lindem (acee)"
<[email-masked] on behalf of [email-masked]> wrote:

>This begins the WG last call for the subject draft. Please send your
>comments to this list prior to 12:00 AM GMT, August 22th, 2015. Note that
>we are doing a 4 week WG last call due to the volume of IETF WG last calls
>made this week and the fact that many WG participants may be taking
>vacation in August.
>
>Thanks,
>Acee
>
>_______________________________________________
>OSPF mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ospf

---

From: Shraddha Hegde <[email-masked]>
Date: Thu, 27 Aug 2015 04:36:34 +0000

Acee,

Agree with you that the interpretation should be that the node tags for certain router is  the super set of all the tags from all node-admin tag TLVs from all instances of RI LSA advertised by that router.
Will update the document.

Rgds
Shraddha

-----Original Message-----
From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Friday, August 21, 2015 5:21 AM
To: Acee Lindem (acee) <[email-masked]>; OSPF WG List <[email-masked]>
Subject: Re: [OSPF] Working Group Last Call for "Advertising per-node administrative tags in OSPF" - draft-ietf-ospf-node-admin-tag-02

Authors, 

In the “Elements of Procedure” section, please address how multiple instances of the TLV will be handled. At a minimum, the following cases must be handled:

     1. Multiple instances of the TLV in the same OSPF(v3) Router Information LSA
     2. Multiple instances of the TLV in multiple OSPF(v3) Router Information LSA instances
     3. Removal an instance of the TLV in an OSPF(v3) Router Information LSA through re-origination
     4. Purge of an OSPF(v3) Router Information LSA containing the node admin tags TLV. 

One possible interpretation (and probably the simplest) is that the set of valid tags for a given OSPF(v3) router is the superset of the tags in all the existing OSPF(v3) Router Information LSAs advertised by that router.

Thanks,
Acee  

On 7/23/15, 2:24 PM, "OSPF on behalf of Acee Lindem (acee)"
<[email-masked] on behalf of [email-masked]> wrote:

>comments to this list prior to 12:00 AM GMT, August 22th, 2015. Note 
>that we are doing a 4 week WG last call due to the volume of IETF WG 
>last calls made this week and the fact that many WG participants may be 
>taking vacation in August.
>
>Thanks,
>Acee
>