Subject: [OSPF] Immediate Replying Hello

From: <[email-masked]>
Date: Wed, 31 Jan 2018 08:27:47 -0000

Hi,

Many OSPF implementations include the Immediate Replying Hello feature,
which I believe is not standard.

The only reference I found is the draft "Update to OSPF Hello procedure,
draft-kou-ospf-immediately-replying-hello-02.txt" which has expired.

Are vendors following what is written in this draft? Is there a document
from any vendor that details this feature? 

Thanks.

Rui Valadas

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 31 Jan 2018 12:47:28 +0000

Hi Rui,

It is not a standard. However, it is a technique used by many implementations to speed adjacency formation when a hello packet is received and the neighbor state is less than two-way. At least one of the implementations with witch with I have been associated would unicast the hello.

Hope this helps,
Acee

From: OSPF <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Wednesday, January 31, 2018 at 3:28 AM
To: OSPF WG List <[email-masked]>
Subject: [OSPF] Immediate Replying Hello

Hi,

Many OSPF implementations include the Immediate Replying Hello feature, which I believe is not standard.

The only reference I found is the draft “Update to OSPF Hello procedure, draft-kou-ospf-immediately-replying-hello-02.txt” which has expired.

Are vendors following what is written in this draft? Is there a document from any vendor that details this feature?

Thanks.

Rui Valadas

---

From: <[email-masked]>
Date: Wed, 31 Jan 2018 13:41:31 -0000

Hi,

It helps, thanks.

But the Kou draft (https://datatracker.ietf.org/doc/draft-kou-ospf-immediately-replying-hello/ ) also mentions two other situations where immediate hellos must be sent: after state changes from “2-Way” or greater down to “Init” (case 2), and after DR election (case 3). Do you know if these cases are also implemented?

Thanks.

Rui

From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Wednesday, January 31, 2018 12:47 PM
To: [email-masked]; [email-masked]
Subject: Re: [OSPF] Immediate Replying Hello

Hi Rui, 

Hope this helps, 

Acee 

From: OSPF <[email-masked] <mailto:[email-masked]> > on behalf of "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >
Date: Wednesday, January 31, 2018 at 3:28 AM
To: OSPF WG List <[email-masked] <mailto:[email-masked]> >
Subject: [OSPF] Immediate Replying Hello

Hi,

Thanks.

Rui Valadas

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 31 Jan 2018 15:15:31 +0000

From: OSPF <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Wednesday, January 31, 2018 at 8:44 AM
To: OSPF WG List <[email-masked]>
Subject: Re: [OSPF] Immediate Replying Hello

Hi,

It helps, thanks.

While there are other cases where hellos are sent other than on a timer, I don’t know of these cases being implemented.

Thanks,
Acee

Thanks.

Rui

Hi Rui,

Hope this helps,
Acee

From: OSPF <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 31, 2018 at 3:28 AM
To: OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [OSPF] Immediate Replying Hello

Hi,

Thanks.

Rui Valadas