Subject: Re: [OSPF] [Isis-wg] Link-State Routing WG charter

From: Jeff Tantsura <[email-masked]>
Date: Wed, 24 Jan 2018 15:11:00 -0800

Wouldn’t L2 reference would be a bit outdated? 

Cheers,

Jeff

From: OSPF <[email-masked]> on behalf of "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wednesday, January 24, 2018 at 15:09
To: Stewart Bryant <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>, Alia Atlas <[email-masked]>
Cc: OSPF List <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [OSPF] [Isis-wg] Link-State Routing WG charter

It occurred to me after sending this that perhaps a better statement as regards IS-IS would be:

“LSR’s work is focused on IP/IPv6 and Layer 2 routing…”

though admittedly there isn’t much going on as regards Layer2 and IS-IS at the moment. 

   Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Wednesday, January 24, 2018 2:33 PM
To: Stewart Bryant <[email-masked]>; Acee Lindem (acee) <[email-masked]>; Alia Atlas <[email-masked]>
Cc: OSPF List <[email-masked]>; [email-masked]
Subject: Re: [Isis-wg] Link-State Routing WG charter

Since a charter only provides a general definition of the work that falls within the purview of the WG it requires some adjunct to keep track of the current priorities.

That could be the list of milestones (which OSPF has regularly maintained – but IS-IS has not) – or it could simply be the list of active WG documents.

I just don’t see that we should expect the charter to express “work in progress” now – or in the future.

Alia – do you think the statement about IS-IS:

“LSR’s work is focused on IP routing…”

Could be improved by saying

“LSR’s work is focused on IP/IPv6 routing…”

???

   Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Wednesday, January 24, 2018 10:01 AM
To: Acee Lindem (acee) <[email-masked]>; Alia Atlas <[email-masked]>
Cc: OSPF List <[email-masked]>; [email-masked]
Subject: Re: [Isis-wg] Link-State Routing WG charter

Yes that fixes that.

How about:

s/The following topics are expected to be an initial focus:/ In addition to ongoing maintenance, the following topics are expected to be an initial focus:/

I am just concerned that we need not to loose focus on work in progress.

- Stewart

On 24/01/2018 17:54, Acee Lindem (acee) wrote:

How about:

LSR will coordinate with CCAMP and BIER on their extensions to the LSR IGPs as

applicable to LSV protocol operation and scale. 

Thanks,

Acee 

From: Isis-wg <[email-masked]> on behalf of Alia Atlas <[email-masked]>
Date: Wednesday, January 24, 2018 at 12:42 PM
To: Stewart Bryant <[email-masked]>
Cc: OSPF WG List <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Isis-wg] Link-State Routing WG charter

Hi Stewart, 

Thanks for the quick feedback.  Feel free to provide suggestions for text changes if you have them.

You've certainly written enough charters :-)

Regards,

Alia

On Wed, Jan 24, 2018 at 12:32 PM, Stewart Bryant <[email-masked]> wrote:

Alia,

I think that this merger is long overdue, and hopefully it will help new features to be written in an aligned way.

I think the remit to perform general maintenance should slightly clarified since the way the charter is written they look like they are at a lower priority than the enumerated list.

I would have thought that "LSR can coordinate with CCAMP and BIER on their extensions " should have been more directive. 

- Stewart 

On 24/01/2018 17:18, Alia Atlas wrote:

Here is the proposed charter for the LSR working group 

that will be created from the SPF and ISIS working groups.

This is scheduled for internal review for the IESG telechat on February 8.

https://datatracker.ietf.org/doc/charter-ietf-lsr/

The Link-State Routing (LSR) Working Group is chartered to document current protocol implementation practices and improvements, protocol usage scenarios, maintenance and extensions of link-state routing interior gateway protocols (IGPs) with a focus on IS-IS, OSPFv2, and OSPFv3.  The LSR Working Group is formed by merging the isis and ospf WGs and will take on all their existing adopted work at the time of chartering.

IS-IS is an IGP specified and standardized by ISO through ISO 10589:2002 and additional RFC standards with extensions to support IP that has been deployed in the Internet for decades.  For the IS-IS protocol, LSR’s work is focused on IP routing, currently based on the agreement in RFC 3563 with ISO/JTC1/SC6. The LSR WG will interact with other standards bodies that have responsible for standardizing IS-IS.

OSPFv2 [RFC 2328 and extensions], is an IGP that has been deployed in the Internet for decades. OSPFv3 [RFC5340 and extensions] provides OSPF for IPv6 and IPv4 [RFC5838] which can be delivered over IPv6 or IPv4 [RFC 7949].

The LSR Working Group will generally manage its specific work items by milestones agreed with the responsible Area Director.

The following topics are expected to be an initial focus:

1) Improving OSPF support for IPv6 and extensions using OSPFv3 LSA Extendibility.

2) Extensions needed for Segment Routing and associated architectural changes

3) YANG models for IS-IS, OSPFv2, and OSPFv3 and extensions

4) Extensions for source-destination routing [draft-ietf-rtgwg-dst-src-routing]

5) Potentially, extensions to better support specific network topologies such as 

ones commonly used in data centers.

The Link-State Routing (LSR) Working Group will coordinate with other working groups, such as RTGWG, SPRING, MPLS, TEAS, V6OPS, and 6MAN, to understand the need for extensions and to confirm that the planned work meets the needs.  LSR can coordinate with CCAMP and BIER on their extensions to the LSR IGPs as useful.  LSR may coordinate with other WGs as needed.

Regards,

Alia

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

_______________________________________________ OSPF mailing list [email-masked] https://www.ietf.org/mailman/listinfo/ospf

---

From: Alia Atlas <[email-masked]>
Date: Wed, 24 Jan 2018 19:17:07 -0500

> Wouldn’t L2 reference would be a bit outdated?

There has been work from IEEE and from TRILL in the past as well as other
aspects  (e.g. RFC 6165, RFC 6326,
RFC 6329, RFC 7176) and - particularly with TRILL closing soon - making
sure that such work isn't out of scope
seems useful.

Regards,
Alia

>
>
> Cheers,
>
> Jeff
>
>
>
> *From: *OSPF <[email-masked]> on behalf of "Les Ginsberg
> (ginsberg)" <[email-masked]>
> *Date: *Wednesday, January 24, 2018 at 15:09
> *To: *Stewart Bryant <[email-masked]>, "Acee Lindem (acee)" <
> [email-masked]>, Alia Atlas <[email-masked]>
> *Cc: *OSPF List <[email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *Re: [OSPF] [Isis-wg] Link-State Routing WG charter
>
>
>
> *From:* Isis-wg [mailto:[email-masked]] *On Behalf Of *Les
> Ginsberg (ginsberg)
> *Sent:* Wednesday, January 24, 2018 2:33 PM
> *To:* Stewart Bryant <[email-masked]>; Acee Lindem (acee) <
> [email-masked]>; Alia Atlas <[email-masked]>
> *Cc:* OSPF List <[email-masked]>; [email-masked]
> *Subject:* Re: [Isis-wg] Link-State Routing WG charter
>
>
>
> Since a charter only provides a general definition of the work that falls
> within the purview of the WG it requires some adjunct to keep track of the
> current priorities.
>
> That could be the list of milestones (which OSPF has regularly maintained
> – but IS-IS has not) – or it could simply be the list of active WG
> documents.
>
> *From:* Isis-wg [mailto:[email-masked]
> <[email-masked]>] *On Behalf Of *Stewart Bryant
> *Sent:* Wednesday, January 24, 2018 10:01 AM
> *To:* Acee Lindem (acee) <[email-masked]>; Alia Atlas <[email-masked]>
> *Cc:* OSPF List <[email-masked]>; [email-masked]
> *Subject:* Re: [Isis-wg] Link-State Routing WG charter
>
>
>
> Yes that fixes that.
>
> How about:
>
> s/The following topics are expected to be an initial focus:/ In addition
> to ongoing maintenance, the following topics are expected to be an initial
> focus:/
>
> *From: *Isis-wg <[email-masked]> <[email-masked]> on
> behalf of Alia Atlas <[email-masked]> <[email-masked]>
> *Date: *Wednesday, January 24, 2018 at 12:42 PM
> *To: *Stewart Bryant <[email-masked]> <[email-masked]>
> *Cc: *OSPF WG List <[email-masked]> <[email-masked]>, "[email-masked]"
> <[email-masked]> <[email-masked]> <[email-masked]>
> *Subject: *Re: [Isis-wg] Link-State Routing WG charter
>
>
>
> Hi Stewart,
>
>
>
> I think that this merger is long overdue, and hopefully it will help new
> features to be written in an aligned way.
>
> I think the remit to perform general maintenance should slightly clarified
> since the way the charter is written they look like they are at a lower
> priority than the enumerated list.
>
> I would have thought that "LSR can coordinate with CCAMP and BIER on their
> extensions " should have been more directive.
>
> - Stewart
>
>
>
> The Link-State Routing (LSR) Working Group is chartered to document
> current protocol implementation practices and improvements, protocol usage
> scenarios, maintenance and extensions of link-state routing interior
> gateway protocols (IGPs) with a focus on IS-IS, OSPFv2, and OSPFv3.  The
> LSR Working Group is formed by merging the isis and ospf WGs and will take
> on all their existing adopted work at the time of chartering.
>
>
>
> IS-IS is an IGP specified and standardized by ISO through ISO 10589:2002
> and additional RFC standards with extensions to support IP that has been
> deployed in the Internet for decades.  For the IS-IS protocol, LSR’s work
> is focused on IP routing, currently based on the agreement in RFC 3563 with
> ISO/JTC1/SC6. The LSR WG will interact with other standards bodies that
> have responsible for standardizing IS-IS.
>
>
>
> OSPFv2 [RFC 2328 and extensions], is an IGP that has been deployed in the
> Internet for decades. OSPFv3 [RFC5340 and extensions] provides OSPF for
> IPv6 and IPv4 [RFC5838] which can be delivered over IPv6 or IPv4 [RFC 7949].
>
>
>
> The LSR Working Group will generally manage its specific work items by
> milestones agreed with the responsible Area Director.
>
>
>
> The Link-State Routing (LSR) Working Group will coordinate with other
> working groups, such as RTGWG, SPRING, MPLS, TEAS, V6OPS, and 6MAN, to
> understand the need for extensions and to confirm that the planned work
> meets the needs.  LSR can coordinate with CCAMP and BIER on their
> extensions to the LSR IGPs as useful.  LSR may coordinate with other WGs as
> needed.
>
>
>
> Regards,
>
> Alia
>
>
>
>
> _______________________________________________ OSPF mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/ospf
>