Subject: Re: [p2pi] Charter and problem statement

From: songhaibin 64081 <[email-masked]>
Date: Wed, 16 Jul 2008 16:00:02 +0800

Hi Stas,

I think "cache selection" would be better to describe this issue and should be included in the scope of ALTO, just like the "peer selection". If caches are deployed by the ISP (Probably true in most cases), then it meets the requirement that ALTO wants to expose the information that P2P application can't measure for traffic optimization.

Here cache is a special kind of peer, which is registered to the ALTO server. ALTO server must respond to peer selection queries with the selected peers and also caches. Of course, client can request resources from the cache that doesn't have the requested resource, as cache can fetch the resource from other peers/servers even other caches.

IMO, there may be kinds of caches, P2P caches, http caches and etc. I don’t know if ALTO takes into account all these kinds of caches. If so, the ALTO client must identify the "kind" of cache it wants to get from the ALTO server's selection. I don't know if it violates the rule of application agnostic here.

Best Regards!
Song Haibin

_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

---

From: songhaibin 64081 <[email-masked]>
Date: Wed, 16 Jul 2008 16:05:15 +0800

Because there is something wrong with my email server, please ignore if you receive this email again.

----- Original Message -----
From: songhaibin 64081 <[email-masked]>
Date: Wednesday, July 16, 2008 4:00 pm
Subject: Re: [p2pi] Charter and problem statement

> Hi Stas,
> 
> I think "cache selection" would be better to describe this issue 
> and should be included in the scope of ALTO, just like the "peer 
> selection". If caches are deployed by the ISP (Probably true in 
> most cases), then it meets the requirement that ALTO wants to 
> expose the information that P2P application can't measure for 
> traffic optimization.
> 
> Here cache is a special kind of peer, which is registered to the 
> ALTO server. ALTO server must respond to peer selection queries 
> with the selected peers and also caches. Of course, client can 
> request resources from the cache that doesn't have the requested 
> resource, as cache can fetch the resource from other peers/servers 
> even other caches.
> 
> IMO, there may be kinds of caches, P2P caches, http caches and 
> etc. I don’t know if ALTO takes into account all these kinds of 
> caches. If so, the ALTO client must identify the "kind" of cache 
> it wants to get from the ALTO server's selection. I don't know if 
> it violates the rule of application agnostic here.
> 
> Best Regards!
> Song Haibin
> 
>