Subject: Re: [p2pi] ALTO BoF - generalize the problem

From: Stanislav Shalunov <[email-masked]>
Date: Tue, 15 Jul 2008 16:36:38 -0700

Solving self-interference is the very point of congestion control, which is totally in scope for TANA.

-----Original Message-----
From: "Salman Abdul Baset" <[email-masked]>
To: "Enrico Marocco" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Sent: 7/15/08 6:16 AM
Subject: Re: [p2pi] ALTO BoF - generalize 

Information about self-interference can guide peer selection. For 
example, with this information, a P2PSIP application running on one of 
several machines behind the cable/DSL modem can more accurately determine 
the presence or absence of self-interference. In the absence of 
self-interference and after network usage has left the P2PSIP 
application convinced that it has enough capacity, it can advertise itself 
as a relay in the overlay.

> The TANA BoF discussed on the [email-masked] mailing list explicitly
> covers transport issues like congestion notification and sharing of
> network resources; its problem statement is available at:
> http://tools.ietf.org/id/draft-shalunov-tana-problem-statement

It is not clear to me whether it will/should be in the scope of ALTO or 
TANA to address the self-interference issue. Note that self-interference 
can be categorized as (1) interference with applications running on the 
*same* machine (2) interference with applications running on *different* 
machines that are behind the same cable/DSL modem.

-s
_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

---

From: Laird Popkin <[email-masked]>
Date: Tue, 15 Jul 2008 20:28:30 -0400 (EDT)

Good answer! :-)

- Laird Popkin, CTO, Pando Networks
  mobile: 646/465-0570

-----Original Message-----
From: "Salman Abdul Baset" <[email-masked]>
To: "Enrico Marocco" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Sent: 7/15/08 6:16 AM
Subject: Re: [p2pi] ALTO BoF - generalize 

-s