Subject: Re: [p2pi] Charter and problem statement

From: "Woundy, Richard" <[email-masked]>
Date: Tue, 15 Jul 2008 20:12:09 -0400

>OTOH, unconditionally obtaining the closest cache has no obvious problems.

I could see a problem here. If ISP X makes an investment in caching servers, to benefit its customers in some way, it may not want ISP Y customers to contact its caching servers. Especially if the ISP X caching servers are closest to ISP Y customers only because ISP Y does not deploy any caching servers.

(Of course in this scenario the ISP X caching servers could block non-ISP X traffic, if that is desired. I'm not advocating 'security by obscurity', just trying to avoid public announcement of non-global resources.)

In this case, I could see the rationale for ISP X's ALTO server announcing caching servers to ISP X customer / ALTO clients.

-- Rich

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Enrico Marocco <[email-masked]>; Sebastian Kiesel <[email-masked]>
Cc: [email-masked] <[email-masked]>
Sent: Tue Jul 15 19:36:30 2008
Subject: Re: [p2pi] Charter and problem statement

It would require whatever is giving caches out to query them beforehand, a task easily accomplished by the client.

More importantly, this would defeat the point of a cache, no?  First, it's empty. So, nobody gets it. So it remains empty.

OTOH, unconditionally obtaining the closest cache has no obvious problems.

-----Original Message-----
From: "Enrico Marocco" <[email-masked]>
To: "Sebastian Kiesel" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Sent: 7/15/08 6:32 AM
Subject: Re: [p2pi] Charter and problem statement

Sebastian Kiesel wrote:
> On Fri, Jul 11, 2008 at 11:10:41AM -0400, Laird Popkin wrote:
>> For this level of discussion, I agree that caches should simply be
>> viewed as a peer in ALTO.
> 
> What happens if we consider caches and rare content, i.e., content where
> the likelyhood is high, that there is a cache miss when we ask for it
> and that the cache will never deliver a second copy of it? It might not
> be wise to select a cache which is in the "opposite direction" of the
> original content, even if connectivity to the cache is "better"
> (according to whatever criteria). If the cache tries to fetch the
> content the request may pass by the client and go through the same "bad"
> link plus twice through the "good" one.

As long as caches are viewed as regular peers, they will be included in
ALTO requests/responses only if they actually have the resource the
querying peer wants to access.

-- 
Ciao,
Enrico

_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi
_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

---

From: Stanislav Shalunov <[email-masked]>
Date: Tue, 15 Jul 2008 17:31:38 -0700

Agreed.  I was tacitly assuming that the mechanism we use for cache  
discovery would not allow ISP Y to hand out ISP X's caches, because  
this is a property of most mechanisms we considered for this.  Should  
ALTO come up with a non-centralized mechanism that does not have this  
property, it'd make sense to mention that it's in poor taste to make  
thy customers covet thy neighbor's ass by announcing its address to  
them.

But not to worry: should ISP Y's customers somehow discover ISP X's  
cache through some sort of unanticipated leak -- say, through peer  
exchange, the cache, as you point out quite correctly, doesn't need to  
serve them any data, nor in fact accept their connections.

-- Stas

On Jul 15, 2008, at 5:12 PM, Woundy, Richard wrote:

> I could see a problem here. If ISP X makes an investment in caching  
> servers, to benefit its customers in some way, it may not want ISP Y  
> customers to contact its caching servers. Especially if the ISP X  
> caching servers are closest to ISP Y customers only because ISP Y  
> does not deploy any caching servers.
>
> (Of course in this scenario the ISP X caching servers could block  
> non-ISP X traffic, if that is desired. I'm not advocating 'security  
> by obscurity', just trying to avoid public announcement of non- 
> global resources.)
>
> In this case, I could see the rationale for ISP X's ALTO server  
> announcing caching servers to ISP X customer / ALTO clients.
>
> -- Rich
>
>
> It would require whatever is giving caches out to query them  
> beforehand, a task easily accomplished by the client.
>
> More importantly, this would defeat the point of a cache, no?   
> First, it's empty. So, nobody gets it. So it remains empty.
>

-- 
Stanislav Shalunov
http://shlang.com