Subject: Re: [p2pi] Charter and problem statement

From: Stanislav Shalunov <[email-masked]>
Date: Tue, 15 Jul 2008 16:36:30 -0700

It would require whatever is giving caches out to query them beforehand, a task easily accomplished by the client.

More importantly, this would defeat the point of a cache, no?  First, it's empty. So, nobody gets it. So it remains empty.

OTOH, unconditionally obtaining the closest cache has no obvious problems.

-----Original Message-----
From: "Enrico Marocco" <[email-masked]>
To: "Sebastian Kiesel" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Sent: 7/15/08 6:32 AM
Subject: Re: [p2pi] Charter and problem statement

Sebastian Kiesel wrote:
> On Fri, Jul 11, 2008 at 11:10:41AM -0400, Laird Popkin wrote:
>> For this level of discussion, I agree that caches should simply be
>> viewed as a peer in ALTO.
> 
> What happens if we consider caches and rare content, i.e., content where
> the likelyhood is high, that there is a cache miss when we ask for it
> and that the cache will never deliver a second copy of it? It might not
> be wise to select a cache which is in the "opposite direction" of the
> original content, even if connectivity to the cache is "better"
> (according to whatever criteria). If the cache tries to fetch the
> content the request may pass by the client and go through the same "bad"
> link plus twice through the "good" one.

As long as caches are viewed as regular peers, they will be included in
ALTO requests/responses only if they actually have the resource the
querying peer wants to access.

-- 
Ciao,
Enrico

_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

---

From: Enrico Marocco <[email-masked]>
Date: Wed, 16 Jul 2008 09:38:41 +0200

Stanislav Shalunov wrote:
> It would require whatever is giving caches out to query them
> beforehand, a task easily accomplished by the client.
> 
> More importantly, this would defeat the point of a cache, no?  First,
> it's empty. So, nobody gets it. So it remains empty.

Right, what I meant was a mirror, not really a cache.