Subject: Re: [p2pi] Charter and problem statement

From: Laird Popkin <[email-masked]>
Date: Sat, 19 Jul 2008 09:28:23 -0400 (EDT)

There are a couple of ways that ALTO and p2p caching could interact (that I can think of - I am sure that there are more).

- ALTO returns a list of several nearby cache servers. The p2p client connects to all of the caches (as peers) and tries to use them. Each cache server individually (or collectively) decides what to cache where, and thus each cache server chooses to particpate (or not) in a given swarm. Note that it's desirable for a p2p client to receive data from multiple p2p caches, as it produces better delivery performance, and operational resilience than a single cache server.

- ALTO returns one nearest cache server. The p2p client connects to it, and the cache server either serves the content, redirects to another cache server that has the content, or determines that the content isn't cached. Note that p2p protocols don't have a 'redirect' in the way that HTTP does (for example), but they provide comparable mechanisms (e.g. peer exchange) that could be used to connect the peer and the other cache. The 'redirect' could be ALTO guided (e.g. the first cache uses ALTO to find other cache servers near the p2p client).

- The cache system operates a 'master' that knows where all content is cached, the network topology, etc. ALTO tells all peers in the ISP to connect to the 'master' which they redirects all p2p transfers to the appropriate caches.

In all of these scenarios, ALTO provides relatively static network-aware information (e.g. location of nearby caches), and the caching system decides what is cached where (which is highly dynamic).

- Laird Popkin, CTO, Pando Networks
  mobile: 646/465-0570

----- Original Message -----
From: "Stas Khirman" <[email-masked]>
To: "Laird Popkin" <[email-masked]>, "stefano previdi" <[email-masked]>
Cc: [email-masked]
Sent: Friday, July 18, 2008 10:34:40 PM (GMT-0500) America/New_York
Subject: RE: [p2pi] Charter and problem statement

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Laird Popkin
> Sent: Friday, July 18, 2008 4:01 AM
> To: stefano previdi
> Cc: [email-masked]
> Subject: Re: [p2pi] Charter and problem statement
> 
> We should minimize the amount of caching metadata and logic are exposed in
> ALTO. As long as ALTO can introduce the p2p cache server to the p2p
> clients, and tell them that they are caches rather than normal peers, the
> rest (specific content assignment to specific caches, preferential use of
> caches over normal peers, etc.) can be negotiated between the p2p clients
> and the caches using the p2p protocols, without ALTO's involvement.
> 
> - Laird Popkin, CTO, Pando Networks
>   mobile: 646/465-0570
> 
[Stas Khirman] 
Sorry, does " specific content assignment to specific caches... can be
negotiated between the p2p clients and the caches ... without ALTO's
involvement " mean that what p2p client will negotiate what specific cache
server to use without ALTO assistance/recommendation ?

In this case, selected cache may not be an optimal (closes, cheapest, etc )

_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

---

From: Reinaldo Penno <[email-masked]>
Date: Sat, 19 Jul 2008 09:04:53 -0700

Hello Laird,

I agree with your assessment but I think from an ALTO perspective they boil
down to having an extensible protocol. The second or third redirection steps
seems to be outside the scope of ALTO (at this point).

>From a protocol requirements perspective what we are saying is that ALTO
protocol need to have types/handles for cache and other resources. Cache is
certainly a low-hanging fruit because a cache is also a peer, but an ALTO
server might need to convey IP addresses related to other resources.

Regards,

Reinaldo

On 7/19/08 6:28 AM, "Laird Popkin" <[email-masked]> wrote:

> There are a couple of ways that ALTO and p2p caching could interact (that I
> can think of - I am sure that there are more).
> 
> - ALTO returns a list of several nearby cache servers. The p2p client connects
> to all of the caches (as peers) and tries to use them. Each cache server
> individually (or collectively) decides what to cache where, and thus each
> cache server chooses to particpate (or not) in a given swarm. Note that it's
> desirable for a p2p client to receive data from multiple p2p caches, as it
> produces better delivery performance, and operational resilience than a single
> cache server.
> 
> - ALTO returns one nearest cache server. The p2p client connects to it, and
> the cache server either serves the content, redirects to another cache server
> that has the content, or determines that the content isn't cached. Note that
> p2p protocols don't have a 'redirect' in the way that HTTP does (for example),
> but they provide comparable mechanisms (e.g. peer exchange) that could be used
> to connect the peer and the other cache. The 'redirect' could be ALTO guided
> (e.g. the first cache uses ALTO to find other cache servers near the p2p
> client).
> 
> - The cache system operates a 'master' that knows where all content is cached,
> the network topology, etc. ALTO tells all peers in the ISP to connect to the
> 'master' which they redirects all p2p transfers to the appropriate caches.
> 
> In all of these scenarios, ALTO provides relatively static network-aware
> information (e.g. location of nearby caches), and the caching system decides
> what is cached where (which is highly dynamic).
>