Subject: Re: [p2pi] Real life torrent statistics

From: Victor Semanic <[email-masked]>
Date: Mon, 18 Aug 2008 11:55:09 -0700 (PDT)

Dear Dr. Khirman:

You write:
> The dataset includes 19333 unique <ip,port> pairs (some IPs are 
> repeatable) from 1459 ASs.  Or 13.25 peers/AS in average.
> While aggregated by “ISP name”, I got 1368 unique ISP names (not very 
> accurate estimation by second part of AS name) or 14.1 peers per “ISP”

Can you kindly provide some more information on the spread?  That is, what 
was the standard deviation and median for the peers/AS.  I note from your 
original email that the 20 most popular ASs account for about 35% of the 
total ASs.  The last AS listed in your table had 0.9% of the total, so I 
suspect that as the AS list increases there are successively less 
percentage of peers in them.  As such, I will like to put in prespective
the 13.25 peers/AS average in light of the 20 most popular ASes.

Thank you in advance for your time.

_______________________________________________
p2pi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/p2pi

---

From: Song Haibin <[email-masked]>
Date: Tue, 19 Aug 2008 10:50:33 +0800

Stas,

Thanks for the valuable information. I think if we can collect the
connection information between peers, and draw a map with the information of
distribution of the peers and their connections, then it will be of great
help. However, perhaps the connection information may not be collected from
the tracker.

Best Regards,
Song Haibin
Email: [email-masked]
Skype: alexsonghw

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Victor
>Semanic
>Sent: Tuesday, August 19, 2008 2:55 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: [p2pi] Real life torrent statistics
>
>Dear Dr. Khirman:
>
>You write:
>> While aggregated by "ISP name", I got 1368 unique ISP names (not very
>> accurate estimation by second part of AS name) or 14.1 peers per "ISP"
>

---

From: "Stas Khirman" <[email-masked]>
Date: Mon, 18 Aug 2008 23:24:08 -0700

Victor,

For my AS dataset, standard deviation is 48.86, average - 13.26, median - 91

I will post full AS data on the web and send you a pointer, so you can
evaluate it as well.

Regards
Stas

> From: Victor Semanic [mailto:[email-masked]]
> Sent: Monday, August 18, 2008 11:55 AM
> To: [email-masked]
> Cc: [email-masked]