Subject: [p2prg] NNTP 2.0

From: Adam Sobieski <[email-masked]>
Date: Sun, 16 Dec 2012 19:07:47 +0000

Internet Research Task Force,
Peer-to-Peer Research Group,

Greetings.  In October of 2006, the IETF released RFC 3977 (http://tools.ietf.org/html/rfc3977) which updated the NNTP protocol, codifying many of the additions made over the years since the 1986 RFC 977 (http://tools.ietf.org/html/rfc977).  Topically to peer-to-peer research and development, it is possible that an entirely decentralized and distributed forum system could be both researched and developed, abstractly referred to as NNTP 2.0 herein, achieving all of the 1986 and 2006 design goals, scaled to current Internet usage, utilizing 2012 state-of-the-art computer science including with regard to distributed computing, distributed databases, and peer-to-peer technologies.

Metadata models for messages, e.g. blog article metadata models, can be applicable to updating both email and NNTP computer networking protocols.  Beyond searchable subject strings and text content, then, could be user-specified folksonomic keywords, categories, and other metadata.  Metadata models can enhance the searchability of blogs, mailing lists, and forums.  Additionally, as with blogs, NNTP 2.0 could utilize pinging configurably by users for each of their messages and per individual messages.  Hyperlinks can interconnect the HTTP-based Web and NNTP 2.0 forum content.

PKI and digital signatures enhance scenarios with the distributed storage of user-generated content.  Additionally, just as NNTPS utilizes TLS, TLS can enhance a peer-to-peer NNTP 2.0.
 
A distributed forum system would contain multiple forums, each forum would contain multiple threads, and each thread would contain multiple messages.  Forum messages, with enhanced metadata, digitally signed by users, can be interrelated by typed links where a forum message could be in response to a number of other messages from various threads in various forums on the distributed system enhancing content discovery and navigation.  NNTP 2.0 would add to the features available with NNTP.

With the aforementioned blog-based pings, configurable by users, Web-based search engine technology could be interoperable with a distributed, decentralized, peer-to-peer NNTP 2.0 system.  NNTP 2.0 could, additionally, include distributed search technologies also enhanced by the aforementioned metadata models.

Kind regards,

Adam Sobieski

---

From: Adam Sobieski <[email-masked]>
Date: Wed, 19 Dec 2012 17:47:27 +0000

On the topic of "NNTP 2.0" or "Usenet 2.0", user-configurable pinging for each of their messages and per individual messages, per article pinging, is discussed in the W3C HTML Working Group in A New Feature for Blogging Platforms (http://lists.w3.org/Archives/Public/public-html/2012Dec/0026.html) and RE: A New Feature for Blogging Platforms (http://lists.w3.org/Archives/Public/public-html/2012Dec/0096.html).  In addition to blogging platforms, such features can enhance forums platforms and technologies.
 
On the topic of enhancing metadata for blog articles, emails, forum posts, and other user-generated content, semantic metadata is possible, with keywords, tags, categories and other metadata as things, not strings, utilizing URI interoperably with Semantic Web technologies, enhancing search and navigation, as well as facilitating and enhancing numerous other features for end users.

Kind regards,

Adam Sobieski