Subject: [p2prg] Peer-to-Peer Multimedia Answering Machine Technology

From: Adam Sobieski <[email-masked]>
Date: Thu, 13 Dec 2012 04:17:28 +0000

Internet Research Task Force,
Peer-to-Peer Research Group,

Greetings.  WebRTC is a contemporary technology and pertains to video calls, conferences, and potentially to video forums.  WebRTC does include P2P technologies and I would like to describe a scenario with regard to the P2P distributed storage of hypertext, audio and video messages, with features and functionality facilitating P2P multimedia answering machine technology.
 
Scenario:

Person A calls Person B. Person A might know whether Person B was online or offline before they commenced a communication activity. If Person B is online, the data motion is as per WebRTC. If Person B is offline, they could have an answering machine multimedia clip available on a group of nodes which they have designated, for example per a social network graph.

Person A can watch Person B's streaming answering machine clip or skip to leaving a message. If Person A leaves a message, that streaming video message is stored on a group of nodes, possibly the union of the two groups of nodes designated by both Person A and Person B. When Person B comes online, within a system-specific duration of time, e.g. 90 days or 1 year, the portions of data are downloaded by them, segmented downloading, and possibly with something like a BITS 4.0+ technology.

If Person B chooses to view any of the streamable media during that initial phase, which might not be uncommon, a log on and check messages pattern, the segmented downloading can toggle to a streaming variety of download, including variable bitrate streaming. Even after Person B might watch real-time segmented downloads of variable-bitrate streaming multimedia, the entirety of their high-bitrate messages could be downloaded and stored by Person B unless or until Person B indicated otherwise.

Video calling and video conferencing have been illustrated with WebRTC technologies, video forums may be realized upcoming, and we can envision, research and develop features for P2P video communication systems, P2P hypertext, audio and video systems, multimedia systems, including P2P answering machine technologies as described.

Kind regards,

Adam Sobieski

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 13 Dec 2012 06:42:02 +0100

Hi Adam,

Did you also look for the following WGs in the IETF working p2p protocols:
- p2psip for p2p voice and video calls
- ppsp for real-time streaming based on p2p (AKA p2p tv)

   Martin

On 12/13/2012 05:17 AM, Adam Sobieski wrote:
> Greetings. WebRTC is a contemporary technology and pertains to video
> calls, conferences, and potentially to video forums. WebRTC does include
> P2P technologies and I would like to describe a scenario with regard to
> the P2P distributed storage of hypertext, audio and video messages, with
> features and functionality facilitating P2P multimedia answering machine
> technology.
>
> Scenario:
>
> Person A calls Person B. Person A might know whether Person B was online
> or offline before they commenced a communication activity. If Person B
> is online, the data motion is as per WebRTC. If Person B is offline,
> they could have an answering machine multimedia clip available on a
> group of nodes which they have designated, for example per a social
> network graph.
>
> Person A can watch Person B's streaming answering machine clip or skip
> to leaving a message. If Person A leaves a message, that streaming video
> message is stored on a group of nodes, possibly the union of the two
> groups of nodes designated by both Person A and Person B. When Person B
> comes online, within a system-specific duration of time, e.g. 90 days or
> 1 year, the portions of data are downloaded by them, segmented
> downloading, and possibly with something like a BITS 4.0+ technology.
>
> If Person B chooses to view any of the streamable media during that
> initial phase, which might not be uncommon, a log on and check messages
> pattern, the segmented downloading can toggle to a streaming variety of
> download, including variable bitrate streaming. Even after Person B
> might watch real-time segmented downloads of variable-bitrate streaming
> multimedia, the entirety of their high-bitrate messages could be
> downloaded and stored by Person B unless or until Person B indicated
> otherwise.
>
>
> Video calling and video conferencing have been illustrated with WebRTC
> technologies, video forums may be realized upcoming, and we can
> envision, research and develop features for P2P video communication
> systems, P2P hypertext, audio and video systems, multimedia systems,
> including P2P answering machine technologies as described.
>
>
>
> Kind regards,
>
> Adam Sobieski
>
>
> _______________________________________________
> p2prg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/p2prg
>

-- 
[email-masked]

NEC Laboratories Europe - Network Research Division NEC Europe Limited
Registered Office: NEC House, 1 Victoria Road, London W3 6BL
Registered in England 283

---

From: zhangyunfei <[email-masked]>
Date: Thu, 13 Dec 2012 14:43:41 +0800

Hi Adam,
    We had ever developed a peer to peer video conferencing system supporting several participants in one meeting (the meeting number is not limited). 
    The hardest problem in such systems is, to the best of my understanding, the distributed mix of video and voice and the sync among the participants. In other words, how to share video and voice content to others can be relatively easily solved, as Martin mentioned, IETF is also doing such standards. 
    Wish it helpful for your work.

BR
Yunfei

zhangyunfei

From: Martin Stiemerling
Date: 2012-12-13 13:42
To: Adam Sobieski
CC: [email-masked]
Subject: Re: [p2prg] Peer-to-Peer Multimedia Answering Machine Technology
Hi Adam,

   Martin