Subject: [p2p-sip] Standardizing upon patented technology ?

From: laurent.castaignet at francetelecom.com (CASTAIGNET Laurent RD-MAPS-ISS)
Date: Tue, 28 Feb 2006 16:25:38 +0100

Hi all,

I was recently informed of the existence of a patent filed mid-2003 by a
so-called "skyper" company (search "skyper" in the PCT database there:
http://www.wipo.int/ipdl/en/). As a summary, the claims include at least
the following points, as far as I understood:

* A decentralized telephone system, based on a peer-to-peer network in
which:
	=> A DHT algorithm (referenced as "global index technology") may
be used to handle end user related data
	=> Peers may be used as relays when direct communication is not
possible 
* An access control based on certificate exchanges
* End user administration means
* Etc.

Of course, what is protected there is simply the Skype architecture. It
seems quite frightening to me, knowing that many of the points mentioned
in this patent are obviously important building blocks for what this
(future) working group is trying to build ...

I'm not aware of the usual IETF procedures in this case. Can anyone
enlight me ? I know that integrating patented technologies in the scope
of an existing working group has already been done, but is it also the
case before its creation ?

Thanks,

Laurent Castaignet.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060228/7dca53cb/attachment.html

---

From: slavitch at gmail.com (Michael Slavitch)
Date: Tue, 28 Feb 2006 10:36:40 -0500

Prior art is of course prior art, and far too many patents are far too
easily granted.

M

On 28/02/06, CASTAIGNET Laurent RD-MAPS-ISS <
laurent.castaignet at francetelecom.com> wrote:
> so-called "skyper" company (search "skyper" in the PCT database there: *
> http://www.wipo.int/ipdl/en/* <http://www.wipo.int/ipdl/en/>). As a
> summary, the claims include at least the following points, as far as I
> understood:
>
> seems quite frightening to me, knowing that many of the points mentioned in
> this patent are obviously important building blocks for what this (future)
> working group is trying to build ?
>
> enlight me ? I know that integrating patented technologies in the scope of
> an existing working group has already been done, but is it also the case
> before its creation ?
>
> Thanks,
>
> Laurent Castaignet.
>
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>
>
>

--
Michael Slavitch
Ottawa, Ontario Canada
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.cs.columbia.edu/pipermail/p2p-sip/attachments/20060228/1d44f6da/attachment.html