Subject: [p2p-sip] I-D: An Architecture for P2P SIP

From: marc1.bailly at francetelecom.com (BAILLY Marc RD-CORE-LAN)
Date: Tue, 28 Feb 2006 11:55:42 +0100

Hi Eunsoo,

Thank your for your interesting draft.

I have some questions about the supernode selection criteria. It is mentionned in your draft that "it is recommended that SNs should be on the public internet" in order to receive P2P messages.
I think it would be interesting to know the proportion of non NATed users in the use case of public P2P VoIP network. Given that it seems that there are more and more NATed users, I fear that the number of potential SN by comparison with the number of ON is too low. Does anyone has information about this? 
Does anyone has an idea of the number of nated ON that can be connected to a SN as a function of the SN capabilities?

That's why I'm wondering if it could be possible to use NAT traversal mechanisms in the P2P overlay in order to be able to include NATed nodes in it (I know this is not a SIP problem but it has impact on the P2P SIP architecture).
Is it possible with a DHT? If possible, what are the impacts on the DHT efficiency?

Regards,

Marc

> -----Message d'origine-----
> De : p2p-sip-bounces at cs.columbia.edu 
> [mailto:p2p-sip-bounces at cs.columbia.edu] De la part de Eunsoo Shim
> Envoy? : mardi 28 f?vrier 2006 00:22
> ? : P2P-SIP
> Objet : [p2p-sip] I-D: An Architecture for P2P SIP
> 
> We submitted an I-D that describes an architecture for P2P SIP.
> You can get it from the link below until it appears in the IETF I-D 
> directory.
> We hope this draft can help the architecture and charter 
> discussion in BOF.
> Your comments will be appreciated.
> Thanks.
> 
> Eunsoo
> 
> http://www.comet.columbia.edu/~eunsoo/ietf/draft-shim-sipping-
> p2p-arch-00.txt
> 
> Abstract
> 
>    This document describes an architecture for peer-to-peer 
> SIP systems
>    in which a separate and independent peer-to-peer overlay layer
>    provides a distributed resource placement and search 
> service for SIP.
>    It also aims to help identify what should be specified for
>    interoperation.
> 
> 
> 
> 
> 
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>

---

From: salman at cs.columbia.edu (Salman Abdul Baset)
Date: Tue, 28 Feb 2006 07:26:26 -0500 (EST)

> I think it would be interesting to know the proportion of non NATed users in the use case of public P2P VoIP network. Given that it seems that there are more and more NATed users, I fear that the n…

A non-statistical answer: Skype works.
According to Nielsen ratings 2 out of 5 Americans have broadband access at
home.
http://www.nielsen-netratings.com/pr/pr_050928.pdf

One can draw his/her own NAT proportion figures based on Nielsen numbers.

I had come across a figure that said about 30% of home Internet users are
behind NATs. However, that figure probably does not tell anything about
the number of non-natted university users. Unfortunately, I am not able to
find the source of that figure.

> Does anyone has an idea of the number of nated ON that can be connected to a SN as a function of the SN capabilities?

SN has two critical capabilities. Message routing and NAT relay.

The former requires less bandwidth while the later can consume a significant
chunk of broadband bandwidth (30-60 kbps out of a 256 kbps, 512 kbps
broadband connection). Given that there are Y number of online users and X
number of user pairs are in a call at a time, and out of those user pairs
x% are both behind a NAT then, loosely speaking, NAT relays are required
only for those x%*2 users.

Y=Total online users.
X=No of users that make a call per second or no of calls per second.
x=Percentage of users behindth of them are behind a NAT.
  or the percentage of calls that require a NAT relay x 2.

PSTN numbers can be plugged in here to estimate calls per second.

> Is it possible with a DHT? If possible, what are the impacts on the DHT efficiency?

NATed hosts are generally (statistically?) bandwidth limited hosts. It
is an interesting question why Skype did not choose NATed hosts for voice
relays.

regards,
salman

---

From: philip_matthews at magma.ca (Philip Matthews)
Date: Tue, 28 Feb 2006 09:03:35 -0500

>> I have some questions about the supernode selection criteria. It  
>> is mentionned in your draft that "it is recommended that SNs  
>> should be on the public internet" in order to receive P2P messages.
>> I think it would be interesting to know the proportion of non  
>> NATed users in the use case of public P2P VoIP network. Given that  
>> it seems that there are more and more NATed users, I fear that the  
>> number of potential SN by comparison with the number of ON is too  
>> low. Does anyone has information about this?
>

[Background for those who have not read the analysis of Skype paper:
Skype seems to use superpeers that have public IP addresses]

In my opinion:
- Skype works because it is one single public network, and the  
network operators can simply add
   additional superpeers whenever the ratio of superpeers to peers  
becomes too low (by adding
   computers with public addresses that run the Skype client software  
to the Internet)
- We are trying to create protocols that allow lots of distinct P2P  
SIP networks. Some of these
   may be public networks and some may be private networks. In some  
cases, none of the peers
   may have public addresses.
- The vast majority of computers used in enterprise environments are
    located behind NATs/Firewalls.
- The vast majority of computers used in homes with two or more  
computers and high-speed
   internet access sit behind a NAT (i.e., the family buys a NAT  
rather that purchasing two or
   more dynamic IP addresses from their provider).
- IPv6 may get rid of NATs, but people will replace them with  
firewalls with similar filtering properties
   (e.g., Address-Restricted filtering, to use the terminology of the  
BEHAVE working group).

I would guess that the vast majority of non-NATed computers today are:
- Dial-up home users
- Universities
- Public web servers and similar

I believe that there are some companies that acquired enough IP  
addresses back in the 1980s
so that they do not need to NAT.  I believe that Nortel is an  
example. However, I suspect that
they still run firewalls with similar filtering properties.

[Parts of the previous message deleted]

>
>>
>> That's why I'm wondering if it could be possible to use NAT  
>> traversal mechanisms in the P2P overlay in order to be able to  
>> include NATed nodes in it (I know this is not a SIP problem but it  
>> has impact on the P2P SIP architecture).

I believe this is less and less true today as enterprises and homes  
with multiple computers
and high-speed access deploy NATs.

- Philip

---

From: salman at cs.columbia.edu (Salman Abdul Baset)
Date: Tue, 28 Feb 2006 09:39:12 -0500 (EST)

>    computers with public addresses that run the Skype client software

I am not sure what exactly you mean by network operators adding
superpeers. Perhaps, you mean network operator adds superpeers in its
administrative domain (or rather NAT relays).

Skype will administer NAT relays only if it measures that existing peers
are insufficient to meet NAT relay requirements. We conducted experiments
in which two Skype clients were forced to use a relay for a call. Unless
Skype is using obscured IP addresses, we do not think that calls
were ever relayed through Skype relays none of which were administered by
Skype.

> - Public web servers and similar

Roughly, 18% of relays had hostnames ending a '.edu' in our Skype
experiments. A total of 7,500 successful calls were made. I sometimes
wonder if universities have enough bandwidth to support relays for a
significant portion of Internet call traffic.

regards,
salman

---

From: philip_matthews at magma.ca (Philip Matthews)
Date: Tue, 28 Feb 2006 12:57:23 -0500

Salman:

I don't completely understand your reply.
This may be because it has been a while since I read your Skype  
analysis paper.

What I meant by my comment was:
Say the network operators at Skype notice that the number of peers  
with public IP addresses
is running low. Then they can take a few cheap PCs, load their client  
software onto them,
assign them public IP addresses, and Voila! Some new peers with  
public IP addresses.

If I understand what you said in your message, you agree with the  
above statement
(perhaps with some qualifications)???

My point was that Skype can do this because there is just ONE network.
However, for P2P SIP we want to allow people to have their own  
private networks.
These networks may not have enough peers with public addresses, and  
their may
be no easy way to add more.

Do you agree?

- philipp

---

From: salman at cs.columbia.edu (Salman Abdul Baset)
Date: Tue, 28 Feb 2006 14:09:50 -0500 (EST)

> (perhaps with some qualifications)???

It is the bandwidth problem not the public IP address problem. If the
Skype network operators noticed that there were not enough relays for
NATed users, they could add more bandwidth to the machines running default
super nodes. In a large p2p network, it is good to have many machines with
public IP addresses and broadband network connectivity because it allows
p2p vendors like Skype not to buy too much bandwidth for NAT relays.

> be no easy way to add more.

I assume you want to solve the NAT traversal problem. The 'vendors' can
add central TURN-equivalent servers as MSN, Yahoo, and Talk messengers do.

-salman