Subject: [p2p-sip] Fwd: what's wrong with DNS?

From: drage at alcatel-lucent.com (Drage, Keith (Keith))
Date: Mon, 4 Dec 2006 19:25:44 +0100

To the best of my knowledge, the draft charter encompasses anything that
SIP can do.

It discusses nothing about the application of SIP, merely provides an
alternative mechanisms for reaching the address of record in SIP.

What SIP can do is of course in the purview of the SIP or SIPPING WG.

Regards

Keith 

> -----Original Message-----
> From: p2p-sip-bounces at cs.columbia.edu 
> [mailto:p2p-sip-bounces at cs.columbia.edu] On Behalf Of David Barrett
> Sent: 28 November 2006 22:15
> To: 'Sean Olson'; 'Henry Sinnreich'; 'Brian Rosen'; 'Matthew 
> Kaufman'; slavitch at gmail.com
> Cc: p2p-sip at cs.columbia.edu; 'Kundan Singh'
> Subject: Re: [p2p-sip] Fwd: what's wrong with DNS?
> 
> Ah, perhaps this is my mistake.  Isn't it limited to the 
> general class of audio/video/realtime communications?  For 
> example, is background swarming file-transfers out of scope?  
> I apologize; I clearly don't know what I'm talking about here 
> regarding scope, I'm sorry for the confusion.
> 
> To take it from another angle, what is out of scope?  Are we 
> competing head to head with UPnP for generalized resource 
> advertisement and discovery?
> 
> -david
> 
> > -----Original Message-----
> > From: Sean Olson [mailto:seanol at exchange.microsoft.com]
> > Sent: Tuesday, November 28, 2006 1:57 PM
> > To: David Barrett; 'Henry Sinnreich'; 'Brian Rosen'; 'Matthew 
> > Kaufman'; slavitch at gmail.com
> > Cc: p2p-sip at cs.columbia.edu; 'Kundan Singh'
> > Subject: RE: [p2p-sip] Fwd: what's wrong with DNS?
> > 
> > I don't understand -- we didn't limit the charter of the SIP WG to 
> > just voice. Why would it be different for P2PSIP?  Why 
> would you get 
> > less service from the P2P network than a traditional trapezoid? IM, 
> > file transfer, video, etc. are all reasonable modalities 
> for P2P. Am I 
> > missing something that would make these harder than voice?
> > 
> > For multicast, the issue is not technical support but admin 
> enablement.
> > Some do; some don't. I've got nothing against using 
> multicast as one 
> > option. But if it is the only option, that would be a deployment 
> > blocker in many real-world customers.
> > 
> > 
> > 
> > -----Original Message-----
> > From: David Barrett [mailto:dbarrett at quinthar.com]
> > Sent: Tuesday, November 28, 2006 1:53 PM
> > To: Sean Olson; 'Henry Sinnreich'; 'Brian Rosen'; 'Matthew 
> Kaufman'; 
> > slavitch at gmail.com
> > Cc: p2p-sip at cs.columbia.edu; 'Kundan Singh'
> > Subject: RE: [p2p-sip] Fwd: what's wrong with DNS?
> > 
> > Incidentally, I believe ad hoc networks *do* support multicast.  
> > Indeed, multicast on the LAN is actually quite common (it's 
> multicast 
> > on the WAN that's generally not available).
> > 
> > Furthermore, it's my impression that the scope of our charter *is* 
> > limited to voice.  If we don't draw the line there, then 
> where *do* we 
> > draw the line?
> > 
> > -david
> > 
> > > -----Original Message-----
> > > From: Sean Olson [mailto:seanol at exchange.microsoft.com]
> > > Sent: Tuesday, November 28, 2006 1:45 PM
> > > To: David Barrett; 'Henry Sinnreich'; 'Brian Rosen'; 'Matthew 
> > > Kaufman'; slavitch at gmail.com
> > > Cc: p2p-sip at cs.columbia.edu; 'Kundan Singh'
> > > Subject: RE: [p2p-sip] Fwd: what's wrong with DNS?
> > >
> > > I'm not advocating limiting this to voice. mDNS is great 
> except when 
> > > multicast is not available. But my real question is not so much 
> > > about technology but the scenario.
> > >
> > > Is this a scenario that is being considered?
> > >
> > >
> > > -----Original Message-----
> > > From: David Barrett [mailto:dbarrett at quinthar.com]
> > > Sent: Tuesday, November 28, 2006 1:43 PM
> > > To: Sean Olson; 'Henry Sinnreich'; 'Brian Rosen'; 
> 'Matthew Kaufman'; 
> > > slavitch at gmail.com
> > > Cc: p2p-sip at cs.columbia.edu; 'Kundan Singh'
> > > Subject: RE: [p2p-sip] Fwd: what's wrong with DNS?
> > >
> > > If they're in the same room, why do they need VoIP?  The range of 
> > > wifi isn't much wider than the range of the spoken voice.
> > >
> > > Even if they did somehow have wifi but not voice range, mDNS (as 
> > > Matthew has repeatedly pointed out) is exactly suited for this 
> > > problem.  If they
> > want
> > > VoIP, they'll probably also want file transfers, IM, and all the 
> > > other accoutrements of internet life.  Why would we have one 
> > > solution for
> > VoIP,
> > > and use something totally different for everything else?
> > >
> > > Why not just make mDNS really easy to use, and then use that for 
> > > these fringe VoIP cases?
> > >
> > > -david
> > >
> > > > -----Original Message-----
> > > > From: Sean Olson [mailto:seanol at exchange.microsoft.com]
> > > > Sent: Tuesday, November 28, 2006 1:36 PM
> > > > To: David Barrett; 'Henry Sinnreich'; 'Brian Rosen'; 'Matthew
> > Kaufman';
> > > > slavitch at gmail.com
> > > > Cc: p2p-sip at cs.columbia.edu; 'Kundan Singh'
> > > > Subject: RE: [p2p-sip] Fwd: what's wrong with DNS?
> > > >
> > > > It would be nice to support an ad-hoc WiFi network 
> among peers and 
> > > > use P2PSIP for voice, chat, etc. This is a scenario 
> where DNS does 
> > > > not
> > exist
> > > > necessarily and it is actually fairly common.  Take for 
> example, a 
> > > > set
> > > of
> > > > consultants working on site with a customer. They 
> probably don't 
> > > > have direct access to the customer's network and maybe 
> not to the 
> > > > broader Internet either. They will however likely have 
> WiFi and be 
> > > > able to
> > setup
> > > a
> > > > small ad-hoc network amongst themselves.
> > > >
> > > > Is this scenario out-of-scope for this WG?
> > > >
> > > >
> > > > -----Original Message-----
> > > > From: p2p-sip-bounces at cs.columbia.edu [mailto:p2p-sip- 
> > > > bounces at cs.columbia.edu] On Behalf Of David Barrett
> > > > Sent: Tuesday, November 28, 2006 1:30 PM
> > > > To: 'Henry Sinnreich'; 'Brian Rosen'; 'Matthew Kaufman'; 
> > > > slavitch at gmail.com
> > > > Cc: p2p-sip at cs.columbia.edu; 'Kundan Singh'
> > > > Subject: Re: [p2p-sip] Fwd: what's wrong with DNS?
> > > >
> > > > > -----Original Message-----
> > > > > From: Henry Sinnreich [mailto:hsinnrei at adobe.com]
> > > > > Subject: RE: [p2p-sip] Fwd: what's wrong with DNS?
> > > > >
> > > > > BTW: Existing P2P traffic is independent of the DNS and it 
> > > > > dominates
> > > the
> > > > > Internet traffic. Numbers between 60% and 80% have 
> been published.
> > > >
> > > > I apologize, but I think that's just simply false and 
> misleading.
> > > >
> > > > First, virtually all of that traffic is file-sharing traffic 
> > > > designed
> > to
> > > > preserve anonymity, which is the direct opposite of our problem.
> > Using
> > > > that
> > > > as justification to keep our system "clean" of DNS is a 
> red herring.
> > > >
> > > > But even ignoring that, most of that traffic is 
> Bittorrent, which
> > *does*
> > > > use
> > > > DNS not only for search (to find torrents on btjunkie.org and so
> > forth),
> > > > but
> > > > to find peers (to contact the tracker).
> > > >
> > > > At the end of the day, DNS is a fundamental part of the 
> internet, 
> > > > used
> > > by
> > > > virtually very user not only ever day, but almost every 
> minute.  
> > > > If
> > DNS
> > > > went
> > > > down globally, the vast majority of internet traffic would also 
> > > > slow
> > to
> > > a
> > > > stop (web, email, bittorrent, etc).  There would be a few 
> > > > survivors -- Skype with its hard-coded IPs would 
> persevere, along 
> > > > with eDonkey, Kazaa and other anonymous or totally 
> closed/private 
> > > > services, but about everything
> > else
> > > > would grind to a halt.  Planning on how to keep working without 
> > > > DNS is like planning on how to work without power -- you just 
> > > > don't.  If DNS goes down, we have bigger problems to 
> worry about.
> > > >
> > > > We certainly *can* reinvent the wheel and figure out how to keep
> > working
> > > > in
> > > > this apocalypse scenario, I just don't see why we should bother.
> > > >
> > > > -david
> > > >
> > > > _______________________________________________
> > > > p2p-sip mailing list
> > > > p2p-sip at cs.columbia.edu
> > > > https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
> 
> _______________________________________________
> p2p-sip mailing list
> p2p-sip at cs.columbia.edu
> https://lists.cs.columbia.edu/cucslists/listinfo/p2p-sip
>

---

From: ag at ag-projects.com (Adrian Georgescu)
Date: Mon, 4 Dec 2006 19:55:18 +0100

Yes Keith, plus

locate and use services related to a SIP AoR in a non-centralized way

Adrian