Subject: Re: [P2PSIP] RE: [Simple] Do we need to introduce SIMPLE into P2Ptorealize presence and IM services?

From: Robert Sparks <[email-masked]>
Date: Mon, 2 Jul 2007 14:12:25 -0500

David -

He's referring to the discussion and analysis taking place in SIMPLE.
See http://www.ietf.org/internet-drafts/draft-ietf-simple-interdomain- 
scaling-analysis-00.txt
for that background.

RjS

On Jul 2, 2007, at 2:06 PM, David Barrett wrote:

>> -----Original Message-----
>> From: Beck01, Wolfgang [mailto:[email-masked]]
>>
>> Presence scalability is an issue even with C/S SIP.
>
> Am I misunderstanding you, or are you saying client-server  
> architectures
> have difficulty scaling presence-based applications?  Hasn't AIM,  
> MSN, ICQ,
> YahooIM, and basically every IM on the planet successfully  
> demonstrated that
> C/S architectures can scale presence-based applications to, well,  
> the entire
> planet?
>
> -david
>
>
> _______________________________________________
> P2PSIP mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/p2psip

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "David Barrett" <[email-masked]>
Date: Mon, 2 Jul 2007 21:08:55 -0700

Thanks, very cool.  Am I correct in understanding that the document
estimates that:

- 2 presence domains
- With 20k online users in each domain
- Would result in 489 messages per second between domains
- Producing 830KBps (6.48Mbps) of sustained traffic between domains

Have you been able to calibrate the assumptions of that document against the
real-world traffic experienced by any of the many IM vendors out there?  

Is there anybody using SIMPLE in the real world that can confirm the
assumptions about average message sizes and such?

-david

> From: Robert Sparks [mailto:[email-masked]]
> Sent: Monday, July 02, 2007 12:12 PM
> To: David Barrett
> Cc: 'Beck01, Wolfgang'; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: [P2PSIP] RE: [Simple] Do we need to introduce SIMPLE into
> P2Ptorealize presence and IM services?
> 
> David -
>