Subject: [P2PSIP] Term for the peer who is responsible for a specific key

From: JiangXingFeng <[email-masked]>
Date: Wed, 29 Aug 2007 15:04:41 +0800

Hi:

When a P2P packet is forwarded through the overlay, it should specify a
destination ID, which may be either a resource ID or peer ID. The peer who
is responsible for the destination ID will accept and process it and return
a response to the request sender. But in the draft-ietf-p2psip-concepts-00,
I don't find an appropriate term to define the peer who is the destination
of the P2P packets. 

P2P admitting peer is used in the join operations and does not say exactly
that it is the destination of the join packet. Some peers may take the
admitting responsibility and the choice of the admitting peer may depend on
the joining peer it depends on the choice of the joining peer.  

Do we need a new term or definition to define this kind of peer? It
frequently used in the upcoming peer protocol?

Comments?

--
Jiang XingFeng

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "HUANG Ping B" <[email-masked]>
Date: Wed, 29 Aug 2007 15:36:18 +0800

dear Jiang
     I agree with your thinking. but some relevant problems arise: if we
define a term to describe "Destination Peer", I think "Proxy
Peer","Redirection Peer" and "Original Peer"also should be defined. in
draft-ietf-p2psip-concepts-00, above Peers are named "P2PSIP Peer". but
for description conveniency , some terms like "Destination Peer","Proxy
Peer","Redirection Peer" and "Original Peer" may be defined. Is this
redundant? pls give comments, thanks!
BR

-----Original Message-----
From: JiangXingFeng [mailto:[email-masked]]
Sent: Wednesday, August 29, 2007 3:05 PM
To: 'P2PSIP Mailing List'
Subject: [P2PSIP] Term for the peer who is responsible for a specific
key

Hi:

When a P2P packet is forwarded through the overlay, it should specify a
destination ID, which may be either a resource ID or peer ID. The peer
who is responsible for the destination ID will accept and process it and
return a response to the request sender. But in the
draft-ietf-p2psip-concepts-00, I don't find an appropriate term to
define the peer who is the destination of the P2P packets. 

P2P admitting peer is used in the join operations and does not say
exactly that it is the destination of the join packet. Some peers may
take the admitting responsibility and the choice of the admitting peer
may depend on the joining peer it depends on the choice of the joining
peer.  

Comments?

--
Jiang XingFeng

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 29 Aug 2007 16:47:08 +0800

I guess it depends on protocols between them are different or not,
if they are the same, I can't see the necessity to define all of them.

-Hui

---

From: Peili Xu <[email-masked]>
Date: Wed, 29 Aug 2007 17:02:34 +0800

Hi Jiang,

The entities defined in concept draft has special
consern for SIP application.
While your consern is for P2P layer routing. I'd espect
it to be defined in the peer protocol if required.

Do you think peer is enough?

Peili

-----Original Message-----
From: JiangXingFeng [mailto:[email-masked]] 
Sent: Wednesday, August 29, 2007 3:05 PM
To: 'P2PSIP Mailing List'
Subject: [P2PSIP] Term for the peer who is responsible
for a specific key

Hi:

When a P2P packet is forwarded through the overlay, it
should specify a destination ID, which may be either a
resource ID or peer ID. The peer who is responsible for
the destination ID will accept and process it and return
a response to the request sender. But in the
draft-ietf-p2psip-concepts-00, I don't find an
appropriate term to define the peer who is the
destination of the P2P packets. 

P2P admitting peer is used in the join operations and
does not say exactly that it is the destination of the
join packet. Some peers may take the admitting
responsibility and the choice of the admitting peer may
depend on the joining peer it depends on the choice of
the joining peer.  

Do we need a new term or definition to define this kind
of peer? It frequently used in the upcoming peer
protocol?

Comments?

--
Jiang XingFeng

---

From: Philip Matthews <[email-masked]>
Date: Wed, 29 Aug 2007 06:30:41 -0400

You are right in that no term has been defined so far for this  
concept in the Concepts draft.

As I recall, none of the current proposals have defined a name for  
this concept,
(Authors of other proposals: please jump in here if my memory if  
faulty).

Feel free to suggest a name and debate it on the list.
If some consensus emerges, we will add it to the draft.

- Philip

On 29-Aug-07, at 03:04 , JiangXingFeng wrote:

> exactly

---

From: "David A. Bryan" <[email-masked]>
Date: Wed, 29 Aug 2007 08:42:25 -0400

I think many people have said "destination of the message" or
"responsible peer", but we've never defined a particular term. I've
never found a need for a particular term for that in writing drafts,
but I guess I wouldn't object if people want one.

David

-- 
David A. Bryan
[email-masked]
+1.757.565.0101 x101
+1.757.565.0088 (fax)
www.SIPeerior.com

---

From: "Henry Sinnreich" <[email-masked]>
Date: Wed, 29 Aug 2007 07:49:06 -0700

There are many p2p terms in the vast p2p literature that our P2PSIP WG
would be well advised to adopt, for obvious reasons. One of them is
there are many other applications beside SIP that actually use and run
on p2p :-)
I plan to come back to this topic...

The origin and destination peers, as far as I remember are called the
"source" and "root", but please don't count on my feeble memory. I need
to find the references for this.

If there is agreement we should use common p2p and DHT terminology, then
I would happy to contribute to a p2p glossary. A p2p glossary would also
prevent contributors to this WG to reinvent terms in I-Ds and thus
contribute to the overall confusion.

What do you think?

Henry

-----Original Message-----
From: HUANG Ping B [mailto:[email-masked]] 
Sent: Wednesday, August 29, 2007 2:36 AM
To: JiangXingFeng; P2PSIP Mailing List
Subject: RE: [P2PSIP] Term for the peer who is responsible for a
specific key

dear Jiang

-----Original Message-----
From: JiangXingFeng [mailto:[email-masked]]
Sent: Wednesday, August 29, 2007 3:05 PM
To: 'P2PSIP Mailing List'
Subject: [P2PSIP] Term for the peer who is responsible for a specific
key

Hi:

Comments?

--
Jiang XingFeng

---

From: Spencer Dawkins <[email-masked]>
Date: Wed, 29 Aug 2007 09:56:14 -0500

I think Peili is correct - as long as we were using SIP for the P2P overlay, 
we could just use SIP terminology - and agree with XingFeng that if we have 
a separate P2P transport protocol, it would be useful to define a term for 
this.

Is "responsible peer" unambiguous? I'm looking for something like

Responsible Peer - the Peer that stores a specific key in a P2P overlay

So, the next question is

- we've had some discussion about redundancy as an application-level 
responsibility ("if you want KEY1 and its attribute stored redundantly, 
insert KEY1-BACKUP1 and KEY1-BACKUP2 in the DHT as well, and then do lookups 
for all three, if necessary"), and

- we've had some discussion about redundancy as an overlay-level 
responsiblity ("KEY1 is stored multiple times, and intermediate peers will 
return KEY1's attribute as long as it is available from *any* peer in the 
overlay").

I don't know where we are on redundancy now.

We may need a "Secondary Responsible Peer", for the peers that handle 
redundancy, but let's pick the first term now and worry about terms that 
reflect redundancy later, OK?

Thanks,

Spencer

---

From: "David A. Bryan" <[email-masked]>
Date: Wed, 29 Aug 2007 11:50:51 -0400

As individual...

I think we should try to include this in the concepts document, rather
than a new glossary, but I strongly support Henry's idea of using
existing terms if possible, and also for people using the terms in the
terminology draft (many of which now represent some very lengthy
discussions among many people to reach agreement) rather than
inventing new ones.

David

-- 
David A. Bryan
[email-masked]
+1.757.565.0101 x101
+1.757.565.0088 (fax)
www.SIPeerior.com

---

From: "Jan Seedorf" <[email-masked]>
Date: Wed, 29 Aug 2007 17:52:59 +0200

Dear Henry and Spencer (I am replying to the last two mails on this thread),

In the DHT literature the node responsible for storing the content belonging to some key is usually referred to as the "root" node for that particular key. If content for a key is additionally stored at several nodes in the DHT to provide resilience on the DHT layer, these nodes are referred to as the "replica roots" for that key.

Hope this helps,

- Jan Seedorf

-----Original Message-----
From: Spencer Dawkins [mailto:[email-masked]] 
Sent: Wednesday, August 29, 2007 4:56 PM
To: P2PSIP Mailing List
Subject: Re: [P2PSIP] Term for the peer who is responsible for a specific key

I think Peili is correct - as long as we were using SIP for the P2P overlay, we could just use SIP terminology - and agree with XingFeng that if we have a separate P2P transport protocol, it would be useful to define a term for this.

So, the next question is

- we've had some discussion about redundancy as an application-level responsibility ("if you want KEY1 and its attribute stored redundantly, insert KEY1-BACKUP1 and KEY1-BACKUP2 in the DHT as well, and then do lookups for all three, if necessary"), and

- we've had some discussion about redundancy as an overlay-level responsiblity ("KEY1 is stored multiple times, and intermediate peers will return KEY1's attribute as long as it is available from *any* peer in the overlay").

We may need a "Secondary Responsible Peer", for the peers that handle redundancy, but let's pick the first term now and worry about terms that reflect redundancy later, OK?

Thanks,

Spencer

>> this concept, (Authors of other proposals: please jump in here if my 
>> memory if faulty).
>>

---

From: "Victor Pascual Ávila" <[email-masked]>
Date: Wed, 29 Aug 2007 21:02:04 +0200

Hello,

On 29/08/2007, David A. Bryan <[email-masked]> wrote:
> than a new glossary,

I support this idea.

Together with some folks -from p2psip mail list- we are developing a
framework for providing advanced communication services in  p2psip overlays
and we are experiencing some problems with p2p and DHT terminology.

By the way, if someone wants to join us it is welcome. Our goal is to submit
this work to the WG as an Internet Draft.

Thanks,
Victor Pascual

---

From: Zheng Hewen <[email-masked]>
Date: Thu, 30 Aug 2007 09:24:37 +0800

Hi,

I suggest that the concept draft would adopt those terms - "P2PSIP root peer" and "P2PSIP replica root peer", they are clear
and useful for contributors to P2PSIP WG.

--Hewen

-----Original Message-----
From: Jan Seedorf [mailto:[email-masked]]
Sent: 2007?8?29? 23:53
To: P2PSIP Mailing List
Subject: RE: [P2PSIP] Term for the peer who is responsible for a specific key

In the DHT literature the node responsible for storing the content belonging to some key is usually referred to as the
"root" node for that particular key. If content for a key is additionally stored at several nodes in the DHT to provide
resilience on the DHT layer, these nodes are referred to as the "replica roots" for that key.

Hope this helps,

- Jan Seedorf

-----Original Message-----
From: Spencer Dawkins [mailto:[email-masked]]
Sent: Wednesday, August 29, 2007 4:56 PM
To: P2PSIP Mailing List
Subject: Re: [P2PSIP] Term for the peer who is responsible for a specific key

I think Peili is correct - as long as we were using SIP for the P2P overlay, we could just use SIP terminology - and agree
with XingFeng that if we have a separate P2P transport protocol, it would be useful to define a term for this.

So, the next question is

- we've had some discussion about redundancy as an application-level responsibility ("if you want KEY1 and its attribute
stored redundantly, insert KEY1-BACKUP1 and KEY1-BACKUP2 in the DHT as well, and then do lookups for all three, if
necessary"), and

- we've had some discussion about redundancy as an overlay-level responsiblity ("KEY1 is stored multiple times, and
intermediate peers will return KEY1's attribute as long as it is available from *any* peer in the overlay").

We may need a "Secondary Responsible Peer", for the peers that handle redundancy, but let's pick the first term now and
worry about terms that reflect redundancy later, OK?

Thanks,

Spencer

---

From: JiangXingFeng <[email-masked]>
Date: Thu, 30 Aug 2007 09:27:11 +0800

Hi, Henry:
This idea is what I intend to achieve. In order to make P2PSIP contributions
use the glossary based on the same understanding among the P2PSIP community,
we should define a uniform suit of glossary.

I am willing to join this contribution. 

Regards!
--
Jiang XingFeng
> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: Wednesday, August 29, 2007 10:49 PM
> To: HUANG Ping B; JiangXingFeng; P2PSIP Mailing List
> Subject: P2P glossary
>

---

From: "HUANG Ping B" <[email-masked]>
Date: Thu, 30 Aug 2007 09:33:16 +0800

Dear ALL
   sorry for later reply, when you are working I'm just in sleep and
maybe vice-versa. one exception is that your sun and my sun are in the
sky in the same time.:)!...
   I support David's suggestions, and strongly support Herry's
suggestion that existing terms should be used if possible. more terms
emerging is not good!
BR
huang ping

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
David A. Bryan
Sent: Wednesday, August 29, 2007 11:51 PM
To: Henry Sinnreich
Cc: HUANG Ping B; JiangXingFeng; P2PSIP Mailing List
Subject: Re: [P2PSIP] P2P glossary

As individual...

discussions among many people to reach agreement) rather than inventing
new ones.

David

> on p2p :-) I plan to come back to this topic...
>
> "source" and "root", but please don't count on my feeble memory. I 
> need to find the references for this.
>
> If there is agreement we should use common p2p and DHT terminology, 
> then I would happy to contribute to a p2p glossary. A p2p glossary 
> would also prevent contributors to this WG to reinvent terms in I-Ds 
> and thus contribute to the overall confusion.
>
> What do you think?
>
> Henry
>
>      I agree with your thinking. but some relevant problems arise: if 
> we define a term to describe "Destination Peer", I think "Proxy 

> draft-ietf-p2psip-concepts-00, above Peers are named "P2PSIP Peer". 
> but for description conveniency , some terms like "Destination 
> Peer","Proxy Peer","Redirection Peer" and "Original Peer" may be 
> defined. Is this redundant? pls give comments, thanks!
> BR
>
> When a P2P packet is forwarded through the overlay, it should specify 
> a destination ID, which may be either a resource ID or peer ID. The 
> peer who is responsible for the destination ID will accept and process

> it and return a response to the request sender. But in the 

--
David A. Bryan
[email-masked]
+1.757.565.0101 x101
+1.757.565.0088 (fax)
www.SIPeerior.com

---

From: Philip Matthews <[email-masked]>
Date: Thu, 30 Aug 2007 11:45:32 -0400

I personally have never heard of the term "root peer" before, and I  
would never guess that it mean the peer that stores the content  
associated with a key. Can someone explain where this term comes  
from? What is it the root of?

- Philip

On 29-Aug-07, at 21:24 , Zheng Hewen wrote:

> Hi,
>
> I suggest that the concept draft would adopt those terms - "P2PSIP  
> root peer" and "P2PSIP replica root peer", they are clear
> In the DHT literature the node responsible for storing the content  
> belonging to some key is usually referred to as the
> "root" node for that particular key. If content for a key is  
> additionally stored at several nodes in the DHT to provide
> I think Peili is correct - as long as we were using SIP for the P2P  
> overlay, we could just use SIP terminology - and agree
> with XingFeng that if we have a separate P2P transport protocol, it  
> would be useful to define a term for this.
>
> - we've had some discussion about redundancy as an application- 
> level responsibility ("if you want KEY1 and its attribute
> stored redundantly, insert KEY1-BACKUP1 and KEY1-BACKUP2 in the DHT  
> as well, and then do lookups for all three, if
> necessary"), and
>
> responsiblity ("KEY1 is stored multiple times, and
> intermediate peers will return KEY1's attribute as long as it is  
> available from *any* peer in the overlay").
>
> We may need a "Secondary Responsible Peer", for the peers that  
> handle redundancy, but let's pick the first term now and

---

From: "Peter Pan" <[email-masked]>
Date: Thu, 30 Aug 2007 08:59:50 -0700

neither have i, though i did heard of "root beer".

peter

----- Original Message -----
From: "Philip Matthews" <[email-masked]>
To: "Zheng Hewen" <[email-masked]>
Cc: "'Jan Seedorf'" <[email-masked]>; "'P2PSIP Mailing List'"
<[email-masked]>
Sent: Thursday, August 30, 2007 8:45 AM
Subject: Re: [P2PSIP] Term for the peer who is responsible for a specific
key

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 30 Aug 2007 09:37:04 -0700

As Jan Seedorf has already indicated (see below), the root in a DHT is
well defined and documented. Here are three examples, including one from
the P2P SIP WG I-D :-)>

If anything, this trail shows the need for a DHT and P2PSIP glossary.

Henry

A. Chord vn. 0.6.3 released on May 3, 2007 features:
* The root node of routing creates and removes replicas on a DHT instead
of the requester if replication is enabled. 
* In case of DHT put, get and remove, a node requests spare root
candidates to be prepared for failure of the root node. 

See http://overlayweaver.sourceforge.net/news/ 

B. Chord and Bamboo

"The DHT assigns every key in the identifier space to
a node, which is called the root (or the successor) of the
key. The main primitive that DHTs support is lookup, in
which a node can efficiently discover a key's root. The
lookup protocol greedily traverses the nodes of the DHT,
progressing closer to the root of the key at each step."

See http://srhea.net/papers/ntr-worlds05.pdf 

C. In the IETF P2P SIP WG:

"Req 7-5: The peer protocol MUST accommodate a DHT for a fast routing 
 algorithm that minimizes hop count to the root node..."

See
http://tools.ietf.org/wg/p2psip/draft-bryan-p2psip-requirements-00.txt 

Henry

-----Original Message-----
From: Peter Pan [mailto:[email-masked]] 
Sent: Thursday, August 30, 2007 11:00 AM
To: Philip Matthews; Zheng Hewen
Cc: 'Jan Seedorf'; 'P2PSIP Mailing List'
Subject: Re: [P2PSIP] Term for the peer who is responsible for a
specific key

peter

----- Original Message -----
From: "Philip Matthews" <[email-masked]>
To: "Zheng Hewen" <[email-masked]>
Cc: "'Jan Seedorf'" <[email-masked]>; "'P2PSIP Mailing List'"
<[email-masked]>
Sent: Thursday, August 30, 2007 8:45 AM
Subject: Re: [P2PSIP] Term for the peer who is responsible for a
specific
key

---

From: Zheng Hewen <[email-masked]>
Date: Fri, 31 Aug 2007 09:30:59 +0800

Abundant info!  No more supplement.
   In fact, I do not care "root peer" or "responsible peer" for the term about the peer which has the responsibility to
store a specific key; I think that we need uniform and explicit definitions for those terms in one distinct glossary I-D or
the concept draft, which are useful and convenient to the contributors of P2PSIP WG.

--Hewen

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]]
Sent: 2007?8?31? 0:37
To: Peter Pan; Philip Matthews; Zheng Hewen
Cc: Jan Seedorf; P2PSIP Mailing List
Subject: RE: [P2PSIP] Term for the peer who is responsible for a specific key

As Jan Seedorf has already indicated (see below), the root in a DHT is well defined and documented. Here are three examples,
including one from the P2P SIP WG I-D :-)>

Henry

A. Chord vn. 0.6.3 released on May 3, 2007 features:
* The root node of routing creates and removes replicas on a DHT instead of the requester if replication is enabled.
* In case of DHT put, get and remove, a node requests spare root candidates to be prepared for failure of the root node.

B. Chord and Bamboo

"The DHT assigns every key in the identifier space to a node, which is called the root (or the successor) of the key. The
main primitive that DHTs support is lookup, in which a node can efficiently discover a key's root. The lookup protocol
greedily traverses the nodes of the DHT, progressing closer to the root of the key at each step."

"Req 7-5: The peer protocol MUST accommodate a DHT for a fast routing  algorithm that minimizes hop count to the root
node..."

See

Henry

-----Original Message-----
From: Peter Pan [mailto:[email-masked]]
Sent: Thursday, August 30, 2007 11:00 AM
To: Philip Matthews; Zheng Hewen
Cc: 'Jan Seedorf'; 'P2PSIP Mailing List'
Subject: Re: [P2PSIP] Term for the peer who is responsible for a specific key

peter

----- Original Message -----
From: "Philip Matthews" <[email-masked]>
To: "Zheng Hewen" <[email-masked]>
Cc: "'Jan Seedorf'" <[email-masked]>; "'P2PSIP Mailing List'"
<[email-masked]>

> associated with a key. Can someone explain where this term comes from?
> What is it the root of?
>
> - Philip
>
> > root peer" and "P2PSIP replica root peer", they are clear and useful
> > for contributors to P2PSIP WG.
> >
> > --Hewen
> >
> > belonging to some key is usually referred to as the "root" node for
> > that particular key. If content for a key is additionally stored at
> > several nodes in the DHT to provide resilience on the DHT layer,
> > these nodes are referred to as the "replica roots" for that key.
> >
> > Hope this helps,
> >
> > - Jan Seedorf
> >