Subject: Re: [P2PSIP] Auth/boot is weakest link

From: "Peter Pan" <[email-masked]>
Date: Mon, 20 Aug 2007 17:04:56 -0700

i thought you were recommending dns for resolving addresses of endpoints
instead of login/bootstrap servers, weren't you?

when you resolve endpoint addresses by dns, for what is dht? (and vice
versa)

sorry, totally confused.

pp

----- Original Message -----
From: "David Barrett" <[email-masked]>
To: "'Peter Pan'" <[email-masked]>; "'Hannes Tschofenig'"
<[email-masked]>
Cc: <[email-masked]>
Sent: Monday, August 20, 2007 3:46 PM
Subject: RE: [P2PSIP] Auth/boot is weakest link

> > -----Original Message-----
> > From: Peter Pan
> > Subject: Re: [P2PSIP] Auth/boot is weakest link
> >
> > do u mean that we should turn our heads away from dht technologies?
>
> No, whether or not to use a DHT is another discussion entirely.
>
> However, even with a DHT used for rendezvous purposes (which I believe is
> the intent of P2PSIP), some other service (non-DHT?) must exist for
> authentication and bootstrapping into the network.  It looked like it was
> the authentication/bootstrapping services that failed in the Skype case
> (though now it's looking like a problem in the p2p layer), and thus I'm
> curious what solutions are on the table for authentication and
> bootstrapping.
>
>
> > another question, can existing dns infrastructure carry millions or even
> > billions of individual sip ua's without overhaul?
>
> I don't see why it couldn't, at least by the time there are truly millions
> or billions of individual SIP UA's using it.  Recall -- even Skype only
has
> 9M simultaneous, and that makes up nearly 100% of all internet-based VoIP.
> It'll be a long, long time before P2PSIP has anything similar to those
> numbers.
>
> -david
>
>

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "David Barrett" <[email-masked]>
Date: Mon, 20 Aug 2007 17:16:36 -0700

> From: Peter Pan [mailto:[email-masked]]

You're right -- using dynDNS/mDNS you wouldn't need the DHT.  I'm sorry, it
was confusing for me to mention it, as that's not the angle I'm trying to
investigate.  (I was just holding it up as one solution to the
authentication/bootstrapping problem in order to stimulate conversation on
alternatives.)

What I'm trying to ask is:

If you *do* choose to use a DHT, what are the top proposals for how to solve
the authentication and bootstrapping problems?

-david