Subject: [P2PSIP] Use Cases -> Deployment Scenarios?

From: Spencer Dawkins <[email-masked]>
Date: Mon, 27 Aug 2007 12:34:46 -0500

In conversations with David and Bruce on a revision of the Use Cases draft, 
it's becoming fairly obvious that what we're talking about isn't use cases 
at all...

http://www.p2psip.org/drafts/draft-bryan-p2psip-usecases-00.html

A quick look at http://en.wikipedia.org/wiki/Use_case confirms my memory 
that a "use case" focuses on the interaction between a user and a system, 
where the system is modeled as a "black box" (no internal interfaces 
matter).

This isn't what the current draft does. I'm suggesting something like 
"deployment scenarios"

Doees this work for people?

Thanks,

Spencer 

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: Philip Matthews <[email-masked]>
Date: Mon, 27 Aug 2007 13:51:34 -0400

I agree that "use-case" doesn't seem to be the right term.

For some time, I have been using the term "usage scenario". Might  
this be even better than "deployment scenario"?

- Philip

On 27-Aug-07, at 13:34 , Spencer Dawkins wrote:

> In conversations with David and Bruce on a revision of the Use  
> Cases draft, it's becoming fairly obvious that what we're talking  
> about isn't use cases at all...
>
> A quick look at http://en.wikipedia.org/wiki/Use_case confirms my  
> memory that a "use case" focuses on the interaction between a user  
> and a system, where the system is modeled as a "black box" (no  
> internal interfaces matter).
>
> This isn't what the current draft does. I'm suggesting something  
> like "deployment scenarios"
>

---

From: Spencer Dawkins <[email-masked]>
Date: Mon, 27 Aug 2007 13:39:02 -0500

Hi, Philip,

I was probably mis-quoting from memory a coversation with you - "usage 
scenario" would work for me, too (even better than "use case", which I think 
is the target I'm shooting at).

Thanks,

Spencer

> For some time, I have been using the term "usage scenario". Might  this be 
> even better than "deployment scenario"?
>
> - Philip
>
>> In conversations with David and Bruce on a revision of the Use  Cases 
>> draft, it's becoming fairly obvious that what we're talking  about isn't 
>> use cases at all...
>>
>> that a "use case" focuses on the interaction between a user  and a 
>> system, where the system is modeled as a "black box" (no  internal 
>> interfaces matter).
>>

---

From: "Eunsoo Shim" <[email-masked]>
Date: Mon, 27 Aug 2007 17:15:03 -0400

Either usage scenario or deployment scenario is fine with me.
Thanks.

Eunsoo

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 27 Aug 2007 19:31:03 -0700

A usage scenario is what the user does.

A deployment scenario is what the service provider spends money on in
the belief to know what the user wants or to control the user no matter
what they want :-)

*

Now seriously, they are different and a definition of the meaning in the
context of the I-D would be useful.

Henry

________________________________

From: Eunsoo Shim [mailto:[email-masked]] 
Sent: Monday, August 27, 2007 4:15 PM
To: Spencer Dawkins
Cc: P2PSIP Mailing List
Subject: Re: [P2PSIP] Use Cases -> Deployment Scenarios?

Eunsoo

On 8/27/07, Spencer Dawkins < [email-masked]
<mailto:[email-masked]> > wrote:

Hi, Philip,

I was probably mis-quoting from memory a coversation with you - "usage 
scenario" would work for me, too (even better than "use case", which I
think
is the target I'm shooting at).

Thanks,

Spencer

> For some time, I have been using the term "usage scenario". Might
this be
>> A quick look at http://en.wikipedia.org/wiki/Use_case confirms my
memory
>> This isn't what the current draft does. I'm suggesting something
like

---

From: "Eunsoo Shim" <[email-masked]>
Date: Tue, 28 Aug 2007 00:23:56 -0400

Oops. This naming discussion is getting serious.
What I understand is that the I-D is about various communication
applications/scenarios for which P2P SIP can be useful.
If none of 'use cases', 'usage scenarios', and 'deployment scenarios' is a
proper name for the I-D, I (or we) need help.
Is 'application scenarios' OK? Or any suggestion?
Thanks.

Charlie

On 8/27/07, Henry Sinnreich <[email-masked]> wrote:
> A deployment scenario is what the service provider spends money on in the
> belief to know what the user wants or to control the user no matter what
> they want J
>
>
>
>  ------------------------------
>
> *From:* Eunsoo Shim [mailto:[email-masked]]
> *Sent:* Monday, August 27, 2007 4:15 PM
> *To:* Spencer Dawkins
> *Cc:* P2PSIP Mailing List
> *Subject:* Re: [P2PSIP] Use Cases -> Deployment Scenarios?
>
>
>
> On 8/27/07, *Spencer Dawkins* < [email-masked]> wrote:
>
> Hi, Philip,
>

---

From: "Henry Sinnreich" <[email-masked]>
Date: Tue, 28 Aug 2007 07:59:10 -0700

Application scenarios look good to me. It avoids defining the other
terms.

Henry

From: Eunsoo Shim [mailto:[email-masked]] 
Sent: Monday, August 27, 2007 11:24 PM
To: Henry Sinnreich
Cc: Spencer Dawkins; P2PSIP Mailing List
Subject: Re: [P2PSIP] Use Cases -> Deployment Scenarios?

Oops. This naming discussion is getting serious.
What I understand is that the I-D is about various communication
applications/scenarios for which P2P SIP can be useful.
If none of 'use cases', 'usage scenarios', and 'deployment scenarios' is
a proper name for the I-D, I (or we) need help. 
Is 'application scenarios' OK? Or any suggestion?
Thanks.

Charlie

On 8/27/07, Henry Sinnreich < [email-masked]
<mailto:[email-masked]> > wrote:

Henry

From: Eunsoo Shim [mailto: [email-masked]] 
Sent: Monday, August 27, 2007 4:15 PM
To: Spencer Dawkins
Cc: P2PSIP Mailing List
Subject: Re: [P2PSIP] Use Cases -> Deployment Scenarios?

Eunsoo

Hi, Philip,

Thanks,

Spencer

this be
memory
like

---

From: "Eunsoo Shim" <[email-masked]>
Date: Tue, 28 Aug 2007 11:19:41 -0400

Hi, Henry,

Thanks a lot.

Eunsoo

On 8/28/07, Henry Sinnreich <[email-masked]> wrote:
> *Sent:* Monday, August 27, 2007 11:24 PM
> *To:* Henry Sinnreich
> *Cc:* Spencer Dawkins; P2PSIP Mailing List
> On 8/27/07, *Henry Sinnreich* < [email-masked]> wrote:
>
> *From:* Eunsoo Shim [mailto: [email-masked]]

---

From: Spencer Dawkins <[email-masked]>
Date: Tue, 28 Aug 2007 10:44:03 -0500

Any objections?

If not, I can start changing text...

Spencer
  ----- Original Message ----- 
  From: Eunsoo Shim 
  To: Henry Sinnreich 
  Cc: Spencer Dawkins ; P2PSIP Mailing List 
  Sent: Tuesday, August 28, 2007 10:19 AM
  Subject: Re: [P2PSIP] Use Cases -> Deployment Scenarios?

  Hi, Henry,

  Thanks a lot.

  Eunsoo

  On 8/28/07, Henry Sinnreich <[email-masked]> wrote: 
    Application scenarios look good to me. It avoids defining the other terms.

    Henry

----------------------------------------------------------------------------

    Oops. This naming discussion is getting serious.
    What I understand is that the I-D is about various communication applications/scenarios for which P2P SIP can be useful.
    If none of 'use cases', 'usage scenarios', and 'deployment scenarios' is a proper name for the I-D, I (or we) need help. 
    Is 'application scenarios' OK? Or any suggestion?
    Thanks.

    Charlie

    On 8/27/07, Henry Sinnreich < [email-masked]> wrote:

    A deployment scenario is what the service provider spends money on in the belief to know what the user wants or to control the user no matter what they want J

    Now seriously, they are different and a definition of the meaning in the context of the I-D would be useful.

    Henry

----------------------------------------------------------------------------

    Eunsoo

    On 8/27/07, Spencer Dawkins < [email-masked]> wrote:

    Hi, Philip,

    Thanks,

    Spencer

---

From: Philip Matthews <[email-masked]>
Date: Tue, 28 Aug 2007 13:10:08 -0400

Works for me.
- Philip
On 28-Aug-07, at 11:44 , Spencer Dawkins wrote:

> If none of 'use cases', 'usage scenarios', and 'deployment  
> scenarios' is a proper name for the I-D, I (or we) need help.
> A deployment scenario is what the service provider spends money on  
> in the belief to know what the user wants or to control the user no  
> matter what they want     J
>
>
> Now seriously, they are different and a definition of the meaning  
> in the context of the I-D would be useful.
>
>
> Henry
>
> Cases