Subject: [P2PSIP] FW: A question on the data type of ASP

From: JiangXingFeng <[email-masked]>
Date: Wed, 08 Aug 2007 15:46:54 +0800

Sorry, I forget copy this mail to the P2PSIP community. 
--
Jiang XingFeng

> -----Original Message-----
> From: JiangXingFeng [mailto:[email-masked]]
> Sent: Wednesday, August 08, 2007 3:46 PM
> To: [email-masked]'; [email-masked]'
> Subject: A question on the data type of ASP
> 
> Hi,
> 
> After I read the ASP draft, I have a question. In this proposal, there is
a typed data
> concept. DHT algorithms often use a huge hash space and think there is no
conflict
> when mapping the resource into the target hash space, i,e, resources which
have
> different strings will have different keys(locus).  The resulting key has
already
> implied the type of the resource.
> 
> Why do you introduce the typed data? Do you think hash conflict will
become
> inevitable after huge resource will be stored in the overlay and using the
type to
> resolve this conflict?
> 
> Any reply is appreciated. Thanks in advance.
> 
> Regards!
> --
> Jiang XingFeng
> --------------------------------------------------------------------
> 
> CONFIDENTIALITY NOTICE
> 
> This e-mail and its attachments contain confidential information from
HUAWEI,
> which is intended only for the person or entity whose address is listed
above. Any
> use of the information contained herein in any way (including, but not
limited to, total
> or partial disclosure, reproduction, or dissemination) by persons other
than the
> intended recipient(s) is prohibited. If you receive this e-mail in error,
please notify the
> sender by phone or email immediately and delete it!
> 
> --------------------------------------------------------------------

_______________________________________________
P2PSIP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/p2psip

---

From: "Peter Pan" <[email-masked]>
Date: Wed, 15 Aug 2007 12:23:17 -0700

sorry, butt getting cold....^_^

peter

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 16 Aug 2007 12:37:57 -0400

Sorry for the delay in responding here.

To answer your question, the purpose of the data types is not to avoid 
hash collisions. As you say that is not likely to happen anyway.

The functionality is there since there are a lot of other things that 
have to happen in the nodes processing that depend on the data type 
definition:

* authorization rules on who can write it
* limits on size
* rules on what the type is (i.e., does one user overwrite another?)

and so on.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com